summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-20 00:31:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-20 00:36:50 +0100
commite46df945dfd382f58fc18218e95953fef2541b67 (patch)
tree7d9bfa43509ced1acb2c1d8e251a042b813345d3
parentkde-frameworks/knewstuff: Add upstream crashfix (diff)
downloadgentoo-e46df945dfd382f58fc18218e95953fef2541b67.tar.gz
gentoo-e46df945dfd382f58fc18218e95953fef2541b67.tar.bz2
gentoo-e46df945dfd382f58fc18218e95953fef2541b67.zip
kde-frameworks/plasma: Fix broken background
Upstream commit b1364fa601866792ecf69cf61b8ab48732150857 See also: https://mail.kde.org/pipermail/distributions/2020-December/000910.html KDE-bug: https://bugs.kde.org/show_bug.cgi?id=430390 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/plasma/Manifest1
-rw-r--r--kde-frameworks/plasma/plasma-5.77.0-r1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/Manifest b/kde-frameworks/plasma/Manifest
index ed22dfcaa319..88b87dcea865 100644
--- a/kde-frameworks/plasma/Manifest
+++ b/kde-frameworks/plasma/Manifest
@@ -1,2 +1,3 @@
+DIST plasma-5.77.0-fix-broken-background.patch.xz 3732 BLAKE2B 19c656de212e3b2162e5f43e6ee2aface46d9169169179b6ac8af3eee01e64ec54139ac0001a6009f2a6d3cc4a59775951a3e10e8c33c7d04bf2b78543564137 SHA512 a262bebc754102709d1b41a2e5571938e58bfbcfd027dce9d0c1dd5cbdb8adee44a1c18b716976dc36d7f55b1d7e16d0536615e9f2895fa62eebb5f08cf05098
DIST plasma-framework-5.74.0.tar.xz 3140648 BLAKE2B dfc8df92d351446a146204f48c42cd4d6325f2652b5b61e0a530b27763fb3b6f07bf14319c86a54f933a58329d214977545e00f261cc784c0d8659eebd8cddb0 SHA512 7aae44d94a175dcdbd779a6801626d20e8d986597d1d05c82c5c035997b874ebb9b4412191e1fa7a26aa4e045ceaf22a7ef359d3e817d812357d51219eb5fb46
DIST plasma-framework-5.77.0.tar.xz 3152748 BLAKE2B 717d620fd5249887d47bbc6ed8ec42f103b56c4e566b0baae3624e64403b48977b5d36ebdbb30b52ae6cbec7694645050cf76eceaf6ab28c3690bcafcf8c7a07 SHA512 abcbb0b5bf063cdda728b0fc03f0d51f0ad84b4c45fb428efe54556aeb27b4cc3c488244ba0f7e3a435c31e802551d09f758bde815ca0a5aa43cf18e916d1ea4
diff --git a/kde-frameworks/plasma/plasma-5.77.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.77.0-r1.ebuild
new file mode 100644
index 000000000000..298dcdf54342
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.77.0-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="${PN}-framework"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Plasma framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${P}-fix-broken-background.patch.xz"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gles2-only wayland X"
+
+BDEPEND="
+ >=kde-frameworks/kdoctools-${PVCUT}:5
+"
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kactivities-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kglobalaccel-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ !gles2-only? ( virtual/opengl )
+ wayland? (
+ =kde-frameworks/kwayland-${PVCUT}*:5
+ media-libs/mesa[egl]
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${WORKDIR}/${P}-fix-broken-background.patch" ) # KDE-bug 430390
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !gles2-only OpenGL)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ $(cmake_use_find_package X XCB)
+ )
+
+ ecm_src_configure
+}