summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-10-25 19:27:25 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-25 19:28:00 +0200
commite530a268c3003ad7455cad8fe0b5b8bf23f8f21a (patch)
tree902ec0816c5198cc0f07393b78b1cdb7277582bd
parentnet-libs/libupnp: 1.6.25 bump (diff)
downloadgentoo-e530a268c3003ad7455cad8fe0b5b8bf23f8f21a.tar.gz
gentoo-e530a268c3003ad7455cad8fe0b5b8bf23f8f21a.tar.bz2
gentoo-e530a268c3003ad7455cad8fe0b5b8bf23f8f21a.zip
www-client/firefox: don't use rustfmt
In addition, move eapply_user to the beginning of src_prepare to increase the chance to apply upstream patches without the need for changes. Closes: https://bugs.gentoo.org/669548 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-63.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-63.0.ebuild b/www-client/firefox/firefox-63.0.ebuild
index 78eee6a7e4e0..3b7c9d2ecfdf 100644
--- a/www-client/firefox/firefox-63.0.ebuild
+++ b/www-client/firefox/firefox-63.0.ebuild
@@ -180,6 +180,9 @@ src_unpack() {
src_prepare() {
eapply "${WORKDIR}/firefox"
+ # Allow user to apply any additional patches without modifing ebuild
+ eapply_user
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
@@ -221,8 +224,10 @@ src_prepare() {
sed '/^MOZ_DEV_EDITION=1/d' \
-i "${S}"/browser/branding/aurora/configure.sh || die
- # Allow user to apply any additional patches without modifing ebuild
- eapply_user
+ # rustfmt, a tool to format Rust code, is optional and not required to build Firefox.
+ # However, when available, an unsupported version can cause problems, bug #669548
+ sed -i -e "s@check_prog('RUSTFMT', add_rustup_path('rustfmt')@check_prog('RUSTFMT', add_rustup_path('rustfmt_do_not_use')@" \
+ "${S}"/build/moz.configure/rust.configure || die
# Autotools configure is now called old-configure.in
# This works because there is still a configure.in that happens to be for the