summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-01-08 12:20:42 +0100
committerDirkjan Ochtman <djc@gentoo.org>2016-01-09 16:05:02 +0100
commite5c864f380da39c511cb463cb3c3379185bec6d0 (patch)
treefe0f5fb837cc6d3d7e7964527e2eee3d4731b63a
parentmedia-libs/gst-plugins-bad: Drop old (diff)
downloadgentoo-e5c864f380da39c511cb463cb3c3379185bec6d0.tar.gz
gentoo-e5c864f380da39c511cb463cb3c3379185bec6d0.tar.bz2
gentoo-e5c864f380da39c511cb463cb3c3379185bec6d0.zip
dev-lang/erlang: remove old versions
-rw-r--r--dev-lang/erlang/Manifest3
-rw-r--r--dev-lang/erlang/erlang-17.3.ebuild159
-rw-r--r--dev-lang/erlang/erlang-18.0-r1.ebuild162
-rw-r--r--dev-lang/erlang/erlang-18.0.ebuild158
4 files changed, 0 insertions, 482 deletions
diff --git a/dev-lang/erlang/Manifest b/dev-lang/erlang/Manifest
index 80c9fdcf169..aa372614b77 100644
--- a/dev-lang/erlang/Manifest
+++ b/dev-lang/erlang/Manifest
@@ -1,12 +1,9 @@
-DIST otp_doc_html_17.3.tar.gz 33444170 SHA256 bd8278b34f610d6025549640d4e03d79d2a69d7129ea230c0d71d7e6b231f5b3 SHA512 4b1f46c4258b7189b3651af8763916d791888bbc2232c9db60cfda019f611d34d215225fadc88dcfc39539a2c00fbe13b0feba59dea334b77522d7777dc55497 WHIRLPOOL 97930374b82609e27e7ea997050efaf7e92817ec5503fa895a9db30faf1a1c293a6582c769a12ab407eb6981d53aeb58d6a1d558a3b97aa8d2b533cab5aa4c3b
DIST otp_doc_html_17.5.tar.gz 33510258 SHA256 baba1d373c1faacf4a1a6ec1220d57d0cb2b977edb74f32cd58dc786361c6cf5 SHA512 d3e455452e6d6e241c40de6e41a7b1069f8daa45c8d2340adb62f8867948261692c8465db7e288378942ebe86fd938847756992600da93aa99cb294fadcb5211 WHIRLPOOL 9657c1fd133fa713d0f30bae0394f47f43b090149ec3457a177bd9f129c052b73f1e757762ced02c1c8bcbaec294e845859b18b0e2004429e04df8e04e36cade
DIST otp_doc_html_18.0.tar.gz 33857396 SHA256 e5a766f68406f5025f921ec32e8959937189ed1245e24b03a74156a8898b03b2 SHA512 5fcbd1ac7fb5f646e181ede385a56adb8d754bc645fd9313c2e3a77a01cb686b1c5975695207f388a78c9599b0d4e6b52c7ea121e900c0a1e2ab20679c0bede1 WHIRLPOOL 5e9174059212b3f5023c04b19164184937b2eb4cbea29103a85813f630b733e60e600e31d3478b3ef759150421b6153a1a3e946e313706bc23e110e01dc1a945
DIST otp_doc_html_R15B03-1.tar.gz 30436303 SHA256 d06f580f11d1303217a5c1cf8d68a98d7e01c535be934dcd430ecdc254f7572e SHA512 8a22ad702d50f40162f7d6051dbbc0226af449f7a1dcfb087e952dd7eb7213257940933441cfb68f055746450e3e5aa2c5ed8107ac67af7c3a940afb195af8c7 WHIRLPOOL ac10f9ce0ffd4cbd98617e4018e5a4729ce83f0ace6a4db219e7beef2f3a626a8c9a419c7f7772c934ca50310f55486df7eb24955ba845a9230c69c93e183d33
-DIST otp_doc_man_17.3.tar.gz 1357195 SHA256 3fabdac0b0594432fdd8186fa2c74ff49a629a9bcc4174e3bd605a3d4002dab7 SHA512 2e1c483dae85b84bb15950bb06e765ab47ec10785d1fe9b06dce0310dfd3d194b4690ed19e4b16c79a21c8fd1a701895a21af0ceb3422ceee84498d16d984715 WHIRLPOOL bd86e3ba1df1a73efdcd746e50f941620c0d16595901f8336f5180d1030cd8103c52d2f8c9f550984591ab9f439484ffa73b58fdd30de442ee08a0371119f458
DIST otp_doc_man_17.5.tar.gz 1363320 SHA256 85b1b2a1011fc01af550f1fe9e5a599a4c5f2a35d264d2804af1d05590a857c3 SHA512 98d241aa127cfe377e5efc52284cd324713cacefc96db5992275c4f8712a9e35e43f0dbc0d2a8d58a1127fbfa3f762eb001aea1bb1c9fa82205a3d83659ad548 WHIRLPOOL b790046a449824aa02e11bef6b84a7027351edba0fffd241221e690739df30c9c692074b7354612970d8d02b3c1bccfdbd81bb988af9874d181f177ffed49e2c
DIST otp_doc_man_18.0.tar.gz 1389178 SHA256 e44f0ec36ee0683867bc2aa9cc7fbb020d9dfd57338f37b98dcd0771f5b95673 SHA512 d3e757b15ee03b4fd89b21a456b89c847a60f4715fb8257c4d3d4f431798cb8d1ae30978608bc85db7f0e25d51072a2d32927745ff410956dca11a01ae4fa034 WHIRLPOOL 83fc8d483a5385b053f5c24e51f35d448dd5ab8e4228500a858422192da17078dbd0f776cbea6d2f77a483c97397cb7e80b5bb5184157611c49743d05fd542bd
DIST otp_doc_man_R15B03-1.tar.gz 1305001 SHA256 07980d8014c7cf8194b7078c137353f5083992add4663ced3dcba2ff91f228d8 SHA512 eb07552c83a942c1e7f1960b45edfab97b0628a1e08c7c827a07d77797901b4b60a6719b35d0f92a49eb04ada924e9263df70968a5920efc6ccf8e4e966933c6 WHIRLPOOL 764495a8bb67e2c67493452c83ff890d959aa5cd3bd711fce75b3c756dbacb913e50f7d92aab14dc33d6839daaac5a37dc7bcc11fc6392af11dd506a8d99076c
-DIST otp_src_17.3.tar.gz 67050599 SHA256 d4be03eb346016f4ca95d53eb9437ffaa6106762f153620dd98cd7f7733b76e4 SHA512 89d005fc3fdb4dc76c191b6e6a35e03f66ce01d765ba4f58cdd812d358025c62e032443d7ae73fea5b06bf6f27c9bf4e786f8090627ecb1e1309b88b82892910 WHIRLPOOL ef73ea10df2126c129ddb85c0a2bd72c6a7885b200b4d584577beab7c90b84f81647e017f2814dc4406427d4b22f48626db983636bcd5a8648f861484bfe6eff
DIST otp_src_17.5.tar.gz 67242289 SHA256 3c28820c981b30c50df8ac2a4a238e5813454fa3ed2ad530bc7948a282846474 SHA512 cfd082c8baee7ded370a34f15a1ba3b846b7d81e06edc36c62308c9220697925f1feda91eeecb70fc658f8987087256f51a2ebd0c526d16eeb09c72889d2390d WHIRLPOOL 3c3d987981383bf148b9788fae0574da398ff63d81eea13da0463bed303922d06fe54354de1cd3d37091eb23438939c645176ab565877f06cc1f11235c4d8d3d
DIST otp_src_18.0.tar.gz 68124710 SHA256 a0b69da34b4f218eb7d63d9e96fc120aa7257bb6c37a0f40fb388e188b4111aa SHA512 84ec2a3834270c1babe153572d6187faa36c12128e604037d55be01719788c0dd79d46769ea7090d530b746206a25fe02346b02849abee10ee41ed4ac7567c02 WHIRLPOOL 7edc237ef906da5e086bcb7b37fe23da3293b3635f612adc9239736e17731270bf64624444c5556d9fd7a03e4e64678a3bd294d04be2aada2a88d897dad9bee0
DIST otp_src_R15B03-1.tar.gz 76123810 SHA256 4bccac86dd76aec050252e44276a0283a0df9218e6470cf042a9b9f9dfc9476c SHA512 baa8f388bd56bbdf1d3818802d011970fb51d38d14434532b1e4f04c1b8203e5a0cd9cc870f93a993cce750cd1af6e4b7df40dffc44e455353bce9d7c46c8e34 WHIRLPOOL ce76d01dfd17e0bc70e3daa7eab218000d1e802f55b0892e2e9654d2ea262f214f3bd006c0988885e787a1cfe782e8b61d5d1ee3a1d05cbced465b5a28e2de2e
diff --git a/dev-lang/erlang/erlang-17.3.ebuild b/dev-lang/erlang/erlang-17.3.ebuild
deleted file mode 100644
index 0d9af90b383..00000000000
--- a/dev-lang/erlang/erlang-17.3.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-WX_GTK_VER="2.8"
-
-inherit autotools elisp-common eutils java-pkg-opt-2 multilib systemd versionator wxwidgets
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/otp_src_${PV}.tar.gz
- http://erlang.org/download/otp_doc_man_${PV}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_html_${PV}.tar.gz )"
-
-LICENSE="ErlPL-1.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="compat-ethread doc emacs halfword hipe java kpoll odbc smp sctp ssl systemd tk wxwidgets"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- wxwidgets? ( x11-libs/wxGTK:2.8[X,opengl] virtual/glu )
- sctp? ( net-misc/lksctp-tools )
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/otp_src_${PV}"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
- if use halfword ; then
- use amd64 || die "halfword support is limited to amd64"
- fi
-}
-
-src_prepare() {
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # bug 263129, don't ignore LDFLAGS, reported upstream
- sed -e 's:LDFLAGS = \$(DED_LDFLAGS):LDFLAGS += \$(DED_LDFLAGS):' -i "${S}"/lib/megaco/src/flex/Makefile.in
-
- # don't ignore LDFLAGS, reported upstream
- sed -e 's:LDFLAGS = \$(ODBC_LIB) \$(EI_LDFLAGS):LDFLAGS += \$(ODBC_LIB) \$(EI_LDFLAGS):' -i "${S}"/lib/odbc/c_src/Makefile.in
-
- if ! use wxwidgets; then
- sed -i 's: wx : :' lib/Makefile
- rm -rf lib/wx
- fi
-
- # Nasty workaround, reported upstream
- cp "${S}"/lib/configure.in.src "${S}"/lib/configure.in
-
- # bug 383697
- sed -i '1i#define OF(x) x' erts/emulator/drivers/common/gzio.c
- cd erts && eautoreconf
-}
-
-src_configure() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable sctp) \
- $(use_enable systemd) \
- $(use_enable halfword halfword-emulator) \
- $(use_enable hipe) \
- $(use_with ssl ssl "${EPREFIX}"/usr) \
- $(use_enable ssl dynamic-ssl-lib) \
- $(use_enable kpoll kernel-poll) \
- $(use_enable smp smp-support) \
- $(use compat-ethread && echo "--enable-ethread-pre-pentium4-compatibility") \
- $(use x64-macos && echo "--enable-darwin-64bit")
-}
-
-src_compile() {
- use java || export JAVAC=false
- emake
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake INSTALL_PREFIX="${D}" install
- dodoc AUTHORS README.md
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
- use smp && dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam.smp" /usr/bin/beam.smp
-
- ## Remove ${D} from the following files
- sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/erl"
- sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${ED}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${ED}/${ERL_LIBDIR}/Install"
-
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # doman sucks so we can't use it
- cp ${file} "${ED}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${EPREFIX}${ERL_LIBDIR}/man\"" > "${ED}/etc/env.d/90erlang"
-
- if use doc ; then
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- sed -e "s:/usr/share:${EPREFIX}/usr/share:g" \
- "${FILESDIR}"/${SITEFILE} > "${T}"/${SITEFILE}
- elisp-site-file-install "${T}"/${SITEFILE}
- popd
- fi
-
- newinitd "${FILESDIR}"/epmd.init epmd
- systemd_dounit "${FILESDIR}"/epmd.service
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/erlang-18.0-r1.ebuild b/dev-lang/erlang/erlang-18.0-r1.ebuild
deleted file mode 100644
index 0d4b0206348..00000000000
--- a/dev-lang/erlang/erlang-18.0-r1.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-WX_GTK_VER="2.8"
-
-inherit autotools elisp-common eutils java-pkg-opt-2 multilib systemd versionator wxwidgets
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/otp_src_${PV}.tar.gz
- http://erlang.org/download/otp_doc_man_${PV}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_html_${PV}.tar.gz )"
-
-LICENSE="ErlPL-1.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="compat-ethread doc emacs halfword hipe java kpoll libressl odbc smp sctp ssl systemd tk wxwidgets"
-
-RDEPEND="
- ssl? (
- !libressl? ( >=dev-libs/openssl-0.9.7d:0 )
- libressl? ( dev-libs/libressl )
- )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- wxwidgets? ( x11-libs/wxGTK:2.8[X,opengl] virtual/glu )
- sctp? ( net-misc/lksctp-tools )
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/otp_src_${PV}"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
- if use halfword ; then
- use amd64 || die "halfword support is limited to amd64"
- fi
-}
-
-src_prepare() {
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # bug 263129, don't ignore LDFLAGS, reported upstream
- sed -e 's:LDFLAGS = \$(DED_LDFLAGS):LDFLAGS += \$(DED_LDFLAGS):' -i "${S}"/lib/megaco/src/flex/Makefile.in
-
- # don't ignore LDFLAGS, reported upstream
- sed -e 's:LDFLAGS = \$(ODBC_LIB) \$(EI_LDFLAGS):LDFLAGS += \$(ODBC_LIB) \$(EI_LDFLAGS):' -i "${S}"/lib/odbc/c_src/Makefile.in
-
- if ! use wxwidgets; then
- sed -i 's: wx : :' lib/Makefile
- rm -rf lib/wx
- fi
-
- # Nasty workaround, reported upstream
- cp "${S}"/lib/configure.in.src "${S}"/lib/configure.in
-
- # bug 383697
- sed -i '1i#define OF(x) x' erts/emulator/drivers/common/gzio.c
- cd erts && eautoreconf
-}
-
-src_configure() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable sctp) \
- $(use_enable systemd) \
- $(use_enable halfword halfword-emulator) \
- $(use_enable hipe) \
- $(use_with ssl ssl "${EPREFIX}"/usr) \
- $(use_enable ssl dynamic-ssl-lib) \
- $(use_enable kpoll kernel-poll) \
- $(use_enable smp smp-support) \
- $(use compat-ethread && echo "--enable-ethread-pre-pentium4-compatibility") \
- $(use x64-macos && echo "--enable-darwin-64bit")
-}
-
-src_compile() {
- use java || export JAVAC=false
- emake
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake INSTALL_PREFIX="${D}" install
- dodoc AUTHORS README.md
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
- use smp && dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam.smp" /usr/bin/beam.smp
-
- ## Remove ${D} from the following files
- sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/erl"
- sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${ED}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${ED}/${ERL_LIBDIR}/Install"
-
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # doman sucks so we can't use it
- cp ${file} "${ED}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${EPREFIX}${ERL_LIBDIR}/man\"" > "${ED}/etc/env.d/90erlang"
-
- if use doc ; then
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- sed -e "s:/usr/share:${EPREFIX}/usr/share:g" \
- "${FILESDIR}"/${SITEFILE} > "${T}"/${SITEFILE}
- elisp-site-file-install "${T}"/${SITEFILE}
- popd
- fi
-
- newinitd "${FILESDIR}"/epmd.init epmd
- systemd_dounit "${FILESDIR}"/epmd.service
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/erlang-18.0.ebuild b/dev-lang/erlang/erlang-18.0.ebuild
deleted file mode 100644
index 547d0a5aa6d..00000000000
--- a/dev-lang/erlang/erlang-18.0.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-WX_GTK_VER="2.8"
-
-inherit autotools elisp-common eutils java-pkg-opt-2 multilib systemd versionator wxwidgets
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/otp_src_${PV}.tar.gz
- http://erlang.org/download/otp_doc_man_${PV}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_html_${PV}.tar.gz )"
-
-LICENSE="ErlPL-1.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="compat-ethread doc emacs halfword hipe java kpoll odbc smp sctp ssl systemd tk wxwidgets"
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- wxwidgets? ( x11-libs/wxGTK:2.8[X,opengl] virtual/glu )
- sctp? ( net-misc/lksctp-tools )
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/otp_src_${PV}"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
- if use halfword ; then
- use amd64 || die "halfword support is limited to amd64"
- fi
-}
-
-src_prepare() {
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # bug 263129, don't ignore LDFLAGS, reported upstream
- sed -e 's:LDFLAGS = \$(DED_LDFLAGS):LDFLAGS += \$(DED_LDFLAGS):' -i "${S}"/lib/megaco/src/flex/Makefile.in
-
- # don't ignore LDFLAGS, reported upstream
- sed -e 's:LDFLAGS = \$(ODBC_LIB) \$(EI_LDFLAGS):LDFLAGS += \$(ODBC_LIB) \$(EI_LDFLAGS):' -i "${S}"/lib/odbc/c_src/Makefile.in
-
- if ! use wxwidgets; then
- sed -i 's: wx : :' lib/Makefile
- rm -rf lib/wx
- fi
-
- # Nasty workaround, reported upstream
- cp "${S}"/lib/configure.in.src "${S}"/lib/configure.in
-
- # bug 383697
- sed -i '1i#define OF(x) x' erts/emulator/drivers/common/gzio.c
- cd erts && eautoreconf
-}
-
-src_configure() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable sctp) \
- $(use_enable systemd) \
- $(use_enable halfword halfword-emulator) \
- $(use_enable hipe) \
- $(use_with ssl ssl "${EPREFIX}"/usr) \
- $(use_enable ssl dynamic-ssl-lib) \
- $(use_enable kpoll kernel-poll) \
- $(use_enable smp smp-support) \
- $(use compat-ethread && echo "--enable-ethread-pre-pentium4-compatibility") \
- $(use x64-macos && echo "--enable-darwin-64bit")
-}
-
-src_compile() {
- use java || export JAVAC=false
- emake
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake INSTALL_PREFIX="${D}" install
- dodoc AUTHORS README.md
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
- use smp && dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam.smp" /usr/bin/beam.smp
-
- ## Remove ${D} from the following files
- sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/erl"
- sed -e "s:${D}::g" -i "${ED}${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${ED}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${ED}/${ERL_LIBDIR}/Install"
-
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # doman sucks so we can't use it
- cp ${file} "${ED}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${EPREFIX}${ERL_LIBDIR}/man\"" > "${ED}/etc/env.d/90erlang"
-
- if use doc ; then
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- sed -e "s:/usr/share:${EPREFIX}/usr/share:g" \
- "${FILESDIR}"/${SITEFILE} > "${T}"/${SITEFILE}
- elisp-site-file-install "${T}"/${SITEFILE}
- popd
- fi
-
- newinitd "${FILESDIR}"/epmd.init epmd
- systemd_dounit "${FILESDIR}"/epmd.service
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}