summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2016-11-26 22:27:44 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2016-11-26 22:28:12 +0100
commite8f718b3e2bcc0989bda3dc5cb0f24f67096f11c (patch)
treedd9946dbdc7f2a7ca42970a062a05be951cefc45
parentapp-emulation/libdsk: Fixes doc installation (diff)
downloadgentoo-e8f718b3e2bcc0989bda3dc5cb0f24f67096f11c.tar.gz
gentoo-e8f718b3e2bcc0989bda3dc5cb0f24f67096f11c.tar.bz2
gentoo-e8f718b3e2bcc0989bda3dc5cb0f24f67096f11c.zip
app-emulation/free42: Respects LDFLAGS
Package-Manager: portage-2.3.0
-rw-r--r--app-emulation/free42/files/free42-1.5.12-fix-makefile.patch27
1 files changed, 23 insertions, 4 deletions
diff --git a/app-emulation/free42/files/free42-1.5.12-fix-makefile.patch b/app-emulation/free42/files/free42-1.5.12-fix-makefile.patch
index 3fe1baf1b487..29c3bb5f5e5e 100644
--- a/app-emulation/free42/files/free42-1.5.12-fix-makefile.patch
+++ b/app-emulation/free42/files/free42-1.5.12-fix-makefile.patch
@@ -1,6 +1,6 @@
diff -Nuar a/gtk/Makefile b/gtk/Makefile
---- a/gtk/Makefile 2016-09-04 18:56:12.000000000 +0200
-+++ b/gtk/Makefile 2016-09-24 16:13:34.824116365 +0200
+--- a/gtk/Makefile 2016-10-04 03:45:02.000000000 +0200
++++ b/gtk/Makefile 2016-11-26 22:06:25.599990576 +0100
@@ -15,11 +15,10 @@
# along with this program; if not, see http://www.gnu.org/licenses/.
###############################################################################
@@ -14,7 +14,7 @@ diff -Nuar a/gtk/Makefile b/gtk/Makefile
-I/usr/X11R6/include \
$(shell pkg-config --cflags gtk+-2.0) \
-DVERSION="\"$(shell cat ../VERSION)\"" \
-@@ -27,14 +26,16 @@
+@@ -27,21 +26,25 @@
-DDECIMAL_GLOBAL_ROUNDING=1 \
-DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
-DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
@@ -31,8 +31,27 @@ diff -Nuar a/gtk/Makefile b/gtk/Makefile
+ ${CXXFLAGS}
-LDFLAGS = -L/usr/X11R6/lib
-+LDFLAGS := -L/usr/X11R6/lib ${LDFLAGS}
++MYLDFLAGS = -L/usr/X11R6/lib
-LIBS = gcc111libbid.a -lXmu $(shell pkg-config --libs gtk+-2.0)
+LIBS = gcc111libbid.a -lX11 -ldl -lXmu $(shell pkg-config --libs gtk+-2.0)
ifeq "$(shell uname -s)" "Linux"
+-LDFLAGS += -Wl,--hash-style=both
++MYLDFLAGS += -Wl,--hash-style=both
+ LIBS += -lpthread
+ endif
+
++MYLDFLAGS += ${LDFLAGS}
++
+ SRCS = shell_main.cc shell_skin.cc skins.cc keymap.cc shell_loadimage.cc \
+ shell_spool.cc core_main.cc core_commands1.cc core_commands2.cc \
+ core_commands3.cc core_commands4.cc core_commands5.cc \
+@@ -83,7 +86,7 @@
+ endif
+
+ $(EXE): $(OBJS)
+- $(CXX) -o $(EXE) $(LDFLAGS) $(OBJS) $(LIBS)
++ $(CXX) -o $(EXE) $(MYLDFLAGS) $(OBJS) $(LIBS)
+
+ $(SRCS) skin2cc.cc keymap2cc.cc skin2cc.conf: symlinks
+