summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-27 13:37:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-27 13:41:21 +0100
commiteae3a6da0446dcdc271e3c9db48902af48e101b4 (patch)
treeb99614fd16c551b97ba88b967a640c2e75119d5c
parentdev-lang/elixir: bump up to 1.4.1 (diff)
downloadgentoo-eae3a6da0446dcdc271e3c9db48902af48e101b4.tar.gz
gentoo-eae3a6da0446dcdc271e3c9db48902af48e101b4.tar.bz2
gentoo-eae3a6da0446dcdc271e3c9db48902af48e101b4.zip
dev-ros/hector_pose_estimation_core: Fix build with latest eigen
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-ros/hector_pose_estimation_core/files/eigen.patch13
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild4
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-ros/hector_pose_estimation_core/files/eigen.patch b/dev-ros/hector_pose_estimation_core/files/eigen.patch
new file mode 100644
index 000000000000..b58bb9e8ca3d
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/files/eigen.patch
@@ -0,0 +1,13 @@
+Index: hector_pose_estimation_core/src/measurements/poseupdate.cpp
+===================================================================
+--- hector_pose_estimation_core.orig/src/measurements/poseupdate.cpp
++++ hector_pose_estimation_core/src/measurements/poseupdate.cpp
+@@ -382,7 +382,7 @@ double PoseUpdate::updateInternal(State
+ ROS_DEBUG_STREAM_NAMED("poseupdate", "alpha = " << alpha << ", beta = " << beta);
+
+ if (max_error > 0.0) {
+- double error2 = error.transpose() * Ix * (Ix + Iy).inverse() * Iy * error;
++ double error2 = error.transpose().dot( Ix * (Ix + Iy).inverse() * Iy * error);
+ if (error2 > max_error * max_error) {
+ if (!jump_on_max_error_ || !jump_function) {
+ ROS_WARN_STREAM_NAMED("poseupdate", "Ignoring poseupdate for " << text << " as the error [ " << error.transpose() << " ], |error| = " << sqrt(error2) << " sigma exceeds max_error!");
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
index 63064ba7710b..99bccdf34e24 100644
--- a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,4 +27,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-cpp/eigen:3"
-PATCHES=( "${FILESDIR}/includes.patch" "${FILESDIR}/gcc6.patch" )
+PATCHES=( "${FILESDIR}/includes.patch" "${FILESDIR}/gcc6.patch" "${FILESDIR}/eigen.patch" )