summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-10 09:14:57 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 09:23:57 +0100
commitecc25873cd730321d24b32f0e3757d6906e6c3e2 (patch)
tree231e5a9d09cf5c21af4365412144ebb98e2e1ff2
parentapp-text/vlna: Bump to EAPI 7 (diff)
downloadgentoo-ecc25873cd730321d24b32f0e3757d6906e6c3e2.tar.gz
gentoo-ecc25873cd730321d24b32f0e3757d6906e6c3e2.tar.bz2
gentoo-ecc25873cd730321d24b32f0e3757d6906e6c3e2.zip
dev-db/db-je: Bump to EAPI 7
Closes: https://bugs.gentoo.org/697364 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-db/db-je/db-je-3.3.75.ebuild26
-rw-r--r--dev-db/db-je/files/db-je-3.3.75-optional-test.patch4
2 files changed, 15 insertions, 15 deletions
diff --git a/dev-db/db-je/db-je-3.3.75.ebuild b/dev-db/db-je/db-je-3.3.75.ebuild
index 4e4723e4f4ce..943c9c9fd986 100644
--- a/dev-db/db-je/db-je-3.3.75.ebuild
+++ b/dev-db/db-je/db-je-3.3.75.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
JAVA_PKG_IUSE="doc source"
@@ -9,30 +9,30 @@ inherit java-pkg-2 java-ant-2
DESCRIPTION="A high performance, transactional storage engine written entirely in Java"
HOMEPAGE="https://www.oracle.com/database/berkeley-db/java-edition.html"
-SRC_URI="http://download.oracle.com/berkeley-db/${P/db-/}.tar.gz"
+SRC_URI="https://download.oracle.com/berkeley-db/${P/db-/}.tar.gz"
+S=${WORKDIR}/${P/db-/}
LICENSE="Sleepycat BSD"
SLOT="3.3"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND=">=virtual/jdk-1.5"
+DEPEND=">=virtual/jdk-1.5
+ dev-java/ant-core:0"
RDEPEND=">=virtual/jre-1.5"
-S=${WORKDIR}/${P/db-/}
-src_unpack() {
- unpack ${A}
- cd "${S}" || die
- epatch "${FILESDIR}"/${P}-optional-test.patch
- rm -rf docs
+EANT_DOC_TARGET="javadoc-all"
+EANT_EXTRA_ARGS="-Dnotest=true"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-optional-test.patch
+ rm -r docs || die
cd lib || die
- rm -v *jar || die
+ rm -v *.jar || die
java-pkg_jar-from --build-only ant-core ant.jar
}
-EANT_DOC_TARGET="javadoc-all"
-EANT_EXTRA_ARGS="-Dnotest=true"
-
src_install() {
java-pkg_dojar build/lib/je.jar
use doc && java-pkg_dojavadoc docs
diff --git a/dev-db/db-je/files/db-je-3.3.75-optional-test.patch b/dev-db/db-je/files/db-je-3.3.75-optional-test.patch
index e8f7600398e2..ac23185c2ba8 100644
--- a/dev-db/db-je/files/db-je-3.3.75-optional-test.patch
+++ b/dev-db/db-je/files/db-je-3.3.75-optional-test.patch
@@ -1,5 +1,5 @@
---- build.xml 2008-06-11 05:25:20.000000000 +0200
-+++ build.xml.new 2008-08-22 15:59:53.000000000 +0200
+--- a/build.xml 2008-06-11 05:25:20.000000000 +0200
++++ b/build.xml 2008-08-22 15:59:53.000000000 +0200
@@ -102,6 +102,7 @@
<path id="empty.classpath"/>