summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-30 09:06:46 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-30 10:09:04 -0500
commiteefe13f987b600eab3dfe3d2f27cd0bfb4501446 (patch)
tree8f44ce4262387447370f3449738aa7ca2a08b706
parentdev-php/pecl-mailparse: Drop masked version (diff)
downloadgentoo-eefe13f987b600eab3dfe3d2f27cd0bfb4501446.tar.gz
gentoo-eefe13f987b600eab3dfe3d2f27cd0bfb4501446.tar.bz2
gentoo-eefe13f987b600eab3dfe3d2f27cd0bfb4501446.zip
dev-php/pecl-memcache: Remove masked versions
Bug: https://bugs.gentoo.org/651784 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/pecl-memcache/Manifest1
-rw-r--r--dev-php/pecl-memcache/files/3.0.8-c99-inline.patch85
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.8-r2.ebuild47
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.8-r3.ebuild46
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 180 deletions
diff --git a/dev-php/pecl-memcache/Manifest b/dev-php/pecl-memcache/Manifest
index b752387adc1a..fa7ce2858cab 100644
--- a/dev-php/pecl-memcache/Manifest
+++ b/dev-php/pecl-memcache/Manifest
@@ -1,2 +1 @@
-DIST memcache-3.0.8.tgz 70523 BLAKE2B 829c842ac2764327037c5ef620cd4759e16d56e22195c035eeed2722d8a499119489d3304ad5223cf1c89a8e3ab6f6830d67742958ec2a37e302bf8ea265dfb1 SHA512 916c6b21ab7c1021128626c0df35ef0b83cb76b6115fe7c45b003ca4f78ad9484bf3c998bc7ebdee19f84349ff1e56759f74e75aee5bc70b1de9a03c45a99bc3
DIST memcache-4.0.5.2.tgz 75061 BLAKE2B fbf96fd182ff4b8764c4492edcdac53263176ebe6d63a27e9f3fb32110a016b221722c246e7c1ae49ee973a6e4cdff045876d1c6119f410f2fa3e796c0580e02 SHA512 93e163acf3a6c28f16b5f0982105f6f558cceeb314b3f09ad71655d8a5adf64d23959f1a2f3589eb7e7a7e18c88ba8132014e13f697a737cd570cf9405137384
diff --git a/dev-php/pecl-memcache/files/3.0.8-c99-inline.patch b/dev-php/pecl-memcache/files/3.0.8-c99-inline.patch
deleted file mode 100644
index 818b3ce1e2d9..000000000000
--- a/dev-php/pecl-memcache/files/3.0.8-c99-inline.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-diff -aurN a/memcache_pool.h b/memcache_pool.h
---- a/memcache_pool.h 2013-04-07 22:12:54.000000000 -0400
-+++ b/memcache_pool.h 2017-05-19 16:04:45.262858090 -0400
-@@ -135,8 +135,14 @@
- #define mmc_buffer_release(b) memset((b), 0, sizeof(*(b)))
- #define mmc_buffer_reset(b) (b)->value.len = (b)->idx = 0
-
--inline void mmc_buffer_alloc(mmc_buffer_t *, unsigned int);
--inline void mmc_buffer_free(mmc_buffer_t *);
-+#if !defined __STDC_VERSION__ || __STDC_VERSION__ < 199901L
-+#define MMC_POOL_INLINE inline
-+#else
-+#define MMC_POOL_INLINE __attribute__ ((gnu_inline)) inline
-+#endif
-+
-+MMC_POOL_INLINE void mmc_buffer_alloc(mmc_buffer_t *, unsigned int);
-+MMC_POOL_INLINE void mmc_buffer_free(mmc_buffer_t *);
-
- /* stream handlers */
- typedef struct mmc_stream mmc_stream_t;
-@@ -391,8 +397,8 @@
- double timeval_to_double(struct timeval tv);
- struct timeval double_to_timeval(double sec);
-
--inline int mmc_prepare_key_ex(const char *, unsigned int, char *, unsigned int *);
--inline int mmc_prepare_key(zval *, char *, unsigned int *);
-+MMC_POOL_INLINE int mmc_prepare_key_ex(const char *, unsigned int, char *, unsigned int *);
-+MMC_POOL_INLINE int mmc_prepare_key(zval *, char *, unsigned int *);
-
- #define mmc_str_left(h, n, hlen, nlen) ((hlen) >= (nlen) ? memcmp((h), (n), (nlen)) == 0 : 0)
-
-diff -aurN a/memcache_queue.h b/memcache_queue.h
---- a/memcache_queue.h 2013-04-07 22:12:54.000000000 -0400
-+++ b/memcache_queue.h 2017-05-19 16:07:23.753983941 -0400
-@@ -40,7 +40,11 @@
- #ifdef PHP_WIN32
- #define MMC_QUEUE_INLINE
- #else
-+#if !defined __STDC_VERSION__ || __STDC_VERSION__ < 199901L
- #define MMC_QUEUE_INLINE inline
-+#else
-+#define MMC_QUEUE_INLINE __attribute__ ((gnu_inline)) inline
-+#endif
- #endif
-
- MMC_QUEUE_INLINE void mmc_queue_push(mmc_queue_t *, void *);
-diff -aurN a/memcache_pool.c b/memcache_pool.c
---- a/memcache_pool.c 2013-04-07 22:12:54.000000000 -0400
-+++ b/memcache_pool.c 2017-05-19 16:22:51.592845885 -0400
-@@ -40,7 +40,7 @@
-
- ZEND_DECLARE_MODULE_GLOBALS(memcache)
-
--inline void mmc_buffer_alloc(mmc_buffer_t *buffer, unsigned int size) /*
-+MMC_POOL_INLINE void mmc_buffer_alloc(mmc_buffer_t *buffer, unsigned int size) /*
- ensures space for an additional size bytes {{{ */
- {
- register size_t newlen;
-@@ -48,7 +48,7 @@
- }
- /* }}} */
-
--inline void mmc_buffer_free(mmc_buffer_t *buffer) /* {{{ */
-+MMC_POOL_INLINE void mmc_buffer_free(mmc_buffer_t *buffer) /* {{{ */
- {
- if (buffer->value.c != NULL) {
- smart_str_free(&(buffer->value));
-@@ -1676,7 +1676,7 @@
- }
- /* }}} */
-
--inline int mmc_prepare_key_ex(const char *key, unsigned int key_len, char *result, unsigned int *result_len) /* {{{ */
-+MMC_POOL_INLINE int mmc_prepare_key_ex(const char *key, unsigned int key_len, char *result, unsigned int *result_len) /* {{{ */
- {
- unsigned int i;
- if (key_len == 0) {
-@@ -1694,7 +1694,7 @@
- }
- /* }}} */
-
--inline int mmc_prepare_key(zval *key, char *result, unsigned int *result_len) /* {{{ */
-+MMC_POOL_INLINE int mmc_prepare_key(zval *key, char *result, unsigned int *result_len) /* {{{ */
- {
- if (Z_TYPE_P(key) == IS_STRING) {
- return mmc_prepare_key_ex(Z_STRVAL_P(key), Z_STRLEN_P(key), result, result_len);
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.8-r2.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.8-r2.ebuild
deleted file mode 100644
index e35e5048a992..000000000000
--- a/dev-php/pecl-memcache/pecl-memcache-3.0.8-r2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PHP_EXT_NAME="memcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( README )
-
-USE_PHP="php5-6"
-
-inherit php-ext-pecl-r3 flag-o-matic
-
-KEYWORDS="amd64 hppa ppc64 x86"
-
-DESCRIPTION="PHP extension for using memcached"
-LICENSE="PHP-3"
-SLOT="0"
-IUSE="+session"
-
-DEPEND="sys-libs/zlib
- dev-lang/php:5.6[session?]"
-RDEPEND="${DEPEND}"
-
-# The test suite requires memcached to be running.
-RESTRICT='test'
-
-src_configure() {
- # fix bug 618920 by restoring pre-GCC5 inline semantics
- append-cflags -std=gnu89
- local PHP_EXT_ECONF_ARGS=( --enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session) )
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-pecl-r3_src_install
-
- php-ext-source-r3_addtoinifiles "memcache.allow_failover" "true"
- php-ext-source-r3_addtoinifiles "memcache.max_failover_attempts" "20"
- php-ext-source-r3_addtoinifiles "memcache.chunk_size" "32768"
- php-ext-source-r3_addtoinifiles "memcache.default_port" "11211"
- php-ext-source-r3_addtoinifiles "memcache.hash_strategy" "consistent"
- php-ext-source-r3_addtoinifiles "memcache.hash_function" "crc32"
- php-ext-source-r3_addtoinifiles "memcache.redundancy" "1"
- php-ext-source-r3_addtoinifiles "memcache.session_redundancy" "2"
- php-ext-source-r3_addtoinifiles "memcache.protocol" "ascii"
-}
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.8-r3.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.8-r3.ebuild
deleted file mode 100644
index 2712c682f647..000000000000
--- a/dev-php/pecl-memcache/pecl-memcache-3.0.8-r3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PHP_EXT_NAME="memcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( README )
-PATCHES=( "${FILESDIR}/3.0.8-c99-inline.patch" )
-
-USE_PHP="php5-6"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
-
-DESCRIPTION="PHP extension for using memcached"
-LICENSE="PHP-3"
-SLOT="0"
-IUSE="+session"
-
-DEPEND="sys-libs/zlib
- dev-lang/php:5.6[session?]"
-RDEPEND="${DEPEND}"
-
-# The test suite requires memcached to be running.
-RESTRICT='test'
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=( --enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session) )
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-pecl-r3_src_install
-
- php-ext-source-r3_addtoinifiles "memcache.allow_failover" "true"
- php-ext-source-r3_addtoinifiles "memcache.max_failover_attempts" "20"
- php-ext-source-r3_addtoinifiles "memcache.chunk_size" "32768"
- php-ext-source-r3_addtoinifiles "memcache.default_port" "11211"
- php-ext-source-r3_addtoinifiles "memcache.hash_strategy" "consistent"
- php-ext-source-r3_addtoinifiles "memcache.hash_function" "crc32"
- php-ext-source-r3_addtoinifiles "memcache.redundancy" "1"
- php-ext-source-r3_addtoinifiles "memcache.session_redundancy" "2"
- php-ext-source-r3_addtoinifiles "memcache.protocol" "ascii"
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index c95b6b7ebb87..c497ef7542e6 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -780,7 +780,6 @@ virtual/httpd-php:5.6
# Brian Evans <grknight@gentoo.org> (2019-10-01)
# Old slots for support of PHP <7
# Removal in 90 days. Bug 651784
-dev-php/pecl-memcache:0
dev-php/pecl-memcached:0
dev-php/pecl-oauth:0
dev-php/pecl-propro:0