summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-08-13 23:15:02 -0500
committerMatthias Maier <tamiko@gentoo.org>2015-08-13 23:15:02 -0500
commitef56e60ef09fbc1920290b8c2ae1c66385ab6fa5 (patch)
tree6bb43fc28a201d5ff28fa10b5f2b46ed8fec7de0
parentapp-editors/curses-hexedit: look up ncurses details via pkg-config (diff)
downloadgentoo-ef56e60ef09fbc1920290b8c2ae1c66385ab6fa5.tar.gz
gentoo-ef56e60ef09fbc1920290b8c2ae1c66385ab6fa5.tar.bz2
gentoo-ef56e60ef09fbc1920290b8c2ae1c66385ab6fa5.zip
app-emulation/libvirt-glib: version bump to 0.22 (bug #557496)
This commit bumps libvirt-glib to version 0.22. The dependency on libvirt is also updated to ">=app-emulation/libvirt-1.2.6". Thanks to Russell Knighton. Gentoo-Bug: 557496 Package-Manager: portage-2.2.20.1
-rw-r--r--app-emulation/libvirt-glib/Manifest1
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.2.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-emulation/libvirt-glib/Manifest b/app-emulation/libvirt-glib/Manifest
index d7bb12e00452..74c17e9e3dd3 100644
--- a/app-emulation/libvirt-glib/Manifest
+++ b/app-emulation/libvirt-glib/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-glib-0.2.0.tar.gz 836245 SHA256 30b7e0f224f9cdcf34c1b05b08803cb617d057613ee96395ae517f4ee6c44a0b SHA512 23b698fe297247dd5ce06d9e37eed2025064ab76a52f008cb89cd835364a52c8fe60ae535f68e67fb6c3454d41328dd77c392efd594a3fb1a237d1beb25d19ae WHIRLPOOL 6ef50cc740fa1b43dafc4666ac221bb57312dd937ee693bd12e582e3cec784a5c7a5d22e3c15cc369ac0a24ae26ce64edc69d2c4b55fc2ea83a8e350bc8003ab
DIST libvirt-glib-0.2.1.tar.gz 844657 SHA256 d856d37b708bc8bf9e6ac294edca7a53f2baa6d857c6f5859be58517a714a2fb SHA512 bd38b5c415f65bd6e8824d419c787afdd43aa322f03045f517f9bae88575de1a0975f0340b24bf776421eeb54632227d798e801a1611ce932878ad7bace3adfb WHIRLPOOL 99408b22553d8b4bea5df75750aea2339800ad45b7497eae1afdc79e11be256f0e79d29fe879ef4bc8992817178850058ee361fa4ac5a4b2213f09a6fa825cb2
+DIST libvirt-glib-0.2.2.tar.gz 853052 SHA256 d7be16025231c91ccae43838b7cdb1d55d181856a2a50b0f7b1c5078ad202d9d SHA512 77adcf74dd057b8c5e3c21e1fbe0a99eedbe0005d0247c0173bce69e4e6209dbffe18c7a2f0de9a4c279f138ab5bcc360c14cc2335d0b2b55f22b5819c3e5b70 WHIRLPOOL 628d76cf20fe0b707a56688ad4f17c2c95b12b89fe89f4628e42cee2e8c5855aeac0e06ad45fe71fb63ae935b1ff7a17ee69f294b8358653f7cbcd03aea59876
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.2.2.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.2.2.ebuild
new file mode 100644
index 000000000000..a5ccb744bdff
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( introspection )
+"
+
+# https://bugzilla.redhat.com/show_bug.cgi?id=1093633
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-1.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_with python)
+}