summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2016-02-16 17:50:46 -0600
committerRyan Hill <rhill@gentoo.org>2016-02-16 17:51:08 -0600
commitef9003abf6bfae6ec8ba8ee54a1bdc785a53f6f9 (patch)
tree519ea4404fbc9af3ef9895666685683a54fa2d40
parentMerge remote-tracking branch 'github/pr/868'. (diff)
downloadgentoo-ef9003abf6bfae6ec8ba8ee54a1bdc785a53f6f9.tar.gz
gentoo-ef9003abf6bfae6ec8ba8ee54a1bdc785a53f6f9.tar.bz2
gentoo-ef9003abf6bfae6ec8ba8ee54a1bdc785a53f6f9.zip
app-pda/barry: Build with -std=c++11 for libsigc++ compatibility (bug #566910).
Package-Manager: portage-2.2.27
-rw-r--r--app-pda/barry/barry-0.18.3.ebuild8
-rw-r--r--app-pda/barry/files/barry-0.18.4-shared_ptr.patch25
2 files changed, 31 insertions, 2 deletions
diff --git a/app-pda/barry/barry-0.18.3.ebuild b/app-pda/barry/barry-0.18.3.ebuild
index 09e88fbcdc64..0e72f701fc46 100644
--- a/app-pda/barry/barry-0.18.3.ebuild
+++ b/app-pda/barry/barry-0.18.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit bash-completion-r1 eutils gnome2-utils udev
+inherit bash-completion-r1 eutils flag-o-matic gnome2-utils udev
DESCRIPTION="Sync, backup, program management, and charging for BlackBerry devices"
HOMEPAGE="http://www.netdirect.ca/software/packages/barry/"
@@ -36,6 +36,10 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog KnownBugs NEWS README TODO )
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.18.4-shared_ptr.patch
+
+ append-cxxflags -std=c++11
+
sed -i -e 's:plugdev:usb:g' "${S}"/udev/99-blackberry-perms.rules || die
sed -i -e '/Icon/s:=.*:=barry:' "${S}"/menu/*.desktop || die
}
diff --git a/app-pda/barry/files/barry-0.18.4-shared_ptr.patch b/app-pda/barry/files/barry-0.18.4-shared_ptr.patch
new file mode 100644
index 000000000000..dbccfe66ea21
--- /dev/null
+++ b/app-pda/barry/files/barry-0.18.4-shared_ptr.patch
@@ -0,0 +1,25 @@
+With -std=c++-11 shared_ptr is available in the standard library so pulling in
+the std::tr1 namespace creates an ambiguous reference. Simple fix is to stop
+doing that but isn't backwards compatible. We don't care in Gentoo since we'll
+always be building barry with -std=c++11 due to libsigc++ abi compatibility.
+
+--- a/tools/bio.cc
++++ b/tools/bio.cc
+@@ -42,7 +42,6 @@
+ #include "i18n.h"
+
+ using namespace std;
+-using namespace std::tr1;
+ using namespace Barry;
+
+ // keeping a record of all the -i device / -o device pin numbers, so
+--- a/tools/btool.cc
++++ b/tools/btool.cc
+@@ -59,7 +59,6 @@
+ #include "barrygetopt.h"
+
+ using namespace std;
+-using namespace std::tr1;
+ using namespace Barry;
+
+ std::map<std::string, std::string> SortKeys;