summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-15 19:32:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-15 19:32:07 +0000
commitf2a50df0bd9c4b81d22dc86a39f7938f5f87c858 (patch)
tree1dfc60cf29594e9055d5129729ac93275a3019de
parentapp-emulation/qemu: add myself to maintainers (diff)
downloadgentoo-f2a50df0bd9c4b81d22dc86a39f7938f5f87c858.tar.gz
gentoo-f2a50df0bd9c4b81d22dc86a39f7938f5f87c858.tar.bz2
gentoo-f2a50df0bd9c4b81d22dc86a39f7938f5f87c858.zip
dev-haskell/pango: tweak for Cabal-1.24
Use older deprecated (but still available) cabal helpers. Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/702986 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/pango/files/pango-0.13.6.1-cabal-1.24.patch33
-rw-r--r--dev-haskell/pango/pango-0.13.6.1.ebuild2
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/pango/files/pango-0.13.6.1-cabal-1.24.patch b/dev-haskell/pango/files/pango-0.13.6.1-cabal-1.24.patch
new file mode 100644
index 000000000000..fbe18552e3e5
--- /dev/null
+++ b/dev-haskell/pango/files/pango-0.13.6.1-cabal-1.24.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/702986
+
+--- a/Setup.hs
++++ b/Setup.hs
+@@ -8,7 +8,7 @@ import Distribution.Simple ( defaultMainWithHooks, UserHooks(postConf),
+ import Gtk2HsSetup ( gtk2hsUserHooks, getPkgConfigPackages)
+ import Distribution.Simple.Setup ( ConfigFlags(configVerbosity), fromFlag)
+ import Distribution.Simple.LocalBuildInfo ( LocalBuildInfo(..) )
+-import Distribution.Simple.BuildPaths ( autogenPackageModulesDir )
++import Distribution.Simple.BuildPaths ( autogenModulesDir )
+ import Distribution.Text ( display )
+ import Distribution.Version ( Version(..) )
+ import Distribution.Verbosity
+@@ -49,7 +49,7 @@ writePangoVersionHeaderFile verbosity lbi (Version (major:minor:micro:_) []) = d
+ , "#define PANGO_VERSION_MICRO " ++ show micro
+ ]
+ where
+- targetDir = autogenPackageModulesDir lbi
++ targetDir = autogenModulesDir lbi
+ targetFile = targetDir </> "hspangoversion.h"
+
+ writeVersionHeaderFile _ _ version =
+--- a/Setup.hs
++++ b/Setup.hs
+@@ -43,7 +43,7 @@ writePangoVersionHeaderFile verbosity lbi (versionNumbers -> (major:minor:micro:
+ writePangoVersionHeaderFile verbosity lbi (Version (major:minor:micro:_) []) = do
+ #endif
+ createDirectoryIfMissingVerbose verbosity True targetDir
+- rewriteFileEx verbosity targetFile $ unlines
++ rewriteFile targetFile $ unlines
+ [ "#define PANGO_VERSION_MAJOR " ++ show major
+ , "#define PANGO_VERSION_MINOR " ++ show minor
+ , "#define PANGO_VERSION_MICRO " ++ show micro
diff --git a/dev-haskell/pango/pango-0.13.6.1.ebuild b/dev-haskell/pango/pango-0.13.6.1.ebuild
index 8f7055b24914..24af52382b9a 100644
--- a/dev-haskell/pango/pango-0.13.6.1.ebuild
+++ b/dev-haskell/pango/pango-0.13.6.1.ebuild
@@ -30,3 +30,5 @@ DEPEND="${RDEPEND}
>=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
virtual/pkgconfig
"
+
+PATCHES=("${FILESDIR}"/${P}-cabal-1.24.patch)