summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-10 13:08:06 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-10 13:08:24 +0100
commitf2aad8a949f1e7c0ff94d1c9192c246481d78417 (patch)
treeb38de8230c970e63770eaf765a5bbd757adecd35
parentapp-misc/freeplane: Update Manifest to final tarball. (diff)
downloadgentoo-f2aad8a949f1e7c0ff94d1c9192c246481d78417.tar.gz
gentoo-f2aad8a949f1e7c0ff94d1c9192c246481d78417.tar.bz2
gentoo-f2aad8a949f1e7c0ff94d1c9192c246481d78417.zip
media-libs/kvazaar: Bump to 1.1.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--media-libs/kvazaar/Manifest1
-rw-r--r--media-libs/kvazaar/kvazaar-1.1.0.ebuild58
-rw-r--r--media-libs/kvazaar/kvazaar-9999.ebuild4
3 files changed, 61 insertions, 2 deletions
diff --git a/media-libs/kvazaar/Manifest b/media-libs/kvazaar/Manifest
index 63b16fc72fa4..97f0d7f0d2c4 100644
--- a/media-libs/kvazaar/Manifest
+++ b/media-libs/kvazaar/Manifest
@@ -1,3 +1,4 @@
DIST greatest-1.2.1.tar.gz 19792 SHA256 e3c1211ec5dfea61092833bca56c6a14620ac23aa0d53940d99943587cbe1677 SHA512 c17162fa222c84fef7826ba5202aae573d516a71bc2c59c8991db2a76f7069ed53d00aaab1b792e0c7e4243fae38183764c2e7ae0a61faf2ff13e78b29ccc211 WHIRLPOOL b4e01659539e02224d5396609ba73715eca1391e9da165ac22cf28f25c13cf89a9c4059cfe3f88e1d88d06e35153f7d1d3e012433b9b4f4deaa2a464e6d6b7ca
DIST kvazaar-0.8.3.tar.gz 429852 SHA256 a5cebc313bc2edcf631684e67c33227e56d803bfbc940cf8c2f3906b4f543a12 SHA512 7de2c311c75b77d1f9a95f1de79212560b86bd6f8d7ae743240ff33cec52ecb2837be7984f12fe617560445838381ada245196bf1bf67eeb3861f025998fdf60 WHIRLPOOL 1fdcf9835aca8a4d4261c184e957abcc4fa21df5e3d0520a63e95dfc800d086dc6ae5f70fc4110db232a013f84205230f1c5e2043f57db21cc100b33ef504d05
DIST kvazaar-1.0.0.tar.gz 473495 SHA256 40eb7b4b23897299e99050f0c011e9380cf898b25615dd143f018b278b972a46 SHA512 94939e9560e82543c0f3a8de6f45e228156544b56cc3ce813385e24d52f5a7b65950f6f752344930951440255ca96c06e93e87ff9e721d7c63d82a7a5714c340 WHIRLPOOL ed0c6332c5a1efa88b569845f2cb5436881c3866e381369d770a3393d61e37605ad5c114dcbdae424035f451ceea5ab1ee0787769c9bf44fc44bbd2815e87ed7
+DIST kvazaar-1.1.0.tar.gz 484601 SHA256 8e382738a51004bfcfca4c832e8b41fe6a17f889f3c39151dc1c1a37261a3a6d SHA512 72cee44e32c76c0a94acf33347457145d3f88d644fb4703588d0db6bff1c7064c9b623034efe4ba39219150767012544e4f45141b6a6183d41e4a29c6cb258b9 WHIRLPOOL c37df11389c237af2c31cfcdbb6244c7e87f4d95f5550ee46e5f27c6eca39dd0328aaa81fbef3d555fc869072ac2226efb71566b7ca7ddda11bab3508d1f2caf
diff --git a/media-libs/kvazaar/kvazaar-1.1.0.ebuild b/media-libs/kvazaar/kvazaar-1.1.0.ebuild
new file mode 100644
index 000000000000..6de1ffe08b07
--- /dev/null
+++ b/media-libs/kvazaar/kvazaar-1.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+
+GREATEST_PV="1.2.1"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
+fi
+
+inherit eutils multilib autotools multilib-minimal toolchain-funcs ${SCM}
+
+DESCRIPTION="An open-source HEVC encoder"
+HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+# subslot = libkvazaar major
+SLOT="0/3"
+IUSE="static-libs test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+REQUIRED_USE="test? ( static-libs )"
+
+ASM_DEP=">=dev-lang/yasm-1.2.0"
+DEPEND="${DEPEND}
+ abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )"
+
+src_prepare() {
+ eautoreconf
+ if use test && [ "${PV#9999}" = "${PV}" ]; then
+ # https://bugs.gentoo.org/show_bug.cgi?id=595932
+ rmdir "${S}/greatest" || die
+ mv "${WORKDIR}/greatest-${GREATEST_PV}" "${S}/greatest" || die
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --docdir "/usr/share/doc/${PF}" \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete
+}
diff --git a/media-libs/kvazaar/kvazaar-9999.ebuild b/media-libs/kvazaar/kvazaar-9999.ebuild
index 003b42f8a078..6de1ffe08b07 100644
--- a/media-libs/kvazaar/kvazaar-9999.ebuild
+++ b/media-libs/kvazaar/kvazaar-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,7 +20,7 @@ HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"
if [ "${PV#9999}" = "${PV}" ] ; then
SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
- KEYWORDS="~amd64 ~ppc"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
fi
LICENSE="LGPL-2.1"