summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 19:13:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:30:20 +0200
commitf32993ffdc9a5be6b13ed5e5a87e6f09f0bc8d88 (patch)
treef0e8d71cc5109e64e45ab400f5e43890ece2195f
parentdev-ros/rospy: bump eapi (diff)
downloadgentoo-f32993ffdc9a5be6b13ed5e5a87e6f09f0bc8d88.tar.gz
gentoo-f32993ffdc9a5be6b13ed5e5a87e6f09f0bc8d88.tar.bz2
gentoo-f32993ffdc9a5be6b13ed5e5a87e6f09f0bc8d88.zip
dev-ros/rospy: Remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/rospy/Manifest2
-rw-r--r--dev-ros/rospy/files/yaml.patch53
-rw-r--r--dev-ros/rospy/rospy-1.14.3-r1.ebuild34
-rw-r--r--dev-ros/rospy/rospy-1.15.4.ebuild33
4 files changed, 0 insertions, 122 deletions
diff --git a/dev-ros/rospy/Manifest b/dev-ros/rospy/Manifest
index e7119a998e05..5d86517495e4 100644
--- a/dev-ros/rospy/Manifest
+++ b/dev-ros/rospy/Manifest
@@ -1,3 +1 @@
-DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
-DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
diff --git a/dev-ros/rospy/files/yaml.patch b/dev-ros/rospy/files/yaml.patch
deleted file mode 100644
index e9e9aa8202a9..000000000000
--- a/dev-ros/rospy/files/yaml.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 29053c4832229efa7160fb944c05e3bc82e11540 Mon Sep 17 00:00:00 2001
-From: Martijn Buijs <Martijn.buijs@gmail.com>
-Date: Tue, 23 Apr 2019 18:20:12 +0200
-Subject: [PATCH] Switch to yaml.safe_load(_all) to prevent YAMLLoadWarning
- (#1688)
-
-* Switch to yaml.safe_load(_all) to prevent YAMLLoadWarning
-
-* Change all usages of yaml.load to yaml.safe_load
-
-* Extend PyYAML's SafeLoader and use it with `yaml.load`
-
-Also added convenience functions for using this loader for reuse in
-`roslaunch`
-
-* fix typo in rosparam.yaml_load_all
-
-* Modify Loader and SafeLoader in yaml module directly
-
-* Revert whitespace change
-
-* Revert unrelated change to import through global variable construction
----
- clients/rospy/src/rospy/client.py | 2 +-
- .../test/test_roslib_message.py | 2 +-
- .../client_verification/test_slave_api.py | 2 +-
- test/test_rosparam/test/check_rosparam.py | 8 ++---
- .../check_rosparam_command_line_online.py | 2 +-
- .../check_rosservice_command_line_online.py | 4 +--
- test/test_rostopic/test/test_rostopic_unit.py | 30 +++++++++----------
- tools/rosbag/src/rosbag/bag.py | 2 +-
- tools/rosgraph/src/rosgraph/roslogging.py | 2 +-
- tools/roslaunch/src/roslaunch/loader.py | 4 +--
- .../test/unit/test_roslaunch_dump_params.py | 4 +--
- tools/rosparam/src/rosparam/__init__.py | 7 ++++-
- tools/rosservice/src/rosservice/__init__.py | 4 +--
- tools/rostopic/src/rostopic/__init__.py | 6 ++--
- tools/topic_tools/scripts/relay_field | 2 +-
- 15 files changed, 43 insertions(+), 38 deletions(-)
-
-diff --git a/clients/rospy/src/rospy/client.py b/clients/rospy/src/rospy/client.py
-index d543c53ac..c72d6d6f0 100644
---- a/clients/rospy/src/rospy/client.py
-+++ b/clients/rospy/src/rospy/client.py
-@@ -101,7 +101,7 @@ def load_command_line_node_params(argv):
- src, dst = [x.strip() for x in arg.split(rosgraph.names.REMAP)]
- if src and dst:
- if len(src) > 1 and src[0] == '_' and src[1] != '_':
-- mappings[src[1:]] = yaml.load(dst)
-+ mappings[src[1:]] = yaml.safe_load(dst)
- return mappings
- except Exception as e:
- raise rospy.exceptions.ROSInitException("invalid command-line parameters: %s"%(str(e)))
diff --git a/dev-ros/rospy/rospy-1.14.3-r1.ebuild b/dev-ros/rospy/rospy-1.14.3-r1.ebuild
deleted file mode 100644
index 72153d4c7f54..000000000000
--- a/dev-ros/rospy/rospy-1.14.3-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
-ROS_SUBDIR=clients/${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Python client library for ROS"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/roscpp[${PYTHON_USEDEP}]
- dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/yaml.patch" )
-
-src_install() {
- ros-catkin_src_install
- # Other tests need these nodes
- exeinto /usr/share/${PN}
- doexe test_nodes/*
-}
diff --git a/dev-ros/rospy/rospy-1.15.4.ebuild b/dev-ros/rospy/rospy-1.15.4.ebuild
deleted file mode 100644
index ed13430b1e69..000000000000
--- a/dev-ros/rospy/rospy-1.15.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
-ROS_SUBDIR=clients/${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Python client library for ROS"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/roscpp[${PYTHON_USEDEP}]
- dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-src_install() {
- ros-catkin_src_install
- # Other tests need these nodes
- exeinto /usr/share/${PN}
- doexe test_nodes/*
-}