summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 19:47:00 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 21:45:06 -0500
commitf407146cb32f1d077d6329d4e78df0f084edec52 (patch)
tree38666e0eb8ea149ca34380d9accfcd5f9df6f640
parentmate-base/caja: Import 1.10.x from Project:MATE repo (diff)
downloadgentoo-f407146cb32f1d077d6329d4e78df0f084edec52.tar.gz
gentoo-f407146cb32f1d077d6329d4e78df0f084edec52.tar.bz2
gentoo-f407146cb32f1d077d6329d4e78df0f084edec52.zip
mate-extra/mate-polkit: Import 1.10.x from Project:MATE repo
Package-Manager: portage-2.2.26
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.10.3.ebuild52
-rw-r--r--mate-extra/mate-polkit/metadata.xml4
3 files changed, 57 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
index 602a1f472017..da477acf12cb 100644
--- a/mate-extra/mate-polkit/Manifest
+++ b/mate-extra/mate-polkit/Manifest
@@ -1 +1,2 @@
+DIST mate-polkit-1.10.3.tar.xz 324732 SHA256 fb829c28da0ba99eddfe3c9440852a301462e95377d064bce9a68a5d2314b20d SHA512 39d5af5d8f1f1db1f45bbbba3b1a21754fb59f1f2682e46008cd3cfedacf22dcb0bca5175d59897206c5a2a17c6a6b4daa132ce8a96462504651884afba25ce6 WHIRLPOOL 08e614fbfd5fab0717b4a981d246127a68ae43d0827e0bc0bec83ed742a7ca35e824e3aaa4daa1756587433ceb5d5d323732310edac9dde381ff56881552ca70
DIST mate-polkit-1.8.0.tar.xz 324960 SHA256 bc01640c63f6248497ca78c3d8df8ff608d8bf1fbfce7c11416b014a109aeccd SHA512 6e7324c539f86a906cd192f8e6a17c417717ae80c0b9d8d46907f1e911f364f73933365520469bbed3201287ae897d8055a7fa14b103ade8e6c7cee9e30912cf WHIRLPOOL b3243bd5814e2d156fd85a376294f1c102dd8661e8716e2007291a9513429202b11ff15bbb53a5b33ea5a9cabac559836374778b99627767973f935a05617d6f
diff --git a/mate-extra/mate-polkit/mate-polkit-1.10.3.ebuild b/mate-extra/mate-polkit/mate-polkit-1.10.3.ebuild
new file mode 100644
index 000000000000..8e2f78332a74
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.10.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+HOMEPAGE="https://github.com/mate-desktop/mate-polkit"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="accountsservice appindicator +introspection"
+
+RDEPEND=">=dev-libs/glib-2.36:2
+ >=sys-auth/polkit-0.102:0[introspection?]
+ >=x11-libs/gtk+-2.24:2[introspection?]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ virtual/libintl:0
+ accountsservice? ( sys-apps/accountsservice:0[introspection?] )
+ appindicator? ( dev-libs/libappindicator:2 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:0 )"
+
+# We call gtkdocize so we need to depend on gtk-doc.
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-1.3:0
+ >=dev-util/intltool-0.35:*
+ >=mate-base/mate-common-1.10:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ !<gnome-extra/polkit-gnome-0.102:0"
+
+# Entropy PMS specific. This way we can install the pkg into the build chroots.
+ENTROPY_RDEPEND="!lxde-base/lxpolkit"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator) \
+ $(use_enable introspection)
+}
+
+DOCS="AUTHORS HACKING NEWS README"
diff --git a/mate-extra/mate-polkit/metadata.xml b/mate-extra/mate-polkit/metadata.xml
index f57e72dcf633..a32febb6af55 100644
--- a/mate-extra/mate-polkit/metadata.xml
+++ b/mate-extra/mate-polkit/metadata.xml
@@ -8,4 +8,8 @@
<upstream>
<remote-id type="github">mate-desktop/mate-polkit</remote-id>
</upstream>
+ <use>
+ <flag name="accountsservice">Support extraction of data from AccountsService</flag>
+ <flag name="appindicator">Add support for AppIndicator</flag>
+ </use>
</pkgmetadata>