summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-18 17:27:35 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-18 17:27:51 -0600
commitf46ea06d6d147b8230a2fbe5e7941fcd8cf5f1bd (patch)
tree40a16f9f936fd04fb0eb701532faa06558303109
parentwww-apps/roundup: x86 stable (bug #705724) (diff)
downloadgentoo-f46ea06d6d147b8230a2fbe5e7941fcd8cf5f1bd.tar.gz
gentoo-f46ea06d6d147b8230a2fbe5e7941fcd8cf5f1bd.tar.bz2
gentoo-f46ea06d6d147b8230a2fbe5e7941fcd8cf5f1bd.zip
app-admin/rasdaemon: 0.6.5 bump
Fixes: https://bugs.gentoo.org/642016 Fixes: https://bugs.gentoo.org/705706 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/rasdaemon/Manifest1
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.5.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/rasdaemon/Manifest b/app-admin/rasdaemon/Manifest
index 7d14f3d50523..a1fcfc65ec65 100644
--- a/app-admin/rasdaemon/Manifest
+++ b/app-admin/rasdaemon/Manifest
@@ -1,2 +1,3 @@
DIST rasdaemon-0.6.1.tar.bz2 363201 BLAKE2B bdc7ec3c2e7e4b2fee02dddc55b5afd82df64717f45da15dbfd5fee87721b80ac425af5806ee7462cad29c6ab2953a2e649c4b1e455983d8821a1f633d76c85d SHA512 a221a7ea0e4555befbf8acb9d4ce22d5cc7861a0da458111a24905fa06be0e8f3b18d8de5334310a423657febc0532d2705236de89cb1788302bf487ede29f60
DIST rasdaemon-0.6.2.tar.bz2 375140 BLAKE2B fd22185172777865120fbd13b7bfb5db9b9b0348fe8575ca6b5f16fd662c1e847729e239342b1c9ece70a4e79ad00352bb69d9f80cfbc8da2c961e68874dd03b SHA512 d8c1ee2cc801124837b3a0739f3016a206165306e300ce51e6aac2cef56bb65479f96cdb019ba3a5cffeba94e7b67ca22686d4ac94bfa8a8a1145db6ba51096b
+DIST rasdaemon-0.6.5.tar.bz2 403435 BLAKE2B bc6fa1aea6a6f0190a4f26df936f0ceb4c9b2ae00183ad9239430a018d9c8178e54b016a0aa9d22d97d851b59321b4a27cad7196f1fc22790d15a19c9c06f6e6 SHA512 aa781f3148ae32c8bc7ff8007574912454180725b9b102e1c7c583101dd1fd96debbdc78f3f2a35db45df359c7547cad4d87b490af66f444341c0dc8429c1310
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.5.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.5.ebuild
new file mode 100644
index 000000000000..37e14a241e64
--- /dev/null
+++ b/app-admin/rasdaemon/rasdaemon-0.6.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Reliability, Availability and Serviceability logging tool"
+HOMEPAGE="http://www.infradead.org/~mchehab/rasdaemon/"
+SRC_URI="http://www.infradead.org/~mchehab/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sqlite"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ sys-devel/gettext
+ sys-apps/dmidecode
+ sqlite? (
+ dev-db/sqlite
+ dev-perl/DBD-SQLite
+ )
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ local CONFIG_CHECK="~ACPI_EXTLOG"
+ check_extra_config
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable sqlite sqlite3)
+ --enable-abrt-report
+ --enable-aer
+ --enable-arm
+ --enable-extlog
+ --enable-hisi-ns-decode
+ --enable-mce
+ --enable-non-standard
+ --enable-devlink
+ --enable-diskerror
+ --includedir="/usr/include/${PN}"
+ --localstatedir=/var
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ keepdir "/var/lib/${PN}"
+
+ systemd_dounit misc/*.service
+
+ newinitd "${FILESDIR}/rasdaemon.openrc-r2" rasdaemon
+ newinitd "${FILESDIR}/ras-mc-ctl.openrc-r1" ras-mc-ctl
+ newconfd "${FILESDIR}"/rasdaemon.confd rasdaemon
+}