summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-24 01:00:52 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-24 01:01:12 +0200
commitf7b098a7a4ea48150fceb7512ae8ccd9e2cab574 (patch)
tree6b2c76ee8ed1591b84fbcfb6b7298dd929b21c23
parentkernel-2.eclass: Add support for gcc 9.1 CPU optimization patch (diff)
downloadgentoo-f7b098a7a4ea48150fceb7512ae8ccd9e2cab574.tar.gz
gentoo-f7b098a7a4ea48150fceb7512ae8ccd9e2cab574.tar.bz2
gentoo-f7b098a7a4ea48150fceb7512ae8ccd9e2cab574.zip
media-sound/mpg123: Bump to version 1.25.12
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-sound/mpg123/Manifest1
-rw-r--r--media-sound/mpg123/mpg123-1.25.12.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index 0cce7887ad86..548424894c27 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,2 +1,3 @@
DIST mpg123-1.25.10.tar.bz2 921219 BLAKE2B 04bfbe8915e3943ed42cc2d3597b0bd9c4686f77ee699f5845e7d1e905022206724cf23d6b0420a36e64b232f840dd9367f46f3c00dc2fe6256f44e8b83fa5b2 SHA512 a33666ae4aca7e7c1a93a6414d8c525ec19044c54f712d578180147d88e63033f7af2370b9ad22960cc3a0b454f15967b7a831cccc97e034c8855f70cdf1ab09
DIST mpg123-1.25.11.tar.bz2 909478 BLAKE2B e821826c91acd3c0b4b9e6b83df6c5625f86611ecfdedd2dcc12b0ce8b3389199aa4cf7eea48b597e5b7f740bbe2c7612d27e75897e34bed2a2407e98b2b7a43 SHA512 986338d0f4829ec9e40990cb384746c7abfa80d3b3d5656b6dda73d03e2441c1f28ffbe7f3f82b0008a1c4ebcfa07aeffb493e95f13f7d04cbc818a09f1008ed
+DIST mpg123-1.25.12.tar.bz2 910149 BLAKE2B 4e1b6329fafb4d1e018c6f5fc0846480ef8cfb6811f92d745f7e88d45fa6a8704ad707d110b12709763ac79fe095603c8ece0bbecb54cc2cde4de819083a2078 SHA512 fa3c719c68dbe45b265fd7677d0932b07f6a14e7ffe365ede965ff1637e655c4b57c86f7e4cd60cace7df5fcc93d48e0d44f082931394b7c6ef19f5d11638eff
diff --git a/media-sound/mpg123/mpg123-1.25.12.ebuild b/media-sound/mpg123/mpg123-1.25.12.ebuild
new file mode 100644
index 000000000000..b0eac0164fa8
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.25.12.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="https://www.mpg123.org/"
+SRC_URI="https://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext alsa altivec coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+RDEPEND="
+ app-eselect/eselect-mpg123
+ dev-libs/libltdl:0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+pkg_setup() {
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+}
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ if $(multilib_is_native_abi) ; then
+ local flag
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+ fi
+
+ use altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext #bug 164504
+ _cpu=generic_fpu
+ elif use x86-macos ; then
+ # ASM doesn't work quite as expected with the Darwin linker
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=(
+ --with-optimization=0
+ --with-audio="${_audio}"
+ --with-default-audio=${_output}
+ --with-cpu=${_cpu}
+ --enable-network
+ $(use_enable ipv6)
+ --enable-int-quality=$(usex int-quality)
+ )
+ multilib_is_native_abi || myconf+=( --disable-modules )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}