summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-15 13:52:55 +0200
committerJeroen Roovers <jer@gentoo.org>2017-10-15 13:52:55 +0200
commitfa3c4862b23c23639467b3ae6c7b8c96130c0ed8 (patch)
treea966381a81942c0aeda0423d9cbc8ef350d2a8bc
parentkde-misc/tellico: version bump 3.1 (diff)
downloadgentoo-fa3c4862b23c23639467b3ae6c7b8c96130c0ed8.tar.gz
gentoo-fa3c4862b23c23639467b3ae6c7b8c96130c0ed8.tar.bz2
gentoo-fa3c4862b23c23639467b3ae6c7b8c96130c0ed8.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.10.15.1.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index ef9116fb301b..009ab62396fb 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec7
DIST youtube-dl-2017.09.24.tar.gz 2810181 SHA256 7d7140ce63377e84a2072b4922809c7a2e90e3916cde2f4f1cc8860664395548 SHA512 de96406aeabb993a39941f5c67947fd1b77ec003be36b215cb3df1e5c90d63c7c570a5ca7627f5b2faae6a15ee07d45cf339cac6b511890acf49c5c38e6c5672 WHIRLPOOL e248990cce1bcbe50ae9e0ac6a95d760948809ec371b93126011d71599e721f1e9b0784690b832d3c5c04fb55c048b08c091193f821b18e1211f4c393ab2d017
DIST youtube-dl-2017.10.01.tar.gz 2813364 SHA256 0b4f0e12b099c46ad47597764b10f45ceae3935834abf99d49ccd8cfb48dff10 SHA512 f1eafecb2418276df7e7bdb73402779521197f551be3431eda9727390884d42c50a73895d0c58fc3783ab04712e4bf5aa072dad6d3241724e19e6c4c80c0080d WHIRLPOOL 281b7cdb288c1890e785d15cf1aa7c1f8e33976c521559551924b0f18b26981fb33a0b60ff86df796613ef34d273a13b3ada3c5f3e851534dad4bf124260f509
DIST youtube-dl-2017.10.07.tar.gz 2816312 SHA256 d9a8935087c1e2fa3307594ae15f1e9ea0f8676e825fa676a50a3a3d471bba83 SHA512 4842c8b324a10a4eff398226749ff8394ca60cf1e47873c1dfb5cf9828b77772670ea30891f32b26bab421aa0e7ca95e2815e062061a2cbaf22e6c5f76e1d87d WHIRLPOOL 525eb2eb3f18bf5ed1776f1a4d43dd010793b3b1681f27b3ed4ed4afdbd0c3dcd2c18b8e532de1fa3c318ac6a5f186c0bdf60fa4c7c69fe939335a7235679c3c
+DIST youtube-dl-2017.10.15.1.tar.gz 2820437 SHA256 da6ae68b2fbe81da7cf4ac6b989fa7bf27b3beb214eed551d466cc6e41d7297f SHA512 6093747f732dac4eda4c71d334ed01fc24ba70d29e5660c38ff795861f06c4029441c3a4576e6a5463974488aeb7732687e5634481c8b04127f77499a2405a1c WHIRLPOOL cc8fca27f2a110fde556e6c6506a88715d4e4a03c971b7e74e77a91a5b28916c66146afd6e476a19aca2fff3270719da102d254a05f62dbabb5dc2a10040d839
diff --git a/net-misc/youtube-dl/youtube-dl-2017.10.15.1.ebuild b/net-misc/youtube-dl/youtube-dl-2017.10.15.1.ebuild
new file mode 100644
index 000000000000..975ce26c347e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.10.15.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex motherless myvidster
+ porn91 porncom pornflip pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}