summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-09-09 00:07:58 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-09-14 21:01:08 +0100
commitfa5358d386302bca9be6a056cfe67891c78ed11e (patch)
tree9600f290d0e45b30e4070b65224456abb0221da3
parentmedia-libs/libgig: 4.1.0 version bump, EAPI-7, use https (diff)
downloadgentoo-fa5358d386302bca9be6a056cfe67891c78ed11e.tar.gz
gentoo-fa5358d386302bca9be6a056cfe67891c78ed11e.tar.bz2
gentoo-fa5358d386302bca9be6a056cfe67891c78ed11e.zip
sys-power/acpid: add new version 2.0.30
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--sys-power/acpid/Manifest1
-rw-r--r--sys-power/acpid/acpid-2.0.30.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-power/acpid/Manifest b/sys-power/acpid/Manifest
index f9dc14c01973..bf09e90723c8 100644
--- a/sys-power/acpid/Manifest
+++ b/sys-power/acpid/Manifest
@@ -1,3 +1,4 @@
DIST acpid-2.0.28.tar.xz 156036 BLAKE2B a6a78f82f7f4ecbd0d883d175c921195970e157a919fefc9cf48a94db534b496a8570c031fda5b08df3fb1775e26a50b5942bac7717aa582d590605930e3af78 SHA512 effe9c3b30b4a6ea20eca4b36a06d4b3da9b262d100685958faec4b38f89377a87dcaecee7a69b87aaddfa47688bcc46fc47a38391ac4bd2019cb3b48ab18fcb
DIST acpid-2.0.29.tar.xz 155568 BLAKE2B 9a2c9f2f8ba035bf7452b633c20a73796ca05d4849d567f076a08a8216f2e07ca7a0b25e995054697e70bacacad07872e153c6c47f8204294964b276bca49f62 SHA512 5f480cb4456b6b843adb239519a8d05f83c3c668525457e55d7fae2ba7725356ec7a1faa16bbd54086f0eab2e8ca20952180c00b2b65a27eda534c3f28e8ed17
+DIST acpid-2.0.30.tar.xz 155528 BLAKE2B cbf387dc6342e0f4256360e99c02f8ebf4c322cd1c1dbd4ff0fcf703a323b90cfb0eb256233917dbdb81cd9a5f9bd075c581de9daee3d3a311208553084a093e SHA512 6901e93cc626817b782e43976caf4b7f89e8c4275eb7e9d31aeeb967b5d5bbb6a2b4dcf71e72ba666e10343cdbdbe8528feee955af5ba14de8ec88ef61b29f96
DIST sys-power_acpid_2.0.29-r1_extras.tar.xz 2548 BLAKE2B 4568f0e44d33382fd294248d48c8852f689f0a6082d9b74b33b77918d3ce21d7f1bf8a3aafeaa252e8fe170b3829155344a256f01fe80414369f02d50a17ff55 SHA512 f2c366c50c75790df32a1f6573b7de640fd09a97c4598155ebd0aad2eba118961ddc82fe0fbb4dc935aa5b6d7fcfe3ade73fff555b4588b0e4579a1028bef12f
diff --git a/sys-power/acpid/acpid-2.0.30.ebuild b/sys-power/acpid/acpid-2.0.30.ebuild
new file mode 100644
index 000000000000..931b65a63269
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.30.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info systemd
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="https://sourceforge.net/projects/acpid2"
+EXTRAS_VER="2.0.29-r1"
+EXTRAS_NAME="${CATEGORY}_${PN}_${EXTRAS_VER}_extras"
+SRC_URI="mirror://sourceforge/${PN}2/${P}.tar.xz
+ https://dev.gentoo.org/~andrey_utkin/distfiles/${EXTRAS_NAME}.tar.xz
+ "
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-apm )"
+DEPEND=">=sys-kernel/linux-headers-3"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~INPUT_EVDEV"
+ local WARNING_INPUT_EVDEV="CONFIG_INPUT_EVDEV is required for ACPI button event support."
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+pkg_setup() { :; }
+
+PATCHES=(
+)
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newdoc kacpimon/README README.kacpimon
+ dodoc -r samples
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING || die
+
+ exeinto /etc/acpi
+ newexe "${WORKDIR}/${EXTRAS_NAME}/${PN}-1.0.6-default.sh" default.sh
+ exeinto /etc/acpi/actions
+ newexe samples/powerbtn/powerbtn.sh powerbtn.sh
+ insinto /etc/acpi/events
+ newins "${WORKDIR}/${EXTRAS_NAME}/${PN}-1.0.4-default" default
+
+ newinitd "${WORKDIR}/${EXTRAS_NAME}/${PN}-2.0.26-init.d" ${PN}
+ newconfd "${WORKDIR}/${EXTRAS_NAME}/${PN}-2.0.16-conf.d" ${PN}
+
+ systemd_dounit "${WORKDIR}"/${EXTRAS_NAME}/systemd/${PN}.{service,socket}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "https://wiki.gentoo.org/wiki/Power_management/Guide"
+ elog
+ fi
+
+ # files/systemd/acpid.socket -> ListenStream=/run/acpid.socket
+ mkdir -p "${ROOT%/}"/run
+
+ if ! grep -qs "^tmpfs.*/run " "${ROOT%/}"/proc/mounts ; then
+ echo
+ ewarn "You should reboot the system now to get /run mounted with tmpfs!"
+ fi
+}