summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2019-04-03 09:59:48 +0000
committerSven Wegener <swegener@gentoo.org>2019-04-03 10:00:22 +0000
commitfa651edb54b1c065eaad368282b10483d7f931d0 (patch)
treeb96868423108c6b5949f7b432af128f672e12e6e
parentpackage.mask: Revert "Last rite games-roguelike/angband" (diff)
downloadgentoo-fa651edb54b1c065eaad368282b10483d7f931d0.tar.gz
gentoo-fa651edb54b1c065eaad368282b10483d7f931d0.tar.bz2
gentoo-fa651edb54b1c065eaad368282b10483d7f931d0.zip
net-dns/pdns-recursor: Version bump
Signed-off-by: Sven Wegener <swegener@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.1.12.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index ee58629e78d4..15614e1efc77 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,2 +1,3 @@
DIST pdns-recursor-4.1.10.tar.bz2 1238148 BLAKE2B b68e33b40d5f1a680cbbd76c9864439a84416071dc75d658a3988e891da7f6a5d0c197d8dda7ff014a30b7f762bfbe5db4a616a6cad4415fd46db119b51ba70a SHA512 204ea40f5c14d1e589935af4fbd24c102090390d741dbc5ad28f4c20044011f4b2b1c7926d8caaf144a7b2b1680f793e66199c5e9238e926da9fba60c5573dcd
DIST pdns-recursor-4.1.11.tar.bz2 1239986 BLAKE2B 33c9b2a2f811c43b67ad2bddf5a11d5d95cc88679d46ba3513f3eeec97bf7694af493a9fea4f733f003056b5f0fc971112e9062883324102ecca28838e2f3e41 SHA512 6041d31f0a517786f44a7fa22c7bfa94d5d4bdc3a7f349d2b47bc66be87404fe8eaf76f45ca18ef8ab96a45c0271f46fdba93a51fbda2542a3ad96e10f51c1d1
+DIST pdns-recursor-4.1.12.tar.bz2 1245110 BLAKE2B 187fe117ab64f234d144d7e2d91a119afe1d6b0a45079f1f9527724081c64f594c8c5d5b4dbc6e25b4beef1fcdfb3e5caed8e5a434921bf6b66e07617d0fb6f9 SHA512 d228976937ede7e9f6b3375e573f5b436d9df7ae246e411b13acb095a1a58f12173b663acc364ce0fbdcc61b3d5522e101472a88da8f044e44541564f9915d9e
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.1.12.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.1.12.ebuild
new file mode 100644
index 000000000000..c054da53ceed
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.1.12.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libressl luajit protobuf snmp sodium systemd"
+
+DEPEND="!luajit? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:= )
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ $(use_enable systemd) \
+ $(use_enable sodium libsodium) \
+ $(use_with !luajit lua) \
+ $(use_with luajit luajit) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=nobody/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r1 pdns-recursor
+
+ keepdir /var/lib/powerdns
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}