summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-01-26 05:17:02 +0000
committerThomas Deutschmann <whissi@gentoo.org>2019-03-04 01:47:14 +0100
commitfb1a9827eecead7c66d6917f36516e85fb650979 (patch)
tree3aa4b8014f0fb08a80c9d4ae0d305eff4310f8ff
parentmedia-gfx/imagemagick: bump to v6.9.10-30 & v7.0.8-30 (diff)
downloadgentoo-fb1a9827eecead7c66d6917f36516e85fb650979.tar.gz
gentoo-fb1a9827eecead7c66d6917f36516e85fb650979.tar.bz2
gentoo-fb1a9827eecead7c66d6917f36516e85fb650979.zip
app-admin/mongo-tools: bump to 3.6.10
Signed-off-by: Tomas Mozes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.6.10.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 3105cbeafe03..77b75c086d1d 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -1,4 +1,5 @@
DIST mongo-tools-3.4.16.tar.gz 4697191 BLAKE2B 2e9a0e7dc8016d3e7d7c7f8d0cf80a97d3d199603c0b8b791df5a0d79d418ffaa232eee694047a7ca11fa7623023b4123becd437cfe3dec11e26cd525720bcad SHA512 b40c6dee75d860de1da73faf79f5f68c098ce7c80681486c66fff04a937474dcede91c7be907a8e36033b3898f7499e8f53271944c0df3360756c27361efb6f5
+DIST mongo-tools-3.6.10.tar.gz 4731097 BLAKE2B dffd18bbcb5a1d869cd3a00b40be7c83d12c2146944044c8d873eba409b9fcb0ce0595c01cd61a6b0405dfce685b8dde7c285380150906d4d38d3de9b42962bf SHA512 3e9808c6b275566215f8c2ce033a6259d373e8b63db5e981cc28235d757404b3209a64dd9aa8a98d9290c5c1da137a1bf9bc48629b278cb27ca28be681e86efc
DIST mongo-tools-3.6.8.tar.gz 4723878 BLAKE2B a1693024d60f69d25c268eaaa30a478b1e4c0042c5fb7a3fd6252ed00aef2fee3fba94516fe825165a1a57887ed38e4fbce488c48ddd4f45349f0b7a1b244020 SHA512 359e8ce2d847d005d48ff12bc2e8af73213d81cd1521d2b5b5ac94792468218248bebbe808e1bd8fd49234eab8480608f294c1b63f317aed58f456b84ef17dcf
DIST mongo-tools-3.6.9.tar.gz 4723117 BLAKE2B 2cc88b9e8424abe082d68a8f7afa02bf2b21d027cabe04298fafbd065346350d57f6a48ece1a849e779cac6da315aa9d5469c5f63ca5aae6be7e8f73fae3fe4b SHA512 def8e2bb68898c540dfa9fbe742696d463c099e7d70fc2f0e114301d321e3983ef0b07588301340b0a3ffdf2280febc3fa37e77d2520f147e723d2ce147c7261
DIST mongo-tools-4.0.3.tar.gz 10874727 BLAKE2B 3e5d07b8ae797d0876b68a3018806e91a30758415aaa236423648a77f5e0d475848060516ee0da91a8448813a12a685410b93bf219b8180beb91f448e329a532 SHA512 cbe74b3fdebd0d4f6be6e3acf7f55f5f1a551b0ad1a23d82782643d2a9eb9ea4b7e0133985485b8c5a88c1fea26595e3ed9c759f1f63b578b6472d850154d67b
diff --git a/app-admin/mongo-tools/mongo-tools-3.6.10.ebuild b/app-admin/mongo-tools/mongo-tools-3.6.10.ebuild
new file mode 100644
index 000000000000..5aacbbb10637
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.6.10.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${MY_P} "${S}" || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
+ echo "Building $i"
+ GOROOT="${PREFIX}/usr/$(get_libdir)/go" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}