summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-11-07 21:09:54 +0100
committerUlrich Müller <ulm@gentoo.org>2015-11-07 21:10:33 +0100
commitfc0340a364ccc83d679dc6972ddff40a6686bb24 (patch)
tree0f642cae7b69f0475803086ad4e4ca9573dd1a4c
parentgnome-extra/cjs: Drop old (diff)
downloadgentoo-fc0340a364ccc83d679dc6972ddff40a6686bb24.tar.gz
gentoo-fc0340a364ccc83d679dc6972ddff40a6686bb24.tar.bz2
gentoo-fc0340a364ccc83d679dc6972ddff40a6686bb24.zip
dev-tex/vc: Initial import.
Ebuild and patches contributed by me. Package-Manager: portage-2.2.23
-rw-r--r--dev-tex/vc/Manifest1
-rw-r--r--dev-tex/vc/files/vc-0.5-git-date.patch14
-rw-r--r--dev-tex/vc/files/vc-0.5-git-status.patch27
-rw-r--r--dev-tex/vc/metadata.xml16
-rw-r--r--dev-tex/vc/vc-0.5.ebuild33
5 files changed, 91 insertions, 0 deletions
diff --git a/dev-tex/vc/Manifest b/dev-tex/vc/Manifest
new file mode 100644
index 000000000000..fd09128269d9
--- /dev/null
+++ b/dev-tex/vc/Manifest
@@ -0,0 +1 @@
+DIST vc-0.5.zip 440260 SHA256 7f11a41f364c0aa48818b69784fee6356db726d5e55f512a3bea0299f9b1ce0a SHA512 0574bb6e6e7a0a9065cb1042726ac6ff09c4c38b7d05acdaf4fab3023439f5be35af12ec228b285a40e9cd9448f85e16e849d0dd08af743115bdba0556f3b969 WHIRLPOOL ce6f648c4ad90596147af2faffe7be30c13da0d89e7fb99430facda9048ff4d810757a8713741432d820225f34665567e056f5ccd6ef630ed864356edef35c21
diff --git a/dev-tex/vc/files/vc-0.5-git-date.patch b/dev-tex/vc/files/vc-0.5-git-date.patch
new file mode 100644
index 000000000000..f05c857d1026
--- /dev/null
+++ b/dev-tex/vc/files/vc-0.5-git-date.patch
@@ -0,0 +1,14 @@
+Use CommitterDate instead of AuthorDate, because the latter is not
+guaranteed to increase monotonously.
+
+--- vc-orig/git-unix/vc-git.awk
++++ vc/git-unix/vc-git.awk
+@@ -39,7 +39,7 @@
+ ### Standard encoding is UTF-8.
+ if (Encoding == "") Encoding = "UTF-8"
+ ### Extract relevant information from variables.
+- LongDate = substr(AuthorDate, 1, 25)
++ LongDate = substr(CommitterDate, 1, 25)
+ DateRAW = substr(LongDate, 1, 10)
+ DateISO = DateRAW
+ DateTEX = DateISO
diff --git a/dev-tex/vc/files/vc-0.5-git-status.patch b/dev-tex/vc/files/vc-0.5-git-status.patch
new file mode 100644
index 000000000000..7ab998ca40c0
--- /dev/null
+++ b/dev-tex/vc/files/vc-0.5-git-status.patch
@@ -0,0 +1,27 @@
+Output format of "git status" has changed which broke parsing.
+Use "git status --porcelain" instead which is a more stable interface,
+intended for processing by scripts.
+
+--- vc-orig/git-unix/vc
++++ vc/git-unix/vc
+@@ -20,5 +20,5 @@
+ git --no-pager log -1 HEAD --pretty=format:"Hash: %H%nAbr. Hash: %h%nParent Hashes: %P%nAbr. Parent Hashes: %p%nAuthor Name: %an%nAuthor Email: %ae%nAuthor Date: %ai%nCommitter Name: %cn%nCommitter Email: %ce%nCommitter Date: %ci%n" |gawk -v script=log -v full=$full -f vc-git.awk > vc.tex
+ if [ "$mod" = 1 ]
+ then
+- git status |gawk -v script=status -f vc-git.awk >> vc.tex
++ git status --porcelain |gawk -v script=status -f vc-git.awk >> vc.tex
+ fi
+--- vc-orig/git-unix/vc-git.awk
++++ vc/git-unix/vc-git.awk
+@@ -26,9 +26,9 @@
+
+ ### Process output of "git status".
+ ### Changed index?
+-script=="status" && /^# Changes to be committed:/ { modified = 1 }
++script=="status" && /^[MADRC]/ { if (modified == 0) modified = 1 }
+ ### Unstaged modifications?
+-script=="status" && /^# Changed but not updated:/ { modified = 2 }
++script=="status" && /^.[MD]/ { modified = 2 }
+
+
+
diff --git a/dev-tex/vc/metadata.xml b/dev-tex/vc/metadata.xml
new file mode 100644
index 000000000000..42f266d3ea99
--- /dev/null
+++ b/dev-tex/vc/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<maintainer>
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<longdescription>
+ This is a script based approach to version control for TeX documents.
+ It works more reliably than keyword substitution based approaches,
+ since it tracks all files in a working copy, not only .tex files.
+
+ The vc bundle works with LaTeX and plain TeX. Currently, Bazaar, Git
+ and Subversion are supported.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-tex/vc/vc-0.5.ebuild b/dev-tex/vc/vc-0.5.ebuild
new file mode 100644
index 000000000000..8d0b9b6ebbe0
--- /dev/null
+++ b/dev-tex/vc/vc-0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="The vc (version control) bundle"
+HOMEPAGE="https://www.ctan.org/pkg/vc"
+# Taken from http://mirrors.ctan.org/support/vc.zip
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+PATCHES=(
+ "${FILESDIR}"/${P}-git-date.patch
+ "${FILESDIR}"/${P}-git-status.patch
+)
+
+src_compile() { :; }
+
+src_install() {
+ insinto ${TEXMF}/scripts/${PN}
+ doins -r bzr-unix git-unix svn-unix
+ latex-package_src_doinstall pdf
+ dodoc CHANGES README
+}