summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Misbakh-Soloviov <mva@gentoo.org>2023-02-08 22:39:54 +0700
committerVadim Misbakh-Soloviov <mva@gentoo.org>2023-02-08 22:39:54 +0700
commitfca327914eac530d8b37251ba459ae8a454de0e1 (patch)
treeb4683b6336d9025a7fd149666ce41a7f0694502a
parentnet-p2p/transmission: add 4.0.0 (diff)
downloadgentoo-fca327914eac530d8b37251ba459ae8a454de0e1.tar.gz
gentoo-fca327914eac530d8b37251ba459ae8a454de0e1.tar.bz2
gentoo-fca327914eac530d8b37251ba459ae8a454de0e1.zip
app-editors/neovim: fixes (see commit details)
1) lua-version and darwin patches are fixed to not fail 2) no more tui conficuration option, see https://github.com/neovim/neovim/commit/9fdcbbb4063daa125e420e0ffe9dae6801c264bc Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch62
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake_lua_version.patch12
-rw-r--r--app-editors/neovim/neovim-9999.ebuild9
3 files changed, 14 insertions, 69 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
index ad47a46e1a7a..b2920451743d 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -1,65 +1,13 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -80,33 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
- # used for check_c_compiler_flag
- include(CheckCCompilerFlag)
-
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
-- # CMake tries to treat /sw and /opt/local as extension of the system path, but
-- # that doesn't really work out very well. Once you have a dependency that
-- # resides there and have to add it as an include directory, then any other
-- # dependency that could be satisfied from there must be--otherwise you can end
-- # up with conflicting versions. So, let's make them more of a priority having
-- # them be included as one of the first places to look for dependencies.
-- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
--
-- # If the macOS deployment target is not set manually (via $MACOSX_DEPLOYMENT_TARGET),
-- # fall back to local system version. Needs to be done both here and in cmake.deps.
-- if(NOT CMAKE_OSX_DEPLOYMENT_TARGET)
-- execute_process(COMMAND sw_vers -productVersion
-- OUTPUT_VARIABLE MACOS_VERSION
-- OUTPUT_STRIP_TRAILING_WHITESPACE)
-- set(CMAKE_OSX_DEPLOYMENT_TARGET "${MACOS_VERSION}")
-- endif()
-- message("Using deployment target ${CMAKE_OSX_DEPLOYMENT_TARGET}")
--
-- # Work around some old, broken detection by CMake for knowing when to use the
-- # isystem flag. Apple's compilers have supported this for quite some time
-- # now.
-- if(CMAKE_C_COMPILER_ID MATCHES "GNU")
-- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
-- endif()
--endif()
--
- if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- # Ignore case when comparing filenames on Windows and Mac.
- set(CASE_INSENSITIVE_FILENAME TRUE)
---- a/cmake.deps/CMakeLists.txt
-+++ b/cmake.deps/CMakeLists.txt
-@@ -112,13 +112,6 @@ if(CMAKE_CXX_COMPILER)
- set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
- endif()
-
--if(CMAKE_OSX_SYSROOT)
-- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- if(DEPS_CXX_COMPILER)
-- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- endif()
--endif()
--
- if(CMAKE_OSX_ARCHITECTURES)
- string(REPLACE ";" "|" CMAKE_OSX_ARCHITECTURES_ALT_SEP "${CMAKE_OSX_ARCHITECTURES}")
- # The LuaJIT build does not like being passed multiple `-arch` flags
--- a/src/nvim/CMakeLists.txt
+++ b/src/nvim/CMakeLists.txt
-@@ -181,10 +181,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
+@@ -440,10 +440,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
+ foreach(gen_include ${prop})
list(APPEND gen_cflags "-I${gen_include}")
endforeach()
-if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
- list(APPEND gen_cflags "-isysroot")
- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
-endif()
- string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
- separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
- separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
+ set(gen_cflags ${gen_cflags} -O2)
+
+ set(NVIM_VERSION_GIT_H ${PROJECT_BINARY_DIR}/cmake.config/auto/versiondef_git.h)
diff --git a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
index 87a898032493..b14b3b992349 100644
--- a/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake_lua_version.patch
@@ -1,11 +1,11 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
@@ -464,7 +464,7 @@ endif()
+ # The unit test lib requires LuaJIT; it will be skipped if LuaJIT is missing.
option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
-
if(PREFER_LUA)
- find_package(Lua 5.1 EXACT REQUIRED)
+ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
- set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
- set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
- # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.
+ target_include_directories(main_lib SYSTEM BEFORE INTERFACE ${LUA_INCLUDE_DIR})
+ target_link_libraries(main_lib INTERFACE ${LUA_LIBRARIES})
+ # Passive (not REQUIRED): if LUAJIT_FOUND is not set, fixtures for unittests is skipped.
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 6083e311ff39..c35d1e3b8870 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+lto +nvimpager test +tui"
+IUSE="+lto +nvimpager test"
REQUIRED_USE="${LUA_REQUIRED_USE}"
# Upstream say the test library needs LuaJIT
@@ -53,10 +53,8 @@ DEPEND="${LUA_DEPS}
>=dev-libs/libvterm-0.3
>=dev-libs/msgpack-3.0.0:=
>=dev-libs/tree-sitter-0.20.2:=
- tui? (
- >=dev-libs/libtermkey-0.22
- >=dev-libs/unibilium-2.0.0:0=
- )
+ >=dev-libs/libtermkey-0.22
+ >=dev-libs/unibilium-2.0.0:0=
"
RDEPEND="
${DEPEND}
@@ -98,7 +96,6 @@ src_configure() {
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
-DENABLE_LTO=$(usex lto)
- -DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
-DLUA_PRG="${ELUA}"
-DMIN_LOG_LEVEL=3