summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-26 08:41:01 +0200
committerHans de Graaff <graaff@gentoo.org>2023-03-26 08:41:01 +0200
commitfcd503bfb60c2c8813fcaa31a0cb90da10dac53f (patch)
tree519ac6a6eaeed16009d6276244676722078a98ea
parentdev-ruby/ruby_version: enable ruby32 (diff)
downloadgentoo-fcd503bfb60c2c8813fcaa31a0cb90da10dac53f.tar.gz
gentoo-fcd503bfb60c2c8813fcaa31a0cb90da10dac53f.tar.bz2
gentoo-fcd503bfb60c2c8813fcaa31a0cb90da10dac53f.zip
dev-ruby/rspec-stubbed_env: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rspec-stubbed_env/rspec-stubbed_env-1.0.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/rspec-stubbed_env/rspec-stubbed_env-1.0.0-r1.ebuild b/dev-ruby/rspec-stubbed_env/rspec-stubbed_env-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..297d99c991d8
--- /dev/null
+++ b/dev-ruby/rspec-stubbed_env/rspec-stubbed_env-1.0.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+# Gem does not contain tests and upstream releases are not tagged
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Stub environment variables in a scoped context for testing"
+HOMEPAGE="https://github.com/pboling/rspec-stubbed_env"
+IUSE=""
+SLOT="1"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+ruby_add_rdepend ">=dev-ruby/rspec-3.0"