summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-01-25 01:28:11 -0500
committerTim Harder <radhermit@gentoo.org>2017-01-25 01:29:06 -0500
commitfe50051b158b98f8011b8cc0a427a15405410857 (patch)
treea3fed07352bdf8fb7f5890d7ee6ebcb3c1a18221
parentnet-im/bitlbee: drop yahoo support (bug #607126) (diff)
downloadgentoo-fe50051b158b98f8011b8cc0a427a15405410857.tar.gz
gentoo-fe50051b158b98f8011b8cc0a427a15405410857.tar.bz2
gentoo-fe50051b158b98f8011b8cc0a427a15405410857.zip
net-im/bitlbee: remove old
-rw-r--r--net-im/bitlbee/Manifest1
-rw-r--r--net-im/bitlbee/bitlbee-3.4.1.ebuild178
-rw-r--r--net-im/bitlbee/bitlbee-3.5.ebuild168
-rw-r--r--net-im/bitlbee/metadata.xml1
4 files changed, 0 insertions, 348 deletions
diff --git a/net-im/bitlbee/Manifest b/net-im/bitlbee/Manifest
index aa756278aa68..1afab0c06103 100644
--- a/net-im/bitlbee/Manifest
+++ b/net-im/bitlbee/Manifest
@@ -1,3 +1,2 @@
-DIST bitlbee-3.4.1.tar.gz 688072 SHA256 500a0b19943040d67458eb3beb0a63d004abb2aa54a777addeb2a895d4f5c0e1 SHA512 fad297c7a792c932ba74daf7dc894883037842ae5d39a4c831c6615100580073001806c1af60555aa1c775399e8a484d99a4e601e96c6a075e12546e5d153532 WHIRLPOOL 431faa8f065233ee7345d4950d147fea9fc627ba4b78ca0f25bed9627804d3dd4d512a12c9f98bd29a01ebfb680c8cf7e756bb53b38a484b304a0e973c657993
DIST bitlbee-3.4.2.tar.gz 719456 SHA256 69c85554def74f314e3b6e390389a30b0e748f23ef37883e9d7545ee2c45ea57 SHA512 2b839c014cfad037d815aa0e0867dda1b4628ff076d8de6fec1e80ab1499bca565d9afbe104929d492ff68c86b745cc3f76acbeba102766d656f2d359b70302e WHIRLPOOL 43803ba2bbe6297e05e465912d22b0547bb0f9c3cd184a6c0c924dc023b9d505e3666aa732de83c79249e59aa0e2d6f621ee15c508ccc17eed1898b755f0112e
DIST bitlbee-3.5.tar.gz 657177 SHA256 549d02181ab303dfe8a219faafd7a1aea7ee642eb071b767f668782a57388319 SHA512 7f044474fff5b1213dddc29e19aae102d1bbe4361cddcf9e58f965c01a58b6f7ed41cbf6ecec050a96f91f55dca15f6df948dee105eff001086d9daa15ba0499 WHIRLPOOL 72434e9d7d43a0d1bf6d1f8c0eda10a099fca262d5431430d0001a7dc7b34e7594e5a6dc0942eebc04f7073bc73d4d8b3f7d00991b21b47d1cfb15ea542715c7
diff --git a/net-im/bitlbee/bitlbee-3.4.1.ebuild b/net-im/bitlbee/bitlbee-3.4.1.ebuild
deleted file mode 100644
index 02ea33f596d7..000000000000
--- a/net-im/bitlbee/bitlbee-3.4.1.ebuild
+++ /dev/null
@@ -1,178 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib user python-single-r1 systemd
-
-DESCRIPTION="irc to IM gateway that support multiple IM protocols"
-HOMEPAGE="http://www.bitlbee.org/"
-SRC_URI="http://get.bitlbee.org/src/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="debug gnutls ipv6 +xmpp libevent msn nss +oscar otr +plugins purple selinux
- skype ssl test twitter +yahoo xinetd libressl"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.16
- purple? ( net-im/pidgin )
- libevent? ( dev-libs/libevent )
- otr? ( >=net-libs/libotr-4 )
- gnutls? ( net-libs/gnutls )
- !gnutls? (
- nss? ( dev-libs/nss )
- !nss? ( ssl? ( !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= ) ) )
- )
- "
-DEPEND="${COMMON_DEPEND}
- dev-lang/python
- virtual/pkgconfig
- selinux? ( sec-policy/selinux-bitlbee )
- test? ( dev-libs/check )"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/logger
- skype? (
- dev-python/skype4py[${PYTHON_USEDEP}]
- net-im/skype
- )
- xinetd? ( sys-apps/xinetd )"
-
-REQUIRED_USE="|| ( purple xmpp msn oscar yahoo )
- msn? ( || ( gnutls nss ssl ) )
- xmpp? ( !nss )"
-
-pkg_setup() {
- if use xmpp && ! use gnutls && ! use ssl ; then
- einfo
- elog "You have enabled support for Jabber but do not have SSL"
- elog "support enabled. This *will* prevent bitlbee from being"
- elog "able to connect to SSL enabled Jabber servers. If you need to"
- elog "connect to Jabber over SSL, enable ONE of the following use"
- elog "flags: gnutls or ssl"
- einfo
- fi
-
- use skype && python-single-r1_pkg_setup
-
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
-src_prepare() {
- sed -i \
- -e "s@/usr/local/sbin/bitlbee@/usr/sbin/bitlbee@" \
- -e "s/nobody/bitlbee/" \
- -e "s/}/ disable = yes\n}/" \
- doc/bitlbee.xinetd || die "sed failed in xinetd"
-
- sed -i \
- -e "s@mozilla-nss@nss@g" \
- configure || die "sed failed in configure"
-
- use skype && python_fix_shebang protocols/skype/skyped.py
-
- epatch "${FILESDIR}"/${PN}-3.2.1-configure.patch
-}
-
-src_configure() {
- # setup plugins, protocol, ipv6 and debug
- use xmpp && myconf="${myconf} --jabber=1"
- for flag in debug ipv6 msn oscar plugins purple skype twitter yahoo ; do
- if use ${flag} ; then
- myconf="${myconf} --${flag}=1"
- else
- myconf="${myconf} --${flag}=0"
- fi
- done
-
- # set otr
- if use otr && use plugins ; then
- myconf="${myconf} --otr=plugin"
- else
- if use otr ; then
- ewarn "OTR support has been disabled automatically because it"
- ewarn "requires the plugins USE flag."
- fi
- myconf="${myconf} --otr=0"
- fi
-
- # setup ssl use flags
- if use gnutls ; then
- myconf="${myconf} --ssl=gnutls"
- einfo "Using gnutls for SSL support"
- elif use ssl ; then
- myconf="${myconf} --ssl=openssl"
- einfo "Using openssl for SSL support"
- elif use nss ; then
- myconf="${myconf} --ssl=nss"
- einfo "Using nss for SSL support"
- else
- myconf="${myconf} --ssl=bogus"
- einfo "You will not have any encryption support enabled."
- fi
-
- # set event handler
- if use libevent ; then
- myconf="${myconf} --events=libevent"
- else
- myconf="${myconf} --events=glib"
- fi
-
- # NOTE: bitlbee's configure script is not an autotool creation,
- # so that is why we don't use econf.
- ./configure \
- --prefix=/usr --datadir=/usr/share/bitlbee \
- --etcdir=/etc/bitlbee --plugindir=/usr/$(get_libdir)/bitlbee \
- --systemdsystemunitdir=$(systemd_get_unitdir) \
- --doc=1 --strip=0 ${myconf} || die "econf failed"
-
- sed -i \
- -e "/^EFLAGS/s:=:&${LDFLAGS} :" \
- Makefile.settings || die "sed failed"
-}
-
-src_install() {
- emake install install-etc install-doc install-dev install-systemd DESTDIR="${D}"
-
- keepdir /var/lib/bitlbee
- fperms 700 /var/lib/bitlbee
- fowners bitlbee:bitlbee /var/lib/bitlbee
-
- dodoc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
-
- if use skype ; then
- newdoc protocols/skype/NEWS NEWS-skype
- newdoc protocols/skype/README README-skype
- fi
-
- if use xinetd ; then
- insinto /etc/xinetd.d
- newins doc/bitlbee.xinetd bitlbee
- fi
-
- newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
- newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee
-
- exeinto /usr/share/bitlbee
- doexe utils/{convert_purple.py,bitlbee-ctl.pl}
-}
-
-pkg_postinst() {
- chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
- [[ -d "${ROOT}"/var/run/bitlbee ]] &&
- chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
-
- einfo
- elog "The bitlbee init script will now attempt to stop all processes owned by the"
- elog "bitlbee user, including per-client forks."
- elog
- elog "Tell the init script not to touch anything besides the main bitlbee process"
- elog "by changing the BITLBEE_STOP_ALL variable in"
- elog " /etc/conf.d/bitlbee"
- einfo
-}
diff --git a/net-im/bitlbee/bitlbee-3.5.ebuild b/net-im/bitlbee/bitlbee-3.5.ebuild
deleted file mode 100644
index d0101436617e..000000000000
--- a/net-im/bitlbee/bitlbee-3.5.ebuild
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit user systemd toolchain-funcs
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
- inherit git-r3
-else
- SRC_URI="https://get.bitlbee.org/src/${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-fi
-
-DESCRIPTION="irc to IM gateway that support multiple IM protocols"
-HOMEPAGE="https://www.bitlbee.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE_PROTOCOLS="msn oscar purple twitter +xmpp yahoo"
-IUSE="debug +gnutls ipv6 libevent libressl nss otr +plugins selinux test xinetd
- ${IUSE_PROTOCOLS}"
-
-REQUIRED_USE="
- || ( purple xmpp msn oscar yahoo )
- xmpp? ( !nss )
-"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.16
- purple? ( net-im/pidgin )
- libevent? ( dev-libs/libevent:= )
- otr? ( >=net-libs/libotr-4 )
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- nss? ( dev-libs/nss )
- !nss? (
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:0= )
- )
- )
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- selinux? ( sec-policy/selinux-bitlbee )
- test? ( dev-libs/check )"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/logger
- xinetd? ( sys-apps/xinetd )"
-
-pkg_setup() {
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
-
-src_prepare() {
- if [[ ${PV} != "9999" ]]; then
- eapply \
- "${FILESDIR}"/${P}-systemd-user.patch \
- "${FILESDIR}"/${P}-verbose-build.patch
- fi
-
- eapply_user
-}
-
-src_configure() {
- local myconf
-
- # setup plugins, protocol, ipv6 and debug
- myconf+=( --jabber=$(usex xmpp 1 0) )
- for flag in debug ipv6 plugins ${IUSE_PROTOCOLS/+xmpp/} ; do
- myconf+=( --${flag}=$(usex ${flag} 1 0) )
- done
-
- # set otr
- if use otr && use plugins ; then
- myconf+=( --otr=plugin )
- else
- if use otr ; then
- ewarn "OTR support has been disabled automatically because it"
- ewarn "requires the plugins USE flag."
- fi
- myconf+=( --otr=0 )
- fi
-
- # setup ssl use flags
- if use gnutls ; then
- myconf+=( --ssl=gnutls )
- einfo "Using gnutls for SSL support"
- else
- ewarn "Only gnutls is officially supported by upstream."
- if use nss ; then
- myconf+=( --ssl=nss )
- einfo "Using nss for SSL support"
- else
- myconf+=( --ssl=openssl )
- einfo "Using openssl for SSL support"
- fi
- fi
-
- # set event handler
- if use libevent ; then
- myconf+=( --events=libevent )
- else
- myconf+=( --events=glib )
- fi
-
- # not autotools-based
- ./configure \
- --prefix=/usr \
- --datadir=/usr/share/bitlbee \
- --etcdir=/etc/bitlbee \
- --plugindir=/usr/$(get_libdir)/bitlbee \
- --systemdsystemunitdir=$(systemd_get_systemunitdir) \
- --doc=1 \
- --strip=0 \
- --verbose=1 \
- "${myconf[@]}" || die
-
- sed -i \
- -e "/^EFLAGS/s:=:&${LDFLAGS} :" \
- Makefile.settings || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" LD="$(tc-getLD)"
-}
-
-src_install() {
- emake DESTDIR="${D}" install install-etc install-doc install-dev install-systemd
-
- keepdir /var/lib/bitlbee
- fperms 700 /var/lib/bitlbee
- fowners bitlbee:bitlbee /var/lib/bitlbee
-
- dodoc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
-
- if use xinetd ; then
- insinto /etc/xinetd.d
- newins doc/bitlbee.xinetd bitlbee
- fi
-
- newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
- newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee
-
- exeinto /usr/share/bitlbee
- doexe utils/{convert_purple.py,bitlbee-ctl.pl}
-}
-
-pkg_postinst() {
- chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
- [[ -d "${ROOT}"/var/run/bitlbee ]] &&
- chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- einfo
- elog "The bitlbee init script will now attempt to stop all processes owned by the"
- elog "bitlbee user, including per-client forks."
- elog
- elog "Tell the init script not to touch anything besides the main bitlbee process"
- elog "by changing the BITLBEE_STOP_ALL variable in"
- elog " /etc/conf.d/bitlbee"
- einfo
- fi
-}
diff --git a/net-im/bitlbee/metadata.xml b/net-im/bitlbee/metadata.xml
index 325106656818..7f107c38de17 100644
--- a/net-im/bitlbee/metadata.xml
+++ b/net-im/bitlbee/metadata.xml
@@ -11,7 +11,6 @@
<flag name="otr">Enable support for encrypted conversations</flag>
<flag name="plugins">Enable support for plugins</flag>
<flag name="purple">Use libpurple instead of the built-in IM protocol support</flag>
- <flag name="skype">Enable Skype support</flag>
<flag name="twitter">Enable Twitter protocol support</flag>
</use>
<longdescription>