summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosiah Mullins <jomull01@protonmail.com>2019-10-18 21:50:27 -0400
committerJoonas Niilola <juippis@gentoo.org>2019-11-04 08:07:41 +0200
commit5fb3202c71a57851398b7df7f7521e158048727e (patch)
tree0bd07cd3ed4fc4ab11dab74804dcbf6c3aae1757 /acct-user
parentacct-group/tox: new package (diff)
downloadgentoo-5fb3202c71a57851398b7df7f7521e158048727e.tar.gz
gentoo-5fb3202c71a57851398b7df7f7521e158048727e.tar.bz2
gentoo-5fb3202c71a57851398b7df7f7521e158048727e.zip
acct-user/tox: new package
This commit will add a package that will allow net-libs/tox to be compliant with GLEP 81. Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/tox/metadata.xml12
-rw-r--r--acct-user/tox/tox-0.ebuild13
2 files changed, 25 insertions, 0 deletions
diff --git a/acct-user/tox/metadata.xml b/acct-user/tox/metadata.xml
new file mode 100644
index 000000000000..5dbf5facde30
--- /dev/null
+++ b/acct-user/tox/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>JoMull01@protonmail.com</email>
+ <name>Josiah Mullins</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/tox/tox-0.ebuild b/acct-user/tox/tox-0.ebuild
new file mode 100644
index 000000000000..35678586fa82
--- /dev/null
+++ b/acct-user/tox/tox-0.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for package net-libs/tox"
+
+ACCT_USER_ID=236 #day-month of first tox commit
+ACCT_USER_GROUPS=( tox )
+
+acct-user_add_deps