summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-05-06 21:32:07 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-05-06 21:32:31 -0500
commita6029c1e887b2492496f230b6546956c7e75fb48 (patch)
tree71063eb16071c9109968a218e1d309d9abc9ffde /app-accessibility/espeakup
parentapp-accessibility/espeakup: revision bump for /sbin/openrc-run migration (diff)
downloadgentoo-a6029c1e887b2492496f230b6546956c7e75fb48.tar.gz
gentoo-a6029c1e887b2492496f230b6546956c7e75fb48.tar.bz2
gentoo-a6029c1e887b2492496f230b6546956c7e75fb48.zip
app-accessibility/espeakup: remove old version
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-accessibility/espeakup')
-rw-r--r--app-accessibility/espeakup/espeakup-0.71.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/app-accessibility/espeakup/espeakup-0.71.ebuild b/app-accessibility/espeakup/espeakup-0.71.ebuild
deleted file mode 100644
index cf5d4298e1a..00000000000
--- a/app-accessibility/espeakup/espeakup-0.71.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit linux-info
-
-DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
-HOMEPAGE="http://www.linux-speakup.org"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-COMMON_DEPEND="|| (
- app-accessibility/espeak[portaudio]
- app-accessibility/espeak[pulseaudio] )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
-CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
-ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
-ERROR_SPEAKUP_SYNTH_SOFT="CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
-
-pkg_setup() {
- if kernel_is -ge 2 6 37; then
- check_extra_config
- elif ! has_version app-accessibility/speakup; then
- ewarn "Cannot find speakup on your system."
- ewarn "Please upgrade your kernel to 2.6.37 or later and enable the"
- ewarn "CONFIG_SPEAKUP and CONFIG_SPEAKUP_SYNTH_SOFT options"
- ewarn "or install app-accessibility/speakup."
- fi
-}
-
-src_compile() {
- emake || die "Compile failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed."
- dodoc ChangeLog README ToDo
- newconfd "${FILESDIR}"/espeakup.confd espeakup
- newinitd "${FILESDIR}"/espeakup.rc espeakup
-}
-
-pkg_postinst() {
- elog "To get espeakup to start automatically, it is currently recommended"
- elog "that you add it to the default run level, by giving the following"
- elog "command as root."
- elog
- elog "rc-update add espeakup default"
- elog
- elog "You can also set a default voice now for espeakup."
- elog "See /etc/conf.d/espeakup for how to do this."
-}