summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-19 22:37:04 -0700
committerMatt Turner <mattst88@gentoo.org>2019-10-21 12:51:02 -0700
commit4472d76233bd875b1bf777c4c7dff128068d74cb (patch)
tree7d78c848175a69d1f029ef566cca19d8acc110b2 /app-accessibility
parentdev-libs/atk: Version bump to 2.34.1 (diff)
downloadgentoo-4472d76233bd875b1bf777c4c7dff128068d74cb.tar.gz
gentoo-4472d76233bd875b1bf777c4c7dff128068d74cb.tar.bz2
gentoo-4472d76233bd875b1bf777c4c7dff128068d74cb.zip
app-accessibility/at-spi2-core: Version bump to 2.34.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.34.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index e573ee9b7cf1..8c12ae3f9a1e 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,3 +1,4 @@
DIST at-spi2-core-2.26.2.tar.xz 494484 BLAKE2B 0c67cea9c0107fb6503a933de134eb662f192ae2a98734bde1b0629da151476858720d2dcb1791a00a44b61ae2ead945178fba659f88303c552567d7f3f9817b SHA512 6a8e158e30c37ce475467b6634aff046a318875271966d7bfa3e56052d0cd26cd37435d0b9ae14f079542b8b3e76088da5bd50ed39eb39f3f40394c55ed3f255
DIST at-spi2-core-2.30.1.tar.xz 188056 BLAKE2B 8686a5bd0a359d575d052f5c42cec76bbd88f7d681decbcec92ef163d5f59dac4e642b544b928e141739479b9e349868c0f5ecb7d42a29e9b32615f27a852e52 SHA512 c8b6a2ae5f96ce7d8c1fd32c9fec861148ceff631069b417296425fe6e2ae15198628826e13a72e018871d38e12b1128aa299edcc45eaf3eb7bbff83774361cd
DIST at-spi2-core-2.32.1.tar.xz 188952 BLAKE2B a12e234b19a38b0fcffbabb8430ef49dc538b38831cc22bbafc7f5d499082007909a82e785184d052f3a62853474cbc4838125540026a6d0e2ac2181e98a6a4c SHA512 cec6ea1426b25d9738c5c401a1038b39e04b1e989b7ef8e02590d117b35cfb253b260cc6e41b09e10e007801fedcb7702c48ba7f3a0c7b6c1f16edd4e8ad0cca
+DIST at-spi2-core-2.34.0.tar.xz 186736 BLAKE2B 6210ef0254760f1ef6e9c9124680f604864e24228650d4be1026dc73ce0ec5d10eec5e9958a98f0970e1292e4fc3935c8379278b10c633c87da5eb3960b94670 SHA512 99f6773e29fb5fcb339cbe5b23133dab78bc52e3c46a1d5bd748788c48345223f1def5078ac48e58756a7692459b177b0e26dc8059898a5ccac56ceb495b7de8
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.34.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.34.0.ebuild
new file mode 100644
index 000000000000..bd6e7782747a
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.34.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson multilib-minimal systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="X gtk-doc +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RDEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+PATCHES=(
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ -Ddocs=$(multilib_native_usex gtk-doc true false)
+ -Dintrospection=$(multilib_native_usex introspection)
+ -Dx11=$(usex X)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}