summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/SphinxTrain/Manifest2
-rw-r--r--app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild41
-rw-r--r--app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild39
-rw-r--r--app-accessibility/SphinxTrain/files/gcc.patch34
-rw-r--r--app-accessibility/SphinxTrain/files/gcc34.patch11
-rw-r--r--app-accessibility/SphinxTrain/metadata.xml15
-rw-r--r--app-accessibility/accerciser/Manifest2
-rw-r--r--app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild67
-rw-r--r--app-accessibility/accerciser/accerciser-3.12.0.ebuild67
-rw-r--r--app-accessibility/accerciser/accerciser-3.14.0.ebuild67
-rw-r--r--app-accessibility/accerciser/metadata.xml10
-rw-r--r--app-accessibility/at-spi2-atk/Manifest3
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1-r1.ebuild47
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1.ebuild39
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.14.1.ebuild47
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild63
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0.ebuild48
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h36
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch26
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch55
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml16
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml11
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml13
-rw-r--r--app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml16
-rw-r--r--app-accessibility/at-spi2-atk/metadata.xml5
-rw-r--r--app-accessibility/at-spi2-core/Manifest3
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.12.0-r1.ebuild65
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild50
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.14.1.ebuild65
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.16.0.ebuild65
-rw-r--r--app-accessibility/at-spi2-core/files/at-spi2-core-2.0.2-disable-teamspaces-test.patch13
-rw-r--r--app-accessibility/at-spi2-core/metadata.xml5
-rw-r--r--app-accessibility/brltty/Manifest1
-rw-r--r--app-accessibility/brltty/brltty-5.2.ebuild189
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch56
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-respect-AR.patch12
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-udev.patch28
-rw-r--r--app-accessibility/brltty/files/brltty.rc13
-rw-r--r--app-accessibility/brltty/files/brltty.tmpfiles.conf1
-rw-r--r--app-accessibility/brltty/metadata.xml26
-rw-r--r--app-accessibility/caribou/Manifest3
-rw-r--r--app-accessibility/caribou/caribou-0.4.17.ebuild89
-rw-r--r--app-accessibility/caribou/caribou-0.4.18.1.ebuild90
-rw-r--r--app-accessibility/caribou/caribou-0.4.18.ebuild90
-rw-r--r--app-accessibility/caribou/metadata.xml12
-rw-r--r--app-accessibility/edbrowse/Manifest1
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.5.1.ebuild58
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch22
-rw-r--r--app-accessibility/edbrowse/metadata.xml9
-rw-r--r--app-accessibility/eflite/Manifest1
-rw-r--r--app-accessibility/eflite/eflite-0.4.1-r2.ebuild46
-rw-r--r--app-accessibility/eflite/files/eflite-0.4.1-flite14.patch24
-rw-r--r--app-accessibility/eflite/files/eflite.rc29
-rw-r--r--app-accessibility/eflite/files/es.conf11
-rw-r--r--app-accessibility/eflite/metadata.xml27
-rw-r--r--app-accessibility/emacspeak-ss/Manifest1
-rw-r--r--app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild32
-rw-r--r--app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch24
-rw-r--r--app-accessibility/emacspeak-ss/metadata.xml20
-rw-r--r--app-accessibility/emacspeak/Manifest1
-rw-r--r--app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild81
-rw-r--r--app-accessibility/emacspeak/emacspeak-9999.ebuild81
-rw-r--r--app-accessibility/emacspeak/metadata.xml16
-rw-r--r--app-accessibility/epos/Manifest1
-rw-r--r--app-accessibility/epos/epos-2.5.37-r1.ebuild43
-rw-r--r--app-accessibility/epos/files/README.gentoo2
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-disable-tests.patch16
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc43.patch23
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc45.patch15
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc47.patch16
-rw-r--r--app-accessibility/epos/files/eposd21
-rw-r--r--app-accessibility/epos/metadata.xml8
-rw-r--r--app-accessibility/espeak/Manifest2
-rw-r--r--app-accessibility/espeak/espeak-1.47.11-r1.ebuild98
-rw-r--r--app-accessibility/espeak/espeak-1.48.04.ebuild98
-rw-r--r--app-accessibility/espeak/metadata.xml11
-rw-r--r--app-accessibility/espeakup/Manifest1
-rw-r--r--app-accessibility/espeakup/espeakup-0.71.ebuild59
-rw-r--r--app-accessibility/espeakup/espeakup-9999.ebuild65
-rw-r--r--app-accessibility/espeakup/files/espeakup.confd9
-rw-r--r--app-accessibility/espeakup/files/espeakup.rc28
-rw-r--r--app-accessibility/espeakup/metadata.xml12
-rw-r--r--app-accessibility/festival-fi/Manifest3
-rw-r--r--app-accessibility/festival-fi/festival-fi-20041119.ebuild47
-rw-r--r--app-accessibility/festival-fi/files/festival-fi-20041119_lavennin_path.patch18
-rw-r--r--app-accessibility/festival-fi/metadata.xml9
-rw-r--r--app-accessibility/festival-freebsoft-utils/Manifest2
-rw-r--r--app-accessibility/festival-freebsoft-utils/festival-freebsoft-utils-0.10.ebuild32
-rw-r--r--app-accessibility/festival-freebsoft-utils/festival-freebsoft-utils-0.2.ebuild24
-rw-r--r--app-accessibility/festival-freebsoft-utils/metadata.xml8
-rw-r--r--app-accessibility/festival-hts/Manifest6
-rw-r--r--app-accessibility/festival-hts/festival-hts-2.1.ebuild28
-rw-r--r--app-accessibility/festival-hts/metadata.xml9
-rw-r--r--app-accessibility/festival-it/Manifest1
-rw-r--r--app-accessibility/festival-it/festival-it-1.0-r2.ebuild83
-rw-r--r--app-accessibility/festival-it/metadata.xml15
-rw-r--r--app-accessibility/festival-ru/Manifest1
-rw-r--r--app-accessibility/festival-ru/festival-ru-0.5.ebuild35
-rw-r--r--app-accessibility/festival-ru/metadata.xml12
-rw-r--r--app-accessibility/festival/Manifest10
-rw-r--r--app-accessibility/festival/festival-2.1-r1.ebuild125
-rw-r--r--app-accessibility/festival/files/festival-2.1-gcc4.7.patch29
-rw-r--r--app-accessibility/festival/files/festival-2.1-gentoo-system.patch124
-rw-r--r--app-accessibility/festival/files/festival-2.1-init-scm.patch24
-rw-r--r--app-accessibility/festival/files/festival-2.1-ldflags.patch12
-rw-r--r--app-accessibility/festival/metadata.xml10
-rw-r--r--app-accessibility/flite/Manifest1
-rw-r--r--app-accessibility/flite/files/flite-1.4-audio-interface.patch22
-rw-r--r--app-accessibility/flite/files/flite-1.4-fix-parallel-builds.patch25
-rw-r--r--app-accessibility/flite/files/flite-1.4-ldflags.patch35
-rw-r--r--app-accessibility/flite/files/flite-1.4-respect-destdir.patch59
-rw-r--r--app-accessibility/flite/files/flite-1.4-tempfile.patch50
-rw-r--r--app-accessibility/flite/flite-1.4-r4.ebuild75
-rw-r--r--app-accessibility/flite/metadata.xml6
-rw-r--r--app-accessibility/freetts/Manifest2
-rw-r--r--app-accessibility/freetts/files/jsapi-gentoo.diff194
-rw-r--r--app-accessibility/freetts/freetts-1.2.1-r2.ebuild66
-rw-r--r--app-accessibility/freetts/freetts-1.2.2.ebuild87
-rw-r--r--app-accessibility/freetts/metadata.xml13
-rw-r--r--app-accessibility/julius/Manifest1
-rw-r--r--app-accessibility/julius/files/julius-4.2.2-install.patch344
-rw-r--r--app-accessibility/julius/files/julius-4.2.2-ldflags.patch11
-rw-r--r--app-accessibility/julius/julius-4.2.2.ebuild63
-rw-r--r--app-accessibility/julius/metadata.xml8
-rw-r--r--app-accessibility/mbrola/Manifest24
-rw-r--r--app-accessibility/mbrola/mbrola-3.0.1h-r6.ebuild101
-rw-r--r--app-accessibility/mbrola/metadata.xml6
-rw-r--r--app-accessibility/metadata.xml39
-rw-r--r--app-accessibility/nfbtrans/Manifest1
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch11
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch40
-rw-r--r--app-accessibility/nfbtrans/metadata.xml9
-rw-r--r--app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild42
-rw-r--r--app-accessibility/nfbtrans/nfbtrans-7.74.ebuild39
-rw-r--r--app-accessibility/orca/Manifest3
-rw-r--r--app-accessibility/orca/metadata.xml15
-rw-r--r--app-accessibility/orca/orca-3.14.3.ebuild78
-rw-r--r--app-accessibility/orca/orca-3.14.4.ebuild77
-rw-r--r--app-accessibility/orca/orca-3.16.2.ebuild77
-rw-r--r--app-accessibility/perlbox-voice/Manifest1
-rw-r--r--app-accessibility/perlbox-voice/metadata.xml10
-rw-r--r--app-accessibility/perlbox-voice/perlbox-voice-0.09-r2.ebuild24
-rw-r--r--app-accessibility/pidgin-festival/Manifest1
-rw-r--r--app-accessibility/pidgin-festival/metadata.xml9
-rw-r--r--app-accessibility/pidgin-festival/pidgin-festival-2.4.ebuild25
-rw-r--r--app-accessibility/pocketsphinx/Manifest1
-rw-r--r--app-accessibility/pocketsphinx/metadata.xml8
-rw-r--r--app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild50
-rw-r--r--app-accessibility/powiedz/Manifest1
-rw-r--r--app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch13
-rw-r--r--app-accessibility/powiedz/files/powiedz.desktop8
-rw-r--r--app-accessibility/powiedz/metadata.xml6
-rw-r--r--app-accessibility/powiedz/powiedz-1.0-r2.ebuild31
-rw-r--r--app-accessibility/simon/Manifest2
-rw-r--r--app-accessibility/simon/files/simon-0.4.0-libdir.patch16
-rw-r--r--app-accessibility/simon/files/simon-0.4.0-linguas.patch84
-rw-r--r--app-accessibility/simon/files/simon-0.4.0-opencv.patch11
-rw-r--r--app-accessibility/simon/files/simon-0.4.0-sphinx.patch16
-rw-r--r--app-accessibility/simon/files/simon-0.4.1-libdir.patch16
-rw-r--r--app-accessibility/simon/files/simon-0.4.1-linguas.patch87
-rw-r--r--app-accessibility/simon/files/simon-0.4.1-sphinx.patch16
-rw-r--r--app-accessibility/simon/metadata.xml11
-rw-r--r--app-accessibility/simon/simon-0.4.0.ebuild90
-rw-r--r--app-accessibility/simon/simon-0.4.1.ebuild89
-rw-r--r--app-accessibility/sound-icons/Manifest1
-rw-r--r--app-accessibility/sound-icons/metadata.xml11
-rw-r--r--app-accessibility/sound-icons/sound-icons-0.1.ebuild29
-rw-r--r--app-accessibility/speakup/Manifest1
-rw-r--r--app-accessibility/speakup/metadata.xml8
-rw-r--r--app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild73
-rw-r--r--app-accessibility/speakup/speakup-9999.ebuild72
-rw-r--r--app-accessibility/speech-dispatcher/Manifest1
-rw-r--r--app-accessibility/speech-dispatcher/metadata.xml13
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild109
-rw-r--r--app-accessibility/speech-tools/Manifest2
-rw-r--r--app-accessibility/speech-tools/files/speech-tools-2.1-underlinking.patch11
-rw-r--r--app-accessibility/speech-tools/metadata.xml9
-rw-r--r--app-accessibility/speech-tools/speech-tools-2.1-r2.ebuild108
-rw-r--r--app-accessibility/speech-tools/speech-tools-2.1-r3.ebuild118
-rw-r--r--app-accessibility/speechd-el/Manifest1
-rw-r--r--app-accessibility/speechd-el/metadata.xml12
-rw-r--r--app-accessibility/speechd-el/speechd-el-2.5.ebuild42
-rw-r--r--app-accessibility/speechd-up/Manifest1
-rw-r--r--app-accessibility/speechd-up/files/speechd-up.confd6
-rw-r--r--app-accessibility/speechd-up/files/speechd-up.rc39
-rw-r--r--app-accessibility/speechd-up/metadata.xml8
-rw-r--r--app-accessibility/speechd-up/speechd-up-0.4-r3.ebuild32
-rw-r--r--app-accessibility/sphinx2/Manifest1
-rw-r--r--app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch25
-rw-r--r--app-accessibility/sphinx2/metadata.xml9
-rw-r--r--app-accessibility/sphinx2/sphinx2-0.6.ebuild30
-rw-r--r--app-accessibility/sphinx3/Manifest2
-rw-r--r--app-accessibility/sphinx3/files/sphinx3-0.8-libutil.patch18
-rw-r--r--app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch34
-rw-r--r--app-accessibility/sphinx3/metadata.xml8
-rw-r--r--app-accessibility/sphinx3/sphinx3-0.6.3.ebuild21
-rw-r--r--app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild61
-rw-r--r--app-accessibility/sphinxbase/Manifest1
-rw-r--r--app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch25
-rw-r--r--app-accessibility/sphinxbase/files/sphinxbase-0.8-unbundle-lapack.patch85
-rw-r--r--app-accessibility/sphinxbase/metadata.xml8
-rw-r--r--app-accessibility/sphinxbase/sphinxbase-0.8.ebuild79
-rw-r--r--app-accessibility/yasr/Manifest1
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-automake113.patch17
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-gcc43.patch26
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch13
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-remove-m4.patch29
-rw-r--r--app-accessibility/yasr/metadata.xml8
-rw-r--r--app-accessibility/yasr/yasr-0.6.9-r1.ebuild54
209 files changed, 6847 insertions, 0 deletions
diff --git a/app-accessibility/SphinxTrain/Manifest b/app-accessibility/SphinxTrain/Manifest
new file mode 100644
index 00000000000..12efac4514b
--- /dev/null
+++ b/app-accessibility/SphinxTrain/Manifest
@@ -0,0 +1,2 @@
+DIST SphinxTrain-0.9.1-beta.tar.gz 469617 SHA256 c1a4b74a3e26777b80ddd7a026547aad194040cca8595e6fe1be320a19f99d18 SHA512 1b33a58a6e05069369fe1ba668609e5a25d6a49fbf2fed1f5d86bdc1fc43d4544627c438e61d46003c2dbd8d7fa6f41c686b57cbca215f73b6c4ba0d7682076d WHIRLPOOL 6399233f803f37d8d267a5005a5cb158513cb64b2b7b3727cb9ee93c46781f29e5ed0729c1d7d1e586de49ede098a7d9658c285399bae0d633f34657000074c8
+DIST sphinxtrain-1.0.8.tar.gz 8925803 SHA256 548e3e513ceaa1b2fd6fd7ed1724349e0a4bf7bdeb11be9c91787e6f2b865203 SHA512 465d2c4ade9acc7b49c1d975449c38ac01d5a3ff332f9841be66cd8ca9d2f0b68fd36cc8a46384c8b510042efa91c3887a080481e84f2d0deb9775a598835f2b WHIRLPOOL d9ccbe09d125579e15167fa625bb72c86e114f9c394e909488216ae2f4e6af4c7b968d469455b65c4aff2a41a7d97701ac290df2cbc6b0450c64c94b042ae94d
diff --git a/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild b/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
new file mode 100644
index 00000000000..7e18d2e5b39
--- /dev/null
+++ b/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Speech Recognition (Training Module)"
+HOMEPAGE="http://cmusphinx.sourceforge.net/html/cmusphinx.php"
+SRC_URI="http://www.speech.cs.cmu.edu/${PN}/${P}-beta.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-accessibility/sphinx2
+ app-accessibility/festival"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/gcc.patch
+ epatch "${FILESDIR}"/gcc34.patch
+ tc-export CC AR RANLIB
+}
+
+src_install() {
+ # dobin bin.*/* fails ... see bug #73586
+ find bin.* -mindepth 1 -maxdepth 1 -type f -exec dobin '{}' \; || die
+
+ dodoc README etc/*cfg
+ dohtml doc/*{txt,html,sgml}
+}
+
+pkg_postinst() {
+ elog "Detailed usage and training instructions can be found at"
+ elog "http://www.speech.cs.cmu.edu/SphinxTrain/"
+}
diff --git a/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild b/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild
new file mode 100644
index 00000000000..e0014a9ac0a
--- /dev/null
+++ b/app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib python-single-r1
+
+DESCRIPTION="Speech Recognition (Training Module)"
+HOMEPAGE="http://cmusphinx.sourceforge.net/html/cmusphinx.php"
+SRC_URI="mirror://sourceforge/cmusphinx/sphinxtrain-${PV}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="app-accessibility/sphinxbase
+ dev-lang/perl
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/sphinxtrain-${PV}
+
+src_install() {
+ default
+ dodoc README etc/*cfg
+
+ python_fix_shebang "${D}"/usr/bin/sphinxtrain
+ python_optimize "${D}"/usr/$(get_libdir)/sphinxtrain/python/cmusphinx
+}
+
+pkg_postinst() {
+ elog "Detailed usage and training instructions can be found at"
+ elog "http://cmusphinx.sourceforge.net/wiki/"
+}
diff --git a/app-accessibility/SphinxTrain/files/gcc.patch b/app-accessibility/SphinxTrain/files/gcc.patch
new file mode 100644
index 00000000000..e3c51275f91
--- /dev/null
+++ b/app-accessibility/SphinxTrain/files/gcc.patch
@@ -0,0 +1,34 @@
+--- src/programs/count_3phone/wrec.h.orig 2003-09-28 18:51:49.000000000 +0900
++++ src/programs/count_3phone/wrec.h 2003-09-28 18:52:23.000000000 +0900
+@@ -44,7 +44,7 @@
+ #define WREC_H
+
+ #include "phrec.h"
+-#include <varargs.h>
++#include <stdarg.h>
+
+ int quit (int status, char *fmt, ...);
+
+--- src/programs/count_3phone/quit.c.orig 2003-09-28 19:12:56.000000000 +0900
++++ src/programs/count_3phone/quit.c 2003-09-28 19:13:12.000000000 +0900
+@@ -74,17 +74,14 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <varargs.h>
++#include <stdarg.h>
+
+-int quit (status,fmt,va_alist)
+- int status;
+- char *fmt;
+- va_dcl
++int quit (int status,char *fmt,...)
+ {
+ va_list args;
+
+ fflush(stdout);
+- va_start(args);
++ va_start(args, fmt);
+ (void) vfprintf(stderr, fmt, args);
+ va_end(args);
+ exit(status);
diff --git a/app-accessibility/SphinxTrain/files/gcc34.patch b/app-accessibility/SphinxTrain/files/gcc34.patch
new file mode 100644
index 00000000000..124aa993edc
--- /dev/null
+++ b/app-accessibility/SphinxTrain/files/gcc34.patch
@@ -0,0 +1,11 @@
+--- SphinxTrain/src/programs/count_3phone/phone_word_io.c~ 2001-04-05 16:00:33.000000000 -0400
++++ SphinxTrain/src/programs/count_3phone/phone_word_io.c 2005-05-01 12:48:42.000000000 -0400
+@@ -71,7 +71,7 @@
+ #ifdef __alpha
+ void *malloc();
+ #else
+-char *malloc();
++//char *malloc();
+ #endif
+
+ extern int Num_Phones, Num_Words;
diff --git a/app-accessibility/SphinxTrain/metadata.xml b/app-accessibility/SphinxTrain/metadata.xml
new file mode 100644
index 00000000000..acc417de6d3
--- /dev/null
+++ b/app-accessibility/SphinxTrain/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ SphinxTrain is CMU Sphinx's training package.
+</longdescription>
+ <longdescription lang="ja">
+ SphinxTrainはCMU Sphinxの調教パッケージです。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">cmusphinx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
new file mode 100644
index 00000000000..eb85a827ecc
--- /dev/null
+++ b/app-accessibility/accerciser/Manifest
@@ -0,0 +1,2 @@
+DIST accerciser-3.12.0.tar.xz 3212432 SHA256 0d421a59cd294966441fb6591d34f28e4b60340815bdf91c9e8f39c2d826e96b SHA512 d15d301f7579a92e3b3aa65d22fd726d71bee8330b450c7ed232d4a8d7fc312402573073f67a490ab659122ad98651f8a073235770caa9eba8a4b6dc9d68e6d3 WHIRLPOOL 4b753de73afc1c8fda7d71a8b6f8007ebb4627985a6049be887d8e916f4e37c3a5484a481d8e516a1d4cc245e987ed29a2a87c2780b882bced032f5d2d14d5d6
+DIST accerciser-3.14.0.tar.xz 3213916 SHA256 f5a5915d475e9241396414ccd167724c88807e77e69151cf0b40b32bd57d0574 SHA512 bafc30e15fe0121f8abc64239e48834ab06a03fe64fc368a221d167a13079721962441e0343f17934dde57cd012c9132374739297c23c79c567fc36cc60fb07d WHIRLPOOL 4b9679145ad1ad7f8d059dfdfb12d372c1b27780532a7c19cc25b66bbe0a13db5b864548e332b74e0327eebb488622ae471514046737b738c15624969d8df7a8
diff --git a/app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild b/app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild
new file mode 100644
index 00000000000..9d96f0ff36a
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/accerciser/accerciser-3.12.0.ebuild b/app-accessibility/accerciser/accerciser-3.12.0.ebuild
new file mode 100644
index 00000000000..1f3e53c44fb
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.12.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python3_3 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="http://live.gnome.org/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/accerciser/accerciser-3.14.0.ebuild b/app-accessibility/accerciser/accerciser-3.14.0.ebuild
new file mode 100644
index 00000000000..3bbf84471ae
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.14.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/accerciser/metadata.xml b/app-accessibility/accerciser/metadata.xml
new file mode 100644
index 00000000000..de03c27559d
--- /dev/null
+++ b/app-accessibility/accerciser/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-accessibility</herd>
+ <longdescription lang="en">
+Accerciser is an interactive Python accessibility explorer for the GNOME desktop. It uses AT-SPI to inspect and control widgets, allowing you to check if an application is providing correct information to assistive technologies and automated test frameworks. Accerciser has a simple plugin framework which you can use to create custom views of accessibility information.
+
+In essence, Accerciser is a next generation at-poke tool.
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/at-spi2-atk/Manifest b/app-accessibility/at-spi2-atk/Manifest
new file mode 100644
index 00000000000..881c14eadea
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/Manifest
@@ -0,0 +1,3 @@
+DIST at-spi2-atk-2.12.1.tar.xz 280568 SHA256 5fa9c527bdec028e06797563cd52d49bcf06f638549df983424d88db89bb1336 SHA512 a7fc3cbc3665741ea6cee716cc68467ed110c0f6425fe418ea0f1b702931e4a07306e48264e9cd160d98c5bf762f076cad66ff2e46690af226ce33146d11aee2 WHIRLPOOL dc84563059d24ae56029989853d9e5a9a8cca5eecbed1227c4e36cd760aed4035beefbb71668221646cbd03057f1e30e44128081e2a6b32cfe48baabf4a631e5
+DIST at-spi2-atk-2.14.1.tar.xz 280952 SHA256 058f34ea60edf0a5f831c9f2bdd280fe95c1bcafb76e466e44aa0fb356d17bcb SHA512 1daee942d3c477444aaa42fb6ede6d821ff9b613f0686dd4a545406c97ceb819a3544419e0cb5d2e661f3a1b6fc92af9394801f3c51377db0ab77620e5c3d437 WHIRLPOOL 75d7e4569eed83df842e363c6203571b7bc26dbfdd71555ead0c1656eb61923817673ce18f8042c4a989a45af956ad9fd85aee5386c8aafb121bf71de99c04c6
+DIST at-spi2-atk-2.16.0.tar.xz 286668 SHA256 78efc45ec36383bf785f8636e64a8d866defeb020e00a08f92978f1fc3772ff9 SHA512 fcd40693e5ef55c640a52158996dc8bc66f53ef211c343cd5401c4bcd1669110ea836e0550eb41caee9c9f3a4f9670095a7dd8252600af943ddcb374bf50f011 WHIRLPOOL 0865cb8bfd62449bf345938a382c2a7d8efd425154e7e674c8097702e6873d98b8d2be8ac841858ba7dce166c2be4e18be1b1daf4fed43f667430ac3eeccebe2
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1-r1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1-r1.ebuild
new file mode 100644
index 00000000000..3b9ad24a813
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.11.2[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.11.90[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1.ebuild
new file mode 100644
index 00000000000..b122f70e787
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.11.2
+ >=dev-libs/atk-2.11.90
+ >=dev-libs/glib-2.32:2
+ >=sys-apps/dbus-1.5
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure --enable-p2p
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.14.1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.14.1.ebuild
new file mode 100644
index 00000000000..3440682319d
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.14.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.11.2[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.11.90[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild
new file mode 100644
index 00000000000..045bd50ab91
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 multilib-minimal
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.15.5[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.15.4[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751137
+ epatch "${FILESDIR}"/${PN}-2.16.0-out-of-source.patch
+ # Fixed in upstream git
+ epatch "${FILESDIR}"/${P}-null-gobject.patch
+ # Upstream forgot to put this in tarball :/
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751138
+ cp -n "${FILESDIR}"/${PN}-2.16.0-atk_suite.h tests/atk_suite.h || die
+ mkdir tests/data/ || die
+ cp -n "${FILESDIR}"/${PN}-2.16.0-tests-data/*.xml tests/data/ || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p $(use_with test tests)
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ dbus-run-session -- emake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0.ebuild
new file mode 100644
index 00000000000..f5fde6e381f
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.16.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.15.5[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.15.4[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p $(use_with test tests)
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h
new file mode 100644
index 00000000000..17aefcdd03d
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-atk_suite.h
@@ -0,0 +1,36 @@
+/*
+ * AT-SPI - Assistive Technology Service Provider Interface
+ * (Gnome Accessibility Project; https://wiki.gnome.org/Accessibility)
+ *
+ * Copyright (c) 2014 Samsung Electronics Co., Ltd.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Library General Public
+ * License as published by the Free Software Foundation; either
+ * version 2 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Library General Public License for more details.
+ *
+ * You should have received a copy of the GNU Library General Public
+ * License along with this library; if not, write to the
+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ * Boston, MA 02111-1307, USA.
+ */
+
+#ifndef _ATK_SUITE_H
+#define _ATK_SUITE_H
+
+#include <atspi/atspi.h>
+
+#define ATK_TEST_PATH_ACCESSIBLE (const char *)"/Accessible"
+#define ATK_TEST_PATH_ACTION (const char *)"/Action"
+#define ATK_TEST_PATH_COMP (const char *)"/Component"
+
+void atk_test_accessible (void);
+void atk_test_action (void);
+void atk_test_component (void);
+
+#endif /* _ATK_SUITE_H */
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch
new file mode 100644
index 00000000000..a8f02a0eae1
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-null-gobject.patch
@@ -0,0 +1,26 @@
+From 72220192a31df6b297312d82f059e9824e8a4dc3 Mon Sep 17 00:00:00 2001
+From: Christian Hergert <christian@hergert.me>
+Date: Fri, 15 May 2015 13:07:18 -0700
+Subject: [PATCH] atk-adapter: be careful with potential NULL GObjects
+
+I've been seeing warnings in my Gtk application for a while due to this.
+---
+ atk-adaptor/accessible-stateset.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/atk-adaptor/accessible-stateset.c b/atk-adaptor/accessible-stateset.c
+index f82910b..82820de 100644
+--- a/atk-adaptor/accessible-stateset.c
++++ b/atk-adaptor/accessible-stateset.c
+@@ -185,7 +185,7 @@ spi_atk_state_to_dbus_array (AtkObject * object, dbus_uint32_t * array)
+ {
+ AtkStateSet *set = atk_object_ref_state_set (object);
+ spi_atk_state_set_to_dbus_array (set, array);
+- g_object_unref (set);
++ g_clear_object (&set);
+ }
+
+ void
+--
+2.4.3
+
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch
new file mode 100644
index 00000000000..df9f006350d
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-out-of-source.patch
@@ -0,0 +1,55 @@
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 6d388c9..b05b9bd 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -9,15 +9,15 @@ atk_test_CFLAGS = $(DBUS_CFLAGS) \
+ $(ATSPI_CFLAGS) \
+ -I$(top_builddir)\
+ -I$(top_srcdir)/tests/dummyatk/ \
+- -I$(top_srcdir)/tests/dummyatk/.libs \
+- -I$(top_srcdir)/tests/dummyatk/.deps \
++ -I$(top_builddir)/tests/dummyatk/.libs \
++ -I$(top_builddir)/tests/dummyatk/.deps \
+ -I$(top_srcdir)
+
+-atk_test_LDFLAGS = libxmlloader.la \
+- libtestutils.la \
+- $(GLIB_LIBS) \
+- $(ATSPI_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la
++atk_test_LDADD = libxmlloader.la \
++ libtestutils.la \
++ $(GLIB_LIBS) \
++ $(ATSPI_LIBS) \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la
+
+ atk_test_CPPFLAGS = -DTESTS_BUILD_DIR=\"$(top_builddir)/tests\" \
+ -DTESTS_SRC_DIR=\"$(top_srcdir)/tests\" \
+@@ -34,12 +34,12 @@ app_test_CFLAGS = -I$(top_builddir) \
+ -I$(top_srcdir)/tests/dummyatk \
+ -I$(top_srcdir)/atk-adaptor
+
+-app_test_LDFLAGS = libxmlloader.la \
+- libtestutils.la \
+- $(GLIB_LIBS) \
+- $(ATK_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la \
+- $(top_srcdir)/atk-adaptor/libatk-bridge-2.0.la
++app_test_LDADD = libxmlloader.la \
++ libtestutils.la \
++ $(GLIB_LIBS) \
++ $(ATK_LIBS) \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la \
++ $(top_builddir)/atk-adaptor/libatk-bridge-2.0.la
+
+ app_test_SOURCES = test-application.c
+
+@@ -52,7 +52,7 @@ libxmlloader_la_CFLAGS = $(GLIB_CFLAGS) \
+ libxmlloader_la_LIBADD = $(GLIB_LIBS) \
+ $(XML_LIBS) \
+ $(GOBJ_LIBS) \
+- $(top_srcdir)/tests/dummyatk/libdummyatk.la \
++ $(top_builddir)/tests/dummyatk/libdummyatk.la \
+ $(ATK_LIBS)
+
+ libxmlloader_la_SOURCES = atk-object-xml-loader.c\
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml
new file mode 100644
index 00000000000..26728ddfd6f
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-accessible.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert">
+ <state state_enum="modal"/>
+ <state state_enum="multi-line"/>
+ </accessible>
+ <accessible description="second child" name="obj2" role="animation">
+ <accessible description="first prechild" name="obj2/1" role="arrow">
+ <relation relation_type="2" target_name="obj2"/>
+ </accessible>
+ <accessible description="second prechild" name="obj2/2" role="canvas"/>
+ </accessible>
+ <accessible description="third child" name="obj3" role="check box">
+ <accessible description="first prechild" name="obj3/1" role="check menu item"/>
+ </accessible>
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml
new file mode 100644
index 00000000000..41ddf00760e
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-action.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert"/>
+ <accessible_action description="second child" name="obj2" role="application">
+ <action action_name="action1" action_description="action1 description" key_binding="action1 key binding"/>
+ <action action_name="action2" action_description="action2 description" key_binding="action2 key binding"/>
+ </accessible_action>
+ <accessible_action description="third child" name="obj3" role="push button">
+ <action action_name="action1" action_description="action1 description" key_binding="action1 key binding"/>
+ </accessible_action>
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml
new file mode 100644
index 00000000000..80929b0cf7a
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test-component.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible_component description="second child" name="obj2" role="application">
+ <component x="350" y="200" width="0" height="0" layer="2" zorder="1" alpha="1.5"/>
+ </accessible_component>
+ <accessible_component description="third child" name="obj3" role="push button">
+ <component x="250" y="250" width="350" height="200" layer="3" zorder="2" alpha="2.5"/>
+ <accessible_component description="third child a" name="aobj3" role="push button">
+ <component x="250" y="250" width="350" height="200" layer="4" zorder="3" alpha="3.5"/>
+ </accessible_component>
+ </accessible_component>
+ <accessible description="second child" name="obj2" role="application" />
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml
new file mode 100644
index 00000000000..26728ddfd6f
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/files/at-spi2-atk-2.16.0-tests-data/test.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" ?>
+<accessible description="Root of the accessible tree" name="root_object" role="accelerator label">
+ <accessible description="first child" name="obj1" role="alert">
+ <state state_enum="modal"/>
+ <state state_enum="multi-line"/>
+ </accessible>
+ <accessible description="second child" name="obj2" role="animation">
+ <accessible description="first prechild" name="obj2/1" role="arrow">
+ <relation relation_type="2" target_name="obj2"/>
+ </accessible>
+ <accessible description="second prechild" name="obj2/2" role="canvas"/>
+ </accessible>
+ <accessible description="third child" name="obj3" role="check box">
+ <accessible description="first prechild" name="obj3/1" role="check menu item"/>
+ </accessible>
+</accessible>
diff --git a/app-accessibility/at-spi2-atk/metadata.xml b/app-accessibility/at-spi2-atk/metadata.xml
new file mode 100644
index 00000000000..d9f21e6a89d
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-accessibility</herd>
+</pkgmetadata>
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
new file mode 100644
index 00000000000..f8041bb60fa
--- /dev/null
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -0,0 +1,3 @@
+DIST at-spi2-core-2.12.0.tar.xz 454668 SHA256 db550edd98e53b4252521459c2dcaf0f3b060a9bad52489b9dbadbaedad3fb89 SHA512 955249568e28441201d0a079e26bd703e21716b9189e372bfa20cda70e1079bbb51f62246cdeb1b914953f448e0432b749d402d723710247f2a1b8b343b37ccc WHIRLPOOL 67870b40b3c0e343b3119bae93b23540f8ab2c71137d033c9b4ee000d28a4c66353dae8a72d815367ac8b291471dd3c21d985a0cdd4c6812e43f95ca1931010a
+DIST at-spi2-core-2.14.1.tar.xz 456272 SHA256 eef9660b14fdf0fb1f30d1be7c72d591fa7cbb87b00ca3a444425712f46ce657 SHA512 263f2353961787b510a22ede6243ebd6f9eba7fe00740b252ba372e78a2b4a20bd6ed1a9f509b2e33342fc5516d1e8b95f886573d51962755e51584771ac86b9 WHIRLPOOL 54d02cd41f1039c3b166c01215d983b768011c99b81831fc3256a4dde66b3a2fbff7b0fafa4958bbce367fee164c5f5c90531de11f57d65a1972af009b5afd62
+DIST at-spi2-core-2.16.0.tar.xz 455264 SHA256 1c0b77fb8ce81abbf1d80c0afee9858b3f9229f673b7881995fe0fc16b1a74d0 SHA512 b61cb6dad15e2a6f6cd4788e6b63fed37d0098a56d1417b43aed2ba111a7dd7fccbe7c393f0be794bcaf900f38decbd3974c36e395548000d429086f8717df57 WHIRLPOOL 556c504ba9aef2e4ad2b63e3b4d0417ce24a49fafd45287cf3d669612c2d23058f3e7b373a69a569d63938a0333b62d5c601e8a0f1f4b78d0252bea4b64ede3e
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.12.0-r1.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.12.0-r1.ebuild
new file mode 100644
index 00000000000..6a040714f58
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.12.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="+X +introspection"
+KEYWORDS="~alpha ~amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+
+# x11-libs/libSM is needed until upstream #719808 is solved either
+# making the dep unneeded or fixing their configure
+# Only libX11 is optional right now
+COMMON_DEPEND="
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-xevie \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable X x11)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/libatspi/html doc/libatspi/html || die
+ fi
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild
new file mode 100644
index 00000000000..ee6ab161617
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.12.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="+X +introspection"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+
+# x11-libs/libSM is needed until upstream #719808 is solved either
+# making the dep unneeded or fixing their configure
+# Only libX11 is optional right now
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=sys-apps/dbus-1
+ x11-libs/libSM
+ x11-libs/libXi
+ x11-libs/libXtst
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ gnome2_src_configure \
+ --disable-xevie \
+ $(use_enable introspection) \
+ $(use_enable X x11)
+}
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.14.1.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.14.1.ebuild
new file mode 100644
index 00000000000..70660003764
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.14.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="+X +introspection"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+
+# x11-libs/libSM is needed until upstream #719808 is solved either
+# making the dep unneeded or fixing their configure
+# Only libX11 is optional right now
+COMMON_DEPEND="
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-xevie \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable X x11)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/libatspi/html doc/libatspi/html || die
+ fi
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.16.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.16.0.ebuild
new file mode 100644
index 00000000000..ef52d210951
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.16.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+IUSE="+X +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+
+# x11-libs/libSM is needed until upstream #719808 is solved either
+# making the dep unneeded or fixing their configure
+# Only libX11 is optional right now
+COMMON_DEPEND="
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-xevie \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable X x11)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/libatspi/html doc/libatspi/html || die
+ fi
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-core/files/at-spi2-core-2.0.2-disable-teamspaces-test.patch b/app-accessibility/at-spi2-core/files/at-spi2-core-2.0.2-disable-teamspaces-test.patch
new file mode 100644
index 00000000000..269236d177e
--- /dev/null
+++ b/app-accessibility/at-spi2-core/files/at-spi2-core-2.0.2-disable-teamspaces-test.patch
@@ -0,0 +1,13 @@
+diff --git a/dbind/dbtest.c b/dbind/dbtest.c
+index e8bbb63..9843c3d 100644
+--- a/dbind/dbtest.c
++++ b/dbind/dbtest.c
+@@ -417,7 +417,7 @@ int main (int argc, char **argv)
+
+ test_helpers ();
+ test_marshalling ();
+- test_teamspaces (bus);
++ /* test_teamspaces (bus); */
+
+ return 0;
+ }
diff --git a/app-accessibility/at-spi2-core/metadata.xml b/app-accessibility/at-spi2-core/metadata.xml
new file mode 100644
index 00000000000..d9f21e6a89d
--- /dev/null
+++ b/app-accessibility/at-spi2-core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-accessibility</herd>
+</pkgmetadata>
diff --git a/app-accessibility/brltty/Manifest b/app-accessibility/brltty/Manifest
new file mode 100644
index 00000000000..6e11ab2ba9c
--- /dev/null
+++ b/app-accessibility/brltty/Manifest
@@ -0,0 +1 @@
+DIST brltty-5.2.tar.xz 2532684 SHA256 f1293940317a675d0eaeaf3f363bbfe4bfaa5225c2116123a61ce2d3c71943f7 SHA512 8e16701e9c9d776c76e3ad0cb4319b2753295fea229bd3f60cb0dffc0b6946037e6f98daafae873238c4eff90d4b8ddb697b7d425e700c5a098aba8fed9eed3f WHIRLPOOL 33fcf326be381309f2baa3f59807145a0ca3a614f32b0b27e4b76af1c1f46f6459f7be1d629002538588ce71ab017b52bfc642fc06aa2c3f883aba272e61f20e
diff --git a/app-accessibility/brltty/brltty-5.2.ebuild b/app-accessibility/brltty/brltty-5.2.ebuild
new file mode 100644
index 00000000000..e9e9815fc3c
--- /dev/null
+++ b/app-accessibility/brltty/brltty-5.2.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+FINDLIB_USE="ocaml"
+
+inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic \
+ autotools udev systemd python-r1
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://brltty.com/"
+SRC_URI="http://brltty.com/archive/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 x86"
+IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
+ java +midi ncurses nls ocaml +pcm python usb +speech
+ tcl X"
+REQUIRED_USE="doc? ( api )
+ java? ( api )
+ ocaml? ( api )
+ python? ( api )
+ tcl? ( api )"
+
+COMMON_DEP="bluetooth? ( net-wireless/bluez )
+ gpm? ( >=sys-libs/gpm-1.20 )
+ iconv? ( virtual/libiconv )
+ icu? ( dev-libs/icu:= )
+ python? ( ${PYTHON_DEPS} )
+ ncurses? ( sys-libs/ncurses )
+ nls? ( virtual/libintl )
+ tcl? ( >=dev-lang/tcl-8.4.15:0= )
+ usb? ( virtual/libusb:0 )
+ X? ( x11-libs/libXaw )"
+DEPEND="virtual/pkgconfig
+ java? ( >=virtual/jdk-1.4 )
+ python? ( >=dev-python/cython-0.16[${PYTHON_USEDEP}] )
+ ${COMMON_DEP}"
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ ${COMMON_DEP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-ldflags.patch \
+ "${FILESDIR}"/${P}-udev.patch \
+ "${FILESDIR}"/${P}-respect-AR.patch
+
+ java-pkg-opt-2_src_prepare
+
+ # The code runs `pkg-config` directly instead of locating a suitable
+ # pkg-config wrapper (or respecting $PKG_CONFIG).
+ sed -i \
+ -e 's/\<pkg-config\>/${PKG_CONFIG:-pkg-config}/' \
+ aclocal.m4 configure.ac || die
+
+ # We run eautoconf instead of using eautoreconf because brltty uses
+ # a custom build system that uses autoconf without the rest of the
+ # autotools.
+ eautoconf
+ python_copy_sources
+}
+
+src_configure() {
+ tc-export AR LD PKG_CONFIG
+ # override prefix in order to install into /
+ # braille terminal needs to be available as soon in the boot process as
+ # possible
+ # Also override localstatedir so that the lib/brltty directory is installed
+ # correctly.
+ # Disable stripping since we do that ourselves.
+ local myconf=(
+ --prefix=/
+ --localedir=/usr/share/locale
+ --includedir=/usr/include
+ --localstatedir=/var
+ --disable-stripping
+ --with-install-root="${D}"
+ --with-writable-directory="/run/brltty"
+ $(use_enable api)
+ $(use_with beeper beep-package)
+ $(use_enable contracted-braille)
+ $(use_with fm fm-package)
+ $(use_enable gpm)
+ $(use_enable iconv)
+ $(use_enable icu)
+ $(use_enable java java-bindings)
+ $(use_with midi midi-package)
+ $(use_enable nls i18n)
+ $(use_enable ocaml ocaml-bindings)
+ $(use_with pcm pcm-package)
+ $(use_enable speech speech-support)
+ $(use_enable tcl tcl-bindings)
+ $(use_enable X x)
+ $(use_with bluetooth bluetooth-package)
+ $(use_with ncurses curses)
+ $(use_with usb usb-package) )
+
+ econf "${myconf[@]}"
+
+ if use python; then
+ myconf+=( $(use_enable python python-bindings ) )
+
+ python_configure() {
+ econf "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+src_compile() {
+ local JAVAC_CONF=""
+ local OUR_JNI_FLAGS=""
+ if use java; then
+ OUR_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
+ JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
+ fi
+
+ emake JAVA_JNI_FLAGS="${OUR_JNI_FLAGS}" JAVAC="${JAVAC_CONF}"
+
+ if use python; then
+ python_build() {
+ cd "Bindings/Python" || die
+ emake
+ }
+ python_foreach_impl run_in_build_dir python_build
+ fi
+}
+
+src_install() {
+ if use ocaml; then
+ findlib_src_preinst
+ fi
+
+ emake OCAML_LDCONF= install
+
+ if use python; then
+ python_install() {
+ cd "Bindings/Python" || die
+ emake install
+ }
+ python_foreach_impl run_in_build_dir python_install
+ fi
+
+ if use java; then
+ # make install puts the _java.so there, and no it's not $(get_libdir)
+ rm -rf "${D}/usr/lib/java"
+ java-pkg_doso Bindings/Java/libbrlapi_java.so
+ java-pkg_dojar Bindings/Java/brlapi.jar
+ fi
+
+ insinto /etc
+ doins Documents/brltty.conf
+ udev_newrules Autostart/Udev/udev.rules 70-brltty.rules
+ newinitd "${FILESDIR}"/brltty.rc brltty
+ systemd_dounit Autostart/Systemd/brltty.service
+ systemd_dotmpfilesd "${FILESDIR}/${PN}.tmpfiles.conf"
+
+ libdir="$(get_libdir)"
+ mkdir -p "${D}"/usr/${libdir}/
+ mv "${D}"/${libdir}/*.a "${D}"/usr/${libdir}/
+ gen_usr_ldscript libbrlapi.so
+
+ cd Documents
+ mv Manual-BRLTTY/English/BRLTTY.txt BRLTTY-en.txt
+ mv Manual-BRLTTY/French/BRLTTY.txt BRLTTY-fr.txt
+ mv Manual-BrlAPI/English/BrlAPI.txt BrlAPI-en.txt
+ dodoc CONTRIBUTORS ChangeLog HISTORY README* TODO BRLTTY-*.txt
+ dohtml -r Manual-BRLTTY
+ if use doc; then
+ dohtml -r Manual-BrlAPI
+ dodoc BrlAPI-*.txt
+ fi
+
+ keepdir /var/lib/brlapi
+ rmdir "${D}/run/brltty"
+ rmdir "${D}/run"
+}
+
+pkg_postinst() {
+ elog
+ elog please be sure "${ROOT}"etc/brltty.conf is correct for your system.
+ elog
+ elog To make brltty start on boot, type this command as root:
+ elog
+ elog rc-update add brltty boot
+}
diff --git a/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch b/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
new file mode 100644
index 00000000000..e60ea9a4e50
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
@@ -0,0 +1,56 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -377,7 +377,7 @@
+ case "${host_os}"
+ in
+ linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|cygwin*|mingw*|elf*)
+- brltty_mkmod_ld_make="-shared"
++ brltty_mkmod_ld_make="-shared ${LDFLAGS}"
+ ;;
+ solaris*)
+ brltty_mkmod_ld_make="-G"
+@@ -404,7 +404,7 @@
+ esac
+ if test "${GCC}" = "yes"
+ then
+- brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
++ brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
+ else
+ brltty_cv_prog_mkmod="\$(LD) ${brltty_mkmod_ld_make} ${brltty_mkmod_ld_options} -o"
+ fi])
+@@ -414,7 +414,7 @@
+ case "${host_os}"
+ in
+ linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|elf*)
+- brltty_mklib_ld_make="-shared"
++ brltty_mklib_ld_make="-shared ${LDFLAGS}"
+ brltty_mklib_ld_options="-soname"
+ ;;
+ solaris*)
+@@ -449,7 +449,7 @@
+ esac
+ if test "${GCC}" = "yes"
+ then
+- brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
++ brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
+ else
+ brltty_cv_prog_mklib="\$(LD) ${brltty_mklib_ld_make} ${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>} -o"
+ fi])
+--- a/Bindings/OCaml/Makefile.in
++++ b/Bindings/OCaml/Makefile.in
+@@ -55,13 +55,13 @@
+ all : $(OCAML_FILES)
+
+ $(OCAML_CLIBS) : brlapi_stubs.$O brlapi
+- $(OCAMLMKLIB) $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
++ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
+
+ $(OCAML_BCLIB) : $(OCAML_CLIBS) brlapi.cmo
+ $(OCAMLC) -a $(OCAMLMKLIB_FLAGS) -o $(OCAML_LIB).cma brlapi.cmo
+
+ $(OCAML_NCLIB) : $(OCAML_CLIBS) brlapi.cmx
+- $(OCAMLMKLIB) $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
++ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
+
+ brlapi.cmi: brlapi.mli
+ $(OCAMLC) -o $@ -c brlapi.mli
diff --git a/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch b/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch
new file mode 100644
index 00000000000..95451dc98b7
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch
@@ -0,0 +1,12 @@
+diff -Naur brltty-5.2/Programs/Makefile.in brltty-5.2-new/Programs/Makefile.in
+--- brltty-5.2/Programs/Makefile.in 2014-11-06 07:28:41.000000000 -0800
++++ brltty-5.2-new/Programs/Makefile.in 2014-11-20 05:41:57.144219093 -0800
+@@ -434,7 +434,7 @@
+ [ ! -f lib.def ] || mv lib.def $(API_DEF)
+
+ $(API_ARC): $(API_CLIENT_OBJECTS)
+- ar rc $@ $(API_CLIENT_OBJECTS)
++ $(AR) rc $@ $(API_CLIENT_OBJECTS)
+ $(RANLIB) $@
+
+ brlapi_client.$O:
diff --git a/app-accessibility/brltty/files/brltty-5.2-udev.patch b/app-accessibility/brltty/files/brltty-5.2-udev.patch
new file mode 100644
index 00000000000..dbbc2989766
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-udev.patch
@@ -0,0 +1,28 @@
+diff -Naur brltty-5.2/Autostart/Udev/udev.rules brltty-5.2-new/Autostart/Udev/udev.rules
+--- brltty-5.2/Autostart/Udev/udev.rules 2014-11-06 07:28:41.000000000 -0800
++++ brltty-5.2-new/Autostart/Udev/udev.rules 2014-11-20 05:28:44.404885312 -0800
+@@ -182,20 +182,22 @@
+ # FreedomScientific [Focus Blue]
+ ENV{PRODUCT}=="f4e/114/*", ENV{BRLTTY_BRAILLE_DRIVER}="fs", GOTO="brltty_usb_run"
+
++# Seika rules are commented out, because they conflict with USB-to-serial
++# converters.
+ # Device: 10C4:EA60
+ # Generic Identifier
+ # Vendor: Cygnal Integrated Products, Inc.
+ # Product: CP210x UART Bridge / myAVR mySmartUSB light
+ # BrailleMemo [Pocket]
+ # Seika [Braille Display]
+-ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
++#ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
+
+ # Device: 10C4:EA80
+ # Generic Identifier
+ # Vendor: Cygnal Integrated Products, Inc.
+ # Product: CP210x UART Bridge
+ # Seika [Note Taker]
+-ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
++#ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
+
+ # Device: 1148:0301
+ # BrailleMemo [Smart]
diff --git a/app-accessibility/brltty/files/brltty.rc b/app-accessibility/brltty/files/brltty.rc
new file mode 100644
index 00000000000..3afc5af76d3
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty.rc
@@ -0,0 +1,13 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+command=/bin/brltty
+pidfile=/var/run/brltty.pid
+command_args="-P $pidfile -q"
+
+depend() {
+ before *
+ after clock
+}
diff --git a/app-accessibility/brltty/files/brltty.tmpfiles.conf b/app-accessibility/brltty/files/brltty.tmpfiles.conf
new file mode 100644
index 00000000000..18cc4021e33
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty.tmpfiles.conf
@@ -0,0 +1 @@
+d /run/brltty 0755 root root -
diff --git a/app-accessibility/brltty/metadata.xml b/app-accessibility/brltty/metadata.xml
new file mode 100644
index 00000000000..395bfb3cec4
--- /dev/null
+++ b/app-accessibility/brltty/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+ <use>
+ <flag name="api">build brltty's application program interface</flag>
+ <flag name="beeper">support the console tone generator</flag>
+ <flag name="contracted-braille">support in-line contracted braille</flag>
+ <flag name="fm">support for the sound card synthesizer</flag>
+ <flag name="midi">support the musical instrument digital interface</flag>
+ <flag name="pcm">support for sound card digital audio</flag>
+ <flag name="speech">speech support</flag>
+</use>
+<longdescription lang="en">
+BRLTTY is a background process (daemon) which provides access to the Linux/Unix
+console (when in text mode) for a blind person using a refreshable braille
+display. It drives the braille display, and provides complete screen review
+functionality. Some speech capability has also been incorporated.
+</longdescription>
+<longdescription lang="ja">
+BRLTTYは、盲人用ブライユ点字ディスプレイのためのLinux/Unixコンソールを制御するバ
+ックグラウンド・プロセス(デーモン)です。ブライユ点字ディスプレイを動かし、その多
+機能な完全なスクリーン・レビューを提供します。幾つかの台詞読み上げ機能も統合され
+ています。
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/caribou/Manifest b/app-accessibility/caribou/Manifest
new file mode 100644
index 00000000000..9960825b72a
--- /dev/null
+++ b/app-accessibility/caribou/Manifest
@@ -0,0 +1,3 @@
+DIST caribou-0.4.17.tar.xz 421960 SHA256 31828886b812421dd7217a7aa29043945b8601f3a101507f7e3faa0dc157e516 SHA512 97e773fb44f6bcf827bd8c839cd0669e029ebb377e1c3c777f7acf1cbf262ee58af09ea3e941843bc9519eee3bb59f3c572c04ddea0fb888baac9129c74c8932 WHIRLPOOL b3dee923e7815788655279857c5f6b4a6eac9ad34cffffff0b95f05bcb36ea09882acea5b88e1043b2c806d7a78a52a86772affd2e052588eacec41e76fcbf6b
+DIST caribou-0.4.18.1.tar.xz 410548 SHA256 aefadf125a647fc68696f4134e99ee43dca121da5de8e1edf6eab5664a9f3150 SHA512 226ca64fafb4e7c5e38ba714059e9e6ef7bbfce04160b98884fb299dc465e4f7d278033477f2539ba64fe9c39c62448903a8273dee0315bff81dbbe107d665d5 WHIRLPOOL 1310f79944ee547535a04563dd7910dfff2db400faf6c28685deecc062432759a24f0587f875d88cc87ddcdcd4c249a83abde0222ffcab4a24afe91dc9a55cdb
+DIST caribou-0.4.18.tar.xz 422580 SHA256 8d94977f3364926600b5f711406e765a9a61aa444609f87a1d435b301e147226 SHA512 cb1dbfa33ef7898b98d05af8ec937f4ecd6ee17148d136186e6bd1e00da97c4146d04e283f9b72a2ac88e8379f8aa4051535a247bce91dd87f32558322fa3720 WHIRLPOOL 5e3dcfb5ccf74d33f698678092468b2236b7cb1e78ba53816221c1c159c1a657ad32f56f2f389075d1ab4fb363ddaf019f0f3d27164b061ae8e9bba47015a56c
diff --git a/app-accessibility/caribou/caribou-0.4.17.ebuild b/app-accessibility/caribou/caribou-0.4.17.ebuild
new file mode 100644
index 00000000000..1bf20f30210
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.17.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/gtk+:2
+ >=dev-libs/gobject-introspection-0.10.7
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+ # + caribou is python2 only so fix the shell scripts
+ sed -e '/export PYTHONPATH=.*python/ d' \
+ -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
+ -i bin/{antler-keyboard,caribou-preferences}.in ||
+ die "sed failed"
+
+ gnome2_src_prepare
+
+ prepare_caribou() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_caribou
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --disable-docs \
+ --disable-static \
+ --enable-gtk3-module \
+ --enable-gtk2-module \
+ VALAC=$(type -P true)
+ # vala is not needed for tarball builds, but configure checks for it...
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+ dodoc AUTHORS NEWS README # ChangeLog simply points to git log
+}
diff --git a/app-accessibility/caribou/caribou-0.4.18.1.ebuild b/app-accessibility/caribou/caribou-0.4.18.1.ebuild
new file mode 100644
index 00000000000..77a349079dd
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.18.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/gtk+:2
+ >=dev-libs/gobject-introspection-0.10.7:=
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/glib[dbus]
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+ # + caribou is python2 only so fix the shell scripts
+ sed -e '/export PYTHONPATH=.*python/ d' \
+ -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
+ -i bin/{antler-keyboard,caribou-preferences}.in ||
+ die "sed failed"
+
+ gnome2_src_prepare
+
+ prepare_caribou() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_caribou
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --disable-docs \
+ --disable-static \
+ --enable-gtk3-module \
+ --enable-gtk2-module \
+ VALAC=$(type -P true)
+ # vala is not needed for tarball builds, but configure checks for it...
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+ dodoc AUTHORS NEWS README # ChangeLog simply points to git log
+}
diff --git a/app-accessibility/caribou/caribou-0.4.18.ebuild b/app-accessibility/caribou/caribou-0.4.18.ebuild
new file mode 100644
index 00000000000..26c3157d1a7
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.18.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/gtk+:2
+ >=dev-libs/gobject-introspection-0.10.7:=
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/glib[dbus]
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+ # + caribou is python2 only so fix the shell scripts
+ sed -e '/export PYTHONPATH=.*python/ d' \
+ -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
+ -i bin/{antler-keyboard,caribou-preferences}.in ||
+ die "sed failed"
+
+ gnome2_src_prepare
+
+ prepare_caribou() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_caribou
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --disable-docs \
+ --disable-static \
+ --enable-gtk3-module \
+ --enable-gtk2-module \
+ VALAC=$(type -P true)
+ # vala is not needed for tarball builds, but configure checks for it...
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+ dodoc AUTHORS NEWS README # ChangeLog simply points to git log
+}
diff --git a/app-accessibility/caribou/metadata.xml b/app-accessibility/caribou/metadata.xml
new file mode 100644
index 00000000000..4d1f3599c74
--- /dev/null
+++ b/app-accessibility/caribou/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<longdescription lang="en">
+Caribou is a text entry and UI navigation application being developed as an
+alternative to the Gnome On-screen Keyboard. The overarching goal for Caribou
+is to create a usable solution for people whose primary way of accessing a
+computer is a switch device. The initial goal is to make an in-place on-screen
+keyboard suitable for people who can use a mouse but not a hardware keyboard.
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/edbrowse/Manifest b/app-accessibility/edbrowse/Manifest
new file mode 100644
index 00000000000..1bbc405aab2
--- /dev/null
+++ b/app-accessibility/edbrowse/Manifest
@@ -0,0 +1 @@
+DIST edbrowse-3.5.1.zip 745277 SHA256 e379cffb1098cfedf56ceedaaa7e20064551a0737ad6cd8ad5124fdfb18d9a5f SHA512 83bdb1d49afa04a41a84b71e86969880b518d8d6c1e448380d70710ad2373ed57cb3699d3ad50226ea4d5776f511ff50b9510655b27d26948213113699512fc2 WHIRLPOOL e7517c5ae60a438d6d651fbfdbfd7f625c2369f43bb2ba92c1c974e34a7d8ddbb6d441cb1ef79c4354cf88e2796f05110bb0e5ff1b1699cb55b23221c2bd000b
diff --git a/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild b/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild
new file mode 100644
index 00000000000..1c2a80b3862
--- /dev/null
+++ b/app-accessibility/edbrowse/edbrowse-3.5.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="editor, browser, and mail client using the /bin/ed interface"
+HOMEPAGE="http://the-brannons.com/edbrowse/"
+SRC_URI="http://the-brannons.com/${PN}/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_fr odbc"
+COMMON_DEPEND=">=dev-lang/spidermonkey-24.0:24
+ >=sys-libs/readline-6.0
+ >=net-misc/curl-7.36.0
+ >=dev-libs/libpcre-7.8
+ >=dev-libs/openssl-0.9.8j
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-implicit-decl.patch"
+}
+
+src_compile() {
+ jscppflags=$(pkg-config --cflags mozjs-24)
+ jslib=$(pkg-config --libs mozjs-24)
+ emake prefix=/usr JSLIB="${jslib}" JS_CXXFLAGS="${jscppflags}" STRIP=''
+ if use odbc; then
+ # Top-level makefile doesn't have this target.
+ cd src
+ emake prefix=/usr JSLIB="${jslib}" JS_CXXFLAGS="${jscppflags}" STRIP=''
+ cd ..
+ fi
+}
+
+src_install() {
+ cd src
+ emake prefix=/usr DESTDIR="${D}" install
+ if use odbc; then
+ dobin edbrowseodbc
+ fi
+ cd ..
+ dodoc CHANGES README todo
+ cd doc
+ dobin setup.ebrc
+ dohtml usersguide.html philosophy.html
+ dodoc sample.ebrc
+ if use linguas_fr; then
+ dohtml usersguide_fr.html philosophy_fr.html
+ dodoc sample_fr.ebrc
+ fi
+}
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch b/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch
new file mode 100644
index 00000000000..1880d2b3bfe
--- /dev/null
+++ b/app-accessibility/edbrowse/files/edbrowse-3.5.1-implicit-decl.patch
@@ -0,0 +1,22 @@
+diff -Naur edbrowse-3.5.1/src/fetchmail.c edbrowse-3.5.1.new/src/fetchmail.c
+--- edbrowse-3.5.1/src/fetchmail.c 2014-09-23 21:50:37.000000000 -0700
++++ edbrowse-3.5.1.new/src/fetchmail.c 2014-09-29 02:29:46.193856866 -0700
+@@ -6,6 +6,7 @@
+ * This file is part of the edbrowse project, released under GPL.
+ */
+
++#define _GNU_SOURCE
+ #include "eb.h"
+
+ #define MHLINE 200 /* length of a mail header line */
+diff -Naur edbrowse-3.5.1/src/sendmail.c edbrowse-3.5.1.new/src/sendmail.c
+--- edbrowse-3.5.1/src/sendmail.c 2014-09-23 21:50:37.000000000 -0700
++++ edbrowse-3.5.1.new/src/sendmail.c 2014-09-29 02:29:37.105874233 -0700
+@@ -5,6 +5,7 @@
+ * This file is part of the edbrowse project, released under GPL.
+ */
+
++#define _GNU_SOURCE
+ #include "eb.h"
+
+ #include <time.h>
diff --git a/app-accessibility/edbrowse/metadata.xml b/app-accessibility/edbrowse/metadata.xml
new file mode 100644
index 00000000000..234d31d9397
--- /dev/null
+++ b/app-accessibility/edbrowse/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<longdescription>
+ edbrowse is a line editor, web browser and email client using the /bin/ed
+ user interface.
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/eflite/Manifest b/app-accessibility/eflite/Manifest
new file mode 100644
index 00000000000..9c1520f9624
--- /dev/null
+++ b/app-accessibility/eflite/Manifest
@@ -0,0 +1 @@
+DIST eflite-0.4.1.tar.gz 63192 SHA256 91ad85855e55a3fc3b97a1a525db5fd1d211d54342bbfc88d1026813104f1721 SHA512 0060980fd5bb65ad94f1609f6d87cb89b91e680228b603fa590e6ba70b51e894493dda4271dca4d8c97f38cdefbd456c3be0447e5f88a0be7ae39324baa2c796 WHIRLPOOL 50e5e31bd0e8759fdfae1b5183c3fc4b9d1d03d2aa04dd7102651e2aaebafc9b312b1e20082c20bdcb745b7c7fad47bd64f145e392551e6c1d31fa01af5b7969
diff --git a/app-accessibility/eflite/eflite-0.4.1-r2.ebuild b/app-accessibility/eflite/eflite-0.4.1-r2.ebuild
new file mode 100644
index 00000000000..621a9ba0338
--- /dev/null
+++ b/app-accessibility/eflite/eflite-0.4.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools eutils user
+
+DESCRIPTION="A speech server that allows emacspeak and other screen readers to interact with festival lite"
+HOMEPAGE="http://eflite.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE="+16k_voice"
+
+DEPEND=">=app-accessibility/flite-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's:/etc/es.conf:/etc/eflite/es.conf:g' *
+ epatch "${FILESDIR}"/${PN}-0.4.1-flite14.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use 16k_voice; then
+ myconf='--with-vox=cmu_us_kal16'
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ einstall
+ dodoc ChangeLog README INSTALL eflite_test.txt
+
+ insinto /etc/eflite
+ doins "${FILESDIR}"/es.conf
+
+ newinitd "${FILESDIR}"/eflite.rc eflite
+}
+
+pkg_postinst() {
+ enewgroup speech
+}
diff --git a/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
new file mode 100644
index 00000000000..cb3096d88a4
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
@@ -0,0 +1,24 @@
+diff -Naur eflite-0.4.1/Makefile.in eflite-0.4.1-new/Makefile.in
+--- eflite-0.4.1/Makefile.in 2007-01-18 18:01:09.000000000 -0600
++++ eflite-0.4.1-new/Makefile.in 2010-07-23 20:06:45.000000000 -0500
+@@ -34,7 +34,7 @@
+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
+
+ fs.o: fs.c
+- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
++ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
+
+ tone.o: tone.c
+ $(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<
+diff -Naur eflite-0.4.1/fs.c eflite-0.4.1.new/fs.c
+--- eflite-0.4.1/fs.c 2007-01-18 16:01:09.000000000 -0800
++++ eflite-0.4.1.new/fs.c 2013-09-08 09:31:57.417262688 -0700
+@@ -523,7 +523,7 @@
+ int playlen, skip;
+ if (type == SPEECH)
+ {
+- skip = (187 * wptr->sample_rate) / speed;
++ skip = 0;
+ playlen = wptr->num_samples - (skip * 2);
+ if (playlen > 0 && playlen < 500) playlen += (skip * 2) / 3;
+ }
diff --git a/app-accessibility/eflite/files/eflite.rc b/app-accessibility/eflite/files/eflite.rc
new file mode 100644
index 00000000000..ff91540460c
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite.rc
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use alsasound
+ use modules
+ use hotplug
+}
+
+start() {
+ ebegin "Starting eflite"
+ start-stop-daemon --start --exec /usr/bin/eflite --background \
+ --quiet --pidfile /var/run/eflite.pid --make-pidfile -- -D || eend 1
+
+ SOCKET=`egrep '^sockname=' /etc/eflite/es.conf | sed 's/^sockname=//'`
+ [ ! -S ${SOCKET} ] && SOCKET=/tmp/es.socket
+
+ chown root:speech ${SOCKET}
+ chmod 660 ${SOCKET}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping eflite"
+ start-stop-daemon --stop --quiet --pidfile /var/run/eflite.pid
+ eend $?
+}
diff --git a/app-accessibility/eflite/files/es.conf b/app-accessibility/eflite/files/es.conf
new file mode 100644
index 00000000000..17443d3e42b
--- /dev/null
+++ b/app-accessibility/eflite/files/es.conf
@@ -0,0 +1,11 @@
+# What socket do we listen on
+sockname=/tmp/es.socket
+
+# What volume do we set?
+tone_volume=8192
+
+# Do we use the PC Speaker? (0/1)
+speaker_tones=0
+
+# Do we use the sound card (via flite)? (0/1)
+soundcard_tones=1
diff --git a/app-accessibility/eflite/metadata.xml b/app-accessibility/eflite/metadata.xml
new file mode 100644
index 00000000000..c4c56fa229f
--- /dev/null
+++ b/app-accessibility/eflite/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="16k_voice">Use a higher-quality voice.</flag>
+ </use>
+ <longdescription lang="en">
+ EFlite is a speech server for Emacspeak and other screen readers
+ that allows them to interface with Festival Lite, a free
+ text-to-speech engine developed at the CMU Speech Center as an
+ off-shoot of Festival.
+</longdescription>
+ <longdescription lang="ja">
+ EFliteはEmacspeakと他のスクリーン読取り装置のスピーチサーバ。この
+ サーバーで前のプログラムはFestival Lite(CMU Speech Centerで開発した
+ Festivalのようにスピーチにテキストを変わるエンジン。)と
+ インタフェスすることが出来る。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">eflite</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/emacspeak-ss/Manifest b/app-accessibility/emacspeak-ss/Manifest
new file mode 100644
index 00000000000..c73124f6a43
--- /dev/null
+++ b/app-accessibility/emacspeak-ss/Manifest
@@ -0,0 +1 @@
+DIST emacspeak-ss-1.9.1.tar.gz 49077 SHA256 67131f9958381fd62be38b9c27b49d77d2d2d5cc4af1106d0dc9d74d2d9cf94e SHA512 a95505a1eaa0b45732d6d8e7322fb75bebc59b876233ae07c5912f1582f0be29d3258dfd5659993ce4b03f72eb316469de95688dcefb7ec61b4ef328f2f50335 WHIRLPOOL 54e838777f957a6e9f2f495db51b639448b7d71f2b9b6668fce58f6567998df56fd6f1582ed6d2435cac0c631efcc4054b766f692ddff805ec24f2f17cad5813
diff --git a/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild b/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild
new file mode 100644
index 00000000000..4bb34886357
--- /dev/null
+++ b/app-accessibility/emacspeak-ss/emacspeak-ss-1.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="adds support for several speech synthesizers to emacspeak"
+HOMEPAGE="http://leb.net/blinux/"
+SRC_URI="http://leb.net/pub/blinux/emacspeak/blinux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86 ppc"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-accessibility/emacspeak-18"
+
+src_prepare() {
+ epatch "${FILESDIR}"/gentoo-apollo-fix.patch
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ man1dir="${D}"/usr/share/man/man1 \
+ install
+ dodoc CREDITS ChangeLog OtherSynthesizers TODO TROUBLESHOOTING README*
+}
diff --git a/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch b/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch
new file mode 100644
index 00000000000..3d8aa016453
--- /dev/null
+++ b/app-accessibility/emacspeak-ss/files/gentoo-apollo-fix.patch
@@ -0,0 +1,24 @@
+diff -Naur emacspeak-ss-1.9.1.old/Makefile.in emacspeak-ss-1.9.1/Makefile.in
+--- emacspeak-ss-1.9.1.old/Makefile.in 2000-05-07 18:51:21.000000000 -0500
++++ emacspeak-ss-1.9.1/Makefile.in 2004-04-22 18:43:20.635283200 -0500
+@@ -3,7 +3,7 @@
+ man1dir=@mandir@/man1
+ exec_prefix = @exec_prefix@
+ bindir=$(prefix)/share/emacs/site-lisp/emacspeak/
+-libdir=$(prefix)/lib/emacs/common/emacspeak/
++libdir=$(prefix)/lib/emacspeak-ss
+
+ INSTALL=@INSTALL@
+ VERSION=@VERSION@
+diff -Naur emacspeak-ss-1.9.1.old/apollo.in emacspeak-ss-1.9.1/apollo.in
+--- emacspeak-ss-1.9.1.old/apollo.in 2000-05-07 18:27:31.000000000 -0500
++++ emacspeak-ss-1.9.1/apollo.in 2004-04-22 18:35:09.255401085 -0500
+@@ -101,7 +101,7 @@
+ # write the argument to the synthesizer, and return its response if any
+ proc tts_ping {query} {
+ global tts
+- set status [exec /usr/lib/emacs/common/emacspeak/ping-apollo "$query" $tts(port) ]
++ set status [exec /usr/lib/emacspeak-ss/ping-apollo "$query" $tts(port) ]
+ return $status
+ }
+
diff --git a/app-accessibility/emacspeak-ss/metadata.xml b/app-accessibility/emacspeak-ss/metadata.xml
new file mode 100644
index 00000000000..5e5b1e56d56
--- /dev/null
+++ b/app-accessibility/emacspeak-ss/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ Emacspeak speech servers for DoubleTalk PC and AT,
+ Braille 'n Speak, Type 'n Speak, Braille Lite from Blazie,
+ Accent SA, Apollo 2, JUNO, and JUNO-sp from Dolphin,
+ Spanish ciber 232 (+plus), Spanish PC Hablado notebook.
+</longdescription>
+<longdescription lang="ja">
+ DoubleTalkPC and ATとBraille 'n SpeakとType 'n SpeakとBlazieから
+ Braille LiteとAccent SAとApollo SAとApollo 2とDolphinからJUNO
+ and JUNO-spとSpanish ciber 232 (+plus)とSpanish PC Hablado
+ notebookのEmacspeakスピーチサーバーです。
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/emacspeak/Manifest b/app-accessibility/emacspeak/Manifest
new file mode 100644
index 00000000000..a3025832748
--- /dev/null
+++ b/app-accessibility/emacspeak/Manifest
@@ -0,0 +1 @@
+DIST emacspeak-39.0.tar.bz2 4989631 SHA256 aff805271ea02ad7e08c121d42886d1a774d1b58a42bf2c570cc6722b903fc71 SHA512 c0a0c503d6ccc2abb53a8be580997b44e0449c2225e8a64cee73c24d69a28c3f47c0e660a95a6e77dd4d660272ad562ff747ce3c0a989f8fe7c8171f60349173 WHIRLPOOL 9f4c3cdd2d2695b7351f83733454afcdfe569921f8d304447132a973fa9a02b572ee149a7b0d0ee0b914c00e37fcacb26aaef270f8fa43a93b528591af12e862
diff --git a/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild b/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild
new file mode 100644
index 00000000000..6c2ee753ed4
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+NEED_EMACS=24
+FORCE_PRINT_ELOG=1
+DISABLE_AUTOFORMATTING=1
+inherit eutils readme.gentoo elisp
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk"
+ inherit subversion
+else
+ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+ KEYWORDS="amd64 ppc x86"
+fi
+
+DESCRIPTION="the emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="+espeak"
+
+ DEPEND="espeak? ( app-accessibility/espeak )"
+
+RDEPEND="${DEPEND}
+ >=dev-tcltk/tclx-8.4"
+
+DOC_CONTENTS='
+As of version 39.0 and later, the /usr/bin/emacspeak
+shell script has been removed downstream in Gentoo.
+You should launch emacspeak by another method, for instance
+by adding the following to your ~/.emacs file:
+(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
+'
+
+src_prepare() {
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_configure() {
+ emake config
+}
+
+src_compile() {
+ emake emacspeak
+ if use espeak; then
+ local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+ if [[ -z $tcl_version ]]; then
+ die 'Unable to detect the installed version of dev-lang/tcl.'
+ fi
+ cd servers/linux-espeak
+ emake TCL_VERSION="${tcl_version}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${D}/usr/bin/emacspeak"
+ if use espeak; then
+ pushd servers/linux-espeak > /dev/null || die
+ emake DESTDIR="${D}" install
+ local orig_serverdir="/usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak"
+ local serverfile="${D}${orig_serverdir}/tclespeak.so"
+ install -Dm755 "$serverfile" \
+ "${D}/usr/$(get_libdir)/emacspeak/tclespeak.so" || die
+ rm -f "$serverfile" || die
+ dosym "/usr/$(get_libdir)/emacspeak/tclespeak.so" \
+ "$orig_serverdir/tclespeak.so"
+ popd > /dev/null || die
+ fi
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+ cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
+ user-guide || die
+ readme.gentoo_create_doc
+}
diff --git a/app-accessibility/emacspeak/emacspeak-9999.ebuild b/app-accessibility/emacspeak/emacspeak-9999.ebuild
new file mode 100644
index 00000000000..306aeefb012
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+NEED_EMACS=24
+FORCE_PRINT_ELOG=1
+DISABLE_AUTOFORMATTING=1
+inherit eutils readme.gentoo elisp
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/tvraman/emacspeak.git"
+ inherit git-r3
+else
+ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+DESCRIPTION="the emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="+espeak"
+
+ DEPEND="espeak? ( app-accessibility/espeak )"
+
+RDEPEND="${DEPEND}
+ >=dev-tcltk/tclx-8.4"
+
+DOC_CONTENTS='
+As of version 39.0 and later, the /usr/bin/emacspeak
+shell script has been removed downstream in Gentoo.
+You should launch emacspeak by another method, for instance
+by adding the following to your ~/.emacs file:
+(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
+'
+
+src_prepare() {
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_configure() {
+ emake config
+}
+
+src_compile() {
+ emake emacspeak
+ if use espeak; then
+ local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+ if [[ -z $tcl_version ]]; then
+ die 'Unable to detect the installed version of dev-lang/tcl.'
+ fi
+ cd servers/linux-espeak
+ emake TCL_VERSION="${tcl_version}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${D}/usr/bin/emacspeak"
+ if use espeak; then
+ pushd servers/linux-espeak > /dev/null || die
+ emake DESTDIR="${D}" install
+ local orig_serverdir="/usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak"
+ local serverfile="${D}${orig_serverdir}/tclespeak.so"
+ install -Dm755 "$serverfile" \
+ "${D}/usr/$(get_libdir)/emacspeak/tclespeak.so" || die
+ rm -f "$serverfile" || die
+ dosym "/usr/$(get_libdir)/emacspeak/tclespeak.so" \
+ "$orig_serverdir/tclespeak.so"
+ popd > /dev/null || die
+ fi
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+ cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
+ user-guide || die
+ readme.gentoo_create_doc
+}
diff --git a/app-accessibility/emacspeak/metadata.xml b/app-accessibility/emacspeak/metadata.xml
new file mode 100644
index 00000000000..3a804e6c49f
--- /dev/null
+++ b/app-accessibility/emacspeak/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>emacs</herd>
+ <longdescription lang="en">Emacspeak is a speech interface that allows visually impaired
+ users to interact independently and efficiently with the computer.</longdescription>
+ <longdescription lang="ja">Emacspeakで視覚障害者が単独と手際良くでコンピュータを
+ 使うことが出来る。</longdescription>
+ <use>
+ <flag name="espeak">Adds support for the espeak tts engine</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">emacspeak</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/epos/Manifest b/app-accessibility/epos/Manifest
new file mode 100644
index 00000000000..0d27ef42255
--- /dev/null
+++ b/app-accessibility/epos/Manifest
@@ -0,0 +1 @@
+DIST epos-2.5.37.tar.gz 976240 SHA256 7b6e835d4db4f64cfdcf3359d84b6b0ed02e8fb89851aed7615768f7d07c8607 SHA512 870718a5e7b5048eafd62c478963de92fe8a90b3e755f79ea665dc33ad762c0ec4ebaf7c99d5f2be8983a0deacba284ae07b24d9a31bdd1a1eff5924327255ef WHIRLPOOL 874657f4f9435d6fed821747229758e2f064ed467dae418a085c5d2268aa2ac1b22ba55bbd393ecd7a08d4332d1ee742e2b032abfa99b2ff1c9d06cc26b851c1
diff --git a/app-accessibility/epos/epos-2.5.37-r1.ebuild b/app-accessibility/epos/epos-2.5.37-r1.ebuild
new file mode 100644
index 00000000000..4cd66ace9d2
--- /dev/null
+++ b/app-accessibility/epos/epos-2.5.37-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="language independent text-to-speech system"
+HOMEPAGE="http://epos.ure.cas.cz/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND=">=app-text/sgmltools-lite-3.0.3-r9"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-disable-tests.patch
+
+ sed -i -e "s/CCC/#CCC/" configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-charsets \
+ --disable-portaudio
+}
+
+src_install() {
+ default
+
+ doinitd "${FILESDIR}/eposd"
+ dodoc WELCOME THANKS Changes "${FILESDIR}/README.gentoo"
+}
diff --git a/app-accessibility/epos/files/README.gentoo b/app-accessibility/epos/files/README.gentoo
new file mode 100644
index 00000000000..a058564ea27
--- /dev/null
+++ b/app-accessibility/epos/files/README.gentoo
@@ -0,0 +1,2 @@
+Due to /usr/bin/say conflicting with the speech-dispatcher ebuild, it has
+beenn moved to /usr/bin/epos_say.
diff --git a/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch b/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch
new file mode 100644
index 00000000000..a877ca68486
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch
@@ -0,0 +1,16 @@
+diff -uNr epos-2.5.37.org/src/tests/Makefile.am epos-2.5.37/src/tests/Makefile.am
+--- epos-2.5.37.org/src/tests/Makefile.am 2012-04-14 00:38:56.000000000 -0400
++++ epos-2.5.37/src/tests/Makefile.am 2012-04-14 00:39:10.000000000 -0400
+@@ -1,11 +1,9 @@
+ ## Process this file with automake run in the top directory to yield Makefile.in
+
+ TESTS=hard_zero_data_test \
+- intr_test \
+- legal_data_test long_data_test long_strm_test \
++ legal_data_test long_data_test \
+ random_data_test \
+ soft_zero_data_test \
+- syn2_test \
+ vogon_test \
+ shutdown_test
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc43.patch b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
new file mode 100644
index 00000000000..4a61b5ffd04
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
@@ -0,0 +1,23 @@
+--- epos-2.5.37.orig/src/nnet/neural.cc
++++ epos-2.5.37/src/nnet/neural.cc
+@@ -38,7 +38,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <time.h>
+
+ /*
+--- epos-2.5.37.orig/arch/win/service/install.cpp
++++ epos-2.5.37/arch/win/service/install.cpp
+@@ -23,7 +23,7 @@
+ #include <winsvc.h>
+ #include "service.h"
+ #include <stdio.h> //sprintf & fopen
+-#include <iostream.h>
++#include <iostream>
+ #include "Shlwapi.h"
+
+ SC_HANDLE scm;
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc45.patch b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
new file mode 100644
index 00000000000..70af1db9440
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
@@ -0,0 +1,15 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318585
+
+--- src/nnet/neural_parse.yy
++++ src/nnet/neural_parse.yy
+@@ -255,7 +255,7 @@
+
+ int yyerror (char *s)
+ {
+- shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf, s));
++ shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf.c_str(), s));
+ return -1;
+ }
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc47.patch b/app-accessibility/epos/files/epos-2.5.37-gcc47.patch
new file mode 100644
index 00000000000..6e795e3548a
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc47.patch
@@ -0,0 +1,16 @@
+ https://bugs.gentoo.org/440354
+
+ src/nnet/map.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/nnet/map.h
++++ b/src/nnet/map.h
+@@ -25,7 +25,7 @@ T2 & TMap<T1,T2>::operator [] (const T1 &key) {
+ else {
+ TData x;
+ x.first() = key;
+- return insert (x)->second();
++ return this->insert (x)->second();
+ }
+ }
+
diff --git a/app-accessibility/epos/files/eposd b/app-accessibility/epos/files/eposd
new file mode 100644
index 00000000000..b245da92a23
--- /dev/null
+++ b/app-accessibility/epos/files/eposd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use alsasound esound
+}
+
+start() {
+ ebegin "Starting eposd"
+ start-stop-daemon --start --quiet --background --make-pidfile --pidfile /var/run/eposd.pid \
+ --exec /usr/bin/eposd -- -f
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping eposd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/eposd.pid
+ eend $?
+}
diff --git a/app-accessibility/epos/metadata.xml b/app-accessibility/epos/metadata.xml
new file mode 100644
index 00000000000..e85edf9eb1d
--- /dev/null
+++ b/app-accessibility/epos/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge">epos</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/espeak/Manifest b/app-accessibility/espeak/Manifest
new file mode 100644
index 00000000000..e8492b3bf2e
--- /dev/null
+++ b/app-accessibility/espeak/Manifest
@@ -0,0 +1,2 @@
+DIST espeak-1.47.11-source.zip 2813649 SHA256 9bd4d0569af48a2cb13fa76704dec3124d27025a3f21c87598457976472b360c SHA512 77c3989fbd0e4aadae0da2d7f1c587854895ae103633704ee5b4042b0618897d01edffa80b1f13e6cbf356f2f31beaf4fdb7e90e4ab641d5286d559aaefe932b WHIRLPOOL c26f481d4c3c485ba0eb3fe7ae3bcf36e7001d49e0e27a6f0934fdb9c91cfef4974c1d34daebd0286694346a44c647cfb96769da54536e0b4380778af755673c
+DIST espeak-1.48.04-source.zip 3019245 SHA256 bf9a17673adffcc28ff7ea18764f06136547e97bbd9edf2ec612f09b207f0659 SHA512 f0759e6ace2604c8cbb19e8c3fd4b106edf4dcece247a6677f6b734af7746c35a367126edfbe585396c98f6c54f07e25d64bfab35e258e64f09bd2c0833247fa WHIRLPOOL 259fe408a2d3808f4b1ecec6850262f3b7c0e9a4511fa1bcca414da7d6608e2a0b847a3abb19687ea1cb4e21ca8334fdf0b66b6a78bd363882891b3ebdfb06fc
diff --git a/app-accessibility/espeak/espeak-1.47.11-r1.ebuild b/app-accessibility/espeak/espeak-1.47.11-r1.ebuild
new file mode 100644
index 00000000000..5c7c1e44687
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.47.11-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="portaudio pulseaudio"
+
+COMMON_DEPEND=" portaudio? ( >=media-libs/portaudio-19_pre20071207 )
+ pulseaudio? ( media-sound/pulseaudio )"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip"
+
+RDEPEND="${COMMON_DEPEND}
+ media-sound/sox"
+
+S=${WORKDIR}/${MY_P}/src
+
+get_audio() {
+ if use portaudio && use pulseaudio; then
+ echo runtime
+ elif use portaudio; then
+ echo portaudio
+ elif use pulseaudio; then
+ echo pulseaudio
+ else
+ echo none
+ fi
+}
+
+src_prepare() {
+ # gentoo uses portaudio 19.
+ mv -f portaudio19.h portaudio.h
+}
+
+src_compile() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ AR="$(tc-getAR)" \
+ AUDIO="$(get_audio)" \
+ all
+
+ einfo "Fixing byte order of phoneme data files"
+ pushd ../platforms/big_endian > /dev/null
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+ ./espeak-phoneme-data \
+ ../../espeak-data \
+ . \
+ ../../espeak-data/phondata-manifest
+ cp -f phondata phonindex phontab "../../espeak-data"
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ DESTDIR="${D}" \
+ AUDIO="$(get_audio)" \
+ install
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog.txt ReadMe
+ dohtml -r docs/*
+}
+
+pkg_preinst() {
+ local voicedir="${ROOT}/usr/share/${PN}-data/voices/en"
+ if [ -d "${voicedir}" ]; then
+ rm -rf "${voicedir}"
+ fi
+}
+
+pkg_postinst() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn "Since portaudio and pulseaudio are not in your use flags,"
+ ewarn "espeak will only be able to create wav files."
+ ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
+ ewarn "with either portaudio or pulseaudio USE flag enabled."
+ fi
+}
diff --git a/app-accessibility/espeak/espeak-1.48.04.ebuild b/app-accessibility/espeak/espeak-1.48.04.ebuild
new file mode 100644
index 00000000000..dd706023dd1
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.48.04.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="portaudio pulseaudio"
+
+COMMON_DEPEND=" portaudio? ( >=media-libs/portaudio-19_pre20071207 )
+ pulseaudio? ( media-sound/pulseaudio )"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip"
+
+RDEPEND="${COMMON_DEPEND}
+ media-sound/sox"
+
+S=${WORKDIR}/${MY_P}/src
+
+get_audio() {
+ if use portaudio && use pulseaudio; then
+ echo runtime
+ elif use portaudio; then
+ echo portaudio
+ elif use pulseaudio; then
+ echo pulseaudio
+ else
+ echo none
+ fi
+}
+
+src_prepare() {
+ # gentoo uses portaudio 19.
+ mv -f portaudio19.h portaudio.h
+}
+
+src_compile() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ AR="$(tc-getAR)" \
+ AUDIO="$(get_audio)" \
+ all
+
+ einfo "Fixing byte order of phoneme data files"
+ pushd ../platforms/big_endian > /dev/null
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+ ./espeak-phoneme-data \
+ ../../espeak-data \
+ . \
+ ../../espeak-data/phondata-manifest
+ cp -f phondata phonindex phontab "../../espeak-data"
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ DESTDIR="${D}" \
+ AUDIO="$(get_audio)" \
+ install
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog.txt ReadMe
+ dohtml -r docs/*
+}
+
+pkg_preinst() {
+ local voicedir="${ROOT}/usr/share/${PN}-data/voices/en"
+ if [ -d "${voicedir}" ]; then
+ rm -rf "${voicedir}"
+ fi
+}
+
+pkg_postinst() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn "Since portaudio and pulseaudio are not in your use flags,"
+ ewarn "espeak will only be able to create wav files."
+ ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
+ ewarn "with either portaudio or pulseaudio USE flag enabled."
+ fi
+}
diff --git a/app-accessibility/espeak/metadata.xml b/app-accessibility/espeak/metadata.xml
new file mode 100644
index 00000000000..c07bb6b946a
--- /dev/null
+++ b/app-accessibility/espeak/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">espeak</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/espeakup/Manifest b/app-accessibility/espeakup/Manifest
new file mode 100644
index 00000000000..d37f8fcc5be
--- /dev/null
+++ b/app-accessibility/espeakup/Manifest
@@ -0,0 +1 @@
+DIST espeakup-0.71.tar.bz2 24663 SHA256 8307986998256db21e615c4edc1befedde28a6995971da258e9d513dd79bd3ab SHA512 01091560cd4843897fa6925a54b4c856fe57ed5728ddc0c091c93b1ae14eb2f4d07ab2247e40bd5a5968cc22ee3696abfe1b28f67b95aa7ab61e33667c51135d WHIRLPOOL 8cc6d335e40a560c14ed17fddc475473722606c7e98148f2f3aa786443b49bdee343cfa0c85e845ce79e8c0bdd330825232512e67869bf8aed6fac81d5e3f4b8
diff --git a/app-accessibility/espeakup/espeakup-0.71.ebuild b/app-accessibility/espeakup/espeakup-0.71.ebuild
new file mode 100644
index 00000000000..cf5d4298e1a
--- /dev/null
+++ b/app-accessibility/espeakup/espeakup-0.71.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
+HOMEPAGE="http://www.linux-speakup.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="|| (
+ app-accessibility/espeak[portaudio]
+ app-accessibility/espeak[pulseaudio] )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
+ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
+ERROR_SPEAKUP_SYNTH_SOFT="CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
+
+pkg_setup() {
+ if kernel_is -ge 2 6 37; then
+ check_extra_config
+ elif ! has_version app-accessibility/speakup; then
+ ewarn "Cannot find speakup on your system."
+ ewarn "Please upgrade your kernel to 2.6.37 or later and enable the"
+ ewarn "CONFIG_SPEAKUP and CONFIG_SPEAKUP_SYNTH_SOFT options"
+ ewarn "or install app-accessibility/speakup."
+ fi
+}
+
+src_compile() {
+ emake || die "Compile failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed."
+ dodoc ChangeLog README ToDo
+ newconfd "${FILESDIR}"/espeakup.confd espeakup
+ newinitd "${FILESDIR}"/espeakup.rc espeakup
+}
+
+pkg_postinst() {
+ elog "To get espeakup to start automatically, it is currently recommended"
+ elog "that you add it to the default run level, by giving the following"
+ elog "command as root."
+ elog
+ elog "rc-update add espeakup default"
+ elog
+ elog "You can also set a default voice now for espeakup."
+ elog "See /etc/conf.d/espeakup for how to do this."
+}
diff --git a/app-accessibility/espeakup/espeakup-9999.ebuild b/app-accessibility/espeakup/espeakup-9999.ebuild
new file mode 100644
index 00000000000..7138fd63579
--- /dev/null
+++ b/app-accessibility/espeakup/espeakup-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/williamh/espeakup.git"
+ vcs=git-2
+else
+ SRC_URI=""
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit $vcs linux-info
+
+DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
+HOMEPAGE="http://www.github.com/williamh/espeakup"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="|| (
+ app-accessibility/espeak[portaudio]
+ app-accessibility/espeak[pulseaudio] )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
+ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
+ERROR_SPEAKUP_SYNTH_SOFT="CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
+
+pkg_setup() {
+ if kernel_is -ge 2 6 37; then
+ check_extra_config
+ elif ! has_version app-accessibility/speakup; then
+ ewarn "Cannot find speakup on your system."
+ ewarn "Please upgrade your kernel to 2.6.37 or later and enable the"
+ ewarn "CONFIG_SPEAKUP and CONFIG_SPEAKUP_SYNTH_SOFT options"
+ ewarn "or install app-accessibility/speakup."
+ fi
+}
+
+src_compile() {
+ emake || die "Compile failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed."
+ dodoc README ToDo
+ newconfd "${FILESDIR}"/espeakup.confd espeakup
+ newinitd "${FILESDIR}"/espeakup.rc espeakup
+}
+
+pkg_postinst() {
+ elog "To get espeakup to start automatically, it is currently recommended"
+ elog "that you add it to the default run level, by giving the following"
+ elog "command as root."
+ elog
+ elog "rc-update add espeakup default"
+ elog
+ elog "You can also set a default voice now for espeakup."
+ elog "See /etc/conf.d/espeakup for how to do this."
+}
diff --git a/app-accessibility/espeakup/files/espeakup.confd b/app-accessibility/espeakup/files/espeakup.confd
new file mode 100644
index 00000000000..035012cc08e
--- /dev/null
+++ b/app-accessibility/espeakup/files/espeakup.confd
@@ -0,0 +1,9 @@
+# conf.d file for espeakup
+#
+# Please check man 8 espeakup for more information about the options
+# espeakup accepts.
+#
+# Currently, the only meaningful option is:
+# --default-voice=voicename -- set the espeak voice espeakup will use.
+#
+ESPEAKUP_OPTS=""
diff --git a/app-accessibility/espeakup/files/espeakup.rc b/app-accessibility/espeakup/files/espeakup.rc
new file mode 100644
index 00000000000..f0777e1c2f2
--- /dev/null
+++ b/app-accessibility/espeakup/files/espeakup.rc
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ after modules
+ use alsasound pulseaudio
+}
+
+start() {
+ ebegin "Starting espeakup"
+ start-stop-daemon --start --exec /usr/bin/espeakup \
+ -- ${ESPEAKUP_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping espeakup"
+ start-stop-daemon --stop --pidfile /var/run/espeakup.pid
+ eend $?
+}
+
+restart() {
+ svc_stop || exit 1
+ sleep 2
+ svc_start || exit 1
+}
diff --git a/app-accessibility/espeakup/metadata.xml b/app-accessibility/espeakup/metadata.xml
new file mode 100644
index 00000000000..484f3c3991e
--- /dev/null
+++ b/app-accessibility/espeakup/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<longdescription>
+Espeakup is a small lightweight connector which makes it possible for
+speakup to use espeak as its synthesizer.
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/festival-fi/Manifest b/app-accessibility/festival-fi/Manifest
new file mode 100644
index 00000000000..e44801c236f
--- /dev/null
+++ b/app-accessibility/festival-fi/Manifest
@@ -0,0 +1,3 @@
+DIST hy_fi_mv_diphone-20041119.tgz 3670516 SHA256 6d1e93cdf6c40fe15615e0d31edbe21198cf8e5c8f1cd734a09719843e80b988 SHA512 8e762a988e028c4b44430252150525a23421d1d58a1d58a9826866623729e4fadbb668fd891d1e0e36eee963319ae6cb2bb03dac6ce1f64629d5227d57157d60 WHIRLPOOL 1b750f092688b102b83322b5c24fa69d868b11151ef68343f103a298c7e114a7880ed110ebc305969ac8aa48376fcab04a6f9a4fa7d1c6917d2672a4479b8cb8
+DIST lavennin-20041119.tgz 172438 SHA256 db47f99c85f3c46ca4598365b6e0885b6f1407460d4e7e355d3b09f865ba451f SHA512 0f20ad71ce1862f05e5ee78860804255f0d40e93b80e5869276e7c8032d594b8ad259a60018fde95ea655e30d8f0574138c5bb53d5fbe61e20658d299493897d WHIRLPOOL 3a24e173f5bf004c85f5bcd9282a6931c19e2f474431dac2fab75d968b52a9dfbfc5ebd568198d9f23b81dff08af249d97c8f494de2b6d1454f70000c0ae6597
+DIST suo_fi_lj-1.0g-20051204.tgz 5928158 SHA256 d9c4dbbb8f1701dc5a0ef99b4aa1317266873e49b6b97163590abade952f8588 SHA512 f239f34836a6e70be77a5f20a6cae1eba394f07e9ecb6db081b7c6d272d1c26b29ed89dc22deb7f9189562c75c00049ecb4e3426eecaa835145dfbd4aa86c360 WHIRLPOOL edebcdb3f3afabe056401c3c95e1d3b55db6a2af42807fc5a8d9ee1d0bb45d051390e3e91dca78d914036b7ebc7f79f1ba6bf6c912b17fcd4fe73b38ea04fd7e
diff --git a/app-accessibility/festival-fi/festival-fi-20041119.ebuild b/app-accessibility/festival-fi/festival-fi-20041119.ebuild
new file mode 100644
index 00000000000..9843573e9d2
--- /dev/null
+++ b/app-accessibility/festival-fi/festival-fi-20041119.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Finnish diphones and text to speech script for festival"
+HOMEPAGE="http://www.ling.helsinki.fi/suopuhe"
+SRC_URI="http://www.ling.helsinki.fi/suopuhe/download/hy_fi_mv_diphone-${PV}.tgz
+ http://phon.joensuu.fi/suopuhe/tulosaineisto/suo_fi_lj-1.0g-20051204.tgz
+ http://www.ling.helsinki.fi/suopuhe/download/lavennin-${PV}.tgz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="perl"
+
+RDEPEND=">=app-accessibility/festival-1.96_beta"
+DEPEND=""
+
+src_prepare(){
+ cd "${WORKDIR}/lavennin/bin"
+ epatch "${FILESDIR}/${P}_lavennin_path.patch"
+}
+
+src_install() {
+ cd "${WORKDIR}"
+ dodoc festival/lib/voices/finnish/hy_fi_mv_diphone/README.mv
+ rm festival/lib/voices/finnish/hy_fi_mv_diphone/{README.mv,LICENSE}
+ insinto /usr/share/festival/
+ cd festival/lib/
+ doins -r voices/
+ cd "${WORKDIR}/lavennin/"
+ newdoc README.txt README.lavennin
+ dodoc man/*.shtml
+
+ if use perl; then
+
+ newbin bin/lavennin suopuhe-lavennin
+ dodir /usr/share/suopuhe/data/
+ insinto /usr/share/suopuhe
+ doins -r data
+
+ elog "TTS perl script installed as suopuhe-lavennin"
+ fi
+}
diff --git a/app-accessibility/festival-fi/files/festival-fi-20041119_lavennin_path.patch b/app-accessibility/festival-fi/files/festival-fi-20041119_lavennin_path.patch
new file mode 100644
index 00000000000..7084641a669
--- /dev/null
+++ b/app-accessibility/festival-fi/files/festival-fi-20041119_lavennin_path.patch
@@ -0,0 +1,18 @@
+# 08/May/2009
+# Patch to fix the path to data files for Gentoo
+# Not sending this to upstrem.
+# neurogeek@gentoo.org
+
+--- bin/lavennin.orig 2009-05-08 01:05:48.000000000 -0430
++++ bin/lavennin 2009-05-08 01:07:07.000000000 -0430
+@@ -164,8 +164,8 @@
+ $HOME = get_home_directory();
+ }
+
+-my $DATA_DIR = $HOME . "/data";
+-
++#Gentoo Data Dir
++my $DATA_DIR = "/usr/share/suopuhe/data";
+
+ # making the TMP dir...
+ unless ( -e "$HOME/tmp" || $www ) {
diff --git a/app-accessibility/festival-fi/metadata.xml b/app-accessibility/festival-fi/metadata.xml
new file mode 100644
index 00000000000..f66d895ca4e
--- /dev/null
+++ b/app-accessibility/festival-fi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-accessibility/festival-freebsoft-utils/Manifest b/app-accessibility/festival-freebsoft-utils/Manifest
new file mode 100644
index 00000000000..8dc1b089d3d
--- /dev/null
+++ b/app-accessibility/festival-freebsoft-utils/Manifest
@@ -0,0 +1,2 @@
+DIST festival-freebsoft-utils-0.10.tar.gz 73022 SHA256 c16cbd1d5494b1b058b787ef936fa483ac2f3ce92657372c92b3dbf153750457 SHA512 26305b9d0fc7f1333786d38cc0efbbe2cb2734e9f981e846ce7b9369cf012adf04e357af9c39fea650620cf7ff619ad15c48dbbd5d6a2781907301817718136c WHIRLPOOL 665583026de7d632f4b87db518e2bfe8026d401b8f827889437874cb53a04c1234b6eed388186dcf07f8b1318c2cfa860837a134cd6501cb724adbd264de6372
+DIST festival-freebsoft-utils-0.2.tar.gz 65591 SHA256 58c947ceff0764bf564e0489ed04e27582aff989da12aaa851326882e24be9e0 SHA512 a0744c415461b2a58205e0c8c6e8f77695a2c0f91c6ecf245d0a5c6108ba806c8557591e36c73c02db51f1a5a97254a9eb1bc7422aa7b3043f798b3376b04e2e WHIRLPOOL 9a33c4f6b24d25d4630d8c2fa574a2e6573e042f5225bc07e8e0474146f124bd3f3ba2fdb82833712cb7bae5efcdbc747f03c5ca2d45fa22be1e425f9298627e
diff --git a/app-accessibility/festival-freebsoft-utils/festival-freebsoft-utils-0.10.ebuild b/app-accessibility/festival-freebsoft-utils/festival-freebsoft-utils-0.10.ebuild
new file mode 100644
index 00000000000..f1139427f66
--- /dev/null
+++ b/app-accessibility/festival-freebsoft-utils/festival-freebsoft-utils-0.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="a collection of Festival functions for speech-dispatcher"
+HOMEPAGE="http://www.freebsoft.org/festival-freebsoft-utils"
+SRC_URI="http://www.freebsoft.org/pub/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-accessibility/festival-1.4.3
+ media-sound/sox
+ virtual/libiconv"
+# We depend on virtual/libiconv for the iconv command-line tool. This
+# command should be available in both packages providing the virtual.
+
+src_compile(){
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ dodoc ANNOUNCE NEWS README
+ doinfo doc/*.info
+ insinto /usr/share/festival
+ doins "${S}"/*.scm
+}
diff --git a/app-accessibility/festival-freebsoft-utils/festival-freebsoft-utils-0.2.ebuild b/app-accessibility/festival-freebsoft-utils/festival-freebsoft-utils-0.2.ebuild
new file mode 100644
index 00000000000..3b506846a60
--- /dev/null
+++ b/app-accessibility/festival-freebsoft-utils/festival-freebsoft-utils-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="a collection of Festival functions for speech-dispatcher"
+HOMEPAGE="http://www.freebsoft.org/festival-freebsoft-utils"
+SRC_URI="http://www.freebsoft.org/pub/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE=""
+
+DEPEND=">=app-accessibility/festival-1.4.3"
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ insinto /usr/lib/festival
+ doins "${S}"/*.scm
+}
diff --git a/app-accessibility/festival-freebsoft-utils/metadata.xml b/app-accessibility/festival-freebsoft-utils/metadata.xml
new file mode 100644
index 00000000000..f7b66d2f7a9
--- /dev/null
+++ b/app-accessibility/festival-freebsoft-utils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-accessibility/festival-hts/Manifest b/app-accessibility/festival-hts/Manifest
new file mode 100644
index 00000000000..db0b88768a1
--- /dev/null
+++ b/app-accessibility/festival-hts/Manifest
@@ -0,0 +1,6 @@
+DIST festvox_nitech_us_awb_arctic_hts-2.1.tar.bz2 1636752 SHA256 7aea67674661d29ee8686b45af38f4f090204e101abaead04aa731bdb7635569 SHA512 8121ca6cecf3c036ede782892a1a61737b4f967757567c285dca30e510ba0824cc94235464b0ba2594848c132e684e29e5dc3a1c6029096315b95fd3fd938240 WHIRLPOOL 4ac23712e8188d916707b87b91b1feb5a49301745092d0f7759f17abf47c35035f2c21a729f574fae44eba020880578b600c6f8f1079627ebde8dc5ed3efd5c6
+DIST festvox_nitech_us_bdl_arctic_hts-2.1.tar.bz2 1855093 SHA256 5133aebf7a620e577f01a5e7669c7da95fb527071902eb8364d0b40f0be47835 SHA512 c09a14e928fd03b2fa3d2bcbf5aa197ab25d1cb336135161d119734c10702ee9a6d103d00a9a9ba22e9df9e8245aa610b717babfbf4a6d8e00f89a396ec797ec WHIRLPOOL 5225374b969f70cfa1e813914245cbee1565c9485efe08c6c673e83d415cf989ba99fd4aaa2b8f6edd81f3996a2561031112a31bf0f801d826e735267933cd9f
+DIST festvox_nitech_us_clb_arctic_hts-2.1.tar.bz2 2201989 SHA256 4cf35b17d2db5b92498a0a371ed61330ce57d57b97f40803653fee8a77e2b338 SHA512 133e146eff001934a6a40a82570344b0ea03fbe08a3e2538f5e4d16145eb8d5147020b2f0be02f6831003a8c39caabc289700507734a2a16064b2b4e089578b7 WHIRLPOOL 12edaba6acee8a1bbe68ffbd4a2e4da9130aa931d8f0d7babcf00fe4d842ae205074b39a40acf1b7365308d0bdf063db0d0af342c7e8d115dce16d88319e9308
+DIST festvox_nitech_us_jmk_arctic_hts-2.1.tar.bz2 1607055 SHA256 e86e57c8a8361693671343473f68790160a3b69ccc7b906eb2cd1f5855d35ce3 SHA512 4b6b7280351bdf7c6268be4a0e13487e242117374a17bf543494159b83adfc34225c26abb94d9ea08c480c11b24dcea8c7b9dd35d5794685a1684e276953ec7c WHIRLPOOL e096e3b191ec411d2ec8459ab23afdeae034dbd33def1155e3fe2adc5517d9dfd2103f0578b31190a0a2206fb8410b4ac36c1f2363ef686f7907444a3428aa8e
+DIST festvox_nitech_us_rms_arctic_hts-2.1.tar.bz2 1829779 SHA256 845ae4ff9d7afed0b8270ab71d0709136f4a648ba67b66caecdb71d9bf1e993c SHA512 8072d5a1ea859aa65ea6a68ab7bbf40c080a8aede174310c81eba737c9d4b7e07bed26a2ec06c61860cd8f7f2b468e6c54325c18992209f7914046abf2509179 WHIRLPOOL 774147d9d452fa54f5d711dd17e06b93c85d2d858670ebc3419bfefd4e46ecfc7743eb3b3612cd9e1405bd5ce8917c316e021e36132a2d6dec4135568e280e06
+DIST festvox_nitech_us_slt_arctic_hts-2.1.tar.bz2 1865263 SHA256 0aff67531eb9575f3204ad516a1fa81fe2356873e3567d0ee3dba94565eea47d SHA512 47b3801c009775b53e9d5b2e5d20abe6a222c77cd4ac13abd9525bf38897c550a38e1819287db2ac10a863bf47837e6936b22c685d2ccfc1ed4e7a8128cb4112 WHIRLPOOL 279b1aa759e0790e8053212aebe690fa62517602cb6fa069c0850e616690dff0ce8cadff32d02c02844ca0f576dcd94bc57fe5c5f44c012030899d7794a29ce6
diff --git a/app-accessibility/festival-hts/festival-hts-2.1.ebuild b/app-accessibility/festival-hts/festival-hts-2.1.ebuild
new file mode 100644
index 00000000000..fd50f82334f
--- /dev/null
+++ b/app-accessibility/festival-hts/festival-hts-2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="HTS voices for Festival"
+HOMEPAGE="http://hts.sp.nitech.ac.jp/"
+SITE="http://hts.sp.nitech.ac.jp/archives/${PV}"
+SRC_URI="${SITE}/festvox_nitech_us_awb_arctic_hts-${PV}.tar.bz2
+ ${SITE}/festvox_nitech_us_bdl_arctic_hts-${PV}.tar.bz2
+ ${SITE}/festvox_nitech_us_clb_arctic_hts-${PV}.tar.bz2
+ ${SITE}/festvox_nitech_us_jmk_arctic_hts-${PV}.tar.bz2
+ ${SITE}/festvox_nitech_us_rms_arctic_hts-${PV}.tar.bz2
+ ${SITE}/festvox_nitech_us_slt_arctic_hts-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=app-accessibility/festival-1.96"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/share/festival/voices/
+ doins -r lib/voices/*
+}
diff --git a/app-accessibility/festival-hts/metadata.xml b/app-accessibility/festival-hts/metadata.xml
new file mode 100644
index 00000000000..be48b593dcc
--- /dev/null
+++ b/app-accessibility/festival-hts/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>neurogeek@gentoo.org</email>
+</maintainer>
+<herd>accessibility</herd>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/app-accessibility/festival-it/Manifest b/app-accessibility/festival-it/Manifest
new file mode 100644
index 00000000000..a11e3160e30
--- /dev/null
+++ b/app-accessibility/festival-it/Manifest
@@ -0,0 +1 @@
+DIST Italian-FESTIVAL.zip 20715806 SHA256 747ef3a31571896d7d772ea46d4ee68cf0fbc57af21e8c5220fced731695f496 SHA512 6044683bda58253d9bb447f24316d258e233c3a1389666667b758c89249422a3cf169eecc6a2b03c7a6548316bb45ff9d63b4d5321cedfef011954fc1ea65c34 WHIRLPOOL aa88ef39a66bc4d852be51bb41e8dfbc1a295af2283bcd2a96caf6c917387d5a9742166687cc60ee05591bdcc50960ff6d3a31bb9e7bdd2a043ba65d2869df5f
diff --git a/app-accessibility/festival-it/festival-it-1.0-r2.ebuild b/app-accessibility/festival-it/festival-it-1.0-r2.ebuild
new file mode 100644
index 00000000000..7a3a3dacf30
--- /dev/null
+++ b/app-accessibility/festival-it/festival-it-1.0-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A collection of italian voices for Festival TTS"
+HOMEPAGE="http://www2.pd.istc.cnr.it/FESTIVAL/home"
+SRC_URI="mirror://sourceforge/it-festival/Italian-FESTIVAL.zip"
+
+RDEPEND=">=app-accessibility/festival-2.1
+ mbrola? ( >=app-accessibility/mbrola-3.0.1h-r4[linguas_it] )"
+DEPEND="app-arch/unzip"
+IUSE="mbrola"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}
+
+src_prepare() {
+
+ unzip -qo italian_scm.zip
+ unzip -qo lex_ifd.zip
+ unzip -qo lp_diphone.zip
+ unzip -qo pc_diphone.zip
+
+ if use mbrola; then
+ unzip -qo lp_mbrola_unix.zip
+ unzip -qo pc_mbrola_unix.zip
+ fi
+
+ # Deletes some useless files
+ rm -f *.zip
+
+ rm -f `find festival/ -name install_unix.txt`
+ rm -f `find festival/ -name italian_mbrola_win.scm`
+
+ if ! use mbrola; then
+ rm -f `find festival/ -name italian_mbrola_unix.scm`
+ fi
+
+ # Aggregates some README files
+ mkdir docs
+ mv `find festival/ -name \*README` docs/
+
+ # All remaining files are moved "here"
+ mv festival/lib/* .
+ rm -rf festival/
+}
+
+src_install () {
+ # Install the docs
+ dodoc "${WORKDIR}"/docs/*
+
+ # Install the voice scheme
+ insinto /usr/share/festival/
+ doins -r "${WORKDIR}"/italian_scm/
+
+ # Install the dicts
+ insinto /usr/share/festival/dicts
+ doins -r "${WORKDIR}"/dicts/*
+
+ # Installs the voices
+ insinto /usr/share/festival/voices
+ doins -r "${WORKDIR}"/voices/*
+
+ # Enables the mbrola-based voices
+ if use mbrola; then
+ dosym /opt/mbrola/it3 /usr/share/festival/voices/italian/pc_mbrola/it3
+ dosym /opt/mbrola/it4 /usr/share/festival/voices/italian/lp_mbrola/it4
+ fi
+}
+
+pkg_postinst () {
+ einfo "Italian voices installed:"
+ for VOICE in `ls "${ROOT}/usr/share/festival/voices/italian/"`; do
+ einfo " (voice_${VOICE})"
+ done
+}
diff --git a/app-accessibility/festival-it/metadata.xml b/app-accessibility/festival-it/metadata.xml
new file mode 100644
index 00000000000..9776e2a6b64
--- /dev/null
+++ b/app-accessibility/festival-it/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="mbrola">Adds support for mbrola voices</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">it-festival</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/festival-ru/Manifest b/app-accessibility/festival-ru/Manifest
new file mode 100644
index 00000000000..e20fbffe49d
--- /dev/null
+++ b/app-accessibility/festival-ru/Manifest
@@ -0,0 +1 @@
+DIST msu_ru_nsh_clunits-0.5.tar.bz2 176320511 SHA256 6237d50a221eaaac7abaeb91c95c9701b7eb61f9c3da56417d9e2a0564c25525 SHA512 17428fb230cbf8154c88819c2ffe58a9e8044e80f87d2e90cb22043431558e7d3faca45d2817414754be4062dbc5a2b72957d2fbd1961e535b738b11567856e7 WHIRLPOOL d5b439138c7b59ec9bf59adb25cf035e2314dd3956c1fb39e68f8c6c5fcae1d1abe1323ffef9e4f527184dbff9ba96924148ee81a23d0a5731f5d6c0676d6289
diff --git a/app-accessibility/festival-ru/festival-ru-0.5.ebuild b/app-accessibility/festival-ru/festival-ru-0.5.ebuild
new file mode 100644
index 00000000000..2a420e99200
--- /dev/null
+++ b/app-accessibility/festival-ru/festival-ru-0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+MY_PN=msu_ru_nsh_clunits
+
+DESCRIPTION="Russian voices for Festival"
+HOMEPAGE="http://sourceforge.net/projects/festlang.berlios/"
+SRC_URI="mirror://sourceforge/project/festlang.berlios/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-accessibility/festival-1.96_beta"
+DEPEND=""
+
+src_install() {
+ dodoc "${MY_PN}/README" || die "Could not install README"
+ rm "${MY_PN}/{README,COPYING}"
+
+ insinto "/usr/share/festival/voices/russian/"
+ doins -r "${MY_PN}/" || die "Could not install Russian Voices"
+}
+
+pkg_postinst() {
+ elog
+ elog " To enable russian voices run festval and use command:"
+ elog " (voice_msu_ru_nsh_clunits)"
+ elog
+ elog " Please note that text input should have UTF-8 encoding."
+ elog
+}
diff --git a/app-accessibility/festival-ru/metadata.xml b/app-accessibility/festival-ru/metadata.xml
new file mode 100644
index 00000000000..95bb8e9a11a
--- /dev/null
+++ b/app-accessibility/festival-ru/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">festlang.berlios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/festival/Manifest b/app-accessibility/festival/Manifest
new file mode 100644
index 00000000000..ab4ef9cd842
--- /dev/null
+++ b/app-accessibility/festival/Manifest
@@ -0,0 +1,10 @@
+DIST festival-2.1-release.tar.gz 787313 SHA256 06f3dcbad9d26e27443fc66947a0faf0c6679482220df4b5f42a261adf758080 SHA512 1f9f28af7106c98e313d3c4d4bb26a7f927c1214fa5a0e2b4972fc85e1011e328331b73852abb57f26fa5062263d1dbccaf65e3be59c6ec762ccf340fc93797a WHIRLPOOL 0e90a9b3e673ea7ca63a4fdb7f60868db3a74347281267aad20a94548f385b8c1a66472145f0b7c7e4c02a30a695ca012e25443ffdb9ecbafd4cd3bac2f72568
+DIST festlex_CMU.tar.gz 1925748 SHA256 c19430919bca45d5368cd4c82af6153fbcc96a487ebd30b78b5f3c08718b7c07 SHA512 c293344020fd3337193303cd5dfb7e2b0a1012770a484d8bccaae921b0c61b75699204bec45fee0db754506d6f1558fd616866cc94e76afcbb85a4dcbcf9542b WHIRLPOOL 040094e7dcbfb280a18b5862927855cdde62a49f8eac8d63045c1f92f720cc0041f2991ebacb05d457cd77c4c471e935a808a6e185df28e7f87d0e1d08f21905
+DIST festlex_OALD.tar.gz 1472516 SHA256 61afc02c4b9dee6322412958ea8be477ee451c3cdab789b88c4907e3e377ccd5 SHA512 0221c3d78140c6cb4e74f98edbdf0dbe5987a8efa3e7205844a5c01c31a98aaced3b20e4a42b09aaa4a3c93c9225d9f24d96df3fb5d963092e955d4cb4674aac WHIRLPOOL 12f96f04d0b7257a032e9e720136bb79e1377fa63f83cd5f3b35dbed5687da838dc4c11de183df89794a389d139c83ea1ea4df3ab6e7c87018c408ed9dbdf290
+DIST festlex_POSLEX.tar.gz 242914 SHA256 5ef8cc5d35e9f2141b5a0a4774df82dc9731fe7e9800eb09ecf264f2f8503e7b SHA512 5c3857a195f5f5ebc4c366f37685437af41eb7e86a1a13b41b08cab91e536114ae4ddfa8b124acb40ec32c13b53d0dbf2c857d4c756b0720c9a363866ecb8c47 WHIRLPOOL 8c5b1ed51b89377bb56cfdb12cc0affb9646cdf57b8c908deb547c3bb08c66881c59bef5f04ed1973b6f00c8ce45e0f85b9339afddb2bc460599f5ca11b8f05e
+DIST festvox_cmu_us_awb_cg.tar.gz 4452760 SHA256 f6010538b3e2f32152cc75741a62b8c7eecfaa3e51153c9db735723002807264 SHA512 b77174d2e9ab914ee3c4d6e0d83e29b64034bb45d3fe021acf3a6da13304acc819c4ac5b1046a6f022312e90aa23c73b585aaf11f927e80aee4533584b60356b WHIRLPOOL fe2aa698dfa917f8e72c49bb1399c3c430d65da2b3b072d53cb6810e6cde49b19de8c5b44e0ee23647a93ded1fc6a39c80eab059c25e3eb28805a7d9977f3539
+DIST festvox_cmu_us_rms_cg.tar.gz 5222226 SHA256 5f0ffc3181df76b63f3c13db3cdc6e67e02639a3982c6b6fa55bbbd2fe1cbc30 SHA512 a251fa27f6cabecb29cf4199cb040cb2ce512a6a447840d31b0d2055d26e6a86f4730bbe3e0f1612e413858f41fdbdd184f04575f9f64658d3f34171612ee172 WHIRLPOOL c9a5f712952c2c88d901e49cf33f03328d44fd6befaca16bcf5041a82beeb092bd6fd47751b7da9da6393c752a3b4b9ae52119a99a6ad1aca6b335cc78a8c2ae
+DIST festvox_cmu_us_slt_arctic_hts.tar.gz 955706 SHA256 adcc187fc7db39e17c119811936be57f0b788908f06c3d9b330856ad8357b128 SHA512 58908094c7e538118471ebd80d86d91f681d0958587f0c5ee6c3a00e1ad5f41519e7bb2a96353f9a68946aba343e11c2949fe2b1efafc53f0d8a6b20d7e3e1f8 WHIRLPOOL 2e87cedb571b4ece257e8c27ab9570fe183691ebc17ddb8fc4323201bd4fc2a449f30a5879a3ce8cc8f8673283c3162761235bf253c96a089d86796b898607a0
+DIST festvox_kallpc16k.tar.gz 4104056 SHA256 9eb6336f35c202c8069d37e489fb009a7e9fd8539cd47644329db1e92c6aba83 SHA512 ad8d45e04cb704f31a01de8f4d1b3adb4530563728e8b331b0a730c762bd0c0590e5d49f893404a0199f51fb6afce4b786107ae1fdbc4d1b61c3139ce805267c WHIRLPOOL c0242c9abb733c30cbba75178de8aa825a0be17bc24a2851eff64147a080c2cbd0d374de1e6e4a8bce562f727474d1e80d26535efe12e8ed640d7eb7bce75832
+DIST festvox_rablpc16k.tar.gz 5369001 SHA256 54835837ca734e62c0210c0f9dd27380d2ad89819ae91ec6e8cfab4e515b7bdc SHA512 11539bfb822eec9c4803c8526364d3cf6ad735a0edfd018471e95df1447e0cd3e19fdee44faaf0f0fbceed281a06b21a971f0c2a3a3ff6c46ea8272202f53f11 WHIRLPOOL 08266d82182ebc939965f52ef591043de664ed8380105e42eb39b4a96f50bda5d8958d9b7850e963fe1e8324fd6a5d05a5d1d7ab41f4c88940e61fe783dbf557
+DIST speech_tools-2.1-release.tar.gz 1681999 SHA256 ff6167cd929a88e2f91b47191c6c4dae87c9c06ba39fccc4465af9d79e9b2be9 SHA512 6ef9a7dd01ede152c4dafd0b2037312d62a79d875813d74ea048899a52eee505b93ffbabef9b6c0a1d15aeadb5508fd18a2f392e85276847fe071173aec5db96 WHIRLPOOL 6df6ca5168462599fadf209827e367c963af5ca6be05277618c9d09aac34a3b151665b860a14fa4742482cc77246e372671ac94b23bdca63bbbb7b8c7b234644
diff --git a/app-accessibility/festival/festival-2.1-r1.ebuild b/app-accessibility/festival/festival-2.1-r1.ebuild
new file mode 100644
index 00000000000..d840aee1941
--- /dev/null
+++ b/app-accessibility/festival/festival-2.1-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit eutils multilib toolchain-funcs user
+
+MY_PV="${PV}-release"
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Festival Text to Speech engine"
+HOMEPAGE="http://www.cstr.ed.ac.uk/projects/festival/"
+SITE="http://www.festvox.org/packed/${PN}/${PV}"
+SRC_URI="${SITE}/${MY_P}.tar.gz
+ ${SITE}/festlex_CMU.tar.gz
+ ${SITE}/festlex_OALD.tar.gz
+ ${SITE}/festlex_POSLEX.tar.gz
+ ${SITE}/festvox_cmu_us_awb_cg.tar.gz
+ ${SITE}/festvox_cmu_us_rms_cg.tar.gz
+ ${SITE}/festvox_cmu_us_slt_arctic_hts.tar.gz
+ ${SITE}/festvox_rablpc16k.tar.gz
+ ${SITE}/festvox_kallpc16k.tar.gz
+ ${SITE}/speech_tools-${MY_PV}.tar.gz"
+
+LICENSE="FESTIVAL HPND BSD rc regexp-UofT free-noncomm"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~app-accessibility/speech-tools-2.1
+ >=sys-libs/ncurses-5.6-r2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/festival
+
+pkg_setup() {
+ enewuser festival -1 -1 -1 audio
+}
+
+src_prepare() {
+ # tell festival to use the speech-tools we have installed.
+ sed -i -e "s:\(EST=\).*:\1${EPREFIX}/usr/share/speech-tools:" "${S}"/config/config.in
+ sed -i -e "s:\$(EST)/lib:/usr/$(get_libdir):" "${S}"/config/project.mak
+
+ # fix the reference to /usr/lib/festival
+ sed -i -e "s:\(FTLIBDIR.*=.*\)\$.*:\1${EPREFIX}/usr/share/festival:" "${S}"/config/project.mak
+
+ # Fix path for examples in festival.scm
+ sed -i -e "s:\.\./examples/:${EPREFIX}/usr/share/doc/${PF}/examples/:" "${S}"/lib/festival.scm
+
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-init-scm.patch"
+ epatch "${FILESDIR}/${P}-gentoo-system.patch"
+
+ # copy what we need for MultiSyn from speech_tools.
+ cp -pr "${WORKDIR}"/speech_tools/base_class "${S}"/src/modules/MultiSyn
+
+ epatch "${FILESDIR}/${P}-gcc4.7.patch"
+
+ echo "(Parameter.set 'Audio_Command \"aplay -q -c 1 -t raw -f s16 -r \$SR \$FILE\")" >> "${S}"/lib/siteinit.scm
+ echo "(Parameter.set 'Audio_Method 'Audio_Command)" >> "${S}"/lib/siteinit.scm
+}
+
+src_configure() {
+ econf || die "econf failed"
+}
+
+src_compile() {
+ emake -j1 PROJECT_LIBDEPS="" REQUIRED_LIBDEPS="" LOCAL_LIBDEPS="" \
+ OPTIMISE_CXXFLAGS="${CXXFLAGS}" OPTIMISE_CCFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ # Install the binaries
+ dobin src/main/festival
+ dobin lib/etc/*Linux*/audsp
+ dolib.a src/lib/libFestival.a
+
+ # Install the main libraries
+ insinto /usr/share/festival
+ doins -r lib/*
+
+ # Install the examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # Need to fix saytime, etc. to look for festival in the correct spot
+ for ex in "${D}"/usr/share/doc/${PF}/examples/*.sh; do
+ exnoext=${ex%%.sh}
+ chmod a+x "${exnoext}"
+ dosed "s:${S}/bin/festival:/usr/bin/festival:" "${exnoext##$D}"
+ done
+
+ # Install the header files
+ insinto /usr/include/festival
+ doins src/include/*.h
+
+ insinto /etc/festival
+ doins lib/site*
+
+ # Install the docs
+ dodoc "${S}"/{ACKNOWLEDGMENTS,NEWS,README}
+ doman "${S}"/doc/{festival.1,festival_client.1}
+
+ # create the directory where our log file will go.
+ diropts -m 0755 -o festival -g audio
+ keepdir /var/log/festival
+
+}
+
+pkg_postinst() {
+ elog
+ elog " Useful examples include saytime, text2wave. For example, try:"
+ elog " \"/usr/share/doc/${PF}/examples/saytime\""
+ elog
+ elog " Or for something more fun:"
+ elog ' "echo "Gentoo can speak" | festival --tts"'
+ elog
+ elog "This version also allows configuration of site specific"
+ elog "initialization in /etc/festival/siteinit.scm and"
+ elog "variables in /etc/festival/sitevars.scm."
+ elog
+}
diff --git a/app-accessibility/festival/files/festival-2.1-gcc4.7.patch b/app-accessibility/festival/files/festival-2.1-gcc4.7.patch
new file mode 100644
index 00000000000..8ebc8cc472c
--- /dev/null
+++ b/app-accessibility/festival/files/festival-2.1-gcc4.7.patch
@@ -0,0 +1,29 @@
+diff -uNr festival.orig/src/modules/MultiSyn/base_class/EST_TSimpleVector.cc festival/src/modules/MultiSyn/base_class/EST_TSimpleVector.cc
+--- festival.orig/src/modules/MultiSyn/base_class/EST_TSimpleVector.cc 2012-12-02 23:03:27.000000000 +0000
++++ festival/src/modules/MultiSyn/base_class/EST_TSimpleVector.cc 2012-12-02 23:21:17.000000000 +0000
+@@ -42,6 +42,7 @@
+
+ #include "EST_TSimpleVector.h"
+ #include "EST_matrix_support.h"
++#include <cstring>
+ #include <fstream>
+ #include "EST_cutils.h"
+
+@@ -49,7 +50,7 @@
+ {
+ if (this->p_column_step==1 && a.p_column_step==1)
+ {
+- resize(a.n(), FALSE);
++ this->resize(a.n(), FALSE);
+ memcpy((void *)(this->p_memory), (const void *)(a.p_memory), this->n() * sizeof(T));
+ }
+ else
+@@ -70,7 +71,7 @@
+ int old_offset = this->p_offset;
+ unsigned int q;
+
+- just_resize(newn, &old_vals);
++ this->just_resize(newn, &old_vals);
+
+ if (set && old_vals)
+ {
diff --git a/app-accessibility/festival/files/festival-2.1-gentoo-system.patch b/app-accessibility/festival/files/festival-2.1-gentoo-system.patch
new file mode 100644
index 00000000000..a09e1379eeb
--- /dev/null
+++ b/app-accessibility/festival/files/festival-2.1-gentoo-system.patch
@@ -0,0 +1,124 @@
+diff -uNr festival.orig/config/systems/GentooLinux.mak festival/config/systems/GentooLinux.mak
+--- festival.orig/config/systems/GentooLinux.mak 1969-12-31 19:00:00.000000000 -0500
++++ festival/config/systems/GentooLinux.mak 2011-02-09 10:43:28.000000000 -0500
+@@ -0,0 +1,42 @@
++ ###########################################################################
++ ## ##
++ ## Centre for Speech Technology Research ##
++ ## University of Edinburgh, UK ##
++ ## Copyright (c) 1996 ##
++ ## All Rights Reserved. ##
++ ## ##
++ ## Permission is hereby granted, free of charge, to use and distribute ##
++ ## this software and its documentation without restriction, including ##
++ ## without limitation the rights to use, copy, modify, merge, publish, ##
++ ## distribute, sublicense, and/or sell copies of this work, and to ##
++ ## permit persons to whom this work is furnished to do so, subject to ##
++ ## the following conditions: ##
++ ## 1. The code must retain the above copyright notice, this list of ##
++ ## conditions and the following disclaimer. ##
++ ## 2. Any modifications must be clearly marked as such. ##
++ ## 3. Original authors' names are not deleted. ##
++ ## 4. The authors' names are not used to endorse or promote products ##
++ ## derived from this software without specific prior written ##
++ ## permission. ##
++ ## ##
++ ## THE UNIVERSITY OF EDINBURGH AND THE CONTRIBUTORS TO THIS WORK ##
++ ## DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ##
++ ## ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT ##
++ ## SHALL THE UNIVERSITY OF EDINBURGH NOR THE CONTRIBUTORS BE LIABLE ##
++ ## FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES ##
++ ## WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN ##
++ ## AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ##
++ ## ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF ##
++ ## THIS SOFTWARE. ##
++ ## ##
++ ###########################################################################
++ ## ##
++ ## Author: William Hubbs <williamh@gentoo.org> ##
++ ## -------------------------------------------------------------------- ##
++ ## Settings for Gentoo Linux distributions. ##
++ ## ##
++ ###########################################################################
++
++MANDIR=$(INSTALL_PREFIX)/share/man
++# Gentoo does not use termcap
++OS_LIBS = $(LDFLAGS) -ldl -lncurses
+diff -uNr festival.orig/config/systems/Makefile festival/config/systems/Makefile
+--- festival.orig/config/systems/Makefile 2011-02-09 10:41:01.000000000 -0500
++++ festival/config/systems/Makefile 2011-02-09 10:44:22.000000000 -0500
+@@ -41,6 +41,7 @@
+ Linux.mak \
+ RedHatLinux.mak \
+ DebianGNULinux.mak \
++ GentooLinux.mak \
+ alpha_Linux.mak \
+ alpha_OSF1V4.0.mak \
+ alpha_RedHatLinux.mak \
+@@ -94,6 +95,7 @@
+ sparc_SunOS5.8.mak \
+ sparc_SunOS5.mak \
+ unknown_DebianGNULinux.mak \
++ unknown_GentooLinux.mak \
+ unknown_Linux.mak \
+ unknown_RedHatLinux.mak \
+ power_macintosh_Darwin.mak \
+diff -uNr festival.orig/config/systems/unknown_GentooLinux.mak festival/config/systems/unknown_GentooLinux.mak
+--- festival.orig/config/systems/unknown_GentooLinux.mak 1969-12-31 19:00:00.000000000 -0500
++++ festival/config/systems/unknown_GentooLinux.mak 2011-02-09 10:45:34.000000000 -0500
+@@ -0,0 +1,41 @@
++###########################################################################
++## ##
++## Centre for Speech Technology Research ##
++## University of Edinburgh, UK ##
++## Copyright (c) 1996 ##
++## All Rights Reserved. ##
++## ##
++## Permission is hereby granted, free of charge, to use and distribute ##
++## this software and its documentation without restriction, including ##
++## without limitation the rights to use, copy, modify, merge, publish, ##
++## distribute, sublicense, and/or sell copies of this work, and to ##
++## permit persons to whom this work is furnished to do so, subject to ##
++## the following conditions: ##
++## 1. The code must retain the above copyright notice, this list of ##
++## conditions and the following disclaimer. ##
++## 2. Any modifications must be clearly marked as such. ##
++## 3. Original authors' names are not deleted. ##
++## 4. The authors' names are not used to endorse or promote products ##
++## derived from this software without specific prior written ##
++## permission. ##
++## ##
++## THE UNIVERSITY OF EDINBURGH AND THE CONTRIBUTORS TO THIS WORK ##
++## DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ##
++## ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT ##
++## SHALL THE UNIVERSITY OF EDINBURGH NOR THE CONTRIBUTORS BE LIABLE ##
++## FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES ##
++## WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN ##
++## AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ##
++## ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF ##
++## THIS SOFTWARE. ##
++## ##
++###########################################################################
++## ##
++## Author: William Hubbs <williamh@gentoo.org> ##
++## -------------------------------------------------------------------- ##
++## Settings for Gentoo Linux distributions. ##
++## ##
++###########################################################################
++
++include $(EST)/config/systems/Linux.mak
++include $(EST)/config/systems/GentooLinux.mak
+diff -uNr festival.orig/config/system.sh festival/config/system.sh
+--- festival.orig/config/system.sh 2011-02-09 10:41:01.000000000 -0500
++++ festival/config/system.sh 2011-02-09 10:42:10.000000000 -0500
+@@ -70,6 +70,10 @@
+ then
+ OSTYPE=DebianGNULinux
+ OSREV=`cat /etc/debian_version`
++ elif [ -f "/etc/gentoo-release" ]
++ then
++ OSTYPE=GentooLinux
++ OSREV=""
+ else
+ # Generic unknown GNU/Linux system.
+ OSTYPE=Linux
diff --git a/app-accessibility/festival/files/festival-2.1-init-scm.patch b/app-accessibility/festival/files/festival-2.1-init-scm.patch
new file mode 100644
index 00000000000..efe575b0c2b
--- /dev/null
+++ b/app-accessibility/festival/files/festival-2.1-init-scm.patch
@@ -0,0 +1,24 @@
+--- festival/lib/init.scm 2006-09-15 01:34:32.000000000 -0500
++++ festival/lib/init.scm 2006-09-15 01:50:30.000000000 -0500
+@@ -52,8 +52,8 @@
+
+ ;;; A chance to set various variables to a local setting e.g.
+ ;;; lexdir, voices_dir audio etc etc.
+-(if (probe_file (path-append libdir "sitevars.scm"))
+- (load (path-append libdir "sitevars.scm")))
++(if (probe_file "/etc/festival/sitevars.scm")
++ (load "/etc/festival/sitevars.scm"))
+
+ ;;; CSTR siod extensions
+ (require 'cstr)
+@@ -133,8 +133,8 @@
+ ;;;
+ ;;; Local site initialization, if the file exists load it
+ ;;;
+-(if (probe_file (path-append libdir "siteinit.scm"))
+- (load (path-append libdir "siteinit.scm")))
++(if (probe_file "/etc/festival/siteinit.scm")
++ (load "/etc/festival/siteinit.scm"))
+
+ ;;; User initialization, if a user has a personal customization
+ ;;; file loaded it
diff --git a/app-accessibility/festival/files/festival-2.1-ldflags.patch b/app-accessibility/festival/files/festival-2.1-ldflags.patch
new file mode 100644
index 00000000000..e6559c8a816
--- /dev/null
+++ b/app-accessibility/festival/files/festival-2.1-ldflags.patch
@@ -0,0 +1,12 @@
+diff -uNr festival.orig/config/systems/Linux.mak festival/config/systems/Linux.mak
+--- festival.orig/config/systems/Linux.mak 2011-02-09 10:08:20.000000000 -0500
++++ festival/config/systems/Linux.mak 2011-02-09 10:09:04.000000000 -0500
+@@ -46,7 +46,7 @@
+ JAVAH=/usr/bin/javah
+
+ TCL_LIBRARY = -ltcl
+-OS_LIBS = -ldl
++OS_LIBS = $(OPTIMISE_LDFLAGS) -ldl
+
+ ## the native audio module for this type of system
+ NATIVE_AUDIO_MODULE = LINUX16
diff --git a/app-accessibility/festival/metadata.xml b/app-accessibility/festival/metadata.xml
new file mode 100644
index 00000000000..0c64cf5a25f
--- /dev/null
+++ b/app-accessibility/festival/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+</maintainer>
+<herd>accessibility</herd>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/app-accessibility/flite/Manifest b/app-accessibility/flite/Manifest
new file mode 100644
index 00000000000..6eda17aecfc
--- /dev/null
+++ b/app-accessibility/flite/Manifest
@@ -0,0 +1 @@
+DIST flite-1.4-release.tar.bz2 15163897 SHA256 45c662160aeca6560589f78daf42ab62c6111dd4d244afc28118c4e6f553cd0c SHA512 eec1022077fb7a47db3848ae6944509e18a6c86a25aa24f921b8b6c2af708fc9811b287e76d96cf64fc68f8e1d0a43b7e878659f15bfcf76957eddd75e599112 WHIRLPOOL 5e641fe58fb1c28609154377f009691587a74fbbad7a621947ca06382e5e2da52d3be86f1388730c42dc2a671881320b37dfc10a91185e601d0838526ddae2f2
diff --git a/app-accessibility/flite/files/flite-1.4-audio-interface.patch b/app-accessibility/flite/files/flite-1.4-audio-interface.patch
new file mode 100644
index 00000000000..bc8d25b89bc
--- /dev/null
+++ b/app-accessibility/flite/files/flite-1.4-audio-interface.patch
@@ -0,0 +1,22 @@
+--- configure.in 2009-08-15 06:46:38.000000000 +1000
++++ configure.in 2011-08-30 00:53:26.000000000 +1000
+@@ -304,7 +304,6 @@
+ [ --with-audio with specific audio support (none linux freebsd etc) ],
+ AUDIODRIVER=$with_audio )
+
+-if test "x$AUDIODEFS" = x; then
+ case "$AUDIODRIVER" in
+ linux|oss)
+ AUDIODRIVER=oss
+@@ -325,9 +324,10 @@
+ ;;
+ none)
+ AUDIODEFS=-DCST_AUDIO_NONE
++ AUDIOLIBS=
+ ;;
+ esac
+-fi
++
+ AC_SUBST(AUDIODRIVER)
+ AC_SUBST(AUDIODEFS)
+ AC_SUBST(AUDIOLIBS)
diff --git a/app-accessibility/flite/files/flite-1.4-fix-parallel-builds.patch b/app-accessibility/flite/files/flite-1.4-fix-parallel-builds.patch
new file mode 100644
index 00000000000..270395877c5
--- /dev/null
+++ b/app-accessibility/flite/files/flite-1.4-fix-parallel-builds.patch
@@ -0,0 +1,25 @@
+From dec7aff03916dce6ba4c244314c60cc7b9359585 Mon Sep 17 00:00:00 2001
+From: William Hubbs <w.d.hubbs@gmail.com>
+Date: Fri, 1 Jan 2010 12:59:59 -0600
+Subject: [PATCH] fix parallel builds
+
+---
+ main/Makefile | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/main/Makefile b/main/Makefile
+index 0513e59..e4d04fe 100644
+--- a/main/Makefile
++++ b/main/Makefile
+@@ -81,6 +81,8 @@ else
+ shared_libs: nothing
+ endif
+
++.NOTPARALLEL: $(ALL)
++
+ $(BINDIR)/flite$(EXEEXT): flite_main.o $(flite_LIBS_deps)
+ $(TOP)/tools/make_voice_list $(VOICES)
+ rm -f flite_voice_list.o
+--
+1.6.4.4
+
diff --git a/app-accessibility/flite/files/flite-1.4-ldflags.patch b/app-accessibility/flite/files/flite-1.4-ldflags.patch
new file mode 100644
index 00000000000..f9295fb853b
--- /dev/null
+++ b/app-accessibility/flite/files/flite-1.4-ldflags.patch
@@ -0,0 +1,35 @@
+diff -Naur flite-1.4-release/config/common_make_rules flite-1.4-release.new/config/common_make_rules
+--- flite-1.4-release/config/common_make_rules 2009-07-30 14:52:56.000000000 +0000
++++ flite-1.4-release.new/config/common_make_rules 2011-03-26 20:22:59.000000000 +0000
+@@ -68,7 +68,7 @@
+
+ FLITELIBS = $(BUILDDIR)/lib/libflite.a
+ FLITELIBFLAGS = -L$(BUILDDIR)/lib -lflite
+-LDFLAGS += -lm $(AUDIOLIBS) $(OTHERLIBS)
++LDLIBS += -lm $(AUDIOLIBS) $(OTHERLIBS)
+
+ FULLOBJS = $(OBJS:%=$(OBJDIR)/%)
+ ifdef SHFLAGS
+@@ -123,7 +123,7 @@
+ @ rm -rf shared_os && mkdir shared_os
+ @ rm -f $@ $@.${PROJECT_VERSION} $@.${PROJECT_SHLIB_VERSION}
+ @ (cd shared_os && ar x ../$<)
+- @ (cd shared_os && $(CC) -shared -Wl,-soname,`basename $@`.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os)
++ @ (cd shared_os && $(CC) ${LDFLAGS} -shared -Wl,-soname,`basename $@`.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os $(LDLIBS))
+ @ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_VERSION}` `basename $@.${PROJECT_SHLIB_VERSION}` )
+ @ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_SHLIB_VERSION}` `basename $@` )
+ @ rm -rf shared_os
+--- flite-1.4-release/tools/Makefile~ 2009-08-22 20:19:01.000000000 +0100
++++ flite-1.4-release.new/tools/Makefile 2013-01-20 20:06:34.259527220 +0000
+@@ -62,9 +62,9 @@
+ LOCAL_CLEAN = $(BINDIR)/find_sts $(BINDIR)/flite_sort
+
+ $(BINDIR)/find_sts: find_sts_main.o $(FLITELIBS)
+- $(CC) $(CFLAGS) -o $@ find_sts_main.o $(FLITELIBFLAGS) $(LDFLAGS)
++ $(CC) $(CFLAGS) ${LDFLAGS} -o $@ find_sts_main.o $(FLITELIBFLAGS) $(LDLIBS)
+ $(BINDIR)/flite_sort: flite_sort_main.o $(FLITELIBS)
+- $(CC) $(CFLAGS) -o $@ flite_sort_main.o $(FLITELIBFLAGS) $(LDFLAGS)
++ $(CC) $(CFLAGS) ${LDFLAGS} -o $@ flite_sort_main.o $(FLITELIBFLAGS) $(LDLIBS)
+ makescripts:
+ @ cp -p $(SCRIPTS) $(TOP)/bin
+
diff --git a/app-accessibility/flite/files/flite-1.4-respect-destdir.patch b/app-accessibility/flite/files/flite-1.4-respect-destdir.patch
new file mode 100644
index 00000000000..d54771423e1
--- /dev/null
+++ b/app-accessibility/flite/files/flite-1.4-respect-destdir.patch
@@ -0,0 +1,59 @@
+From a0ae616d84e9f051ae8536574a9d1289e5f0c060 Mon Sep 17 00:00:00 2001
+From: William Hubbs <w.d.hubbs@gmail.com>
+Date: Thu, 31 Dec 2009 12:57:18 -0600
+Subject: [PATCH] respect destdir
+
+---
+ Makefile | 10 +++++-----
+ main/Makefile | 10 +++++-----
+ 2 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2d3ff09..26b2386 100644
+--- a/Makefile
++++ b/Makefile
+@@ -106,11 +106,11 @@ tags:
+
+ install:
+ @echo Installing
+- mkdir -p $(INSTALLBINDIR)
+- mkdir -p $(INSTALLLIBDIR)
+- mkdir -p $(INSTALLINCDIR)
+- $(INSTALL) -m 644 include/*.h $(INSTALLINCDIR)
+- @ $(MAKE) -C main --no-print-directory install
++ mkdir -p $(DESTDIR)$(INSTALLBINDIR)
++ mkdir -p $(DESTDIR)$(INSTALLLIBDIR)
++ mkdir -p $(DESTDIR)$(INSTALLINCDIR)
++ $(INSTALL) -m 644 include/*.h $(DESTDIR)$(INSTALLINCDIR)
++ @ $(MAKE) -C main --no-print-directory DESTDIR=$(DESTDIR) install
+
+ time-stamp :
+ @ echo $(PROJECT_NAME) >.time-stamp
+diff --git a/main/Makefile b/main/Makefile
+index 8163e40..0513e59 100644
+--- a/main/Makefile
++++ b/main/Makefile
+@@ -111,15 +111,15 @@ $(BINDIR)/flite_${VOICE}: flite_main.o $(flite_LIBS_deps)
+
+ install:
+ # The basic binaries
+- @ $(INSTALL) -m 755 $(BINDIR)/flite $(INSTALLBINDIR)
++ @ $(INSTALL) -m 755 $(BINDIR)/flite $(DESTDIR)$(INSTALLBINDIR)
+ @ for i in $(VOICES) ; \
+ do \
+- $(INSTALL) $(BINDIR)/flite_$$i $(INSTALLBINDIR); \
++ $(INSTALL) $(BINDIR)/flite_$$i $(DESTDIR)$(INSTALLBINDIR); \
+ done
+- $(INSTALL) -m 755 $(BINDIR)/flite_time $(INSTALLBINDIR)
++ $(INSTALL) -m 755 $(BINDIR)/flite_time $(DESTDIR)$(INSTALLBINDIR)
+ # The libraries: static and shared (if built)
+- cp -pd $(flite_LIBS_deps) $(INSTALLLIBDIR)
++ cp -pd $(flite_LIBS_deps) $(DESTDIR)$(INSTALLLIBDIR)
+ ifdef SHFLAGS
+- cp -pd $(SHAREDLIBS) $(VERSIONSHAREDLIBS) $(INSTALLLIBDIR)
++ cp -pd $(SHAREDLIBS) $(VERSIONSHAREDLIBS) $(DESTDIR)$(INSTALLLIBDIR)
+ endif
+
+--
+1.6.4.4
+
diff --git a/app-accessibility/flite/files/flite-1.4-tempfile.patch b/app-accessibility/flite/files/flite-1.4-tempfile.patch
new file mode 100644
index 00000000000..09b54f64ea2
--- /dev/null
+++ b/app-accessibility/flite/files/flite-1.4-tempfile.patch
@@ -0,0 +1,50 @@
+From a85193f122b7ec0d377e0a39ac58c64f12c51085 Mon Sep 17 00:00:00 2001
+From: Rui Matos <tiagomatos@gmail.com>
+Date: Mon, 6 Jan 2014 13:45:00 +0000
+Subject: [PATCH] auserver.c: Only write audio data to a file in debug builds
+
+This isn't useful in regular builds and is actually a security
+concern.
+---
+ src/audio/auserver.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/src/audio/auserver.c b/src/audio/auserver.c
+index 29716d3..3e838d0 100644
+--- a/src/audio/auserver.c
++++ b/src/audio/auserver.c
+@@ -58,9 +58,11 @@ static int play_wave_from_socket(snd_header *header,int audiostream)
+ int q,i,n,r;
+ unsigned char bytes[CST_AUDIOBUFFSIZE];
+ short shorts[CST_AUDIOBUFFSIZE];
++#ifdef DEBUG
+ cst_file fff;
+
+ fff = cst_fopen("/tmp/awb.wav",CST_OPEN_WRITE|CST_OPEN_BINARY);
++#endif
+
+ if ((audio_device = audio_open(header->sample_rate,1,
+ (header->encoding == CST_SND_SHORT) ?
+@@ -107,7 +109,9 @@ static int play_wave_from_socket(snd_header *header,int audiostream)
+ for (q=r; q > 0; q-=n)
+ {
+ n = audio_write(audio_device,shorts,q);
++#ifdef DEBUG
+ cst_fwrite(fff,shorts,2,q);
++#endif
+ if (n <= 0)
+ {
+ audio_close(audio_device);
+@@ -116,7 +120,9 @@ static int play_wave_from_socket(snd_header *header,int audiostream)
+ }
+ }
+ audio_close(audio_device);
++#ifdef DEBUG
+ cst_fclose(fff);
++#endif
+
+ return CST_OK_FORMAT;
+
+--
+1.8.3.1
+
diff --git a/app-accessibility/flite/flite-1.4-r4.ebuild b/app-accessibility/flite/flite-1.4-r4.ebuild
new file mode 100644
index 00000000000..c789fbb61ca
--- /dev/null
+++ b/app-accessibility/flite/flite-1.4-r4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="Flite text to speech engine"
+HOMEPAGE="http://www.speech.cs.cmu.edu/flite/index.html"
+SRC_URI=" http://www.speech.cs.cmu.edu/${PN}/packed/${P}/${P}-release.tar.bz2"
+
+LICENSE="BSD freetts public-domain regexp-UofT BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ppc ppc64 sparc x86"
+IUSE="alsa oss static-libs"
+
+DEPEND="alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-release
+
+get_audio() {
+ if use alsa; then
+ echo alsa
+ elif use oss; then
+ echo oss
+ else
+ echo none
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tempfile.patch
+ epatch "${FILESDIR}"/${P}-fix-parallel-builds.patch
+ epatch "${FILESDIR}"/${P}-respect-destdir.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-audio-interface.patch
+ sed -i main/Makefile \
+ -e '/-rpath/s|$(LIBDIR)|$(INSTALLLIBDIR)|g' \
+ || die
+ eautoreconf
+
+ # custom makefiles
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if ! use static-libs; then
+ myconf+=( --enable-shared )
+ fi
+ myconf+=( --with-audio=$(get_audio) )
+
+ econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+multilib_src_install_all() {
+ dodoc ACKNOWLEDGEMENTS README
+
+ if ! use static-libs; then
+ rm -rf "${D}"/usr/lib*/*.a
+ fi
+}
+
+pkg_postinst() {
+ if [[ "$(get_audio)" = "none" ]]; then
+ ewarn "you have built flite without audio support."
+ ewarn "If you want audio support, re-emerge"
+ ewarn "flite with alsa or oss in your use flags."
+ fi
+}
diff --git a/app-accessibility/flite/metadata.xml b/app-accessibility/flite/metadata.xml
new file mode 100644
index 00000000000..523097ffe30
--- /dev/null
+++ b/app-accessibility/flite/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/app-accessibility/freetts/Manifest b/app-accessibility/freetts/Manifest
new file mode 100644
index 00000000000..c6e64a5c27f
--- /dev/null
+++ b/app-accessibility/freetts/Manifest
@@ -0,0 +1,2 @@
+DIST freetts-1.2.1-src.zip 14100414 SHA256 e21421f3b6bd4364f4310e273128f20b63a6b885e8f17d9a441df20d4c455280 SHA512 927d881263f561df8e8ee919ea6019ed44d6ecad7d434c618e333063e992f938d50161a281094b27a4dd8312ac3eedc34040ede947df91e94bbca06c25ba45d3 WHIRLPOOL dbb1d27491f48041fd22d9be472cafe4cd94f514d0a39235d72e613aaaed887245cb377575768420c8546706c33e06765d7894c1e3599560bf4570e7be6a5eb0
+DIST freetts-1.2.2-src.zip 14111416 SHA256 270bbf8c3ab1571585f0a78818ba73b601ef515eb1e6087293c41177219ed156 SHA512 a2cce0b1fd2267cc8dbd3e2ad3ec1f99526de3988443c0937405cc7b2eab9ef517001ef0b4b387e8721d3c33610cd642c6b7cf83217996a83481830de9713de7 WHIRLPOOL e7bfd3e72e1fc4f6d36d2c743b7c61856d1471ddfa59158b799552800cfbb307cf14012c53280fa5052df35c0aa0cb680ed20d99ec8111efb8785c0a00492021
diff --git a/app-accessibility/freetts/files/jsapi-gentoo.diff b/app-accessibility/freetts/files/jsapi-gentoo.diff
new file mode 100644
index 00000000000..016263e24d0
--- /dev/null
+++ b/app-accessibility/freetts/files/jsapi-gentoo.diff
@@ -0,0 +1,194 @@
+--- jsapi.sh 2001-12-20 09:51:28.000000000 -0500
++++ jsapi-gentoo.sh 2004-03-20 01:36:10.021810888 -0500
+@@ -10,191 +10,6 @@
+ # ------ ---------- ------------------------------------------
+ # 51811 -rw-rw-r-- jsapi.jar
+ #
+-more <<- xxxFOOxxx
+-
+- Sun Microsystems, Inc.
+- Binary Code License Agreement
+-
+-READ THE TERMS OF THIS AGREEMENT AND ANY PROVIDED SUPPLEMENTAL LICENSE
+-TERMS (COLLECTIVELY "AGREEMENT") CAREFULLY BEFORE OPENING THE SOFTWARE
+-MEDIA PACKAGE. BY OPENING THE SOFTWARE MEDIA PACKAGE, YOU AGREE TO THE
+-TERMS OF THIS AGREEMENT. IF YOU ARE ACCESSING THE SOFTWARE
+-ELECTRONICALLY, INDICATE YOUR ACCEPTANCE OF THESE TERMS BY SELECTING
+-THE "ACCEPT" BUTTON AT THE END OF THIS AGREEMENT. IF YOU DO NOT AGREE
+-TO ALL THESE TERMS, PROMPTLY RETURN THE UNUSED SOFTWARE TO YOUR PLACE
+-OF PURCHASE FOR A REFUND OR, IF THE SOFTWARE IS ACCESSED
+-ELECTRONICALLY, SELECT THE "DECLINE" BUTTON AT THE END OF THIS
+-AGREEMENT.
+-
+-1. LICENSE TO USE. Sun grants you a non-exclusive and
+-non-transferable license for the internal use only of the accompanying
+-software and documentation and any error corrections provided by Sun
+-(collectively "Software"), by the number of users and the class of
+-computer hardware for which the corresponding fee has been paid.
+-
+-2. RESTRICTIONS. Software is confidential and copyrighted. Title to
+-Software and all associated intellectual property rights is retained by
+-Sun and/or its licensors. Except as specifically authorized in any
+-Supplemental License Terms, you may not make copies of Software, other
+-than a single copy of Software for archival purposes. Unless
+-enforcement is prohibited by applicable law, you may not modify,
+-decompile, or reverse engineer Software. You acknowledge that Software
+-is not designed, licensed or intended for use in the design,
+-construction, operation or maintenance of any nuclear facility. Sun
+-disclaims any express or implied warranty of fitness for such uses. No
+-right, title or interest in or to any trademark, service mark, logo or
+-trade name of Sun or its licensors is granted under this Agreement.
+-
+-3. LIMITED WARRANTY. Sun warrants to you that for a period of ninety
+-(90) days from the date of purchase, as evidenced by a copy of the
+-receipt, the media on which Software is furnished (if any) will be free
+-of defects in materials and workmanship under normal use. Except for
+-the foregoing, Software is provided "AS IS". Your exclusive remedy and
+-Sun's entire liability under this limited warranty will be at Sun's
+-option to replace Software media or refund the fee paid for Software.
+-
+-4. DISCLAIMER OF WARRANTY. UNLESS SPECIFIED IN THIS AGREEMENT, ALL
+-EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES,
+-INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A
+-PARTICULAR PURPOSE OR NON-INFRINGEMENT ARE DISCLAIMED, EXCEPT TO THE
+-EXTENT THAT THESE DISCLAIMERS ARE HELD TO BE LEGALLY INVALID.
+-
+-5. LIMITATION OF LIABILITY. TO THE EXTENT NOT PROHIBITED BY LAW, IN
+-NO EVENT WILL SUN OR ITS LICENSORS BE LIABLE FOR ANY LOST REVENUE,
+-PROFIT OR DATA, OR FOR SPECIAL, INDIRECT, CONSEQUENTIAL, INCIDENTAL OR
+-PUNITIVE DAMAGES, HOWEVER CAUSED REGARDLESS OF THE THEORY OF LIABILITY,
+-ARISING OUT OF OR RELATED TO THE USE OF OR INABILITY TO USE SOFTWARE,
+-EVEN IF SUN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. In no
+-event will Sun's liability to you, whether in contract, tort (including
+-negligence), or otherwise, exceed the amount paid by you for Software
+-under this Agreement. The foregoing limitations will apply even if the
+-above stated warranty fails of its essential purpose.
+-
+-6. Termination. This Agreement is effective until terminated. You
+-may terminate this Agreement at any time by destroying all copies of
+-Software. This Agreement will terminate immediately without notice
+-from Sun if you fail to comply with any provision of this Agreement.
+-Upon Termination, you must destroy all copies of Software.
+-
+-7. Export Regulations. All Software and technical data delivered under
+-this Agreement are subject to US export control laws and may be subject
+-to export or import regulations in other countries. You agree to
+-comply strictly with all such laws and regulations and acknowledge that
+-you have the responsibility to obtain such licenses to export,
+-re-export, or import as may be required after delivery to you.
+-
+-8. U.S. Government Restricted Rights. If Software is being acquired
+-by or on behalf of the U.S. Government or by a U.S. Government prime
+-contractor or subcontractor (at any tier), then the Government's rights
+-in Software and accompanying documentation will be only as set forth in
+-this Agreement; this is in accordance with 48 CFR 227.7201 through
+-227.7202-4 (for Department of Defense (DOD) acquisitions) and with 48
+-CFR 2.101 and 12.212 (for non-DOD acquisitions).
+-
+-9. Governing Law. Any action related to this Agreement will be
+-governed by California law and controlling U.S. federal law. No choice
+-of law rules of any jurisdiction will apply.
+-
+-10. Severability. If any provision of this Agreement is held to be
+-unenforceable, this Agreement will remain in effect with the provision
+-omitted, unless omission would frustrate the intent of the parties, in
+-which case this Agreement will immediately terminate.
+-
+-11. Integration. This Agreement is the entire agreement between you
+-and Sun relating to its subject matter. It supersedes all prior or
+-contemporaneous oral or written communications, proposals,
+-representations and warranties and prevails over any conflicting or
+-additional terms of any quote, order, acknowledgment, or other
+-communication between the parties relating to its subject matter during
+-the term of this Agreement. No modification of this Agreement will be
+-binding, unless in writing and signed by an authorized representative
+-of each party.
+-
+- JAVA(TM) SPEECH API (JSAPI) SPECIFICATION IMPLEMETATION, VERSION
+- 1.0
+- SUPPLEMENTAL LICENSE TERMS
+-
+-These supplemental license terms ("Supplemental Terms") add to or
+-modify the terms of the Binary Code License Agreement (collectively,
+-the "Agreement"). Capitalized terms not defined in these Supplemental
+-Terms shall have the same meanings ascribed to them in the Agreement.
+-These Supplemental Terms shall supersede any inconsistent or
+-conflicting terms in the Agreement, or in any license contained within
+-the Software.
+-
+-1. Software Internal Use and Development License Grant. Subject to the
+-terms and conditions of this Agreement, including, but not limited to
+-Section 3 (Java(TM) Technology Restrictions) of these Supplemental
+-Terms, Sun grants you a non-exclusive, non-transferable, limited
+-license to reproduce internally and use internally the binary form of
+-the Software, complete and unmodified, for the sole purpose of
+-designing, developing and testing your Java applets and applications
+-("Programs").
+-
+-2. License to Distribute Software. In addition to the license granted
+-in Section 1 (Software Internal Use and Development License Grant) of
+-these Supplemental Terms, subject to the terms and conditions of this
+-Agreement, including but not limited to Section 3 (Java Technology
+-Restrictions), Sun grants you a non-exclusive, non-transferable,
+-limited license to reproduce and distribute the Software in binary form
+-only, provided that you (i) distribute the Software complete and
+-unmodified and only bundled as part of your Programs, (ii) do not
+-distribute additional software intended to replace any component(s) of
+-the Software, (iii) do not remove or alter any proprietary legends or
+-notices contained in the Software, (iv) only distribute the Software
+-subject to a license agreement that protects Sun's interests consistent
+-with the terms contained in this Agreement, and (v) agree to defend and
+-indemnify Sun and its licensors from and against any damages, costs,
+-liabilities, settlement amounts and/or expenses (including attorneys'
+-fees) incurred in connection with any claim, lawsuit or action by any
+-third party that arises or results from the use or distribution of any
+-and all Programs and/or Software.
+-
+-3. Java Technology Restrictions. You may not modify the Java Platform
+-Interface ("JPI", identified as classes contained within the "java"
+-package or any subpackages of the "java" package), by creating
+-additional classes within the JPI or otherwise causing the addition to
+-or modification of the classes in the JPI. In the event that you
+-create an additional class and associated API(s) which (i) extends the
+-functionality of the Java Platform, and (ii) is exposed to third party
+-software developers for the purpose of developing additional software
+-which invokes such additional API, you must promptly publish broadly an
+-accurate specification for such API for free use by all developers. You
+-may not create, or authorize your licensees to create additional
+-classes, interfaces, or subpackages that are in any way identified as
+-"java", "javax", "sun" or similar convention as specified by Sun in any
+-naming convention designation.
+-
+-4. Trademarks and Logos. You acknowledge and agree as between you and
+-Sun that Sun owns the SUN, SOLARIS, JAVA, JINI, FORTE, and iPLANET
+-trademarks and all SUN, SOLARIS, JAVA, JINI, FORTE, and iPLANET-related
+-trademarks, service marks, logos and other brand designations ("Sun
+-Marks"), and you agree to comply with the Sun Trademark and Logo Usage
+-Requirements currently located at
+-http://www.sun.com/policies/trademarks. Any use you make of the Sun
+-Marks inures to Sun's benefit.
+-
+-5. Source Code. Software may contain source code that is provided
+-solely for reference purposes pursuant to the terms of this Agreement.
+-Source code may not be redistributed unless expressly provided for in
+-this Agreement.
+-
+-6. Termination for Infringement. Either party may terminate this
+-Agreement immediately should any Software become, or in either party's
+-opinion be likely to become, the subject of a claim of infringement of
+-any intellectual property right.
+-
+-For inquiries please contact: Sun Microsystems, Inc. 901 San Antonio
+-Road, Palo Alto, California 94303 (LFI#108931/Form ID#011801)
+-xxxFOOxxx
+-
+-echo "Accept (y/n)?: "
+-read ans
+-if [ "$ans" != "y" ]
+-then
+- echo 'failed to accept license'
+- exit 1
+-fi
+ save_IFS="${IFS}"
+ IFS="${IFS}:"
+ gettext_dir=FAILED
diff --git a/app-accessibility/freetts/freetts-1.2.1-r2.ebuild b/app-accessibility/freetts/freetts-1.2.1-r2.ebuild
new file mode 100644
index 00000000000..0097a1c2d92
--- /dev/null
+++ b/app-accessibility/freetts/freetts-1.2.1-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A speech synthesis system written entirely in Java"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+HOMEPAGE="http://freetts.sourceforge.net/"
+
+RDEPEND=">=virtual/jre-1.4
+ mbrola? ( >=app-accessibility/mbrola-3.0.1h-r6 ) "
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ jsapi? ( app-arch/sharutils )
+ app-arch/unzip"
+
+LICENSE="jsapi? ( sun-bcla-jsapi ) freetts"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="doc jsapi mbrola"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/lib"
+
+ chmod 0755 jsapi.sh
+ epatch "${FILESDIR}/jsapi-gentoo.diff"
+
+ use mbrola && echo "mbrola.base=/usr/share/mbrola/" >> "${S}/speech.properties"
+}
+
+src_compile() {
+ cd "${S}/lib"
+ if use jsapi; then
+ ./jsapi.sh || die "jsapi.sh failed"
+ fi
+ cd "${S}"
+ eant jars
+}
+
+# Tests dont' seem included
+# http://freetts.sourceforge.net/docs/index.php#how_test
+#src_test() {
+# ANT_TASKS="ant-junit" eant junit
+#}
+
+src_install() {
+ java-pkg_dojar lib/*.jar mbrola/*.jar
+
+ use mbrola && local jflags="--java_args -Dmbrola.base=/usr/share/mbrola"
+ java-pkg_dolauncher ${PN} --main com.sun.speech.freetts.FreeTTS ${jflags}
+
+ insinto /usr/share/${PN}
+ doins speech.properties
+
+ cp -R "${S}/demo" "${D}/usr/share/${PN}"
+ cp -R "${S}/tools" "${D}/usr/share/${PN}"
+
+ dodoc README.txt RELEASE_NOTES acknowledgments.txt || die
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r "${S}"/docs/*
+ java-pkg_dojavadoc "${S}/javadoc"
+ fi
+}
diff --git a/app-accessibility/freetts/freetts-1.2.2.ebuild b/app-accessibility/freetts/freetts-1.2.2.ebuild
new file mode 100644
index 00000000000..37676c28939
--- /dev/null
+++ b/app-accessibility/freetts/freetts-1.2.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A speech synthesis system written entirely in Java"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+HOMEPAGE="http://freetts.sourceforge.net/"
+
+RDEPEND=">=virtual/jre-1.4
+ mbrola? ( >=app-accessibility/mbrola-3.0.1h-r6 ) "
+
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ jsapi? ( app-arch/sharutils )
+ app-arch/unzip"
+
+LICENSE="jsapi? ( sun-bcla-jsapi ) freetts"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+IUSE="jsapi mbrola"
+
+# Tests aren't present.
+RESTRICT="test"
+
+java_prepare() {
+ # Prepare source directory.
+ mkdir src || die "Failed to create source directory."
+ mv com de src/ || die "Failed to move files to source directory."
+
+ # Prepare library directory.
+ cd lib || die "Lib directory not present."
+ chmod 0755 jsapi.sh || die "jsapi.sh not present or can't change permissions."
+ epatch "${FILESDIR}"/jsapi-gentoo.diff
+
+ use mbrola && echo "mbrola.base=/usr/share/mbrola/" >> "${S}"/speech.properties
+}
+
+src_compile() {
+ if use jsapi; then
+ pushd lib
+ ./jsapi.sh || die "jsapi.sh failed"
+ popd
+ fi
+
+ eant jars
+}
+
+# Tests aren't present.
+# http://freetts.sourceforge.net/docs/index.php#how_test
+#src_test() {
+# ANT_TASKS="ant-junit" eant junit
+#}
+
+src_install() {
+ java-pkg_dojar lib/*.jar mbrola/*.jar
+
+ use mbrola && local jflags="--java_args -Dmbrola.base=/usr/share/mbrola"
+
+ java-pkg_dolauncher ${PN} --main com.sun.speech.freetts.FreeTTS ${jflags}
+
+ insinto /usr/share/${PN}
+ doins speech.properties
+ doins -r tools
+
+ dodoc ANNOUNCE.txt README.txt RELEASE_NOTES
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r docs/*
+ java-pkg_dojavadoc javadoc
+ fi
+
+ if use examples ; then
+ java-pkg_doexamples demo
+ fi
+
+ if use source ; then
+ java-pkg-dosrc src/*
+ fi
+}
diff --git a/app-accessibility/freetts/metadata.xml b/app-accessibility/freetts/metadata.xml
new file mode 100644
index 00000000000..654f205d7a0
--- /dev/null
+++ b/app-accessibility/freetts/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>java</herd>
+ <use>
+ <flag name="jsapi">build Java Speech API (JSAPI)</flag>
+ <flag name="mbrola">Adds support for mbrola voices</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">freetts</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/julius/Manifest b/app-accessibility/julius/Manifest
new file mode 100644
index 00000000000..25a9d054531
--- /dev/null
+++ b/app-accessibility/julius/Manifest
@@ -0,0 +1 @@
+DIST julius-4.2.2.tar.gz 1720888 SHA256 f53caf18be4fb8266b988071855565dccb78c09f00f1d36a8e258b7be6b3cef5 SHA512 c1d6c4016cf326becc2e8945c08cbab9b5acefd0e648b6e35b3078850b1746b5bbdb994fccc66c0adab175fb45fc86c25b8a655047a97c130a2f8e922d3d1c0f WHIRLPOOL 51f25ca9cedafc47239e5645a75ffda3eadc0b4e1053d90bf5c22d366d3557c29e9f496b9d45f1d3c5a5cdc92993710429196a679a29307815cd8e052de6cb99
diff --git a/app-accessibility/julius/files/julius-4.2.2-install.patch b/app-accessibility/julius/files/julius-4.2.2-install.patch
new file mode 100644
index 00000000000..d40b6c69fdc
--- /dev/null
+++ b/app-accessibility/julius/files/julius-4.2.2-install.patch
@@ -0,0 +1,344 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Mar 31 20:38:49 UTC 2013
+Subject: respect DESTDIR
+
+--- julius-4.2.2/libsent/Makefile.in
++++ julius-4.2.2/libsent/Makefile.in
+@@ -144,16 +144,16 @@
+ install: install.lib install.include install.bin
+
+ install.lib: $(TARGET)
+- ${INSTALL} -d ${libdir}
+- ${INSTALL_DATA} $(TARGET) ${libdir}
++ ${INSTALL} -d $(DESTDIR)/${libdir}
++ ${INSTALL_DATA} $(TARGET) $(DESTDIR)/${libdir}
+
+ install.include:
+- ${INSTALL} -d ${includedir}/sent
+- ${INSTALL_DATA} include/sent/*.h ${includedir}/sent
++ ${INSTALL} -d $(DESTDIR)/${includedir}/sent
++ ${INSTALL_DATA} include/sent/*.h $(DESTDIR)/${includedir}/sent
+
+ install.bin: libsent-config-dist
+- ${INSTALL} -d ${bindir}
+- ${INSTALL_PROGRAM} libsent-config-dist ${bindir}/libsent-config
++ ${INSTALL} -d $(DESTDIR)/${bindir}
++ ${INSTALL_PROGRAM} libsent-config-dist $(DESTDIR)/${bindir}/libsent-config
+
+ clean:
+ $(RM) *~ src/*/*~ src/*/*.o src/*/*/*.o src/*/*/*/*.o src/*/*/*/*/*.o include/sent/*~
+--- julius-4.2.2/libjulius/Makefile.in
++++ julius-4.2.2/libjulius/Makefile.in
+@@ -90,16 +90,16 @@
+ install: install.lib install.include install.bin
+
+ install.lib: $(TARGET)
+- ${INSTALL} -d ${libdir}
+- ${INSTALL_DATA} $(TARGET) ${libdir}
++ ${INSTALL} -d $(DESTDIR)/${libdir}
++ ${INSTALL_DATA} $(TARGET) $(DESTDIR)/${libdir}
+
+ install.include:
+- ${INSTALL} -d ${includedir}/julius
+- ${INSTALL_DATA} include/julius/*.h ${includedir}/julius
++ ${INSTALL} -d $(DESTDIR)/${includedir}/julius
++ ${INSTALL_DATA} include/julius/*.h $(DESTDIR)/${includedir}/julius
+
+ install.bin: libjulius-config-dist
+- ${INSTALL} -d ${bindir}
+- ${INSTALL_PROGRAM} libjulius-config-dist ${bindir}/libjulius-config
++ ${INSTALL} -d $(DESTDIR)/${bindir}
++ ${INSTALL_PROGRAM} libjulius-config-dist $(DESTDIR)/${bindir}/libjulius-config
+
+ depend:
+ makedepend -- $(CFLAGS) -- $(OBJSENT)
+--- julius-4.2.2/julius/Makefile.in
++++ julius-4.2.2/julius/Makefile.in
+@@ -61,8 +61,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- ${INSTALL_PROGRAM} $(TARGET) ${bindir}/${INSTALLTARGET}
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ ${INSTALL_PROGRAM} $(TARGET) $(DESTDIR)/${bindir}/${INSTALLTARGET}
+
+ depend:
+ makedepend -- $(CFLAGS) -- $(OBJSENT)
+--- julius-4.2.2/mkbingram/Makefile.in
++++ julius-4.2.2/mkbingram/Makefile.in
+@@ -32,8 +32,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ clean:
+ $(RM) $(OBJ)
+--- julius-4.2.2/mkbinhmm/Makefile.in
++++ julius-4.2.2/mkbinhmm/Makefile.in
+@@ -32,8 +32,8 @@
+ install: install.bin
+
+ install.bin: mkbinhmm@EXEEXT@ mkbinhmmlist@EXEEXT@
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ mkbinhmm@EXEEXT@ mkbinhmmlist@EXEEXT@ @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ mkbinhmm@EXEEXT@ mkbinhmmlist@EXEEXT@ $(DESTDIR)/@bindir@
+
+ clean:
+ $(RM) mkbinhmm.o mkbinhmmlist.o
+--- julius-4.2.2/adinrec/Makefile.in
++++ julius-4.2.2/adinrec/Makefile.in
+@@ -36,8 +36,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/adintool/Makefile.in
++++ julius-4.2.2/adintool/Makefile.in
+@@ -36,8 +36,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/mkgshmm/Makefile.in
++++ julius-4.2.2/mkgshmm/Makefile.in
+@@ -23,8 +23,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/mkss/Makefile.in
++++ julius-4.2.2/mkss/Makefile.in
+@@ -36,8 +36,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/jcontrol/Makefile.in
++++ julius-4.2.2/jcontrol/Makefile.in
+@@ -31,19 +31,19 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@/jucontrol
+
+ clean:
+ $(RM) $(OBJ)
+ $(RM) config.log config.cache
+ $(RM) *~ core
+- $(RM) $(TARGET) $(TARGET).exe
++ $(RM) $(TARGET) $(TARGET).exe jucontrol
+
+ distclean:
+ $(RM) $(OBJ)
+ $(RM) config.log config.cache
+ $(RM) *~ core
+- $(RM) $(TARGET) $(TARGET).exe
++ $(RM) $(TARGET) $(TARGET).exe jucontrol
+ $(RM) config.status
+ $(RM) Makefile
+--- julius-4.2.2/gramtools/accept_check/Makefile.in
++++ julius-4.2.2/gramtools/accept_check/Makefile.in
+@@ -36,8 +36,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/gramtools/dfa_determinize/Makefile.in
++++ julius-4.2.2/gramtools/dfa_determinize/Makefile.in
+@@ -35,8 +35,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/gramtools/dfa_minimize/Makefile.in
++++ julius-4.2.2/gramtools/dfa_minimize/Makefile.in
+@@ -34,8 +34,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/gramtools/generate/Makefile.in
++++ julius-4.2.2/gramtools/generate/Makefile.in
+@@ -35,8 +35,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/gramtools/gram2sapixml/Makefile.in
++++ julius-4.2.2/gramtools/gram2sapixml/Makefile.in
+@@ -17,8 +17,8 @@
+ install: install.bin
+
+ install.bin:
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ clean:
+ echo nothing to do
+--- julius-4.2.2/gramtools/mkdfa/Makefile.in
++++ julius-4.2.2/gramtools/mkdfa/Makefile.in
+@@ -18,13 +18,13 @@
+
+ install:
+ (cd $(SUBDIR); $(MAKE) install)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ install.bin:
+ (cd $(SUBDIR); $(MAKE) install.bin)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ clean:
+ (cd $(SUBDIR); $(MAKE) clean)
+--- julius-4.2.2/gramtools/mkdfa/mkfa-1.44-flex/Makefile.in
++++ julius-4.2.2/gramtools/mkdfa/mkfa-1.44-flex/Makefile.in
+@@ -43,8 +43,8 @@
+ install: install.bin
+
+ install.bin:
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ clean:
+ $(RM) *.o *~ core
+--- julius-4.2.2/gramtools/nextword/Makefile.in
++++ julius-4.2.2/gramtools/nextword/Makefile.in
+@@ -36,8 +36,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ ############################################################
+
+--- julius-4.2.2/gramtools/yomi2voca/Makefile.in
++++ julius-4.2.2/gramtools/yomi2voca/Makefile.in
+@@ -17,8 +17,8 @@
+ install: install.bin
+
+ install.bin:
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ clean:
+ echo nothing to do
+--- julius-4.2.2/generate-ngram/Makefile.in
++++ julius-4.2.2/generate-ngram/Makefile.in
+@@ -33,8 +33,8 @@
+ install: install.bin
+
+ install.bin: $(TARGET)
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ clean:
+ $(RM) $(OBJ) *~ core
+--- julius-4.2.2/jclient-perl/Makefile.in
++++ julius-4.2.2/jclient-perl/Makefile.in
+@@ -17,8 +17,8 @@
+ install: install.bin
+
+ install.bin:
+- ${INSTALL} -d @bindir@
+- @INSTALL_PROGRAM@ $(TARGET) @bindir@
++ ${INSTALL} -d $(DESTDIR)/@bindir@
++ @INSTALL_PROGRAM@ $(TARGET) $(DESTDIR)/@bindir@
+
+ clean:
+ echo nothing to do
+--- julius-4.2.2/man/Makefile.in
++++ julius-4.2.2/man/Makefile.in
+@@ -19,16 +19,16 @@
+ install: install.man install.man.ja
+
+ install.man:
+- ${INSTALL} -d @mandir@/man1
++ ${INSTALL} -d $(DESTDIR)/@mandir@/man1
+ for f in *.1; do \
+- @INSTALL_DATA@ $$f @mandir@/man1/$$f; \
++ @INSTALL_DATA@ $$f $(DESTDIR)/@mandir@/man1/$$f; \
+ done
+
+ install.man.ja:
+- ${INSTALL} -d @mandir@/ja/man1
++ ${INSTALL} -d $(DESTDIR)/@mandir@/ja/man1
+ cd ja;
+ for f in *.1; do \
+- @INSTALL_DATA@ $$f @mandir@/ja/man1/$$f; \
++ @INSTALL_DATA@ $$f $(DESTDIR)/@mandir@/ja/man1/$$f; \
+ done
+ cd ..
+
diff --git a/app-accessibility/julius/files/julius-4.2.2-ldflags.patch b/app-accessibility/julius/files/julius-4.2.2-ldflags.patch
new file mode 100644
index 00000000000..a5c3645a52f
--- /dev/null
+++ b/app-accessibility/julius/files/julius-4.2.2-ldflags.patch
@@ -0,0 +1,11 @@
+--- julius-4.2.2/jcontrol/Makefile.in
++++ julius-4.2.2/jcontrol/Makefile.in
+@@ -14,7 +14,7 @@
+ CC=@CC@
+ CFLAGS=@CFLAGS@
+ CPPFLAGS=@CPPFLAGS@ @DEFS@
+-LDFLAGS=@LIBS@ @EXTRALIB@
++LDFLAGS += @LIBS@ @EXTRALIB@
+ RM=@RM@ -f
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
diff --git a/app-accessibility/julius/julius-4.2.2.ebuild b/app-accessibility/julius/julius-4.2.2.ebuild
new file mode 100644
index 00000000000..94aedc4cf59
--- /dev/null
+++ b/app-accessibility/julius/julius-4.2.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Large Vocabulary Continuous Speech Recognition Engine"
+HOMEPAGE="http://julius.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/julius/56549/${P}.tar.gz"
+
+LICENSE="julius"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+alsa oss portaudio pulseaudio sndfile"
+REQUIRED_USE="^^ ( alsa oss portaudio pulseaudio )"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Jcode
+ sys-libs/readline:0
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sndfile? ( media-libs/libsndfile )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+pkg_setup() {
+ tc-export CC CXX
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ local mymic i
+ for i in alsa oss portaudio pulseaudio ; do
+ use ${i} && mymic=${i}
+ done
+
+ econf \
+ --with-mictype=${mymic} \
+ $(use_with sndfile)
+}
+
+src_install() {
+ default
+ if ! has ja ${LINGUAS} ; then
+ rm -r "${ED}"/usr/share/man/ja || die
+ fi
+}
+
+pkg_postinst() {
+ eerror "IMPORTANT NOTICE"
+ elog "/usr/bin/jcontrol has been renamed to /usr/bin/jucontrol"
+ elog "to avoid file collision with dev-java/java-config."
+ elog "If this creates a problem with applications, file a gentoo bug."
+}
diff --git a/app-accessibility/julius/metadata.xml b/app-accessibility/julius/metadata.xml
new file mode 100644
index 00000000000..cbed4e8e981
--- /dev/null
+++ b/app-accessibility/julius/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge-jp">julius</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/mbrola/Manifest b/app-accessibility/mbrola/Manifest
new file mode 100644
index 00000000000..6edb6122458
--- /dev/null
+++ b/app-accessibility/mbrola/Manifest
@@ -0,0 +1,24 @@
+DIST de1-980227.zip 9946342 SHA256 0007641e23c7a508b7262242f32ac0449f57cd64b10521e2083256acedb64b1e SHA512 df9027ee1a1bd32542d02bb851bff54379a9526f3d52429786e51c4a96b9de9cb1b8e1e7d66d4c6c77a13e285311c62fa0a13e0e749c8590c7292121e231fb47 WHIRLPOOL c906db43bab165d6bb43db84f0cc7c4dbf5d990ca23450c6117729bc4ac7bb8ba8d0e93671c5de517414236b2717a10d18d214cef1bbd1de116dab3b791bb089
+DIST de2-990106.zip 9463658 SHA256 51fd848141c8e5c2205fd18e08666411f1c2a9a4dcd861309d0f9cc4bb404acb SHA512 9d2dfb685c71d4348bad142035152c6c4bfb60f98121ea1be4e51adfb078137aa93c0b8b4c1e43c9aaee51e0d3bad4a6c7a2f6ffc019e0cb34ac853cddd8b7be WHIRLPOOL 287073109b5fe1f3928dbb3929fc1984a3615cbf41c1802fb3c877ab324c20ce4e5f409248c1fd47aa8b69d1e5c7efab925e9e020795956fe226fd82c413c46f
+DIST de3-000307.zip 10486554 SHA256 c4ee8375e3ed1e737db799b859e419a8d5d1899bfdab988339fe5abbaeb15511 SHA512 32bbf8d19d2f1032429b1f777c43d49746c45d5c150258f08a1533f7681df973483ac96f3db8c6bfff0481f7558853b749ee7c024410237982e712880935ccb9 WHIRLPOOL d27863876c01e4d3282b1f3fdf09cf270b46fff3a5fc8d7728c5f01ae8a7b78cd606aeea2f37ac0813271a0b8738ec70d51d41db50540f9cd08f6751cae79f2f
+DIST de4.zip 19520969 SHA256 35250b24ce5e003a7df12f7d0b96fe270ffdac30515cff223dd1b2e558bbfe6a SHA512 ea8ab4192c68b9ad6c4f4c02500015449fc332c22f811cdeee8956a85c347bb48fa263082495f5cd20c0b3641b67673acb7b3da081cb15863271d988b238b4d7 WHIRLPOOL 2530b722d992fc36e763efabdc0e7f89edcfcabf1a236e433e127f027896ce0c243d8c912410cd33066d37c50a59058b34ba406ca67309a655d8a454837dab76
+DIST de5.zip 13134662 SHA256 b277863d8058dedf7d76fad7efd2373abc04769d3c0650979f8dc55f68c2b7f5 SHA512 652110430f13cb81420ffa08d368d7992a5ce814c9682d5ab90ec1cd43aa631b6cae9df918171864184efdda0ad804ca4560ede6d048ef3067332f712f72cc19 WHIRLPOOL ad2d5fa9ad44629edd7bf0b5e444fba98444ccc85f7440f5e20096303b438c41c6feb954f268811f5827fb8376bb2de8d194bff1f773fcd70f91398c6a2ef7f4
+DIST de8.zip 9693603 SHA256 2df96f039f4875318f22400561dedf8d9a9f54cc8f517da6fa220d6248ceac4c SHA512 6e8d1be85eb8c24d5c38c1c102cecca4af9538a55b75b78ef62bccf0761a431beb0ed3d31e4aea271c29037631ed4b00763aea90c06dffddb3b52cbe8d65b3d7 WHIRLPOOL c0845c04f8ca1f8ff7fc796212c4c3ad772553768f177ecac2b095c42b63a1b534be2d66209f5c27e77176960a73c8b6cc045df277118e4a71d77248834df4be
+DIST es1-980610.zip 2110022 SHA256 a7ae7474499dd8d3898ef008c903f33a4d3bb470f5ac2a19c6c5ff9675e0e224 SHA512 1459a346c66133e70eeb1cec057b762e6f22d11472c33c732cd45b92afecb8628de861992abb07c3272ee640bb023154b838d1648b6541228256e57206216ed5 WHIRLPOOL 4018d91642af368b8ff6d7143c42559596111419d323626cd96dab72d9815609d93f7f02440698c3a94a111a16de1fa0aaf22ed482f32898f846b570fb073ebc
+DIST es2-989825.zip 5111601 SHA256 d8b25527064fe1b17f1e4710d04609e7a5cc29847993c07bad3d11072b5bb12a SHA512 69d9bb62b42607714ea692a3570c70ddbe32590f2dd6c0466f6cad685a292c74ade693af7fead0d4bbdf12a70a36e06e3205bd07854855b628f59d7bc1d1be3a WHIRLPOOL aa0932f1cb47505511735b9e9e65f7fcc805ee1679d455996f0197380c788dd605574fbe708a9548a4e845f09b26a377a92475eb51d6c88f26d91ef16cc57ffd
+DIST es4.zip 2804262 SHA256 3e717696ad6b5297fb349a7da42bdd7994deea7060af217fee619fa596cb39bc SHA512 b5ce924fc894a3e186cf06feb3afc0f8ce2805310e1da34c4a74b52100d2ecfbb073d63c87c5809e05e89b47b57fa32bc0edd44ad7477aa92facc9ac041cd349 WHIRLPOOL 2211ec58f1d9fe9b1132e5a89e7399973f834f6229461bcecd5ecabf2d61d181f71abe869bbbad78bae23eface4a51bf9da429c3bde8086dffecf1cdee658c50
+DIST fr1-990204.zip 4694334 SHA256 8eb4c30f294ef53c3ceeda2cef984b5a917e3cc4b7d0970d23361a1a8efa3831 SHA512 1a24326f6f9989d88f8a8447ebb1d9f8fbfd49f909a28d456c170bc8615b9385be678202e0d6d5c867d3a50ca68ca16f85ea5410d16fd2c70e4f9b6f7b115afb WHIRLPOOL c9d7c1716d32e9199c28fc94611f31699f6008bc7a511bb9b0997e4785dfe56a1cee3392ec20d3e92afc217017de1e843c9feb68e7b77ae369f17aa564ea2553
+DIST fr2-980806.zip 5744598 SHA256 3b836361676ed00da9d33bbfb60b32388f4769f02f0e226d0c573d2030271307 SHA512 cca19bc7db0118e6a09f203346f355e87b2a75902e06ee7d82c2379a4ebaa8144f64ae79b5ff6cd9c49e0d46a26d2a05109f325bda78e1b0462089b6d03a104c WHIRLPOOL 7997bdfa7ee8e9c11b7d39869141d8c2ff315734129b3348034b021fff871fd523458207c07e52982102593a523bde4afc1a8f949b7ebef7a11bd8387b6e5c1f
+DIST fr3-990324.zip 4702681 SHA256 8f3ff80fd95a0cf5066d392de96e7bfe48343ce41cd2ce2ed331c041a4791b78 SHA512 24a715b5913ca931624f5c079d7027d3c84543c6044ab49283550dd7d0158d19c610d2ee9ebb055d8de14f9b817aac1d4b32599729b17838d5f914ec3bf50439 WHIRLPOOL fca792b8d72d7e44185dfad6b1781d640bc5787ff0b9966eff9544c7ba77c7bce5823ef41c0d1b27468f520121ad775d33feb89d9af23e7b1c0af6e3dd32889e
+DIST fr6-010330.zip 4610252 SHA256 fbcafe2f93c3e691b6db058968d8488d6d4a0e5821e4f3234d24bdd343b228fd SHA512 41bfba97e6b06a987a691a7dbb6e6a5bc00c7a6e4576215297e1db974a8efd06fc7e960fc0c83f024852c195c7f4c0da5e8d3ac6f5ad3f641193ee1d65679879 WHIRLPOOL 8935524a7a3184192b684cc3cf6936eba023610deaeb35d4f4f621a4c1dc89150e8bd958fe7ca0688d6c9cae9a82edf0ba9e789f85b1e200625fbba6dcfe69f5
+DIST it3-010304.zip 5349273 SHA256 d134b522d0aa68dbece9144e395246396cff9ff5e91d1c7b6a24d5a061e6ade5 SHA512 cb179430b93cef676d4e3f792d453f2dc3a34ad0f5bd0a36e97ded98b17c0dc5cad1622f7bb7e7f4f6b26d944573b906b33eb519bc19d0bcec01ea4810d8f71c WHIRLPOOL 424529a8bfef30daf98d8740a48204531985fbc54db2d068dc3188694f7804c0f9dedb7836d2bb93b1be19c21d670a88d7bf72484f62a1bdbf81db73b120f247
+DIST it4-010926.zip 5044168 SHA256 8ec74af698fdd9bebf37cbf0877bc2f0382df60ff6cbe7c4c72186ba5b809a69 SHA512 a7fcdff5b30e213bf9f043c2323e73a769357a46ce6df9114579cc62392fe2394ce472120c73018a1a71870c7565d18bb912ba7650a267f8779e18c12f260113 WHIRLPOOL f07f3300aeaac7db244bf297d677fa74ba6bf2b96e5c2b7205efb63c7aa60b2edcea41c081d51fecdab62f17d600380631fc103583c88002828821e3702b6d69
+DIST la1.zip 7627631 SHA256 6f86749c79127125b4bcd347852e3b0d15722398fb3e0ca53b0c9d902e0aad27 SHA512 5a367ede393feb28b587a380975baa84ca1840dfc5479f938de1588954f3ae23b06e0214b854e1f0137f178d197e4999e8e8750b136d964797116d53e49ec6cb WHIRLPOOL bc79f0218bfaff0a532aa8eba45ef5e8603f06734c7315db6926e91a3824b7b67e0aef31ca74021edb8a26a44033aebc1846de275a2c9f205a92d7ed7b345a1d
+DIST mbr301h.zip 309820 SHA256 df402fad97c823206fce68837c1d716b9c0466a4cfb554dfb244df7da5589d6e SHA512 24b522092ff8f18ab606ed9cae609a69ce8ae9ea56228468dfc3c4c6c114bc65ce9d69f420cddbdff75f1200dbed1edb667e8d84937a73218542dea25a88b848 WHIRLPOOL a98dcc0c52b2523054b8f004d7df870cb5fb4082573b2cf7d0432766bfa68250a3a4458da51e89243e6dc08dd6491fd56a048ee50fe4fac8194946df845142f2
+DIST pl1.zip 4050906 SHA256 0966ed3114950983285efde2284e285d8f2a709d4af8a94d9cb226d2409f9917 SHA512 e42d4208719798512c5296e89defa59b46719c787bd352503f6377b185e817b709a27228a8fd2e70536632f68dff81aac9e145902e2a17fe95a366b0d4d03478 WHIRLPOOL 7b8e3a1101b6b8c84e63802415eb5c1c426340dbf976c2579f3263bc2793d53824f0d9987ef2af354fb79607deccb90d3bba23798a33366c4bf587a4ccd9f612
+DIST ro1-980317.zip 3222054 SHA256 6ae11eef95172c7e8aeb2c305104cbaef4c574e54bc0f28e1fee0b8657adf89f SHA512 06075426f3befde1a4a2c589f92340c964b22fc1cf54d34d1808d6ab8ba0d50a57f4a96e1c68ba06badee466d11bb46db6c929ce974ea25212ffb1987468b9a1 WHIRLPOOL 4f917453e492ab12a1c54bee55e9f09204776759bc512b3526d3c0a21a28d23423423756d9ac3509c1834feb3f11ee13a94be7eb4ea9e03678cfe9f24b75f857
+DIST sw1-980623.zip 9386828 SHA256 f63adba2905ae36cc3428c0656bebe3c159ca40b59a52e07522d5ddbaa5af176 SHA512 c3b2493f5ba6f91983bd6e2d821cce741d427886cdfa17f1f3ea58197445229fcaca05bd09f531c3166360f77232d04ef61290a5f2a2bbba22587d689d821484 WHIRLPOOL 6dfd18e7a01e1931b62e40202395356c5b0c21b52bc806953cea3dbd3b34f850de5189496d099395d50cd867d7a9c3f707cce5933ad2d0eb4d9acc66ac133ea1
+DIST sw2-140102.zip 5629399 SHA256 a6d4b7050e5b9850da6e434128d5f432eeb274be63c95dc3db2c91c383629cd8 SHA512 eedfe81cd37e3cbd022b3e2be5878d165cf29fb0cee36ddc700ba567c92181eaec0e48699fedffdd780f2205ab3e1ddd9a9426a88b0e6f02992de1639e4ce0b3 WHIRLPOOL 1e924181f0c3e7a2c7a18673b6c7fe6a6c2b8dd96df5fb6f64f33acb372419a565192930b75c7329488390b5695f1643a929b3d268758e0cd206b60f8df8a9fc
+DIST us1-980512.zip 6562915 SHA256 aea3100a1d9de295c661ad9dd0332358c884c6dd9f667888f6eae507f3451e4f SHA512 e2b1eb7325e9fe0b58f3b0e265899b0da1cf5ec1cb183f241bf73ba670528b56cd091277f432446e6651d81dca21f2b2ea8a84622dd655d125cedda0447cdb62 WHIRLPOOL 3a650a22ef94bf1e4a566a3be64d46d3e28065e35adfb5e00026ac0c5ebe280afb2774454c69e90f406dd1114cda6e8005a89098462c8bf5342102cac4671dbf
+DIST us2-980812.zip 6387442 SHA256 1c9ad0645dbac724acc6f53238be288a951b162f2ca65a1cecf09ac450f47a62 SHA512 a8aea10bc08f6c66e863994a5238fc2caba1d308f5c9ef35ccd18d01eb92a38fcbc0b96593a56bd7abd2f714fe722aa6b3e2c3141da92a4c8c06e81efb843ac6 WHIRLPOOL 5a78bfad1eebd0a74a4a1b1bc468c5304a22024715e8a92e08a19aa0ec7b4f4171baf8c0423b239fe46fb1150cb40305122e2f97b56e212d212602717dd6ee72
+DIST us3-990208.zip 6195800 SHA256 ebaf8af32dab2b7f3b7483b824f86b1d8151cde7e0ef50d2d88488948564b601 SHA512 dbc6b0cdc3040ec3747f25a15dd17f35f0e97c40a153ae44e43a7e8030302e7e7c8710b10fe8184cc38f907de07a187ac0a7e3816be2230ce969aa014641d0ae WHIRLPOOL f840b9a166655bda4a7d9e5409a4ef36ee13c1f51c8c023d105ef6af381ff1e2daa8105fa225998efe563228d7b410f42aad9455c37b39f20a15607456fd7ed6
diff --git a/app-accessibility/mbrola/mbrola-3.0.1h-r6.ebuild b/app-accessibility/mbrola/mbrola-3.0.1h-r6.ebuild
new file mode 100644
index 00000000000..fc67061efb9
--- /dev/null
+++ b/app-accessibility/mbrola/mbrola-3.0.1h-r6.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE="linguas_de linguas_es linguas_fr linguas_it linguas_la linguas_pl
+ linguas_ro linguas_sv"
+
+S=${WORKDIR}
+
+DESCRIPTION="Speech synthesizer based on the concatenation of diphones. Includes sample voices"
+HOMEPAGE="http://tcts.fpms.ac.be/synthesis/mbrola.html"
+MY_PV=${PV//./}
+TCTS="http://tcts.fpms.ac.be/synthesis"
+SRC_URI="http://tcts.fpms.ac.be/synthesis/${PN}/bin/pclinux/mbr${MY_PV}.zip
+ ${TCTS}/mbrola/dba/us1/us1-980512.zip
+ ${TCTS}/mbrola/dba/us1/us2-980812.zip
+ ${TCTS}/mbrola/dba/us3/us3-990208.zip
+ linguas_de? ( ${TCTS}/mbrola/dba/de1/de1-980227.zip
+ ${TCTS}/mbrola/dba/de2/de2-990106.zip
+ ${TCTS}/mbrola/dba/de3/de3-000307.zip
+ ${TCTS}/mbrola/dba/de4/de4.zip
+ ${TCTS}/mbrola/dba/de5/de5.zip
+ ${TCTS}/mbrola/dba/de8/de8.zip )
+ linguas_es? ( ${TCTS}/mbrola/dba/es1/es1-980610.zip
+ ${TCTS}/mbrola/dba/es2/es2-989825.zip
+ ${TCTS}/mbrola/dba/es4/es4.zip )
+ linguas_fr? ( ${TCTS}/mbrola/dba/fr1/fr1-990204.zip
+ ${TCTS}/mbrola/dba/fr2/fr2-980806.zip
+ ${TCTS}/mbrola/dba/fr3/fr3-990324.zip
+ ${TCTS}/mbrola/dba/fr6/fr6-010330.zip )
+ linguas_it? ( ${TCTS}/mbrola/dba/it3/it3-010304.zip
+ ${TCTS}/mbrola/dba/it4/it4-010926.zip )
+ linguas_la? ( ${TCTS}/mbrola/dba/la1/la1.zip )
+ linguas_pl? ( ${TCTS}/mbrola/dba/pl1/pl1.zip )
+ linguas_ro? ( ${TCTS}/mbrola/dba/ro1/ro1-980317.zip )
+ linguas_sv? ( ${TCTS}/mbrola/dba/sw1/sw1-980623.zip
+ ${TCTS}/mbrola/dba/sw2/sw2-140102.zip )"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND=""
+
+RESTRICT="strip"
+QA_PREBUILT="/usr/bin/mbrola"
+
+SLOT="0"
+LICENSE="MBROLA"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+
+src_unpack () {
+ unpack ${A}
+
+ if [[ -f pl1 ]]; then
+ mkdir pl1DIR
+ mv pl1 pl1.txt pl1DIR
+ mv test pl1DIR/TEST
+ mv pl1DIR pl1
+ fi
+
+ case ${ARCH} in
+ x86|amd64)
+ cp mbrola-linux-i386 mbrola || die
+ ;;
+ ppc)
+ cp mbrola302b-linux-ppc mbrola || die
+ ;;
+ sparc)
+ cp mbrola-SuSElinux-ultra1.dat mbrola || die
+ ;;
+ alpha)
+ cp mbrola-linux-alpha mbrola || die
+ ;;
+ *)
+ elog "mbrola binary not available on this architecture. Still installing voices."
+ esac
+}
+
+src_install () {
+
+ # Take care of main binary
+ if [[ -f "mbrola" ]]; then
+ dobin mbrola
+ dosym /usr/bin/mbrola "/usr/share/${PN}/mbrola"
+ fi
+
+ dodoc readme.txt
+
+ for voice in ??[0-9]; do
+ insinto /usr/share/${PN}/${voice}
+ [[ -f "${voice}/license.txt" ]] && doins ${voice}/license.txt
+ [[ -f "${voice}/${voice}" ]] && doins ${voice}/${voice}
+ [[ -f "${voice}/${voice}mrpa" ]] && doins ${voice}/${voice}mrpa
+
+ if [[ -d "${voice}/TEST" ]]; then
+ insinto /usr/share/${PN}/${voice}/TEST
+ doins ${voice}/TEST/*
+ fi
+
+ [[ -f "${voice}/${voice}.txt" ]] && dodoc ${voice}/${voice}.txt
+ done
+}
diff --git a/app-accessibility/mbrola/metadata.xml b/app-accessibility/mbrola/metadata.xml
new file mode 100644
index 00000000000..523097ffe30
--- /dev/null
+++ b/app-accessibility/mbrola/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/app-accessibility/metadata.xml b/app-accessibility/metadata.xml
new file mode 100644
index 00000000000..e76c80d9abf
--- /dev/null
+++ b/app-accessibility/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE catmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<catmetadata>
+ <longdescription lang="en">
+ The app-accessibility category contains packages which help with
+ accessibility (for example, screen readers).
+ </longdescription>
+ <longdescription lang="es">
+ La categoría app-accessibility contiene paquetes para ayudar con
+ accesibilidad (por ejemplo, lectores de pantallas).
+ </longdescription>
+ <longdescription lang="de">
+ Die Kategorie app-accessibility enthält Programme für barrierefreies
+ Arbeiten (Accessibility), wie beispielsweise Screenreader.
+ </longdescription>
+ <longdescription lang="nl">
+ De app-accessibility categorie bevat applicaties die de
+ toegankelijkheid bevorderen, bijvoorbeeld een schermlezer.
+ </longdescription>
+ <longdescription lang="ja">
+ app-accessibilityカテゴリィにはアクセシビリティと
+ 手伝うパッケージが含まれます。
+ </longdescription>
+ <longdescription lang="vi">
+ Nhóm app-accessibility chứa các gói trợ giúp về truy nhập (ví dụ, trình đọc màn hình)
+ </longdescription>
+ <longdescription lang="it">
+ La categoria app-accessibility contiene strumenti per l'accessibilità del software (ad esempio lettori di schermo per ipovedenti).
+ </longdescription>
+ <longdescription lang="pt">
+ A categoria app-accessibility contém pacotes que ajudam com
+ acessibilidade (por exemplo, leitores de tela).
+ </longdescription>
+ <longdescription lang="pl">
+ Kategoria app-accessibility zawiera pakiety ułatwiające dostęp do
+ komputera osobom niepełnosprawnym.
+ </longdescription>
+</catmetadata>
+
diff --git a/app-accessibility/nfbtrans/Manifest b/app-accessibility/nfbtrans/Manifest
new file mode 100644
index 00000000000..641e0e9c11f
--- /dev/null
+++ b/app-accessibility/nfbtrans/Manifest
@@ -0,0 +1 @@
+DIST nfbtr774.zip 470847 SHA256 87cad2aa875f44ad6035f5af080e02ecc23a8c3718e3e1943cb3a006c5fc93ec SHA512 58fa72c53d88d11fa005572f4e2ebd81d21afaec2fac0e986bfad66b42c194ec3573199e2f2b863725001c1cb777b60881605a1533f7eb73e31e24a244673c2c WHIRLPOOL e9bb51ac86ce3cda73b0b0e5199f68b37b8005c29deda1a154f68163eda6db564f887b234cc9184fdd7d13bbaeb93638717b2e7d40d50b16559379600ede5471
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch
new file mode 100644
index 00000000000..b44f5bc207c
--- /dev/null
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch
@@ -0,0 +1,11 @@
+--- nfbtrans.c.orig 2004-09-21 19:52:34.341784094 -0500
++++ nfbtrans.c 2004-09-21 19:54:07.005727168 -0500
+@@ -6,7 +6,7 @@
+ #define LINT_ARGS
+ #define DOS
+ #else
+-#define UNIX_PATH "/usr/local/lib/"
++#define UNIX_PATH "/etc/nfbtrans/"
+ #endif /* unix */
+ #include <stdio.h>
+ #include <sys/types.h>
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch
new file mode 100644
index 00000000000..14c13c06324
--- /dev/null
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-getline-fix.patch
@@ -0,0 +1,40 @@
+diff --git a/nfbtrans.c.orig b/nfbtrans.c
+index e697393..9a2944e 100644
+--- a/nfbtrans.c.orig
++++ b/nfbtrans.c
+@@ -534,7 +534,7 @@ void compact_line(char *);
+ void length_error(char *);
+ void do_lop_op(foptype *);
+ void do_lop(void);
+-void getline(void);
++void nfbtrans_getline(void);
+ void get_input(char *, int);
+ int get_paragraph_type(int);
+ void check_purge(void);
+@@ -2585,7 +2585,7 @@ void do_lop()
+ }
+ } /* do_lop */
+
+-void getline()
++void nfbtrans_getline()
+ {
+ int i = -1;
+ for (;;)
+@@ -2722,7 +2722,7 @@ int get_paragraph_type(int mode)
+ total_lines = 0;
+ do
+ {
+- getline();
++ nfbtrans_getline();
+ if (linein[0])
+ { /* line not empty */
+ if (prev_char == '\0')
+@@ -2874,7 +2874,7 @@ void get_word()
+ } /* head */
+ else
+ header_flag = 0;
+- getline();
++ nfbtrans_getline();
+ if (remove_page_nums)
+ remove_page_number();
+ if (auto_center)
diff --git a/app-accessibility/nfbtrans/metadata.xml b/app-accessibility/nfbtrans/metadata.xml
new file mode 100644
index 00000000000..2f0bbe44021
--- /dev/null
+++ b/app-accessibility/nfbtrans/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild b/app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild
new file mode 100644
index 00000000000..24ddfb1f2fd
--- /dev/null
+++ b/app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="braille translator from the National Federation of the Blind"
+HOMEPAGE="http://www.nfb.org/nfbtrans"
+SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr774.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=" >=app-arch/unzip-5.50-r2"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ mv MAKEFILE Makefile
+ mv SPANISH.ZIP spanish.zip
+ make lowercase || die
+ epatch "${FILESDIR}"/${P}-gentoo-fix.patch
+ epatch "${FILESDIR}"/${P}-getline-fix.patch
+}
+
+src_compile() {
+ make CC=$(tc-getCC) \
+ LIBS= \
+ CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" all || die
+}
+
+src_install() {
+ dobin nfbtrans || die
+ dodoc *fmt readme.txt makedoc
+ insinto /etc/nfbtrans
+ doins *cnf *tab *dic spell.dat *zip
+}
diff --git a/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild b/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild
new file mode 100644
index 00000000000..3fdb6c04ac6
--- /dev/null
+++ b/app-accessibility/nfbtrans/nfbtrans-7.74.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="braille translator from the National Federation of the Blind"
+HOMEPAGE="http://www.nfb.org/nfbtrans"
+SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr774.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND=" >=app-arch/unzip-5.50-r2"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ mv MAKEFILE Makefile
+ mv SPANISH.ZIP spanish.zip
+ make lowercase || die
+ epatch "${FILESDIR}"/${P}-gentoo-fix.patch
+ epatch "${FILESDIR}"/${P}-getline-fix.patch
+}
+
+src_compile() {
+ make CC=$(tc-getCC) LIBS= CFLAGS="${CFLAGS} -DLINUX" all || die
+}
+
+src_install() {
+ dobin nfbtrans || die
+ dodoc *fmt readme.txt makedoc
+ insinto /etc/nfbtrans
+ doins *cnf *tab *dic spell.dat *zip
+}
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
new file mode 100644
index 00000000000..1e055df5bd8
--- /dev/null
+++ b/app-accessibility/orca/Manifest
@@ -0,0 +1,3 @@
+DIST orca-3.14.3.tar.xz 1998804 SHA256 8258dc3174572a4bf1a266ad36df46cf5f2c5a8dc5df1a071f49f812bec2a315 SHA512 579eb592ab99a98598ce7405e180b9e8657c5b418d792f1209684bca7b309bb8e0857fd2766a39fb53835ae44f12e3447dda08402b21113e16c92bb7f60e661d WHIRLPOOL 624fc3c89ad20e734ab61160839a4d469243c587ed8c72b413ee011275e27eff73ac8ffa82f03dfa69902450c0db970b402d4b371e647298ee4b193218851e64
+DIST orca-3.14.4.tar.xz 2016596 SHA256 94a522e0a29143858be0d092346d9996e62b55fefdf4651b5edf79bcb9f4a1ef SHA512 1270c18c83817f02c0804db711915d112ff8e3b336c2dd39eb3ff5e2110393ce0afb030f82bdefb1a56acf6471107d2f237100aa22b85ac88ab04c7325cebfc8 WHIRLPOOL 298004708658a62d8fde7bb0f2ec53a7d4b64188ed663cfc5edd7d788bcc8de7f07bff5ce58ad625572692233652a251e2666640f1309d23a7ab67574cd20125
+DIST orca-3.16.2.tar.xz 2078728 SHA256 cd14b28878cc04166ec43c7d9a8e6b0056c66cbfb1e4f934f12f74568937789a SHA512 768628c4630d84929a8a2b12b73771de7b104b1754e9462b1fe63c2bbadca192e56416a1e2a43ad5f5594c91a4fe94941d2deb1e44cccaf253d4f03704f31ee1 WHIRLPOOL eea3f9a1a0b1aebb4ca3a6da1a5cf016b1ea6d042c4e8e1b7275325cd08e77c6a7c6519048651ace34ef10d69c22663e9009dab20502ff3fca7d6c6c9a888c9a
diff --git a/app-accessibility/orca/metadata.xml b/app-accessibility/orca/metadata.xml
new file mode 100644
index 00000000000..c42f2333252
--- /dev/null
+++ b/app-accessibility/orca/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-accessibility</herd>
+<use>
+ <flag name="braille">Enable braille support</flag>
+</use>
+<longdescription>
+ Orca is a flexible, extensible, and powerful assistive technology
+ for people with visual impairments. Using various combinations of
+ speech synthesis, braille, and magnification, Orca helps provide
+ access to applications and toolkits that support the AT-SPI (e.g.,
+ the GNOME desktop).
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/orca/orca-3.14.3.ebuild b/app-accessibility/orca/orca-3.14.3.ebuild
new file mode 100644
index 00000000000..5ba9662ce5e
--- /dev/null
+++ b/app-accessibility/orca/orca-3.14.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+# XXX: Check deps for correctness
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-atk-2.10:2
+ >=app-accessibility/at-spi2-core-2.10:2[introspection]
+ >=dev-libs/atk-2.10
+ >=dev-libs/glib-2.28:2
+ >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ dev-python/pyatspi[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_prepare() {
+ gnome2_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL="$(type -P true)" \
+ $(use_with braille liblouis)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+ -i src/orca/orca || die
+ python_doscript src/orca/orca
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/orca/orca-3.14.4.ebuild b/app-accessibility/orca/orca-3.14.4.ebuild
new file mode 100644
index 00000000000..792a5dd736e
--- /dev/null
+++ b/app-accessibility/orca/orca-3.14.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+# XXX: Check deps for correctness
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.10:2
+ >=app-accessibility/at-spi2-core-2.10:2[introspection]
+ >=dev-libs/atk-2.10
+ >=dev-libs/glib-2.28:2
+ >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ dev-python/pyatspi[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_prepare() {
+ gnome2_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL="$(type -P true)" \
+ $(use_with braille liblouis)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+ -i src/orca/orca || die
+ python_doscript src/orca/orca
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/orca/orca-3.16.2.ebuild b/app-accessibility/orca/orca-3.16.2.ebuild
new file mode 100644
index 00000000000..4a779289d55
--- /dev/null
+++ b/app-accessibility/orca/orca-3.16.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+# XXX: Check deps for correctness
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.10:2
+ >=app-accessibility/at-spi2-core-2.10:2[introspection]
+ >=dev-libs/atk-2.10
+ >=dev-libs/glib-2.28:2
+ >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ dev-python/pyatspi[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_prepare() {
+ gnome2_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL="$(type -P true)" \
+ $(use_with braille liblouis)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+ -i src/orca/orca || die
+ python_doscript src/orca/orca
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/perlbox-voice/Manifest b/app-accessibility/perlbox-voice/Manifest
new file mode 100644
index 00000000000..56b54ec8c20
--- /dev/null
+++ b/app-accessibility/perlbox-voice/Manifest
@@ -0,0 +1 @@
+DIST perlbox-voice-0.09.noarch.tgz 1316675 SHA256 b4f8355ffdb31d93e99bb1b9bab764d82c131ded746e36a31121bcbd5cf9e024 SHA512 db461c4b60003383cc14d25dbc6fdbc82069f588dae14434d6d29efa809c566b36c38f4311271492a9c35e965fed8fcdccf0debf06dc121c10fec460211387c6 WHIRLPOOL fff8a243e021f4c572991f2b922a7ed9ce57526da85f349d793730e6c992bd65ce36242d6b5c8a1351300e43e915ee3791bf4ef6f447d06e574df8760a2a92f7
diff --git a/app-accessibility/perlbox-voice/metadata.xml b/app-accessibility/perlbox-voice/metadata.xml
new file mode 100644
index 00000000000..32f1581eed5
--- /dev/null
+++ b/app-accessibility/perlbox-voice/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">perlbox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/perlbox-voice/perlbox-voice-0.09-r2.ebuild b/app-accessibility/perlbox-voice/perlbox-voice-0.09-r2.ebuild
new file mode 100644
index 00000000000..2da32ced108
--- /dev/null
+++ b/app-accessibility/perlbox-voice/perlbox-voice-0.09-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A voice enabled application to bring your desktop under your command"
+HOMEPAGE="http://perlbox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/perlbox/${P}.noarch.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-lang/perl
+ dev-perl/perl-tk
+ app-accessibility/sphinx2
+ app-accessibility/festival
+ app-accessibility/mbrola"
+
+src_install() {
+ tar xvf perlbox-voice.ss -C "${D}" || die "tar failed"
+ dodoc ${PN}.readme
+}
diff --git a/app-accessibility/pidgin-festival/Manifest b/app-accessibility/pidgin-festival/Manifest
new file mode 100644
index 00000000000..b4fd44bc781
--- /dev/null
+++ b/app-accessibility/pidgin-festival/Manifest
@@ -0,0 +1 @@
+DIST pidgin-festival-2.4.tar.gz 359230 SHA256 6bf71c12c30523ac39fae6bbf48f06a317377da224587431c1ec3fb1fc9baf8b SHA512 6f929e53eb3dd6b53cf18e217676f62230c016f955aa18985f186ac3c697318321a3138279bfe6d01a292b371af47d6f0759585ec57490e0fd04e7020e7abd3d WHIRLPOOL c15374b609267730452938af1dd48b8cd652b8a89dd788c94f69be66adcf9d3d0484729358f3630d4b3d8d393b2e876506362ccb096fca7e560856d04329fe25
diff --git a/app-accessibility/pidgin-festival/metadata.xml b/app-accessibility/pidgin-festival/metadata.xml
new file mode 100644
index 00000000000..84a3de50495
--- /dev/null
+++ b/app-accessibility/pidgin-festival/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge">pidgin-festival</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/pidgin-festival/pidgin-festival-2.4.ebuild b/app-accessibility/pidgin-festival/pidgin-festival-2.4.ebuild
new file mode 100644
index 00000000000..fea74e3536c
--- /dev/null
+++ b/app-accessibility/pidgin-festival/pidgin-festival-2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="A plugin for pidgin which enables text-to-speech output of conversations using festival"
+HOMEPAGE="http://sourceforge.net/projects/pidgin-festival/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-accessibility/festival
+ net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog || die
+}
diff --git a/app-accessibility/pocketsphinx/Manifest b/app-accessibility/pocketsphinx/Manifest
new file mode 100644
index 00000000000..cad3a5703cd
--- /dev/null
+++ b/app-accessibility/pocketsphinx/Manifest
@@ -0,0 +1 @@
+DIST pocketsphinx-0.8.tar.gz 23781837 SHA256 874c4c083d91c8ff26a2aec250b689e537912ff728923c141c4dac48662cce7a SHA512 b53ab8883ddbc2c66c6a6af1bac318f3cdfd5a495cb636f33eb649d42f28780b36c43dfd9a61f213d6a1b83f0fba6b114d44b38d9fa091acf62a8e529118e583 WHIRLPOOL 90078dea3bcfeca6f04fb058e9d9d42e505dc3919606ef6f392abaf91251421243a02d6892eafb1c8890ab430b6f87a81b7b0c1c5df73675a737923d384ce674
diff --git a/app-accessibility/pocketsphinx/metadata.xml b/app-accessibility/pocketsphinx/metadata.xml
new file mode 100644
index 00000000000..831e814f076
--- /dev/null
+++ b/app-accessibility/pocketsphinx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge">cmusphinx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild b/app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild
new file mode 100644
index 00000000000..a3c70ee40a9
--- /dev/null
+++ b/app-accessibility/pocketsphinx/pocketsphinx-0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+inherit eutils distutils-r1
+
+DESCRIPTION="Large open source vocabulary, speaker-independent continuous speech recognition engine"
+HOMEPAGE="https://sourceforge.net/projects/cmusphinx/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="python static-libs"
+
+RDEPEND="app-accessibility/sphinxbase
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+run_distutils() {
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_"${@}"
+ popd > /dev/null || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --without-python \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ run_distutils ${FUNCNAME}
+}
+
+src_install() {
+ default
+ run_distutils ${FUNCNAME}
+ prune_libtool_files
+}
diff --git a/app-accessibility/powiedz/Manifest b/app-accessibility/powiedz/Manifest
new file mode 100644
index 00000000000..ec394b71e21
--- /dev/null
+++ b/app-accessibility/powiedz/Manifest
@@ -0,0 +1 @@
+DIST powiedz-1.0.tgz 68672 SHA256 cd13de1b45c8dae8046b3bb522a0bbf6416d3205d74091e2995bd6c9a9834b5c SHA512 1a572ead0c6358b52ef4b5efc66dd633b2c7cb35c97bc911ce46f54fd84f626ca73b4be9951fb48688abaac4fab41f0a5087dbd89fecc91fc9e42f944e188eb3 WHIRLPOOL 2fde99fd75cfbc3ea82596aa3f43a580ea6a0c625dbf3ce78b3cb333467d36c6b56d49e5858fc4630428d0f7e5b6d0fb3810a4b3200b9d691c476d3e14ccddf8
diff --git a/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch b/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch
new file mode 100644
index 00000000000..f18761aff89
--- /dev/null
+++ b/app-accessibility/powiedz/files/powiedz-dsp-handle-fix.patch
@@ -0,0 +1,13 @@
+diff -urN aaa/powiedz/aufile.c powiedz/aufile.c
+--- aaa/powiedz/aufile.c 2003-08-30 20:57:37.000000000 +0200
++++ powiedz/aufile.c 2003-08-31 14:02:42.000000000 +0200
+@@ -217,8 +217,7 @@
+ audio_open(int samp_rate,int disp)
+ {
+ int i;
+-// esd_fd = open(dev_file, O_WRONLY | O_NDELAY);
+- esd_fd = open(audio_dsp, O_WRONLY);
++ esd_fd = open(audio_dsp, O_WRONLY | O_NDELAY);
+ if (esd_fd < 0)
+ {
+ if (disp) perror(audio_dsp);
diff --git a/app-accessibility/powiedz/files/powiedz.desktop b/app-accessibility/powiedz/files/powiedz.desktop
new file mode 100644
index 00000000000..2ea1c4820f6
--- /dev/null
+++ b/app-accessibility/powiedz/files/powiedz.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Powiedz
+Comment=Polish speak synthesizer
+Comment[pl]=Polski syntezator mowy
+Exec=powiedz
+Type=Application
+Terminal=false
+Categories=AudioVideo;Audio;
diff --git a/app-accessibility/powiedz/metadata.xml b/app-accessibility/powiedz/metadata.xml
new file mode 100644
index 00000000000..42fd1198f93
--- /dev/null
+++ b/app-accessibility/powiedz/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/app-accessibility/powiedz/powiedz-1.0-r2.ebuild b/app-accessibility/powiedz/powiedz-1.0-r2.ebuild
new file mode 100644
index 00000000000..b7c1b81df73
--- /dev/null
+++ b/app-accessibility/powiedz/powiedz-1.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Polish speech synthesizer based on rsynth"
+HOMEPAGE="http://kadu.net/index.php?page=download&lang=en"
+SRC_URI="http://kadu.net/download/additions/powiedz-1.0.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-dsp-handle-fix.patch
+}
+
+src_compile() {
+ emake -f Makefile_plain LDLIBS="-lm" CFLAGS="${CFLAGS}" DEFS="" CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin powiedz
+ domenu "${FILESDIR}"/${PN}.desktop
+}
diff --git a/app-accessibility/simon/Manifest b/app-accessibility/simon/Manifest
new file mode 100644
index 00000000000..d6f54033a45
--- /dev/null
+++ b/app-accessibility/simon/Manifest
@@ -0,0 +1,2 @@
+DIST simon-0.4.0.tar.bz2 22139378 SHA256 c7ef35cd28ecf294ceae63f4b0c53384bcf89fc2a6e67916dc9d4116decabc12 SHA512 541c22e09bb4234871707cd73e038a5ab0c68a6cb2a28993571c434edff639e4826554f922a4a188b5c2a70ff9a0d627f53af0954431b561adeedccf9c170c85 WHIRLPOOL c2e0cc8632bf089ed14ef53cae02c51166780692222b7f3c7a3583356e9669cbbcd3222507128b35f282b49de2f10a73c42f63e28596c6e8412ff766bb3febfb
+DIST simon-0.4.1.tar.bz2 23856024 SHA256 8d55bc3f607a89e15efd51b844d93daf67d9967ad243f54efae324754859342d SHA512 d7349af3ec2482f18d8407891eeea7beea75630cc85aeade9f4105e3b84e82fde6284338688bbf84824d43c68de102eb34f3c21068cbe8a3307aa0586732b30d WHIRLPOOL 4c512bdfed8676cb5cfb896eacb14c66e3497abebe97a4faeb6804feb8ba36ed9101bc79a6efa573470d4a4d7eb6dfc94e3315dac488554563d35a397a066acb
diff --git a/app-accessibility/simon/files/simon-0.4.0-libdir.patch b/app-accessibility/simon/files/simon-0.4.0-libdir.patch
new file mode 100644
index 00000000000..18e12fccfde
--- /dev/null
+++ b/app-accessibility/simon/files/simon-0.4.0-libdir.patch
@@ -0,0 +1,16 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Mar 29 22:00:19 UTC 2013
+Subject: build system
+
+make libdir modifiable
+
+--- simon-0.4.0/cmake/SimonDirs.cmake
++++ simon-0.4.0/cmake/SimonDirs.cmake
+@@ -29,6 +29,6 @@
+ #IF(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64")
+ #set(SIMON_LIB_INSTALL_DIR lib64)
+ #ELSE(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64")
+- set(SIMON_LIB_INSTALL_DIR lib)
++ set(SIMON_LIB_INSTALL_DIR lib CACHE STRING "libdir")
+ #ENDIF(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64")
+ ENDIF(WIN32)
diff --git a/app-accessibility/simon/files/simon-0.4.0-linguas.patch b/app-accessibility/simon/files/simon-0.4.0-linguas.patch
new file mode 100644
index 00000000000..bf60f16c834
--- /dev/null
+++ b/app-accessibility/simon/files/simon-0.4.0-linguas.patch
@@ -0,0 +1,84 @@
+--- simon-0.4.0/CMakeLists.txt
++++ simon-0.4.0/CMakeLists.txt
+@@ -14,6 +14,9 @@
+
+ set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
+
++# NLS
++option(ENABLE_NLS "Enable native language support" 1)
++
+ find_package(KDE4 "4.4" REQUIRED)
+ find_package(Qt4 COMPONENTS QtCore QtDbus QtGui QtTest QtXml QtScript QtConcurrent REQUIRED)
+ find_package(Qwt6 REQUIRED)
+@@ -143,4 +146,6 @@
+ macro_display_feature_log()
+
+ include(MacroOptionalAddSubdirectory)
+-macro_optional_add_subdirectory( po )
++if(ENABLE_NLS)
++ macro_optional_add_subdirectory( po )
++endif(ENABLE_NLS)
+--- simon-0.4.0/po/CMakeLists.txt
++++ simon-0.4.0/po/CMakeLists.txt
+@@ -11,24 +11,14 @@
+ if (NOT GETTEXT_MSGFMT_EXECUTABLE)
+ MESSAGE(FATAL_ERROR "Please install msgmerge binary")
+ endif (NOT GETTEXT_MSGFMT_EXECUTABLE)
+-add_subdirectory(cs)
+-add_subdirectory(de)
+-add_subdirectory(da)
+-add_subdirectory(fr)
+-add_subdirectory(nl)
+-add_subdirectory(uk)
+-add_subdirectory(pt_BR)
+-add_subdirectory(pl)
+-add_subdirectory(es)
+-add_subdirectory(ro)
+-add_subdirectory(ca)
+-add_subdirectory(sl)
+-add_subdirectory(pt)
+-add_subdirectory(hu)
+-add_subdirectory(gl)
+-add_subdirectory(sv)
+-add_subdirectory(el)
+-add_subdirectory(fi)
+-add_subdirectory(it)
+-add_subdirectory(zh_TW)
+-add_subdirectory(et)
++
++# gettext behavior
++execute_process(COMMAND sh -c "echo -n \${LINGUAS+x}"
++ OUTPUT_VARIABLE UNSETLINGUAS)
++set(langs cs de da fr nl uk pt_BR pl es ro ca sl pt hu gl sv el fi it zh_TW et)
++
++foreach(mylang ${langs})
++ if($ENV{LINGUAS} MATCHES "^.*${mylang}.*$" OR "${UNSETLINGUAS}" STREQUAL "")
++ add_subdirectory(${mylang})
++ endif()
++endforeach()
+--- simon-0.4.0/doc/CMakeLists.txt
++++ simon-0.4.0/doc/CMakeLists.txt
+@@ -1,9 +1,15 @@
++if(ENABLE_NLS)
++ # gettext behavior
++ execute_process(COMMAND sh -c "echo -n \${LINGUAS+x}"
++ OUTPUT_VARIABLE UNSETLINGUAS)
++set(langs pt_BR ca nl de it pt sv uk)
++
++ foreach(mylang ${langs})
++ if($ENV{LINGUAS} MATCHES "^.*${mylang}.*$" OR "${UNSETLINGUAS}" STREQUAL "")
++ add_subdirectory(${mylang})
++ endif()
++ endforeach()
++endif(ENABLE_NLS)
++
++# default doc
+ add_subdirectory(en_US)
+-add_subdirectory(pt_BR)
+-add_subdirectory(ca)
+-add_subdirectory(nl)
+-add_subdirectory(de)
+-add_subdirectory(it)
+-add_subdirectory(pt)
+-add_subdirectory(sv)
+-add_subdirectory(uk)
diff --git a/app-accessibility/simon/files/simon-0.4.0-opencv.patch b/app-accessibility/simon/files/simon-0.4.0-opencv.patch
new file mode 100644
index 00000000000..bdd4581ceaf
--- /dev/null
+++ b/app-accessibility/simon/files/simon-0.4.0-opencv.patch
@@ -0,0 +1,11 @@
+--- simon-0.4.0/CMakeLists.txt
++++ simon-0.4.0/CMakeLists.txt
+@@ -68,7 +68,7 @@
+ "PocketSphinx is a small-footprint continuous speech recognition system"
+ "http://cmusphinx.sourceforge.net/" FALSE ""
+ "Required to build Pocket Sphinx backend")
+-find_package(OpenCV)
++macro_optional_find_package(OpenCV)
+ macro_log_feature(OpenCV_FOUND "OpenCV"
+ "OpenCV (Open Source Computer Vision) is a library of programming functions for real time computer vision" "http://http://opencv.willowgarage.com/"
+ FALSE "" "Required for Simon Vision")
diff --git a/app-accessibility/simon/files/simon-0.4.0-sphinx.patch b/app-accessibility/simon/files/simon-0.4.0-sphinx.patch
new file mode 100644
index 00000000000..0fe8aa25efa
--- /dev/null
+++ b/app-accessibility/simon/files/simon-0.4.0-sphinx.patch
@@ -0,0 +1,16 @@
+--- simon-0.4.0/CMakeLists.txt
++++ simon-0.4.0/CMakeLists.txt
+@@ -59,11 +59,11 @@
+ macro_optional_find_package(QAccessibilityClient)
+ macro_log_feature(QAccessibilityClient_FOUND "qaccessibilityclient" "KDE client-side accessibility library" "https://projects.kde.org/projects/playground/accessibility/libkdeaccessibilityclient" FALSE "" "Required to enable ATSPI plugin.")
+
+-find_package(Sphinxbase)
++macro_optional_find_package(Sphinxbase)
+ macro_log_feature(SphinxBase_LIBRARIES "Sphinxbase"
+ "Open source toolkit for speech recognition" "http://cmusphinx.sourceforge.net/"
+ FALSE "" "Required to build Sphinx backend")
+-find_package(Pocketsphinx)
++macro_optional_find_package(Pocketsphinx)
+ macro_log_feature(POCKETSPHINX_LIBRARIES "PocketSphinx"
+ "PocketSphinx is a small-footprint continuous speech recognition system"
+ "http://cmusphinx.sourceforge.net/" FALSE ""
diff --git a/app-accessibility/simon/files/simon-0.4.1-libdir.patch b/app-accessibility/simon/files/simon-0.4.1-libdir.patch
new file mode 100644
index 00000000000..b65e4fcb143
--- /dev/null
+++ b/app-accessibility/simon/files/simon-0.4.1-libdir.patch
@@ -0,0 +1,16 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Mar 29 22:00:19 UTC 2013
+Subject: build system
+
+make libdir modifiable
+
+--- simon-0.4.1/cmake/SimonDirs.cmake
++++ simon-0.4.1/cmake/SimonDirs.cmake
+@@ -29,6 +29,6 @@
+ #IF(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64")
+ #set(SIMON_LIB_INSTALL_DIR lib64)
+ #ELSE(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64")
+- set(SIMON_LIB_INSTALL_DIR lib)
++ set(SIMON_LIB_INSTALL_DIR lib CACHE STRING "libdir")
+ #ENDIF(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64")
+ ENDIF(WIN32)
diff --git a/app-accessibility/simon/files/simon-0.4.1-linguas.patch b/app-accessibility/simon/files/simon-0.4.1-linguas.patch
new file mode 100644
index 00000000000..01f25d6550c
--- /dev/null
+++ b/app-accessibility/simon/files/simon-0.4.1-linguas.patch
@@ -0,0 +1,87 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -14,6 +14,9 @@
+
+ set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
+
++# NLS
++option(ENABLE_NLS "Enable native language support" 1)
++
+ find_package(KDE4 "4.4" REQUIRED)
+ find_package(Qt4 COMPONENTS QtCore QtDbus QtGui QtTest QtXml QtScript QtConcurrent REQUIRED)
+ find_package(Qwt6 REQUIRED)
+@@ -143,4 +146,6 @@
+ macro_display_feature_log()
+
+ include(MacroOptionalAddSubdirectory)
+-macro_optional_add_subdirectory( po )
++if(ENABLE_NLS)
++ macro_optional_add_subdirectory( po )
++endif(ENABLE_NLS)
+--- a/doc/CMakeLists.txt
++++ b/doc/CMakeLists.txt
+@@ -1,11 +1,15 @@
++if(ENABLE_NLS)
++ # gettext behavior
++ execute_process(COMMAND sh -c "echo -n \${LINGUAS+x}"
++ OUTPUT_VARIABLE UNSETLINGUAS)
++set(langs pt_BR ca nl et de it pt es sv uk)
++
++ foreach(mylang ${langs})
++ if($ENV{LINGUAS} MATCHES "^.*${mylang}.*$" OR "${UNSETLINGUAS}" STREQUAL "")
++ add_subdirectory(${mylang})
++ endif()
++ endforeach()
++endif(ENABLE_NLS)
++
++# default doc
+ add_subdirectory(en_US)
+-add_subdirectory(pt_BR)
+-add_subdirectory(ca)
+-add_subdirectory(nl)
+-add_subdirectory(et)
+-add_subdirectory(de)
+-add_subdirectory(it)
+-add_subdirectory(pt)
+-add_subdirectory(es)
+-add_subdirectory(sv)
+-add_subdirectory(uk)
+--- a/po/CMakeLists.txt
++++ b/po/CMakeLists.txt
+@@ -11,25 +11,14 @@ endif (NOT GETTEXT_MSGMERGE_EXECUTABLE)
+ if (NOT GETTEXT_MSGFMT_EXECUTABLE)
+ MESSAGE(FATAL_ERROR "Please install msgmerge binary")
+ endif (NOT GETTEXT_MSGFMT_EXECUTABLE)
+-add_subdirectory(de)
+-add_subdirectory(da)
+-add_subdirectory(fr)
+-add_subdirectory(nl)
+-add_subdirectory(uk)
+-add_subdirectory(pt_BR)
+-add_subdirectory(pl)
+-add_subdirectory(es)
+-add_subdirectory(cs)
+-add_subdirectory(ro)
+-add_subdirectory(ca)
+-add_subdirectory(sk)
+-add_subdirectory(sl)
+-add_subdirectory(pt)
+-add_subdirectory(gl)
+-add_subdirectory(ca@valencia)
+-add_subdirectory(sv)
+-add_subdirectory(el)
+-add_subdirectory(fi)
+-add_subdirectory(it)
+-add_subdirectory(zh_TW)
+-add_subdirectory(et)
++
++# gettext behavior
++execute_process(COMMAND sh -c "echo -n \${LINGUAS+x}"
++ OUTPUT_VARIABLE UNSETLINGUAS)
++set(langs ca@valencia cs de da fr nl uk pt_BR pl es ro ca sl pt gl sk sv el fi it zh_TW et)
++
++foreach(mylang ${langs})
++ if($ENV{LINGUAS} MATCHES "^.*${mylang}.*$" OR "${UNSETLINGUAS}" STREQUAL "")
++ add_subdirectory(${mylang})
++ endif()
++endforeach()
diff --git a/app-accessibility/simon/files/simon-0.4.1-sphinx.patch b/app-accessibility/simon/files/simon-0.4.1-sphinx.patch
new file mode 100644
index 00000000000..498475c81d0
--- /dev/null
+++ b/app-accessibility/simon/files/simon-0.4.1-sphinx.patch
@@ -0,0 +1,16 @@
+--- simon-0.4.1/CMakeLists.txt
++++ simon-0.4.1/CMakeLists.txt
+@@ -59,11 +59,11 @@
+ macro_optional_find_package(QAccessibilityClient)
+ macro_log_feature(QAccessibilityClient_FOUND "qaccessibilityclient" "KDE client-side accessibility library" "https://projects.kde.org/projects/playground/accessibility/libkdeaccessibilityclient" FALSE "" "Required to enable ATSPI plugin.")
+
+-find_package(Sphinxbase)
++macro_optional_find_package(Sphinxbase)
+ macro_log_feature(SphinxBase_LIBRARIES "Sphinxbase"
+ "Open source toolkit for speech recognition" "http://cmusphinx.sourceforge.net/"
+ FALSE "" "Required to build Sphinx backend")
+-find_package(Pocketsphinx)
++macro_optional_find_package(Pocketsphinx)
+ macro_log_feature(POCKETSPHINX_LIBRARIES "PocketSphinx"
+ "PocketSphinx is a small-footprint continuous speech recognition system"
+ "http://cmusphinx.sourceforge.net/" FALSE ""
diff --git a/app-accessibility/simon/metadata.xml b/app-accessibility/simon/metadata.xml
new file mode 100644
index 00000000000..29122bebc7e
--- /dev/null
+++ b/app-accessibility/simon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <use>
+ <flag name='kdepim'>Use <pkg>kde-base/kdepimlibs</pkg></flag>
+ <flag name='opencv'>Use <pkg>media-libs/opencv</pkg></flag>
+ <flag name='sphinx'>Build sphinx backend (pulls <pkg>app-accessibility/julius</pkg> if disabled</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/app-accessibility/simon/simon-0.4.0.ebuild b/app-accessibility/simon/simon-0.4.0.ebuild
new file mode 100644
index 00000000000..3a9ecade1b4
--- /dev/null
+++ b/app-accessibility/simon/simon-0.4.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# KEEP KDE ECLASSES OUT OF HERE
+
+# TODO: qaccessibilityclient support (not in portage)
+# https://projects.kde.org/projects/playground/accessibility/libkdeaccessibilityclient/repository
+# TODO: julius
+
+EAPI=5
+
+inherit eutils multilib gnome2-utils cmake-utils
+
+DESCRIPTION="Open-source speech recognition program for replacing mouse and keyboard"
+HOMEPAGE="http://simon-listens.org/"
+SRC_URI="mirror://kde/stable/simon/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="kdepim libsamplerate nls opencv sphinx"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ kde-base/kdelibs:4
+ media-libs/alsa-lib
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/qwt:6
+ kdepim? ( kde-base/kdepimlibs:4 )
+ libsamplerate? ( media-libs/libsamplerate )
+ nls? (
+ kde-apps/kde4-l10n
+ virtual/libintl
+ )
+ opencv? ( media-libs/opencv )
+ sphinx? (
+ >=app-accessibility/pocketsphinx-0.8
+ >=app-accessibility/sphinxbase-0.8
+ >=app-accessibility/SphinxTrain-1
+ )
+ !sphinx? ( app-accessibility/julius )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libdir.patch \
+ "${FILESDIR}"/${P}-linguas.patch \
+ "${FILESDIR}"/${P}-opencv.patch \
+ "${FILESDIR}"/${P}-sphinx.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSIMON_LIB_INSTALL_DIR=/usr/$(get_libdir)
+ -DBackendType=$(usex sphinx "both" "jhtk")
+ $(cmake-utils_use_with sphinx Sphinxbase)
+ $(cmake-utils_use_with sphinx Pocketsphinx)
+ $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with libsamplerate LibSampleRate)
+ $(cmake-utils_use_with opencv OpenCV)
+ $(cmake-utils_use_enable nls NLS)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "optional dependencies:"
+ elog " kde-apps/jovie (support for Jovie TTS system)"
+ use sphinx && elog " app-accessibility/julius (alternative backend)"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-accessibility/simon/simon-0.4.1.ebuild b/app-accessibility/simon/simon-0.4.1.ebuild
new file mode 100644
index 00000000000..b2b9c344428
--- /dev/null
+++ b/app-accessibility/simon/simon-0.4.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# KEEP KDE ECLASSES OUT OF HERE
+
+# TODO: qaccessibilityclient support (not in portage)
+# https://projects.kde.org/projects/playground/accessibility/libkdeaccessibilityclient/repository
+# TODO: julius
+
+EAPI=5
+
+inherit eutils multilib gnome2-utils cmake-utils
+
+DESCRIPTION="Open-source speech recognition program for replacing mouse and keyboard"
+HOMEPAGE="http://simon-listens.org/"
+SRC_URI="mirror://kde/stable/simon/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="kdepim libsamplerate nls opencv sphinx"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ kde-base/kdelibs:4
+ media-libs/alsa-lib
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/qwt:6
+ kdepim? ( kde-base/kdepimlibs:4 )
+ libsamplerate? ( media-libs/libsamplerate )
+ nls? (
+ kde-apps/kde4-l10n
+ virtual/libintl
+ )
+ opencv? ( media-libs/opencv )
+ sphinx? (
+ >=app-accessibility/pocketsphinx-0.8
+ >=app-accessibility/sphinxbase-0.8
+ >=app-accessibility/SphinxTrain-1
+ )
+ !sphinx? ( app-accessibility/julius )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libdir.patch \
+ "${FILESDIR}"/${P}-linguas.patch \
+ "${FILESDIR}"/${P}-sphinx.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSIMON_LIB_INSTALL_DIR=/usr/$(get_libdir)
+ -DBackendType=$(usex sphinx "both" "jhtk")
+ $(cmake-utils_use_with sphinx Sphinxbase)
+ $(cmake-utils_use_with sphinx Pocketsphinx)
+ $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with libsamplerate LibSampleRate)
+ $(cmake-utils_use_with opencv OpenCV)
+ $(cmake-utils_use_enable nls NLS)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "optional dependencies:"
+ elog " kde-apps/jovie (support for Jovie TTS system)"
+ use sphinx && elog " app-accessibility/julius (alternative backend)"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-accessibility/sound-icons/Manifest b/app-accessibility/sound-icons/Manifest
new file mode 100644
index 00000000000..81b11e18fe7
--- /dev/null
+++ b/app-accessibility/sound-icons/Manifest
@@ -0,0 +1 @@
+DIST sound-icons-0.1.tar.gz 591196 SHA256 382dda1d14a07b3125a8b5084695aa9ba5cb0fff02e5aab69fd6c7e23cbcf4d7 SHA512 f0ba9e1e84ace325671c7f323f01d647aa0e1a318e9adc2a6d8af4e0d795e478b2ea66007670f9c7ced9ef7310fdbccb5168b0f404579f5dff8712fe12ad93a0 WHIRLPOOL cacf8afc80819d99fed82a91ec2e82bee9f096483b7334364294bbd5c016e80f9f1fa200416f86c9dc54a8799824eaee7db1eec3c8ca0c506b7a784e2761a70e
diff --git a/app-accessibility/sound-icons/metadata.xml b/app-accessibility/sound-icons/metadata.xml
new file mode 100644
index 00000000000..04c0d89a3a6
--- /dev/null
+++ b/app-accessibility/sound-icons/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+This is a collection of sound icons which can be used by speech dispatcher.
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/sound-icons/sound-icons-0.1.ebuild b/app-accessibility/sound-icons/sound-icons-0.1.ebuild
new file mode 100644
index 00000000000..c49a2f2c88a
--- /dev/null
+++ b/app-accessibility/sound-icons/sound-icons-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="a collection of Sound Icons for speech-dispatcher"
+HOMEPAGE="http://www.freebsoft.org"
+SRC_URI="http://www.freebsoft.org/pub/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="app-accessibility/speech-dispatcher"
+
+src_compile(){
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ dodoc README
+ insinto /usr/share/sounds/sound-icons
+ doins "${S}"/*.wav
+ links="`find ${S} -type l -print`"
+ for link in $links; do
+ target=`readlink -n $link`
+ dosym $target /usr/share/sounds/sound-icons/`basename $link`
+ done
+}
diff --git a/app-accessibility/speakup/Manifest b/app-accessibility/speakup/Manifest
new file mode 100644
index 00000000000..e62a838af6b
--- /dev/null
+++ b/app-accessibility/speakup/Manifest
@@ -0,0 +1 @@
+DIST speakup-3.1.6_p201011120508.tar.bz2 128355 SHA256 29a75654d18a6b5d3067142acd6e33e6ba91453cff3101d86f4ba7af7f3e1e1b SHA512 b15245635d42dc1798734031401c644a55484c299fcc7368a80e2b1ef4c4cdea962e0d1c15bee3ef0f1dab1212bb60a0cd6124d656bf9ad46875ec1d95d8cf88 WHIRLPOOL 7e0c4a9674ac46cf432a0e3c65c291610268dc9b5345edc008ba0c4f15ad6a38c3acb0be04ce3f29e6038de56c8e8fccbe1c92b3615f9ccf572f5adb9d4062fd
diff --git a/app-accessibility/speakup/metadata.xml b/app-accessibility/speakup/metadata.xml
new file mode 100644
index 00000000000..f7b66d2f7a9
--- /dev/null
+++ b/app-accessibility/speakup/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild b/app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild
new file mode 100644
index 00000000000..4f5e7693e50
--- /dev/null
+++ b/app-accessibility/speakup/speakup-3.1.6_p201011120508.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://linux-speakup.org/speakup.git"
+ vcs=git-2
+else
+ SRC_URI="ftp://linux-speakup.org/pub/speakup/${P}.tar.bz2"
+ KEYWORDS="amd64 x86"
+fi
+
+inherit $vcs linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader"
+HOMEPAGE="http://linux-speakup.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="modules"
+
+S="${WORKDIR}/${PN}-3.1.6"
+MODULE_NAMES="speakup(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_acntpc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_acntsa(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_apollo(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_audptr(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_bns(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_decext(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_decpc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dectlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dtlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dummy(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_keypc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_ltlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_soft(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_spkout(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_txprt(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)"
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+BUILD_TARGETS="clean all"
+
+src_prepare() {
+ use modules && cmd=die || cmd=ewarn
+ if ! kernel_is 2 6 36; then
+ $cmd "This version of speakup requires kernel version 2.6.36"
+ fi
+}
+
+src_compile() {
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ use modules && linux-mod_src_install
+ dodoc Bugs.txt README To-Do
+ dodoc drivers/staging/speakup/DefaultKeyAssignments
+ dodoc drivers/staging/speakup/spkguide.txt
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}
diff --git a/app-accessibility/speakup/speakup-9999.ebuild b/app-accessibility/speakup/speakup-9999.ebuild
new file mode 100644
index 00000000000..11d7a80a69a
--- /dev/null
+++ b/app-accessibility/speakup/speakup-9999.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://linux-speakup.org/speakup.git"
+ vcs=git-2
+else
+ SRC_URI="ftp://linux-speakup.org/pub/speakup/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit $vcs linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader"
+HOMEPAGE="http://linux-speakup.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="modules"
+
+MODULE_NAMES="speakup(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_acntpc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_acntsa(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_apollo(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_audptr(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_bns(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_decext(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_decpc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dectlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dtlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_dummy(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_keypc(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_ltlk(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_soft(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_spkout(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)
+ speakup_txprt(${PN}:\"${S}\"/modules:\"${S}\"/drivers/staging/speakup)"
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+BUILD_TARGETS="clean all"
+
+src_prepare() {
+ use modules && cmd=die || cmd=ewarn
+ if kernel_is lt 2 6 36; then
+ $cmd "Speakup requires at least kernel version 2.6.36"
+ fi
+}
+
+src_compile() {
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ use modules && linux-mod_src_install
+ dodoc Bugs.txt README To-Do
+ dodoc drivers/staging/speakup/DefaultKeyAssignments
+ dodoc drivers/staging/speakup/spkguide.txt
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
new file mode 100644
index 00000000000..68a1f1baa93
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/Manifest
@@ -0,0 +1 @@
+DIST speech-dispatcher-0.8.1.tar.gz 1309969 SHA256 d25727239bbee4ee7881dd5e23e4da64a184b2ff3c8c9830088a671fb23b7757 SHA512 35f1ae547001a45d7945406ae5672829ff9ab6ac3f0cccb9eb3670dd92888a63c7cc4270ee90b5a166e6788afe3b117b5c3ef62c41a9df9f9af94dc4e0948fe8 WHIRLPOOL 945ef7ab1d771dc1e3727f223cfadfd309db03813f11fe995c0f4caf3a6f24bc9abc18e1f2f342b072bcd5fd0d626dae315f1fd0228d4172e051a2aba1255092
diff --git a/app-accessibility/speech-dispatcher/metadata.xml b/app-accessibility/speech-dispatcher/metadata.xml
new file mode 100644
index 00000000000..9c608d4058b
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="espeak">Adds support for espeak speech engine</flag>
+ <flag name="flite">Adds support for flite speech engine</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild
new file mode 100644
index 00000000000..6d5217e8d16
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_3 python3_4 )
+
+inherit eutils python-r1
+
+DESCRIPTION="Speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="alsa ao +espeak flite nas pulseaudio python static-libs"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/dotconf-1.3
+ >=dev-libs/glib-2.28:2
+ >=media-libs/libsndfile-1.0.2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ espeak? ( app-accessibility/espeak )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig"
+ RDEPEND="${COMMON_DEPEND}
+ dev-python/pyxdg"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-python
+ $(use_enable static-libs static)
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with espeak)
+ $(use_with flite)
+ $(use_with pulseaudio pulse)
+ $(use_with nas)
+ )
+ econf ${myeconfargs[@]}
+}
+
+src_compile() {
+ use python && python_copy_sources
+
+ emake
+
+ if use python; then
+ building() {
+ cd src/api/python || die
+ emake \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_foreach_impl run_in_build_dir building
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog FAQ NEWS README*
+
+ prune_libtool_files --all
+
+ if use python; then
+ installation() {
+ cd src/api/python || die
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl run_in_build_dir installation
+ python_replicate_script "${ED}"/usr/bin/spd-conf
+ fi
+}
+
+pkg_postinst() {
+ local editconfig="n"
+ if ! use espeak; then
+ ewarn "You have disabled espeak, which is speech-dispatcher's"
+ ewarn "default speech synthesizer."
+ ewarn
+ editconfig="y"
+ fi
+ if ! use pulseaudio; then
+ ewarn "You have disabled pulseaudio support."
+ ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
+ ewarn
+ editconfig="y"
+ fi
+ if [[ "${editconfig}" == "y" ]]; then
+ ewarn "You must edit ${EROOT}etc/speech-dispatcher/speechd.conf"
+ ewarn "and make sure the settings there match your system."
+ ewarn
+ fi
+ elog "For festival support, you need to"
+ elog "install app-accessibility/festival-freebsoft-utils."
+}
diff --git a/app-accessibility/speech-tools/Manifest b/app-accessibility/speech-tools/Manifest
new file mode 100644
index 00000000000..ccc686e63b3
--- /dev/null
+++ b/app-accessibility/speech-tools/Manifest
@@ -0,0 +1,2 @@
+DIST speech_tools-2.1-r3-patches.tar.gz 6876 SHA256 c37357211aa88ca6038932222f664ee332d58c553960d13ef93c489d2bb41e11 SHA512 db4d656a77e3fcfc43447c11b160cf9b45f0c4ec10f2697e4357f0ec86ea56e2841f1b887493a781406975003f5d8065ffbb75eeebb79fcd9873055b52c248e3 WHIRLPOOL a038534ab83819e5c36e74026ee510bfc279e41b6eea62e6fcb54df599a888d51e7398bd91db615e8e6cdc140b52bc99d8d7c7e52c158ce161d2a74e5909cb2c
+DIST speech_tools-2.1-release.tar.gz 1681999 SHA256 ff6167cd929a88e2f91b47191c6c4dae87c9c06ba39fccc4465af9d79e9b2be9 SHA512 6ef9a7dd01ede152c4dafd0b2037312d62a79d875813d74ea048899a52eee505b93ffbabef9b6c0a1d15aeadb5508fd18a2f392e85276847fe071173aec5db96 WHIRLPOOL 6df6ca5168462599fadf209827e367c963af5ca6be05277618c9d09aac34a3b151665b860a14fa4742482cc77246e372671ac94b23bdca63bbbb7b8c7b234644
diff --git a/app-accessibility/speech-tools/files/speech-tools-2.1-underlinking.patch b/app-accessibility/speech-tools/files/speech-tools-2.1-underlinking.patch
new file mode 100644
index 00000000000..35011735cc8
--- /dev/null
+++ b/app-accessibility/speech-tools/files/speech-tools-2.1-underlinking.patch
@@ -0,0 +1,11 @@
+--- speech_tools.orig/config/systems/GentooLinux.mak.old 2013-11-24 01:49:44.000000000 +0200
++++ speech_tools/config/systems/GentooLinux.mak 2013-11-24 13:04:14.327758435 +0200
+@@ -38,6 +38,7 @@
+ ###########################################################################
+
+ MANDIR=$(INSTALL_PREFIX)/share/man
++GENTOO_ALSA_LIBS=$(shell pkg-config --libs alsa)
+ GENTOO_CURSES_LIBS=$(shell pkg-config --libs ncurses)
+ # Gentoo does not use termcap
+-OS_LIBS = $(GENTOO_CURSES_LIBS) $(LDFLAGS) -ldl
++OS_LIBS = $(GENTOO_ALSA_LIBS) $(GENTOO_CURSES_LIBS) $(LDFLAGS) -ldl
diff --git a/app-accessibility/speech-tools/metadata.xml b/app-accessibility/speech-tools/metadata.xml
new file mode 100644
index 00000000000..3378625aa9f
--- /dev/null
+++ b/app-accessibility/speech-tools/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<herd>sound</herd>
+<maintainer>
+ <email>neurogeek@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-accessibility/speech-tools/speech-tools-2.1-r2.ebuild b/app-accessibility/speech-tools/speech-tools-2.1-r2.ebuild
new file mode 100644
index 00000000000..4bbe4bece1a
--- /dev/null
+++ b/app-accessibility/speech-tools/speech-tools-2.1-r2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+MY_P=${P/speech-/speech_}
+PATCHSET="r3"
+
+DESCRIPTION="Speech tools for Festival Text to Speech engine"
+HOMEPAGE="http://www.cstr.ed.ac.uk/projects/speech_tools/"
+SRC_URI="http://www.festvox.org/packed/festival/${PV}/${MY_P}-release.tar.gz
+ http://dev.gentoo.org/~neurogeek/${PN}/${MY_P}-${PATCHSET}-patches.tar.gz"
+
+LICENSE="FESTIVAL HPND BSD rc regexp-UofT"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="nas X"
+
+RDEPEND="
+ nas? ( media-libs/nas )
+ X? ( x11-libs/libX11
+ x11-libs/libXt )
+ >=media-libs/alsa-lib-1.0.20-r1
+ !<app-accessibility/festival-1.96_beta
+ !sys-power/powerman
+ >=sys-libs/ncurses-5.6-r2
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/speech_tools"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch"
+ epatch
+
+ sed -i -e 's,{{HORRIBLELIBARCHKLUDGE}},"/usr/$(get_libdir)",' main/siod_main.cc
+
+ #WRT bug #309983
+ sed -i -e "s:\(GCC_SYSTEM_OPTIONS =\).*:\1:" "${S}"/config/systems/sparc_SunOS5.mak
+
+ # Fix underlinking, bug #493204
+ epatch "${FILESDIR}"/${PN}-2.1-underlinking.patch
+}
+
+src_configure() {
+ local CONFIG=config/config.in
+ sed -i -e 's/@COMPILERTYPE@/gcc42/' ${CONFIG}
+ if use nas; then
+ sed -i -e "s/#.*\(INCLUDE_MODULES += NAS_AUDIO\)/\1/" ${CONFIG}
+ fi
+ if ! use X; then
+ sed -i -e "s/-lX11 -lXt//" config/modules/esd_audio.mak
+ fi
+ econf
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" CXX="$(tc-getCXX)" CXX_OTHER_FLAGS="${CXXFLAGS}" CC_OTHER_FLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dolib.so lib/libest*.so*
+
+ dodoc "${S}"/README
+ dodoc "${S}"/lib/cstrutt.dtd
+
+ insinto /usr/share/doc/${PF}
+ doins -r lib/example_data
+
+ insinto /usr/share/speech-tools
+ doins -r config base_class
+
+ insinto /usr/share/speech-tools/lib
+ doins -r lib/siod
+
+ cd include
+ insinto /usr/include/speech-tools
+ doins -r *
+ dosym /usr/include/speech-tools /usr/share/speech-tools/include
+
+ cd ../bin
+ for file in *; do
+ [ "${file}" = "Makefile" ] && continue
+ dobin ${file}
+ dstfile="${D}/usr/bin/${file}"
+ sed -i -e "s:${S}/testsuite/data:/usr/share/speech-tools/testsuite:g" ${dstfile}
+ sed -i -e "s:${S}/bin:/usr/$(get_libdir)/speech-tools:g" ${dstfile}
+ sed -i -e "s:${S}/main:/usr/$(get_libdir)/speech-tools:g" ${dstfile}
+
+ # This just changes LD_LIBRARY_PATH
+ sed -i -e "s:${S}/lib:/usr/$(get_libdir):g" ${dstfile}
+ done
+
+ cd "${S}"
+ exeinto /usr/$(get_libdir)/speech-tools
+ for file in `find main -perm +100 -type f`; do
+ doexe ${file}
+ done
+
+ #Remove /usr/bin/resynth as it is broken. See bug #253556
+ rm "${D}/usr/bin/resynth"
+}
diff --git a/app-accessibility/speech-tools/speech-tools-2.1-r3.ebuild b/app-accessibility/speech-tools/speech-tools-2.1-r3.ebuild
new file mode 100644
index 00000000000..221351e5f8f
--- /dev/null
+++ b/app-accessibility/speech-tools/speech-tools-2.1-r3.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+MY_P=${P/speech-/speech_}
+PATCHSET="r3"
+
+DESCRIPTION="Speech tools for Festival Text to Speech engine"
+HOMEPAGE="http://www.cstr.ed.ac.uk/projects/speech_tools/"
+SRC_URI="http://www.festvox.org/packed/festival/${PV}/${MY_P}-release.tar.gz
+ http://dev.gentoo.org/~neurogeek/${PN}/${MY_P}-${PATCHSET}-patches.tar.gz"
+
+LICENSE="FESTIVAL HPND BSD rc regexp-UofT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nas X"
+
+RDEPEND="
+ nas? ( media-libs/nas )
+ X? ( x11-libs/libX11
+ x11-libs/libXt )
+ >=media-libs/alsa-lib-1.0.20-r1
+ !<app-accessibility/festival-1.96_beta
+ !sys-power/powerman
+ >=sys-libs/ncurses-5.6-r2
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/speech_tools"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch"
+ epatch
+
+ sed -i -e 's,{{HORRIBLELIBARCHKLUDGE}},"/usr/$(get_libdir)",' \
+ main/siod_main.cc || die
+
+ #WRT bug #309983
+ sed -i -e "s:\(GCC_SYSTEM_OPTIONS =\).*:\1:" \
+ "${S}"/config/systems/sparc_SunOS5.mak || die
+
+ # Fix underlinking, bug #493204
+ epatch "${FILESDIR}"/${PN}-2.1-underlinking.patch
+}
+
+src_configure() {
+ local CONFIG=config/config.in
+ sed -i -e 's/@COMPILERTYPE@/gcc42/' ${CONFIG} || die
+ if use nas; then
+ sed -i -e "s/#.*\(INCLUDE_MODULES += NAS_AUDIO\)/\1/" \
+ ${CONFIG} || die
+ fi
+ if ! use X; then
+ sed -i -e "s/-lX11 -lXt//" config/modules/esd_audio.mak || die
+ fi
+ econf
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" CXX="$(tc-getCXX)" CXX_OTHER_FLAGS="${CXXFLAGS}" CC_OTHER_FLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dolib.so lib/libest*.so*
+
+ dodoc "${S}"/README
+ dodoc "${S}"/lib/cstrutt.dtd
+
+ insinto /usr/share/doc/${PF}
+ doins -r lib/example_data
+
+ insinto /usr/share/speech-tools
+ doins -r config base_class
+
+ insinto /usr/share/speech-tools/lib
+ doins -r lib/siod
+
+ cd include || die
+ insinto /usr/include/speech-tools
+ doins -r *
+ dosym /usr/include/speech-tools /usr/share/speech-tools/include
+
+ cd ../bin || die
+ for file in *; do
+ [ "${file}" = "Makefile" ] && continue
+ dobin ${file}
+ dstfile="${D}/usr/bin/${file}"
+ sed -i -e "s:${S}/testsuite/data:/usr/share/speech-tools/testsuite:g" \
+ ${dstfile} || die
+ sed -i -e "s:${S}/bin:/usr/$(get_libdir)/speech-tools:g" \
+ ${dstfile} || die
+ sed -i -e "s:${S}/main:/usr/$(get_libdir)/speech-tools:g" \
+ ${dstfile} || die
+
+ # This just changes LD_LIBRARY_PATH
+ sed -i -e "s:${S}/lib:/usr/$(get_libdir):g" ${dstfile} || die
+ done
+
+ cd "${S}" || die
+ exeinto /usr/$(get_libdir)/speech-tools
+ for file in `find main -perm /111 -type f`; do
+ doexe ${file}
+ done
+
+ #Remove /usr/bin/resynth as it is broken. See bug #253556
+ rm "${D}/usr/bin/resynth" || die
+
+ # Remove bcat (only useful for testing on windows, see bug #418301).
+ rm "${D}/usr/bin/bcat" || die
+ rm "${D}/usr/$(get_libdir)/speech-tools/bcat" || die
+}
diff --git a/app-accessibility/speechd-el/Manifest b/app-accessibility/speechd-el/Manifest
new file mode 100644
index 00000000000..35e398d6335
--- /dev/null
+++ b/app-accessibility/speechd-el/Manifest
@@ -0,0 +1 @@
+DIST speechd-el-2.5.tar.gz 183278 SHA256 1ec52b27248e1c68d3ac37bee78842f3e124dc78e63891a1b706519349e4824e SHA512 b4e5d00d3a86be9c42172ab48c5b0c0f5f25817cb542302f04e29f594422247e4b008428dfaaa1bb2e208a71f126b9c86d25186974606bf5764212a0d6a1a09f WHIRLPOOL 3063e34e19e239653455ebe51bbc0e2e8630c21d5bd2342a24e39c1c8d6a831bb595165611cfa9b441fb6e9ccab50d956b81e63bb4235a86a03464812ffbe4ac
diff --git a/app-accessibility/speechd-el/metadata.xml b/app-accessibility/speechd-el/metadata.xml
new file mode 100644
index 00000000000..dc145bb72d0
--- /dev/null
+++ b/app-accessibility/speechd-el/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<herd>emacs</herd>
+<maintainer>
+<email>williamh@gentoo.org</email>
+</maintainer>
+ <use>
+ <flag name="brltty">brltty support</flag>
+</use>
+</pkgmetadata>
diff --git a/app-accessibility/speechd-el/speechd-el-2.5.ebuild b/app-accessibility/speechd-el/speechd-el-2.5.ebuild
new file mode 100644
index 00000000000..0936ee27567
--- /dev/null
+++ b/app-accessibility/speechd-el/speechd-el-2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit elisp
+
+DESCRIPTION="Emacs speech support"
+HOMEPAGE="http://www.freebsoft.org/speechd-el"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd-el/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="brltty"
+
+DEPEND=""
+RDEPEND=">=app-accessibility/speech-dispatcher-0.7
+ brltty? ( app-accessibility/brltty )"
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ dobin speechd-log-extractor
+ dodoc ANNOUNCE NEWS README speechd-speak.pdf
+ doinfo speechd-el.info
+}
+
+pkg_postinst() {
+ elog "Execute the following commands from within emacs to get it to speak:"
+ elog " M-x load-library RET speechd-speak RET"
+ elog " M-x speechd-speak RET"
+ elog
+ elog "or add the following to your ~/.emacs file:"
+ elog
+ elog "(autoload 'speechd-speak \"speechd-speak\" nil t)"
+ elog '(speechd-speak)'
+}
diff --git a/app-accessibility/speechd-up/Manifest b/app-accessibility/speechd-up/Manifest
new file mode 100644
index 00000000000..9c72956a627
--- /dev/null
+++ b/app-accessibility/speechd-up/Manifest
@@ -0,0 +1 @@
+DIST speechd-up-0.4.tar.gz 395659 SHA256 03ebc5c05eedebbeb86c561a4708b90deecacfeb7aecd4a8b93ea3b3419d202a SHA512 17f67049e9dbd6986b1e068b6ebb9baf250990d6b3d41e7f5c5f887051e876d48972fe7881d309696c8ed57093297a9a1479046ae97da2428615d566ce51d383 WHIRLPOOL cd42a0b6c2eb9c2746c47f7a8564ccf55e033857886528bbc67d7e40fa1dc5031cf1323b791fc2fc7defea092dd2a36e15c7bb05f0c083573b7ba85769f8c0b9
diff --git a/app-accessibility/speechd-up/files/speechd-up.confd b/app-accessibility/speechd-up/files/speechd-up.confd
new file mode 100644
index 00000000000..2808a6c1b80
--- /dev/null
+++ b/app-accessibility/speechd-up/files/speechd-up.confd
@@ -0,0 +1,6 @@
+# /etc/conf.d/speechd-up: config file for /etc/init.d/speechd-up
+
+# Niceness level at which to run speechd-up
+
+NICELEVEL=-5
+
diff --git a/app-accessibility/speechd-up/files/speechd-up.rc b/app-accessibility/speechd-up/files/speechd-up.rc
new file mode 100644
index 00000000000..76a58506e1d
--- /dev/null
+++ b/app-accessibility/speechd-up/files/speechd-up.rc
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+SPEAKUPDEV=/dev/softsynth
+SPEAKUPDIR=/sys/module/speakup/parameters
+
+depend() {
+ use eflite festival
+ need speech-dispatcher
+}
+
+check_speakup() {
+ if [ ! -d ${SPEAKUPDIR} ]; then
+ eerror "Speakup is not currently running."
+ eerror "Please correct this before using speechd-up."
+ return 1
+ fi
+
+ if [ ! -c ${SPEAKUPDEV} ]; then
+ mknod ${SPEAKUPDEV} c 10 26
+ fi
+ echo soft > ${SPEAKUPDIR}/synth
+ sleep 1
+}
+
+start() {
+ check_speakup || return 1
+ ebegin "Starting speechd-up"
+ start-stop-daemon --start --quiet --nicelevel ${NICELEVEL} --exec /usr/bin/speechd-up -- -d -t
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping speechd-up"
+ start-stop-daemon --stop --quiet --pidfile /var/run/speechd-up.pid
+ eend $?
+}
diff --git a/app-accessibility/speechd-up/metadata.xml b/app-accessibility/speechd-up/metadata.xml
new file mode 100644
index 00000000000..1212c466038
--- /dev/null
+++ b/app-accessibility/speechd-up/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+<email>williamh@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-accessibility/speechd-up/speechd-up-0.4-r3.ebuild b/app-accessibility/speechd-up/speechd-up-0.4-r3.ebuild
new file mode 100644
index 00000000000..26494f4456b
--- /dev/null
+++ b/app-accessibility/speechd-up/speechd-up-0.4-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE=""
+
+inherit eutils
+
+DESCRIPTION="Interface between speakup and speech-dispatcher"
+HOMEPAGE="http://www.freebsoft.org/speechd-up"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd-up/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+DEPEND=">=app-accessibility/speech-dispatcher-0.6"
+RDEPEND="${DEPEND}
+ >=app-accessibility/speakup-3.0.2"
+
+src_compile() {
+ econf || die
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ newinitd "${FILESDIR}"/speechd-up.rc speechd-up
+ newconfd "${FILESDIR}"/speechd-up.confd speechd-up
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ doinfo speechd-up.info
+}
diff --git a/app-accessibility/sphinx2/Manifest b/app-accessibility/sphinx2/Manifest
new file mode 100644
index 00000000000..1753629e379
--- /dev/null
+++ b/app-accessibility/sphinx2/Manifest
@@ -0,0 +1 @@
+DIST sphinx2-0.6.tar.gz 6883359 SHA256 af533d804906706eaeb80170b4222b293ed914b0b95b473334b5d2dba4bb0b65 SHA512 98e66cedf8a147aee7871df85ee45f58ab76637d26163cbb30ee9554638b503f52c9b14f4f3b64bbb49bb84282e399451a0f9a8622b6e7e545889773d72ba5d4 WHIRLPOOL 34cd1d2a3b279ce496d11ffaf7f6ec7452da5a394b545348fbf3e203ccd1b26003a875288985cbf3189ec6f082f3a51deee6798752f926f8864507f9134fbbb6
diff --git a/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch b/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch
new file mode 100644
index 00000000000..0520d4d987e
--- /dev/null
+++ b/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch
@@ -0,0 +1,25 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 05a4f8a..23d0309 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,5 +1,5 @@
+-SUBDIRS = libsphinx2 \
+- libsphinx2fe \
++SUBDIRS = libsphinx2fe \
+ libsphinx2ad \
++ libsphinx2 \
+ examples
+
+diff --git a/src/libsphinx2/Makefile.am b/src/libsphinx2/Makefile.am
+index 66f0ac3..537381c 100644
+--- a/src/libsphinx2/Makefile.am
++++ b/src/libsphinx2/Makefile.am
+@@ -88,7 +88,7 @@ libsphinx2_la_SOURCES = \
+ word_fsg.c
+
+
+-# libsphinx2_la_LIBADD = -lc -lm $(top_srcdir)/src/libsphinx2fe/libsphinx2fe.la
++libsphinx2_la_LIBADD = -lc -lm $(top_srcdir)/src/libsphinx2fe/libsphinx2fe.la
+
+ # hjf@cs.brown.edu - Added for Solaris build
+ # LDADD = -L/usr/demo/SOUND/lib/ -laudio
diff --git a/app-accessibility/sphinx2/metadata.xml b/app-accessibility/sphinx2/metadata.xml
new file mode 100644
index 00000000000..a5e5fcc4902
--- /dev/null
+++ b/app-accessibility/sphinx2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">cmusphinx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/sphinx2/sphinx2-0.6.ebuild b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
new file mode 100644
index 00000000000..d9526356838
--- /dev/null
+++ b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools eutils
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="CMU Speech Recognition-engine"
+HOMEPAGE="http://fife.speech.cs.cmu.edu/sphinx/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README doc/README.bin doc/README.lib doc/SCHMM_format doc/filler.dict doc/phoneset doc/phoneset-old
+ dohtml doc/phoneset_s2.html doc/sphinx2.html
+}
diff --git a/app-accessibility/sphinx3/Manifest b/app-accessibility/sphinx3/Manifest
new file mode 100644
index 00000000000..dfce8a07196
--- /dev/null
+++ b/app-accessibility/sphinx3/Manifest
@@ -0,0 +1,2 @@
+DIST sphinx3-0.6.3.tar.gz 26070353 SHA256 f6a070a67d91ccd00dbce7b6cc55242ed7a5ebaae6d6429eb0364657c4056ede SHA512 2f784459a18692594c0834dac1ee814eb663cca1e4b2906d31915f1e518efc83e760f5ae1a15d3b274a8e8e0ffbc43e56bb338f098a8abc304429b4d8262c11e WHIRLPOOL 4ba83a919a57f2c80450fe9b110179403e7e02adc930e749f7c331d393e71ce798cf194a768db7a735a9bc9879bd31294e471f34abc89ab8caa9bde404d2a84f
+DIST sphinx3-0.8.tar.gz 25226326 SHA256 1cf76a086f9b509e35f7226df2e61b0a0bf8b0858b9676e5b18cfc47b2ea2741 SHA512 85b8e574e2f92a758c8c56ef11b873c49ef8a376e964f30a12d75850d4a0db56e3108eaea25fa5587675ef2ffa4531a13f0f182a85cc8e434c6bcee42058e050 WHIRLPOOL 0f3604b4fa320f59e4ee65b79c4a779c48f2822a944b28b85a740826244f5eb7adc072538919c97ebf4eb270660fbe6f5b30b55cc67ec6276358063cf340aa7b
diff --git a/app-accessibility/sphinx3/files/sphinx3-0.8-libutil.patch b/app-accessibility/sphinx3/files/sphinx3-0.8-libutil.patch
new file mode 100644
index 00000000000..0f7733154a5
--- /dev/null
+++ b/app-accessibility/sphinx3/files/sphinx3-0.8-libutil.patch
@@ -0,0 +1,18 @@
+--- src/libs3decoder/libsearch/fsg_history.c
++++ src/libs3decoder/libsearch/fsg_history.c
+@@ -55,7 +55,6 @@
+ #include <kb.h>
+ /*#include <phone.h>*/
+ #include <search.h>
+-#include "libutil.h"
+
+
+ #define __FSG_DBG__ 0
+--- src/libs3decoder/libcfg/s3_cfg_convert.c
++++ src/libs3decoder/libcfg/s3_cfg_convert.c
+@@ -1,5 +1,4 @@
+
+-#include <libutil.h>
+ #include "s3_cfg.h"
+ #include "fsg.h"
+
diff --git a/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch b/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch
new file mode 100644
index 00000000000..b7b71d97441
--- /dev/null
+++ b/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch
@@ -0,0 +1,34 @@
+diff -uNr sphinx3-0.8.orig/python/setup.py sphinx3-0.8/python/setup.py
+--- sphinx3-0.8.orig/python/setup.py 2008-12-31 23:20:08.000000000 -0500
++++ sphinx3-0.8/python/setup.py 2011-11-17 09:46:57.000000000 -0500
+@@ -8,15 +8,10 @@
+ define_macros = []
+
+ module = Extension('_sphinx3',
+- include_dirs = ['../../sphinxbase/include',
+- '../include',
+- '/usr/local/include/sphinxbase/',
+- '/usr/local/include/sphinx3',
+- ],
++ include_dirs = ['../include',
++ '@GENTOO_PORTAGE_EPREFIX@/usr/include/sphinxbase'],
+ define_macros = define_macros,
+- library_dirs = ['../../sphinxbase/src/libsphinxbase/.libs',
+- '../src/libs3decoder/.libs',
+- '../../sphinxbase/lib/debug',
++ library_dirs = ['../src/libs3decoder/.libs',
+ '../lib/debug',
+ ],
+ libraries = ['sphinxbase', 's3decoder'],
+diff -uNr sphinx3-0.8.orig/src/libs3decoder/libsearch/vithist.c sphinx3-0.8/src/libs3decoder/libsearch/vithist.c
+--- sphinx3-0.8.orig/src/libs3decoder/libsearch/vithist.c 2008-12-31 13:27:56.000000000 -0500
++++ sphinx3-0.8/src/libs3decoder/libsearch/vithist.c 2011-11-17 09:46:24.000000000 -0500
+@@ -647,7 +647,7 @@
+ {
+ int32 se, fe, filler_done, th;
+ vithist_entry_t *ve;
+- heap_t h;
++ heap_t *h;
+ s3wid_t *wid;
+ int32 i;
+
diff --git a/app-accessibility/sphinx3/metadata.xml b/app-accessibility/sphinx3/metadata.xml
new file mode 100644
index 00000000000..831e814f076
--- /dev/null
+++ b/app-accessibility/sphinx3/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge">cmusphinx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/sphinx3/sphinx3-0.6.3.ebuild b/app-accessibility/sphinx3/sphinx3-0.6.3.ebuild
new file mode 100644
index 00000000000..6532801bb45
--- /dev/null
+++ b/app-accessibility/sphinx3/sphinx3-0.6.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="CMU Speech Recognition engine"
+HOMEPAGE="http://fife.speech.cs.cmu.edu/sphinx/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${PV:0:3}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+ cd doc
+ dohtml -r -x CVS s3* s3 *.html
+}
diff --git a/app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild b/app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild
new file mode 100644
index 00000000000..9d8850a100e
--- /dev/null
+++ b/app-accessibility/sphinx3/sphinx3-0.8-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# disable automatic phase exports and deps
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils distutils-r1 prefix eutils
+
+DESCRIPTION="CMU Speech Recognition engine"
+HOMEPAGE="http://cmusphinx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc python static-libs"
+
+RDEPEND=">=app-accessibility/sphinxbase-0.7[static-libs?,python?,${PYTHON_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Due to generated Python setup.py.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_heap_fix.patch" \
+ "${FILESDIR}/${P}-libutil.patch"
+ eprefixify 'python/setup.py'
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README )
+ autotools-utils_src_install
+
+ if use doc; then
+ cd doc || die
+ dohtml -r -x CVS s3* s3 *.html
+ fi
+
+ if use python; then
+ unset DOCS
+
+ cd "${S}"/python || die
+ distutils-r1_src_install
+ fi
+}
diff --git a/app-accessibility/sphinxbase/Manifest b/app-accessibility/sphinxbase/Manifest
new file mode 100644
index 00000000000..406639fcff0
--- /dev/null
+++ b/app-accessibility/sphinxbase/Manifest
@@ -0,0 +1 @@
+DIST sphinxbase-0.8.tar.gz 3313197 SHA256 55708944872bab1015b8ae07b379bf463764f469163a8fd114cbb16c5e486ca8 SHA512 fdb13c07e591e868c395d5f8209ec389fb9d5a93d99104a00cb82382e84d320091ae7e74d53225706331d4959ab5e248fa622582a148bfdb6ab5c38470d1963c WHIRLPOOL df050d547a263954574902ce08d966a184d428ea5ec700128fde2fee5d78f948a5920e2b92540f052e4a1d6ac208b388350d7ad66c0548ee945f99ceab0f0a0c
diff --git a/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch b/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch
new file mode 100644
index 00000000000..11031918ee6
--- /dev/null
+++ b/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch
@@ -0,0 +1,25 @@
+diff -Naur sphinxbase-0.8/test/regression/Makefile.am sphinxbase-0.8.new/test/regression/Makefile.am
+--- sphinxbase-0.8/test/regression/Makefile.am 2012-12-05 06:05:39.000000000 -0800
++++ sphinxbase-0.8.new/test/regression/Makefile.am 2013-10-08 13:05:15.498853962 -0700
+@@ -33,9 +33,19 @@
+
+ # Disable sphinx_fe tests for now if fixed-point due to imprecision
+ if FIXED_POINT
+-TESTS = $(srcdir)/test-cepview.sh $(srcdir)/test-sphinx_pitch.sh
++TESTS = test-cepview.sh test-sphinx_pitch.sh
+ else
+-TESTS = $(srcdir)/test-*.sh
++TESTS = \
++ test-cepview.sh \
++ test-sphinx_fe-ctl.sh \
++ test-sphinx_fe-dct.sh \
++ test-sphinx_fe-dither-seed.sh \
++ test-sphinx_fe-logspec2cep.sh \
++ test-sphinx_fe-logspec.sh \
++ test-sphinx_fe.sh \
++ test-sphinx_fe-smoothspec.sh \
++ test-sphinx_jsgf2fsg.sh \
++ test-sphinx_pitch.sh
+ endif
+
+ EXTRA_DIST += $(TESTS)
diff --git a/app-accessibility/sphinxbase/files/sphinxbase-0.8-unbundle-lapack.patch b/app-accessibility/sphinxbase/files/sphinxbase-0.8-unbundle-lapack.patch
new file mode 100644
index 00000000000..70beae05de7
--- /dev/null
+++ b/app-accessibility/sphinxbase/files/sphinxbase-0.8-unbundle-lapack.patch
@@ -0,0 +1,85 @@
+ configure.in | 40 +++++++++++++++++++++-------------------
+ src/libsphinxbase/Makefile.am | 1 +
+ 2 files changed, 22 insertions(+), 19 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index e10629c..b5d6ea9 100644
+--- a/configure.in
++++ b/configure.in
+@@ -62,13 +62,15 @@ if test x$withval = xno; then
+ use_lapack=false
+ fi
+ ])
+-if test x$use_lapack = xtrue; then
+- AC_CHECK_LIB(lapack, sgesv_,,use_internal_lapack=true)
+- if test x$use_internal_lapack != xtrue; then
+- AC_CHECK_LIB(blas, sgemm_,,use_internal_lapack=true)
+- fi
++AS_IF([test "x$with_lapack" = "xyes"], [
++ PKG_CHECK_MODULES([LAPACK], [lapack],,
++ AC_CHECK_LIB(lapack, sgesv_,,use_internal_lapack=true))
++ AS_IF([test "x$use_internal_lapack" != "xtrue"], [
++ PKG_CHECK_MODULES([BLAS], [blas],,
++ AC_CHECK_LIB(blas, sgemm_,,use_internal_lapack=true))
++ ])
+ AC_DEFINE(WITH_LAPACK, [], [Enable matrix algebra with LAPACK])
+-fi
++])
+ AM_CONDITIONAL(LAPACK_LITE, test x$use_internal_lapack = xtrue)
+ AM_CONDITIONAL(USE_LAPACK, test x$use_lapack = xtrue)
+
+@@ -208,9 +210,15 @@ AM_PROG_LIBTOOL
+ dnl
+ dnl Check for Doxygen, and build dox if present
+ dnl
+-AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, yes, no)
++AC_ARG_ENABLE([doc],
++ AS_HELP_STRING([--enable-doc], [Build docs using doxygen]))
++AS_IF([test "x$enable_doc" = "xyes"], [
++ AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, yes, no)
++ AS_IF([test "x$HAVE_DOXYGEN" != "xyes"], [
++ AC_MSG_ERROR([--enable-doc given, but doxygen not found.]); exit 1
++ ])
++])
+ AM_CONDITIONAL(BUILD_DOXYGEN, test "x$HAVE_DOXYGEN" = "xyes")
+-
+ dnl
+ dnl Check for Python, and build python module if present
+ dnl
+@@ -260,19 +268,13 @@ fi
+ AM_CONDITIONAL(BUILD_CYTHON, test "x$HAVE_CYTHON" = "xyes")
+
+ dnl
+-dnl Check for pkgconfig
+-dnl
+-AC_CHECK_PROG(HAVE_PKGCONFIG, pkg-config, yes, no)
+-
+-dnl
+ dnl Check for libsndfile
+ dnl
+-if test "x$HAVE_PKGCONFIG" = "xyes"; then
+- PKG_CHECK_MODULES(SNDFILE,sndfile,,true)
+- AC_CHECK_HEADERS([sndfile.h])
+- PKG_CHECK_MODULES(SAMPLERATE,samplerate,,true)
+- AC_CHECK_HEADERS([samplerate.h])
+-fi
++PKG_CHECK_MODULES(SNDFILE,sndfile,,true)
++AC_CHECK_HEADERS([sndfile.h])
++PKG_CHECK_MODULES(SAMPLERATE,samplerate,,true)
++AC_CHECK_HEADERS([samplerate.h])
++
+ AC_SUBST(SNDFILE_LIBS)
+ AC_SUBST(SNDFILE_CFLAGS)
+ AC_SUBST(SAMPLERATE_LIBS)
+diff --git a/src/libsphinxbase/Makefile.am b/src/libsphinxbase/Makefile.am
+index 52ee3e1..f4efd8a 100644
+--- a/src/libsphinxbase/Makefile.am
++++ b/src/libsphinxbase/Makefile.am
+@@ -8,6 +8,7 @@ libsphinxbase_la_SOURCES =
+ # This is API version 2, software release 1, which also supports API version 1
+ libsphinxbase_la_LDFLAGS = -version-info 2:1:1
+ libsphinxbase_la_LIBADD = $(LTLIBICONV) \
++ @LAPACK_LIBS@ \
+ util/libsphinxutil.la \
+ fe/libsphinxfe.la \
+ feat/libsphinxfeat.la \
diff --git a/app-accessibility/sphinxbase/metadata.xml b/app-accessibility/sphinxbase/metadata.xml
new file mode 100644
index 00000000000..d72ef0fd2aa
--- /dev/null
+++ b/app-accessibility/sphinxbase/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge">cmusphinx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild b/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild
new file mode 100644
index 00000000000..44181ce3613
--- /dev/null
+++ b/app-accessibility/sphinxbase/sphinxbase-0.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils distutils-r1
+
+DESCRIPTION="Support library required by the Sphinx Speech Recognition Engine"
+HOMEPAGE="http://cmusphinx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD-2 HPND MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc lapack python static-libs"
+
+# automagic dep on pulseaudio
+RDEPEND="
+ media-sound/pulseaudio
+ lapack? ( virtual/lapack )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.4.7 )"
+
+# Due to generated Python setup.py.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${P}-unbundle-lapack.patch
+ "${FILESDIR}"/${P}-automake113.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with lapack)
+ $(use_enable doc)
+ # python modules are built through distutils
+ # so disable the ugly wrapper
+ --without-python
+ )
+ autotools-utils_src_configure
+}
+
+run_distutils() {
+ if use python; then
+ pushd python > /dev/null || die
+ distutils-r1_"${@}"
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ run_distutils ${FUNCNAME}
+}
+
+python_test() {
+ LD_LIBRARY_PATH="${S}"/src/lib${PN}/.libs \
+ "${PYTHON}" sb_test.py || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ autotools-utils_src_test
+
+ run_distutils ${FUNCNAME}
+}
+
+src_install() {
+ run_distutils ${FUNCNAME}
+
+ use doc && local HTML_DOCS=( doc/html/. )
+ autotools-utils_src_install
+}
diff --git a/app-accessibility/yasr/Manifest b/app-accessibility/yasr/Manifest
new file mode 100644
index 00000000000..4a8f0d1ac2b
--- /dev/null
+++ b/app-accessibility/yasr/Manifest
@@ -0,0 +1 @@
+DIST yasr-0.6.9.tar.gz 235768 SHA256 41f17cfab8e88824a8dc1476602a0944b9030a8f8da2538a7a6549e3534e3bdf SHA512 107af558fce20bd79b81d68915032e511aa44df33a37b82ee2e82fb0d60ee14759d9b4dfe8634fdf1926c8b5c57e89aad1966e2dba243b725e72f783fe123df4 WHIRLPOOL f8db1799ab82f6373750b1e72486fd995e33da0d55e866dbc9df4fc475588e82f04015a1668ccaad4c6b3c664bf155420a37ab4ecc8b48fa1419010689f57e2c
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch b/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch
new file mode 100644
index 00000000000..2fbc32c2e98
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch
@@ -0,0 +1,17 @@
+diff --git a/configure.in b/configure.in
+index d78e8b2..15e8666 100644
+--- a/configure.in
++++ b/configure.in
+@@ -2,11 +2,10 @@ dnl Process this file with autoconf to produce a configure script.
+
+ AC_INIT(yasr, 0.6.9, mgorse@alum.wpi.edu)
+ AM_INIT_AUTOMAKE()
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ AC_ISC_POSIX
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AC_HEADER_STDC
+ AC_PROG_INSTALL
+ dnl Checks for libraries.
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-gcc43.patch b/app-accessibility/yasr/files/yasr-0.6.9-gcc43.patch
new file mode 100644
index 00000000000..ee2b1a6ef7b
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-gcc43.patch
@@ -0,0 +1,26 @@
+diff -NrU5 yasr-0.6.9.orig/yasr/yasr.h yasr-0.6.9/yasr/yasr.h
+--- yasr-0.6.9.orig/yasr/yasr.h 2008-06-29 01:23:44.000000000 +0200
++++ yasr-0.6.9/yasr/yasr.h 2008-06-29 01:37:00.000000000 +0200
+@@ -306,22 +306,10 @@
+ extern void opt_say(int num, int flag);
+ extern void opt_set(int num, void *val);
+ extern void opt_queue_empty(int ll);
+ extern void opt_write(FILE * fp);
+
+-/* openpty.c prototypes */
+-extern int openpty(int *, int *, char *, struct termios *, struct winsize *);
+-
+-/* cfmakeraw.c prototypes */
+-extern void cfmakeraw(struct termios *);
+-
+-/* login_tty.c prototypes */
+-extern int login_tty(int);
+-
+-/* forkpty.c prototypes */
+-extern int forkpty(int *, char *, struct termios *, struct winsize *);
+-
+ /* tbc - Would it be more efficient to ensure that "blank" grids always held
+ ascii 0x20 rather than ascii 0x00? */
+ #define y_isblank(ch) ((ch & 0xdf) == 0)
+ #define cblank(r, c) ((win->row[r][c] & 0xdf) == 0)
+ #define ttssend(x) if (x) tts_send(x, strlen(x))
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch b/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch
new file mode 100644
index 00000000000..26337dbc673
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.in b/configure.in
+index c26f577..d78e8b2 100644
+--- a/configure.in
++++ b/configure.in
+@@ -57,7 +57,7 @@ fi
+ changequote([,])dnl
+
+ AM_GNU_GETTEXT(external)
+-AM_GNU_GETTEXT_VERSION([0.17])
++AM_GNU_GETTEXT_VERSION([0.18.1])
+
+ AC_OUTPUT([ m4/Makefile
+ Makefile
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-remove-m4.patch b/app-accessibility/yasr/files/yasr-0.6.9-remove-m4.patch
new file mode 100644
index 00000000000..fa05f0791fc
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-remove-m4.patch
@@ -0,0 +1,29 @@
+diff -Naur yasr-0.6.9.orig/Makefile.am yasr-0.6.9/Makefile.am
+--- yasr-0.6.9.orig/Makefile.am 2008-02-02 06:44:05.000000000 -0600
++++ yasr-0.6.9/Makefile.am 2009-02-06 08:37:07.000000000 -0600
+@@ -7,7 +7,6 @@
+
+ SUBDIRS = \
+ $(yasr_DDIRS) \
+-m4 \
+ po
+
+ pkgdata_DATA = \
+@@ -25,4 +24,3 @@
+ README-fr \
+ README-ru
+
+-ACLOCAL_AMFLAGS = -I m4
+diff -Naur yasr-0.6.9.orig/configure.in yasr-0.6.9/configure.in
+--- yasr-0.6.9.orig/configure.in 2008-02-02 07:09:04.000000000 -0600
++++ yasr-0.6.9/configure.in 2009-02-06 08:36:43.000000000 -0600
+@@ -59,8 +59,7 @@
+ AM_GNU_GETTEXT(external)
+ AM_GNU_GETTEXT_VERSION([0.17])
+
+-AC_OUTPUT([ m4/Makefile
+-Makefile
++AC_OUTPUT([ Makefile
+ yasr/Makefile
+ acclogin/Makefile
+ po/Makefile.in
diff --git a/app-accessibility/yasr/metadata.xml b/app-accessibility/yasr/metadata.xml
new file mode 100644
index 00000000000..6e084ef1667
--- /dev/null
+++ b/app-accessibility/yasr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge">yasr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
new file mode 100644
index 00000000000..e54176e6c93
--- /dev/null
+++ b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="general-purpose console screen reader"
+HOMEPAGE="http://yasr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ local x=/usr/share/gettext/po/Makefile.in.in
+ [[ -e $x ]] && cp -f $x po/ #330879
+
+ epatch "${FILESDIR}"/${P}-automake113.patch \
+ "${FILESDIR}"/${P}-gettext018.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-remove-m4.patch
+
+ rm -r "${S}"/m4
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir=/etc \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README ChangeLog AUTHORS BUGS CREDITS
+ dosed \
+ 's:^\(synthesizer=emacspeak server\):#\1:
+ s:^\(synthesizer port=|/usr/local/bin/eflite\):#\1:
+ s:^#\(synthesizer=speech dispatcher\):\1:
+ s:^#\(synthesizer port=127.0.0.1.6560\):\1:' /etc/yasr/yasr.conf
+}
+
+pkg_postinst() {
+ elog
+ elog "Speech-dispatcher is configured as the default synthesizer for yasr."
+ elog "If this is not what you want, edit /etc/yasr/yasr.conf."
+}