summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-16 22:19:57 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-16 22:55:39 +0100
commita40b4121d2933b19cc2ec1346f59101d39c871e6 (patch)
treee6a8790b07236ab361676d96350dfea336b9cd0d /app-accessibility
parentsci-geosciences/geocode-glib: Uses libsoup instead of libsoup-gnome (diff)
downloadgentoo-a40b4121d2933b19cc2ec1346f59101d39c871e6.tar.gz
gentoo-a40b4121d2933b19cc2ec1346f59101d39c871e6.tar.bz2
gentoo-a40b4121d2933b19cc2ec1346f59101d39c871e6.zip
app-accessibility/at-spi2-atk: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-atk/Manifest1
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.18.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-atk/Manifest b/app-accessibility/at-spi2-atk/Manifest
index 881c14eadea9..b21b46c32814 100644
--- a/app-accessibility/at-spi2-atk/Manifest
+++ b/app-accessibility/at-spi2-atk/Manifest
@@ -1,3 +1,4 @@
DIST at-spi2-atk-2.12.1.tar.xz 280568 SHA256 5fa9c527bdec028e06797563cd52d49bcf06f638549df983424d88db89bb1336 SHA512 a7fc3cbc3665741ea6cee716cc68467ed110c0f6425fe418ea0f1b702931e4a07306e48264e9cd160d98c5bf762f076cad66ff2e46690af226ce33146d11aee2 WHIRLPOOL dc84563059d24ae56029989853d9e5a9a8cca5eecbed1227c4e36cd760aed4035beefbb71668221646cbd03057f1e30e44128081e2a6b32cfe48baabf4a631e5
DIST at-spi2-atk-2.14.1.tar.xz 280952 SHA256 058f34ea60edf0a5f831c9f2bdd280fe95c1bcafb76e466e44aa0fb356d17bcb SHA512 1daee942d3c477444aaa42fb6ede6d821ff9b613f0686dd4a545406c97ceb819a3544419e0cb5d2e661f3a1b6fc92af9394801f3c51377db0ab77620e5c3d437 WHIRLPOOL 75d7e4569eed83df842e363c6203571b7bc26dbfdd71555ead0c1656eb61923817673ce18f8042c4a989a45af956ad9fd85aee5386c8aafb121bf71de99c04c6
DIST at-spi2-atk-2.16.0.tar.xz 286668 SHA256 78efc45ec36383bf785f8636e64a8d866defeb020e00a08f92978f1fc3772ff9 SHA512 fcd40693e5ef55c640a52158996dc8bc66f53ef211c343cd5401c4bcd1669110ea836e0550eb41caee9c9f3a4f9670095a7dd8252600af943ddcb374bf50f011 WHIRLPOOL 0865cb8bfd62449bf345938a382c2a7d8efd425154e7e674c8097702e6873d98b8d2be8ac841858ba7dce166c2be4e18be1b1daf4fed43f667430ac3eeccebe2
+DIST at-spi2-atk-2.18.1.tar.xz 291676 SHA256 c4b15f9386d34d464ddad5f6cc85669742c016df87141ceee93513245979c12d SHA512 bf4cd26c8130dd3b92817eb7d0e927391039e86b5d4bd579154c219988af263421c2bf7712fd40fe910ea136cdd2226cf71ba527498b68d022fdbc768c09c7ad WHIRLPOOL d3a4afc5df9d3121836248eeb211cd4cbe7799931a08cc3d83baa6f69d71c11da8afe58ec7dcdef21769f60445b8b6a11e5a5694e310974da97a479590506a66
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.18.1.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.18.1.ebuild
new file mode 100644
index 000000000000..1a871d82ec03
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.18.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.17.90[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.15.4[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --enable-p2p $(use_with test tests)
+}
+
+multilib_src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ dbus-run-session -- emake check
+}
+
+multilib_src_compile() { gnome2_src_compile; }
+multilib_src_install() { gnome2_src_install; }