summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-12-15 21:24:28 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-17 16:07:54 +0100
commit0dd57a125efcf48e751c71530fd14a96b6bd4644 (patch)
tree6196c157c2b6b5a570035cf59cd24cc905e0028b /app-admin/cdist/cdist-6.9.8.ebuild
parentsci-libs/silo: drop unused patch (diff)
downloadgentoo-0dd57a125efcf48e751c71530fd14a96b6bd4644.tar.gz
gentoo-0dd57a125efcf48e751c71530fd14a96b6bd4644.tar.bz2
gentoo-0dd57a125efcf48e751c71530fd14a96b6bd4644.zip
app-admin/cdist: bump to 6.9.8 and EAPI 8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'app-admin/cdist/cdist-6.9.8.ebuild')
-rw-r--r--app-admin/cdist/cdist-6.9.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/cdist/cdist-6.9.8.ebuild b/app-admin/cdist/cdist-6.9.8.ebuild
new file mode 100644
index 000000000000..1dae10c0230a
--- /dev/null
+++ b/app-admin/cdist/cdist-6.9.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.cdi.st/ https://code.ungleich.ch/ungleich-public/cdist"
+SRC_URI="https://code.ungleich.ch/ungleich-public/cdist/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs/src dev-python/sphinx_rtd_theme
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ echo "VERSION='${PV}'" > cdist/version.py || die "Failed to set version"
+ distutils-r1_python_prepare_all
+}