summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2020-02-10 22:00:49 +1100
committerMichael Palimaka <kensington@gentoo.org>2020-02-10 22:00:49 +1100
commit2b35661a1844af25aa5eb03ffadcf5a2debab196 (patch)
tree6063459299f8f8ef0845cc147fdee50167e69e88 /app-admin
parentapp-text/ansifilter: version bump 2.16 (diff)
downloadgentoo-2b35661a1844af25aa5eb03ffadcf5a2debab196.tar.gz
gentoo-2b35661a1844af25aa5eb03ffadcf5a2debab196.tar.bz2
gentoo-2b35661a1844af25aa5eb03ffadcf5a2debab196.zip
app-admin/keepass: remove 2.42.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/keepass/Manifest1
-rw-r--r--app-admin/keepass/keepass-2.42.1.ebuild113
2 files changed, 0 insertions, 114 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 470ee9d4d770..0ffc6e2a60a2 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,2 +1 @@
-DIST KeePass-2.42.1-Source.zip 5163432 BLAKE2B c24a57da863c92d3f89663f33ed89c277e248c926067c14a6a7e3526e77c458e943e62c4b98a3d86595eea308d8744fd4a17da6d5456030a771e324a662abd9f SHA512 c87581afbaa516f637848db134a8d945db168bbbe97789a9a7424600d4188a21d2b1b3cf907a20577b2903ce8916b6b12355a3296ee1630a5b556c9170c4fa22
DIST KeePass-2.43-Source.zip 5177684 BLAKE2B 72530afd37139d250fe7378ccfec9056e9f2210aa9dfc4cc082d977ccfc517697bc52dad3d487ebabc796977cdbb9679df32a79a6be807c21ceab5931d464df0 SHA512 c403ae5d7b2a997e1aadffd6a522c8292d01a5803371af8b30734414ca5d47871b53a15067251d4cb072215fd41396465b0b16351e76dad7a48044b7ed62a7e8
diff --git a/app-admin/keepass/keepass-2.42.1.ebuild b/app-admin/keepass/keepass-2.42.1.ebuild
deleted file mode 100644
index c5d1b4af3595..000000000000
--- a/app-admin/keepass/keepass-2.42.1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils gnome2-utils xdg-utils
-
-MY_PN="KeePass"
-DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
-HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aot"
-
-COMMON_DEPEND="dev-lang/mono"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip
-"
-RDEPEND="${COMMON_DEPEND}
- dev-dotnet/libgdiplus[cairo]
-"
-
-S="${WORKDIR}"
-PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
-
-src_prepare() {
- # KeePass looks for some XSL files in the same folder as the executable,
- # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
- # This XSL file will not be upstreamed since the KeePass creator said that
- # including this patch would break the Portable USB version of KeePass
- # (which keeps/looks for xsl files in its own folder)
- default
-
- # Switch into build dir so the mono prepration script works correctly
- pushd Build || die
- source PrepMonoDev.sh || die
- popd || die
-}
-
-src_compile() {
- export MONO_REGISTRY_PATH=/dev/null # bug 659808
-
- # Build with Release target
- xbuild /target:KeePass /property:Configuration=Release || die
-
- # Run Ahead Of Time compiler on the binary
- if use aot; then
- cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
- mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
- fi
-}
-
-src_install() {
- # Wrapper script to launch mono
- make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
-
- # Some XSL files
- insinto "/usr/share/${PN}/XSL"
- doins Ext/XSL/*
-
- insinto "/usr/$(get_libdir)/${PN}"
- exeinto "/usr/$(get_libdir)/${PN}"
-
- doins Ext/KeePass.exe.config
-
- # Default configuration, simply says to use user-specific configuration
- doins Ext/KeePass.config.xml
-
- # The actual executable
- doexe Build/KeePass/Release/KeePass.exe
-
- # Copy the AOT compilation result
- if use aot; then
- doexe Build/KeePass/Release/KeePass.exe.so
- fi
-
- # Prepare the icons
- newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
- newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
-
- # Create a desktop entry and associate it with the KeePass mime type
- make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
-
- # MIME descriptor for .kdbx files
- insinto /usr/share/mime/packages
- doins "${FILESDIR}/${PN}.xml"
-
- # sed, because patching this really sucks
- sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-
- if ! has_version x11-misc/xdotool ; then
- elog "Optional dependencies:"
- elog " x11-misc/xdotool (enables autotype/autofill)"
- fi
-
- elog "Some systems may experience issues with copy and paste operations."
- elog "If you encounter this, please install x11-misc/xsel."
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}