summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-07-02 09:12:23 +0000
committerMichał Górny <mgorny@gentoo.org>2019-07-05 19:40:23 +0200
commit3752af45e0dde5009d64add4c23ad3badf7e8a14 (patch)
tree8355a6621c0eeb735ce6ae02c539c2d57f5c5776 /app-admin
parentnet-analyzer/ossec-hids: Fix build issue, version bump (diff)
downloadgentoo-3752af45e0dde5009d64add4c23ad3badf7e8a14.tar.gz
gentoo-3752af45e0dde5009d64add4c23ad3badf7e8a14.tar.bz2
gentoo-3752af45e0dde5009d64add4c23ad3badf7e8a14.zip
app-admin/filebeat: bump to 6.8.1
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/filebeat/Manifest1
-rw-r--r--app-admin/filebeat/filebeat-6.8.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/filebeat/Manifest b/app-admin/filebeat/Manifest
index 9b1b56ee9515..5a8b55221370 100644
--- a/app-admin/filebeat/Manifest
+++ b/app-admin/filebeat/Manifest
@@ -3,3 +3,4 @@ DIST filebeat-6.3.2.tar.gz 20923316 BLAKE2B 70ac7e574f94a6141a7c6a1bd0af45ddbda3
DIST filebeat-6.4.3.tar.gz 22085261 BLAKE2B 466580ba371d02bd0b51bd80f0e8d9766f2af1d371f88cd01144a648cd8d5488ca54447e925e9014790a836009d76be9eec9ef9b14a102287d3f4a71b852d20d SHA512 c28d9939c2082b586ddf744b4e18427096290987efd74f7ea03d2632a1cdcbc5dd2b043ee7ceeb0457098faeb52abbac57652077c518112fb65858954ee27f34
DIST filebeat-6.5.4.tar.gz 25286147 BLAKE2B c3eca03c8e8e2b863918f3fe65bdea46b351739569f5570daac3e321963e98190331c5bf99c2451db5faa615620e023d2fd9c73060d4d775392a86a2f5578d80 SHA512 a48b9ae267ec80c1b45e4e07644f8080f8ba280da5c3543022b73472eb70de9d836cfffd387e576298becf9313d2cfa67d835158442f163b1a1bd0e72df31297
DIST filebeat-6.6.1.tar.gz 29108620 BLAKE2B 21dbe189dcf91efe6170574e3cff858cca4094936fbda54a343f66e61a5f0cd7d29e71d547c34ddd78776283d13e48926dd84925eed58ca07cc7bedf216c9064 SHA512 9c7646efa8aa44c2ae1cbcf85204749bc57491aad075d3ca283cd75a1b3a93d922169603407b2ea111e7e3abe0a43ce26fabccfe93d56a4232bd63e2b2e8b24a
+DIST filebeat-6.8.1.tar.gz 35550017 BLAKE2B 0a1913adf2eda50884f33715a059fcc2028e31560afc5412e87d7fd3a6ed5cc504683ad3c5b28f18df24afd3e4c8d96c5b2a930411ae32d09d05c85cfdff0499 SHA512 5ff047e80099b09e25952ac7fc8ea0c6be25df2cd3b638c07c600e680fac32505c279a3a91ee2e61acf0f9535b4adb390a65f3a7dbc3599e74c6b02e0aa6ef71
diff --git a/app-admin/filebeat/filebeat-6.8.1.ebuild b/app-admin/filebeat/filebeat-6.8.1.ebuild
new file mode 100644
index 000000000000..36a7f617b67c
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.8.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.12.5"
+RDEPEND="!app-admin/filebeat-bin"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # avoid Elastic license
+ rm -r x-pack || die
+
+ # use ${PV} instead of git commit id
+ sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT}/usr/share/doc/${PF}/examples"
+}