summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-16 21:46:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-16 21:50:06 +0300
commit3c7f15ed460dfb74f0e47939377330a4c194d63b (patch)
treeb2fd481ac53a9dea385253ab3a62136f8e026871 /app-admin
parentdev-python/boto3: add 1.24.52 (diff)
downloadgentoo-3c7f15ed460dfb74f0e47939377330a4c194d63b.tar.gz
gentoo-3c7f15ed460dfb74f0e47939377330a4c194d63b.tar.bz2
gentoo-3c7f15ed460dfb74f0e47939377330a4c194d63b.zip
app-admin/awscli: add 1.25.52
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.52.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index efe9a062a150..c8efcd700de0 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.25.47.gh.tar.gz 2241028 BLAKE2B 6aea17029d28bf0875f58472ab27e244e
DIST aws-cli-1.25.49.gh.tar.gz 2241270 BLAKE2B 6c5e3c20855df9da322f3e6085f4f6f5894f4bdb19b7a47011bd111fb5934ecbe921397e45e5539d4734520dfad144906337f488bfc4b2aaf479fe9a74a689aa SHA512 f8dbd6d0ce2e919e20e2c251d289be2720c46e9ca25595e249eb1934d6a0494347c8d13131c9839a7177f0aa89cf4a5ee0ed1a938c53febd70424349c8fcc661
DIST aws-cli-1.25.50.gh.tar.gz 2241527 BLAKE2B 76a594e977bedaeb89bef7b3d61cbd08a157560b3610756719a04a8195b04c5e7480b94a5a6c69494cfe9fd7388550a6b26778e2ab0e1eeeec6e6eb91bfd36e0 SHA512 d112207b0fb654693503baa09ccaf3df3cf8766408a9c4a8533005e8be3cd724d28f197466af1580758ed689ebd3ad0afd895a5c4cfc06c3da15eadda0ca495e
DIST aws-cli-1.25.51.gh.tar.gz 2241823 BLAKE2B 86e7463a8fb63311351d60ac3dcd01a2f87a774dd63430265dbb5546661d6533fa528c81cab72e08d805518c1896779451533a0e4af02ba2565115402a1aae76 SHA512 6ea6d6532dc6e5ad8e3a392cff6034ad3084b8dbdbdcb197ae737f7912088e415da992a56915cf355a7f39206ab28ec3865c10cb618271b2d1f8a71a89a809fd
+DIST aws-cli-1.25.52.gh.tar.gz 2241932 BLAKE2B e11ce7250040886ae9a00413c8ce67c929e90b5697a83d36184750d69d947c389afc4fc97d590c64874c2c259ba4a10b97b5d20f6148aee167d9cf6b9af6ff9d SHA512 5c5e06c9e2b0529508edc829c1baa7359238a1e72712e45e269030fd58644fde2f7b94767d1e33b1ff35859a25985f2b00b7d13c96e37dc5999bc7e24cc4f5da
diff --git a/app-admin/awscli/awscli-1.25.52.ebuild b/app-admin/awscli/awscli-1.25.52.ebuild
new file mode 100644
index 000000000000..9f176fa05cc8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.52.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}