summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-12-01 10:44:40 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2015-12-01 10:44:40 -0600
commit7e980ba2655366510326cb2a803ca064c12b455c (patch)
tree4f888327e89d25d2e35c12bdba8bf13a9693e6bd /app-admin
parentsys-apps/busybox: fix builds w/LDFLAGS=-fuse-ld=gold #499712 (diff)
downloadgentoo-7e980ba2655366510326cb2a803ca064c12b455c.tar.gz
gentoo-7e980ba2655366510326cb2a803ca064c12b455c.tar.bz2
gentoo-7e980ba2655366510326cb2a803ca064c12b455c.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.3.1.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 81079005a316..afec2c51cc50 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -10,3 +10,5 @@ DIST puppet-agent_1.2.7-1wheezy_amd64.deb 15280016 SHA256 c250bcdeb22296ef3b0097
DIST puppet-agent_1.2.7-1wheezy_i386.deb 15214412 SHA256 c2b9f51cfe3d3e43b3cdfb7a1c6c92abaeaf2c4ab26e9ceac5aba2b58cf1480e SHA512 6950e09c49da35c0cf463364b4ec468ba011f15d3caf9c59c58ef01a0cfd859cb5c97a3271d9a11c958a71c4c77ba45a8dab205124b92a80354da519dc1a2f3c WHIRLPOOL 12ce6f5ba23f00d1320d7cd40734485ac69bdddda8a9711e18f3549c12919592ca27394963578c5850400864e2b524e7034833e8b2985b15f06bb66f06df1b75
DIST puppet-agent_1.3.0-1wheezy_amd64.deb 18018964 SHA256 dd107d96f674100e399f1e1a773b22ed2dd77081f3580d7df729f0d02885326f SHA512 20b5a2e516e98db30450b54f0ae042b4c6d5ccf4f44bc3403381bc663c73a7349b393fefaafabfbe334a49afbfcabc8eeae727e4eca54ef7eaa81463a7f05ed2 WHIRLPOOL df75fda9fa2ddc46fea419a65dc0de7eccd9ded41534c96f9be6688b07287fb3f6343ae908fcede47f857d37af1513e74ae5b25302150b1b186f0dc698d85860
DIST puppet-agent_1.3.0-1wheezy_i386.deb 17960480 SHA256 eda86599bd647e1367874636aedb9e2812540043b6bf3f0f614efb00b7f727b8 SHA512 d2a3555c9298c9a14ea9342e787f4971a0e6fbe0ea37a2ca8a6f8ee4863fb8eb21dd5cb45c493ad0bffdc85e239baa6aaec95c778fb697e6ec5fe65ba592ea84 WHIRLPOOL f77446c30aaf56e529ecec2dfbd00d438407ed58bfa460f147cc59c403eeafa4fbb62697d84696173501c349156d0b0c0a0166760dc2bdf1f133371bc9ee1d98
+DIST puppet-agent_1.3.1-1wheezy_amd64.deb 18079810 SHA256 c7df7a99ac0ee08564e60596ec4547f4208010d196c7e229f54fe8c8939cf7fd SHA512 c205c24a2c8aee1f57ddb9c1e0b09172455e953de8b51452c274e43edd95e3d5999c8ff74d00935b3a3b3221532d264bd4e9917a994095e9deee8430e91cc572 WHIRLPOOL fb492b8f6e98565e664bfb14dcb8b06fcae20b5bcefb9a04abd064099271fbae8d21c47b6605e32e0efce7fb6bcceeb9e3e330c1e7338491b700e66945870c5b
+DIST puppet-agent_1.3.1-1wheezy_i386.deb 18015662 SHA256 7a6df5b1ff33ab6791c76d7080fc2b8174e6efdf701c774d7945238f3be28e5a SHA512 3960327559ef9b7f58b6b0997789ec89b74afab2628c8067383556e66cdbfe5a5951ddf5c11840bf0fc76052a8548500f2608dc823ae757c669272ee10a22af5 WHIRLPOOL 9c8c50401e3388af6114a24b70753b6ee96beee5f73e9fbb50ff1e6c63ae6e94ae4110ad197558288f4d310ef36714ca9132d08ff0f122aab8a4885b4ab682cc
diff --git a/app-admin/puppet-agent/puppet-agent-1.3.1.ebuild b/app-admin/puppet-agent/puppet-agent-1.3.1.ebuild
new file mode 100644
index 000000000000..696bcc79467a
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.3.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}