summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-12-24 22:02:24 +0800
committerJason Zaman <perfinion@gentoo.org>2018-12-27 18:06:38 +0800
commitc35abf2b4d20b8a70584813b03cf68204ebcf454 (patch)
treea3b729a769555a18e6ad27f55261532ace7c7432 /app-admin
parentmedia-libs/mutagen: version bump to 1.42.0 (diff)
downloadgentoo-c35abf2b4d20b8a70584813b03cf68204ebcf454.tar.gz
gentoo-c35abf2b4d20b8a70584813b03cf68204ebcf454.tar.bz2
gentoo-c35abf2b4d20b8a70584813b03cf68204ebcf454.zip
app-admin/setools: update live ebuild
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/setools/files/setools-4.2.0-remove-gui.patch18
-rw-r--r--app-admin/setools/metadata.xml2
-rw-r--r--app-admin/setools/setools-9999.ebuild32
3 files changed, 32 insertions, 20 deletions
diff --git a/app-admin/setools/files/setools-4.2.0-remove-gui.patch b/app-admin/setools/files/setools-4.2.0-remove-gui.patch
new file mode 100644
index 000000000000..748b33c9a5d1
--- /dev/null
+++ b/app-admin/setools/files/setools-4.2.0-remove-gui.patch
@@ -0,0 +1,18 @@
+diff --git a/setup.py b/setup.py
+index e075a00..3f8f959 100644
+--- a/setup.py
++++ b/setup.py
+@@ -134,10 +134,10 @@ setup(name='setools',
+ author_email='pebenito@ieee.org',
+ url='https://github.com/SELinuxProject/setools',
+ cmdclass={'build_qhc': QtHelpCommand, 'clean': CleanCommand},
+- packages=['setools', 'setools.diff', 'setoolsgui', 'setoolsgui.apol'],
+- scripts=['apol', 'sediff', 'seinfo', 'seinfoflow', 'sesearch', 'sedta'],
++ packages=['setools', 'setools.diff'],
++ scripts=['sediff', 'seinfo', 'seinfoflow', 'sesearch', 'sedta'],
+ data_files=[(join(sys.prefix, 'share/man/man1'), glob.glob("man/*.1"))],
+- package_data={'': ['*.ui', '*.qhc', '*.qch'], 'setools': ['perm_map']},
++ package_data={'setools': ['perm_map']},
+ ext_modules=cythonize(ext_py_mods, include_path=['setools/policyrep'],
+ annotate=cython_annotate,
+ compiler_directives={"language_level": 3,
diff --git a/app-admin/setools/metadata.xml b/app-admin/setools/metadata.xml
index 8e9f11ed8b4c..fdc3261aeec3 100644
--- a/app-admin/setools/metadata.xml
+++ b/app-admin/setools/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<longdescription>SELinux policy analysis tools.</longdescription>
<upstream>
- <remote-id type="github">TresysTechnology/setools</remote-id>
+ <remote-id type="github">SELinuxProject/setools</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-admin/setools/setools-9999.ebuild b/app-admin/setools/setools-9999.ebuild
index 13b8cb7389c8..70e0fb4bed29 100644
--- a/app-admin/setools/setools-9999.ebuild
+++ b/app-admin/setools/setools-9999.ebuild
@@ -1,52 +1,46 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_COMPAT=( python3_5 python3_6 )
inherit distutils-r1
DESCRIPTION="Policy Analysis Tools for SELinux"
-HOMEPAGE="https://github.com/TresysTechnology/setools/wiki"
+HOMEPAGE="https://github.com/SELinuxProject/setools/wiki"
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/TresysTechnology/setools.git"
+ EGIT_REPO_URI="https://github.com/SELinuxProject/setools.git"
else
- SRC_URI="https://github.com/TresysTechnology/setools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/setools/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="X debug test"
+IUSE="X test"
RDEPEND="${PYTHON_DEPS}
- >=sys-libs/libsepol-2.7:=
- >=sys-libs/libselinux-2.7:=[${PYTHON_USEDEP}]
- >=dev-python/networkx-1.8[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- dev-libs/libpcre:=
+ >=dev-python/networkx-2.0[${PYTHON_USEDEP}]
+ >=sys-libs/libsepol-2.8:=
+ >=sys-libs/libselinux-2.8:=
X? (
dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
)"
DEPEND="${RDEPEND}
- >=dev-lang/swig-2.0.12:0
- sys-devel/bison
- sys-devel/flex
- >=sys-libs/libsepol-2.5
+ >=dev-python/cython-0.27
test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
sys-apps/checkpolicy
)"
python_prepare_all() {
sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
- sed -i "s@^base_lib_dirs = .*@base_lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@g" "${S}"/setup.py || \
- die "failed to set base_lib_dirs"
+ sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
+ die "failed to set lib_dirs"
- use X || local PATCHES=( "${FILESDIR}"/setools-4.1.1-remove-gui.patch )
+ use X || local PATCHES=( "${FILESDIR}"/setools-4.2.0-remove-gui.patch )
distutils-r1_python_prepare_all
}