summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/afio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/afio')
-rw-r--r--app-arch/afio/Manifest2
-rw-r--r--app-arch/afio/afio-2.5.1.ebuild32
-rw-r--r--app-arch/afio/afio-2.5.ebuild44
-rw-r--r--app-arch/afio/files/Makefile-r1.patch23
-rw-r--r--app-arch/afio/files/Makefile.patch25
-rw-r--r--app-arch/afio/metadata.xml17
6 files changed, 143 insertions, 0 deletions
diff --git a/app-arch/afio/Manifest b/app-arch/afio/Manifest
new file mode 100644
index 000000000000..5e4bed0692e5
--- /dev/null
+++ b/app-arch/afio/Manifest
@@ -0,0 +1,2 @@
+DIST afio-2.5.1.tgz 191765 SHA256 363457a5d6ee422d9b704ef56d26369ca5ee671d7209cfe799cab6e30bf2b99a SHA512 afa4e01cc9e7da5bff7c96d2da9a41c296e7b89c50484f58a8b011173a99a144a9e77d3ee8136622e490287b99a7ae76c6eba901a2186b5a3a6bab164a37c864 WHIRLPOOL 15ad4ec743a2b4ac1b9ca37a5680f2f08fee7dd9cfe22d7a1b1949b4958447365e67096c8123e82a0f41f106ec6e73024152cc05121855a1c5d75589a734a764
+DIST afio-2.5.tgz 179184 SHA256 e7801a0f0a8dcbae41f4156dee5dae2a34a558d6c3ceac517efad4fed610ff2e SHA512 8e8fba115989b60284d09fb37b8f4782b6adc4a0887a05544615a38e62c6b3a48c3194b53ea4496fea64b25d420ff89cf6faab31646998f3612082118fcbb052 WHIRLPOOL 9ee08583d4e64ca6984b66e81eda5f422b89c3da13e130d1c9c7f8b2f78090f37b10fbdbfdda6e0dc30c7183813912d4021ff74d198bdf7203fc516425c40df5
diff --git a/app-arch/afio/afio-2.5.1.ebuild b/app-arch/afio/afio-2.5.1.ebuild
new file mode 100644
index 000000000000..c8614d59e70c
--- /dev/null
+++ b/app-arch/afio/afio-2.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="makes cpio-format archives and deals somewhat gracefully with input data corruption"
+HOMEPAGE="http://members.chello.nl/k.holtman/afio.html"
+SRC_URI="http://members.chello.nl/k.holtman/${P}.tgz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/Makefile-r1.patch
+ tc-export CC
+}
+
+src_install() {
+ local i
+ dobin afio
+ dodoc ANNOUNCE-* HISTORY README SCRIPTS
+ for i in 1 2 3 4; do
+ docinto script$i
+ dodoc script$i/*
+ done
+ doman afio.1
+}
diff --git a/app-arch/afio/afio-2.5.ebuild b/app-arch/afio/afio-2.5.ebuild
new file mode 100644
index 000000000000..54998b5776bf
--- /dev/null
+++ b/app-arch/afio/afio-2.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="makes cpio-format archives and deals somewhat gracefully with input data corruption"
+HOMEPAGE="http://freshmeat.net/projects/afio/"
+SRC_URI="http://members.brabant.chello.nl/~k.holtman/${P}.tgz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ppc sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/Makefile.patch
+ # use our cflags
+ sed -i \
+ -e "s:-O2 -fomit-frame-pointer:${CFLAGS}:" \
+ Makefile \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ local i
+ dobin afio || die "dobin failed"
+ dodoc ANNOUNCE-2.5 HISTORY README SCRIPTS
+ for i in 1 2 3 4 5 ; do
+ docinto script$i
+ dodoc script$i/*
+ done
+ doman afio.1
+}
diff --git a/app-arch/afio/files/Makefile-r1.patch b/app-arch/afio/files/Makefile-r1.patch
new file mode 100644
index 000000000000..70ec6caa4b90
--- /dev/null
+++ b/app-arch/afio/files/Makefile-r1.patch
@@ -0,0 +1,23 @@
+diff -urN afio-2.5.1.orig/Makefile afio-2.5.1/Makefile
+--- afio-2.5.1.orig/Makefile 2012-02-05 14:52:24.000000000 +0100
++++ afio-2.5.1/Makefile 2012-03-11 14:02:16.267636685 +0100
+@@ -71,15 +71,12 @@
+ MW=
+ #MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
+
+-CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
+-
+-CC=gcc
+-
+-CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
+-LDFLAGS =
++CC?=gcc
++CFLAGS+=-Wall -Wstrict-prototypes -s ${LARGEFILEFLAGS} ${2} ${3} ${6} ${8} ${c} ${d} ${e2} ${f} ${g}
++LDFLAGS+=
+
+ afio : afio.o compfile.o exten.o match.o $M
+- ${CC} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
++ ${CC} ${CFLAGS} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
+
+ clean:
+ rm -f *.o afio
diff --git a/app-arch/afio/files/Makefile.patch b/app-arch/afio/files/Makefile.patch
new file mode 100644
index 000000000000..537c29939fa2
--- /dev/null
+++ b/app-arch/afio/files/Makefile.patch
@@ -0,0 +1,25 @@
+--- Makefile.orig 2003-11-10 00:11:50.000000000 -0800
++++ Makefile 2003-11-10 00:13:47.000000000 -0800
+@@ -1,4 +1,22 @@
+ SHELL=/bin/sh
++1=
++2=
++3=
++4=
++5=
++6=
++7=
++8=
++9=
++a=
++b=
++c=
++d=
++e=
++f=
++g=
++M=
++I=
+ ##
+ ## I wrote this Makefile, based on comments in the source. -rich $alz.
+ ## Define INDEX to use index() in place of strchr() (v7, BSD).
diff --git a/app-arch/afio/metadata.xml b/app-arch/afio/metadata.xml
new file mode 100644
index 000000000000..9dc430496357
--- /dev/null
+++ b/app-arch/afio/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Afio makes cpio-format archives. It deals somewhat gracefully
+with input data corruption, supports multi-volume archives during interactive
+operation, and can make compressed archives that are much safer than compressed
+tar or cpio archives. Afio is best used as an 'archive engine' in a backup
+script.
+</longdescription>
+ <upstream>
+ <remote-id type="freshmeat">afio</remote-id>
+ </upstream>
+</pkgmetadata>