summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/cksfv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/cksfv')
-rw-r--r--app-arch/cksfv/Manifest3
-rw-r--r--app-arch/cksfv/cksfv-1.3.12.ebuild32
-rw-r--r--app-arch/cksfv/cksfv-1.3.13.ebuild32
-rw-r--r--app-arch/cksfv/cksfv-1.3.14.ebuild31
-rw-r--r--app-arch/cksfv/metadata.xml8
5 files changed, 106 insertions, 0 deletions
diff --git a/app-arch/cksfv/Manifest b/app-arch/cksfv/Manifest
new file mode 100644
index 000000000000..130e74a00d21
--- /dev/null
+++ b/app-arch/cksfv/Manifest
@@ -0,0 +1,3 @@
+DIST cksfv-1.3.12.tar.bz2 26772 SHA256 f029fab94cc7d6df88cc9ec8dbc65707662d82b1f5bacb95266da020528bf53f SHA512 1b98724d8fd20a500b459089538f175ebb94d6c07000cce4cf685c8fea183be15fc28de3a6352f69d9e124b5b102ab08dce5e4c28563d45e897ff35420902317 WHIRLPOOL 178243155eeaf9b209e854b86a782f8d1f838c4fb3fba9460997200d2100e06edaefc87c66d1d1d36f4fa2f9ac380e5dbcb333d14751d96e849fa725fd66ad2f
+DIST cksfv-1.3.13.tar.bz2 26109 SHA256 16ee1bbc0ae8a83909e25e37681d6d501a26dadb18e241310e4333dedc8d1435 SHA512 643bd82b9994087eb1ddc7c182df33f9de1c2b220e89beb878019b2a7489c16baa85d92a45ffe81bc22203f47dbde98b40ec375112978e0ff14a62ffa70faae0 WHIRLPOOL 82c573943ebeda8531d6b5357d34cb6da310531736bb2c70294e4a288d85eb8b51531a5d074b297909845529c17ed50a6ec40775f19f3d338cd4036678cf95ed
+DIST cksfv-1.3.14.tar.bz2 26114 SHA256 8f3c246f3a4a1f0136842a2108568297e66e92f5996e0945d186c27bca07df52 SHA512 016c2f61632980678957fe4b5bc9ecb30360efd548ff09bfbb7a31cc6fc36f6fe7936d3d819fe468a6208c71f8b625662aa3ae0abd668435d7273e149d7e4519 WHIRLPOOL 15d9daa70a37e14a05c0d07b0389dfb9502d5418418601822d74a3048776d25d0f9afb5df448abc67c0bfc1042b3330a1efff4c7a53a7a0d96e64c2528d8d8f1
diff --git a/app-arch/cksfv/cksfv-1.3.12.ebuild b/app-arch/cksfv/cksfv-1.3.12.ebuild
new file mode 100644
index 000000000000..54b8fd5d6cca
--- /dev/null
+++ b/app-arch/cksfv/cksfv-1.3.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/cksfv/"
+SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ # note: not an autoconf configure script
+ ./configure \
+ --compiler=$(tc-getCC) \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ --bindir=/usr/bin \
+ --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install() {
+ emake install || die
+ dodoc ChangeLog README TODO
+}
diff --git a/app-arch/cksfv/cksfv-1.3.13.ebuild b/app-arch/cksfv/cksfv-1.3.13.ebuild
new file mode 100644
index 000000000000..6cd76026687e
--- /dev/null
+++ b/app-arch/cksfv/cksfv-1.3.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/cksfv/"
+SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ # note: not an autoconf configure script
+ ./configure \
+ --compiler=$(tc-getCC) \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ --bindir=/usr/bin \
+ --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install() {
+ emake install || die
+ dodoc ChangeLog README TODO
+}
diff --git a/app-arch/cksfv/cksfv-1.3.14.ebuild b/app-arch/cksfv/cksfv-1.3.14.ebuild
new file mode 100644
index 000000000000..33680f81c054
--- /dev/null
+++ b/app-arch/cksfv/cksfv-1.3.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/cksfv/"
+SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+src_configure() {
+ # note: not an autoconf configure script
+ ./configure \
+ --compiler="$(tc-getCC)" \
+ --prefix="${EPREFIX}"/usr \
+ --package-prefix="${D}" \
+ --bindir="${EPREFIX}"/usr/bin \
+ --mandir="${EPREFIX}"/usr/share/man || die
+}
+
+src_install() {
+ emake install
+ dodoc ChangeLog README TODO
+}
diff --git a/app-arch/cksfv/metadata.xml b/app-arch/cksfv/metadata.xml
new file mode 100644
index 000000000000..01630d73a7f1
--- /dev/null
+++ b/app-arch/cksfv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
+<longdescription>A Simple file verification tool to ensure that the files you recieve are the same as the originals.</longdescription>
+</pkgmetadata>