summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-24 21:42:37 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-24 22:06:25 +0200
commitfad53f6f3a23a9fc3760eb7f11f545a7566fb8ac (patch)
tree2f976ea633f00c115beb9a30bc68ad286d0cc09f /app-arch/file-roller
parentapp-arch/file-roller: Drop old (diff)
downloadgentoo-fad53f6f3a23a9fc3760eb7f11f545a7566fb8ac.tar.gz
gentoo-fad53f6f3a23a9fc3760eb7f11f545a7566fb8ac.tar.bz2
gentoo-fad53f6f3a23a9fc3760eb7f11f545a7566fb8ac.zip
app-arch/file-roller: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest1
-rw-r--r--app-arch/file-roller/file-roller-3.20.2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 05ace3efe837..3b419a170c4e 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1 +1,2 @@
DIST file-roller-3.16.5.tar.xz 1415236 SHA256 09a68db98aa33febdad76e6977d7771b3b444da7f57ab6f4fe7d6a77e39d5a91 SHA512 83c8dddb547f36faa2728996648479255353706a266ce26e79f8f6141794d0281a9817f2a1dc687623ba8382cab93aef23675e2f3ef6d4abb9f8871f253d2c2d WHIRLPOOL 01d54e45d9d8b81c5f965622adbacac1400f56461e230999e97aa1cde135714e7e80317749c04eac7b4a49fea0fa66142b9dfbec0876b743b4709d3d17c72cce
+DIST file-roller-3.20.2.tar.xz 1430448 SHA256 93188a7ac9285cb85551c327082aeaeb51ac39a9722cb96b0e29d5ec2ae353c6 SHA512 a2397215125c5bf10efcc04eb7722459acf5e11c40f3d2acb813c1c4e0de0855656c732cecb0526f850bf3e419c8407b36487c553ce9e26894fc40af309dfdf5 WHIRLPOOL e05ef7a1d86c5dceae079b8e7400acb49977903df0e90bf4bcec7774713d2afcf91311a75ba3a771fca49f6662e005ecde347328ed9e7923864a9082329a9478
diff --git a/app-arch/file-roller/file-roller-3.20.2.ebuild b/app-arch/file-roller/file-roller-3.20.2.ebuild
new file mode 100644
index 000000000000..e90d3ac4745f
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.20.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 readme.gentoo-r1
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ >=x11-libs/libnotify-0.4.3:=
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ nautilus? ( >=gnome-base/nautilus-3 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -f "${FILESDIR}"/3.6.0-packages.match data/packages.match || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}