summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/freeze
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/freeze')
-rw-r--r--app-arch/freeze/Manifest1
-rw-r--r--app-arch/freeze/files/freeze-2.5.0-gentoo.patch55
-rw-r--r--app-arch/freeze/freeze-2.5.0-r1.ebuild45
-rw-r--r--app-arch/freeze/metadata.xml8
4 files changed, 109 insertions, 0 deletions
diff --git a/app-arch/freeze/Manifest b/app-arch/freeze/Manifest
new file mode 100644
index 000000000000..521ae6d60daf
--- /dev/null
+++ b/app-arch/freeze/Manifest
@@ -0,0 +1 @@
+DIST freeze-2.5.0.tar.gz 36010 SHA256 f543eb18bd7de8893a3c0bac0e4fa5fea46a4e10f5d8182cebc40c97b8593863 SHA512 2e0965e1bb772a829763b99c623b3dfa062a624ed2bd5f658c9df0e4040a9c914aec5a85602340fe994634b82d2fac3250030b35ad3d5f5054b0a6f4059469e7 WHIRLPOOL 8415350c9ad833ceebff515922df947a54c1400cbba9606ef283068d6453cded3a6b674c4940fe0260a085834dd7b5b0a5cf3cb0116bbfde9cdd59d26323f0f2
diff --git a/app-arch/freeze/files/freeze-2.5.0-gentoo.patch b/app-arch/freeze/files/freeze-2.5.0-gentoo.patch
new file mode 100644
index 000000000000..3be357c25309
--- /dev/null
+++ b/app-arch/freeze/files/freeze-2.5.0-gentoo.patch
@@ -0,0 +1,55 @@
+--- a/Makefile.in 1999-05-20 11:07:51.000000000 +0200
++++ b/Makefile.in 2012-12-12 17:22:36.444775985 +0100
+@@ -3,7 +3,7 @@
+ VPATH = $(srcdir)
+
+ CC = @CC@
+-CFLAGS = -I. # -O2 # for gcc 2.2.2
++CFLAGS += -I.
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+@@ -79,15 +79,15 @@
+
+ freeze$(EXE): $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+- -strip $@
++
+
+ statist$(EXE): statist.$(OBJ) lz.$(OBJ)
+ $(CC) $(LDFLAGS) -o $@ statist.$(OBJ) lz.$(OBJ) $(LIBS)
+- -strip $@
++
+
+ showhuf$(EXE): showhuf.$(OBJ)
+ $(CC) $(LDFLAGS) -o $@ showhuf.$(OBJ) $(LIBS)
+- -strip $@
++
+
+ clobber: clean
+ rm -f freeze$(EXE) statist$(EXE) showhuf$(EXE) *.man \#* *~ config.h Makefile
+@@ -101,18 +101,18 @@
+
+ $(DEST)/freeze: freeze
+ $(INSTALL_PROGRAM) freeze $@
+- -ln -f $@ $(DEST)/melt
+- -ln -f $@ $(DEST)/unfreeze
+- -ln -f $@ $(DEST)/fcat
++ ln -sf $< $(DEST)/melt
++ ln -sf $< $(DEST)/unfreeze
++ ln -sf $< $(DEST)/fcat
+
+ $(DEST)/statist: statist
+ $(INSTALL_PROGRAM) statist $@
+
+ $(MANDEST)/freeze.$(SEC): freeze.1
+ $(INSTALL_DATA) $(srcdir)/freeze.1 $@
+- -ln -f $@ $(MANDEST)/melt.$(SEC)
+- -ln -f $@ $(MANDEST)/unfreeze.$(SEC)
+- -ln -f $@ $(MANDEST)/fcat.$(SEC)
++ ln -sf $< $(MANDEST)/melt.$(SEC)
++ ln -sf $< $(MANDEST)/unfreeze.$(SEC)
++ ln -sf $< $(MANDEST)/fcat.$(SEC)
+ # This is much better for places which keep preformated manpages.
+ # echo ".so man1/freeze.$(SEC)" > $(MANDEST)/melt.$(SEC)
+ # echo ".so man1/freeze.$(SEC)" > $(MANDEST)/unfreeze.$(SEC)
diff --git a/app-arch/freeze/freeze-2.5.0-r1.ebuild b/app-arch/freeze/freeze-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..2db6da160ea2
--- /dev/null
+++ b/app-arch/freeze/freeze-2.5.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Freeze/unfreeze compression program"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/utils/compress/"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/utils/compress/${P}.tar.gz"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="
+ !<=media-libs/mlt-0.4.2
+ !media-libs/mlt[melt]
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ OPTIONS="-DDEFFILE=\\\"/etc/freeze.cnf\\\""
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+
+ emake \
+ DEST="${D}/usr/bin" \
+ MANDEST="${D}/usr/share/man/man1" \
+ install
+
+ # these symlinks collide with app-forensics/sleuthkit (bug #444872)
+ rm "${D}"/usr/bin/fcat "${D}"/usr/share/man/man1/fcat.1 || die
+
+ dobin showhuf
+ dodoc README *.lsm
+}
diff --git a/app-arch/freeze/metadata.xml b/app-arch/freeze/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/app-arch/freeze/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>