summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-20 15:05:18 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-20 15:05:18 +0200
commita60b3d30eb8940fa25856182246757b8f79ec446 (patch)
treedd7abb0aca312aa4bdb78d2459c638cf22371010 /app-arch
parentapp-arch/libarchive: add libressl support (diff)
downloadgentoo-a60b3d30eb8940fa25856182246757b8f79ec446.tar.gz
gentoo-a60b3d30eb8940fa25856182246757b8f79ec446.tar.bz2
gentoo-a60b3d30eb8940fa25856182246757b8f79ec446.zip
app-arch/unshield: add libressl support
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unshield/unshield-0.6_p20120308-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/unshield/unshield-0.6_p20120308-r1.ebuild b/app-arch/unshield/unshield-0.6_p20120308-r1.ebuild
new file mode 100644
index 000000000000..778549dd9465
--- /dev/null
+++ b/app-arch/unshield/unshield-0.6_p20120308-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="https://github.com/twogood/unshield http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="libressl static-libs"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-bootstrap.patch
+ ./bootstrap
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467548
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-ssl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}