summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-04-03 04:28:49 -0400
committerTim Harder <radhermit@gentoo.org>2017-04-03 04:34:27 -0400
commit7fc0b5ba5849eee0d383948cfe91ee94ac5c7636 (patch)
tree7e21556f4d4ea12605aeb4c29e749dbe3fb5c2a7 /app-backup/duplicity/duplicity-0.7.12.ebuild
parentapp-misc/dateutils: remove old (diff)
downloadgentoo-7fc0b5ba5849eee0d383948cfe91ee94ac5c7636.tar.gz
gentoo-7fc0b5ba5849eee0d383948cfe91ee94ac5c7636.tar.bz2
gentoo-7fc0b5ba5849eee0d383948cfe91ee94ac5c7636.zip
app-backup/duplicity: version bump to 0.7.12
Diffstat (limited to 'app-backup/duplicity/duplicity-0.7.12.ebuild')
-rw-r--r--app-backup/duplicity/duplicity-0.7.12.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-backup/duplicity/duplicity-0.7.12.ebuild b/app-backup/duplicity/duplicity-0.7.12.ebuild
new file mode 100644
index 000000000000..f58453ccdf6d
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.7.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/lockfile
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # workaround until failing test is fixed
+ local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+ distutils-r1_python_prepare_all
+
+ sed -i "s/'COPYING',//" setup.py || die
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Duplicity has many optional dependencies to support various backends."
+ einfo "Currently it's up to you to install them as necessary."
+}