summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-01-19 21:24:18 -0500
committerRichard Freeman <rich0@gentoo.org>2020-01-19 21:24:18 -0500
commitd6a1b2d78796849837ef8f1942bbca431bd6b58e (patch)
treedfaf4b0fb80730eecd813fa22b317bfaa65c235a /app-backup/duplicity/duplicity-0.8.09-r1.ebuild
parentdev-qt: Drop 5.14.0 w/o USE X (diff)
downloadgentoo-d6a1b2d78796849837ef8f1942bbca431bd6b58e.tar.gz
gentoo-d6a1b2d78796849837ef8f1942bbca431bd6b58e.tar.bz2
gentoo-d6a1b2d78796849837ef8f1942bbca431bd6b58e.zip
app-backup/duplicity: fix missing future dep
Closes: https://bugs.gentoo.org/705726 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup/duplicity/duplicity-0.8.09-r1.ebuild')
-rw-r--r--app-backup/duplicity/duplicity-0.8.09-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-backup/duplicity/duplicity-0.8.09-r1.ebuild b/app-backup/duplicity/duplicity-0.8.09-r1.ebuild
new file mode 100644
index 000000000000..f87d57f11a79
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.09-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6)
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}