summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-28 15:43:42 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-28 16:07:11 +0100
commit11e941968974caa61d31f9680c448b61063d8beb (patch)
treeb516d19518e413e260cab2a2ce0252b3b683586f /app-backup
parentapp-backup/cpdup: Port to EAPI 6 (diff)
downloadgentoo-11e941968974caa61d31f9680c448b61063d8beb.tar.gz
gentoo-11e941968974caa61d31f9680c448b61063d8beb.tar.bz2
gentoo-11e941968974caa61d31f9680c448b61063d8beb.zip
app-backup/ccollect: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/ccollect/ccollect-0.8.ebuild53
1 files changed, 28 insertions, 25 deletions
diff --git a/app-backup/ccollect/ccollect-0.8.ebuild b/app-backup/ccollect/ccollect-0.8.ebuild
index 8cd9780edb4b..b5a9a055b4ac 100644
--- a/app-backup/ccollect/ccollect-0.8.ebuild
+++ b/app-backup/ccollect/ccollect-0.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="Pseudo incremental backup with different exclude lists using hardlinks and rsync"
HOMEPAGE="http://www.nico.schottelius.org/software/ccollect/"
@@ -12,64 +12,67 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc ~sparc x86"
IUSE="doc examples"
-DEPEND="doc? ( >=app-text/asciidoc-8.1.0
+DEPEND="
+ doc? (
+ >=app-text/asciidoc-8.1.0
app-text/docbook-xsl-stylesheets
app-text/docbook-xml-dtd:4.2
- dev-libs/libxslt )"
+ dev-libs/libxslt
+ )"
RDEPEND="net-misc/rsync"
# tests need ssh-access
RESTRICT="test"
src_compile() {
- if use doc; then
- emake XSL=/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl documentation || die "building docs failed"
- fi
+ use doc && emake XSL=/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl documentation
}
src_install() {
dobin ccollect.sh
dosym ccollect.sh /usr/bin/ccollect
- local tools="add_source analyse_logs archive_config check_config delete_source list_intervals logwrapper stats"
- for t in ${tools} ; do
- newbin tools/ccollect_${t}.sh ccollect_${t}
+ local i
+ for i in add_source analyse_logs archive_config check_config \
+ delete_source list_intervals logwrapper stats; do
+ newbin tools/ccollect_${i}.sh ccollect_${i}
done
insinto /usr/share/${PN}/tools
doins tools/config-pre* tools/{gnu-du-backup-size-compare,report_success}.sh
- dodoc CREDITS README
- pushd doc/changes
- for n in * ; do
- newdoc ${n} NEWS-${n}
- done
- popd
+ pushd doc/changes >/dev/null || die
+ for i in * ; do
+ newdoc ${i} NEWS-${i}
+ done
+ popd >/dev/null || die
if use doc; then
- dohtml doc/*.htm doc/*.html
- dohtml -r doc/man
doman doc/man/*.1
+
+ find doc/ \( -iname '*.1' -o -iname '*.text' \) -delete || die
+ HTML_DOCS=( doc/{*.htm{,l},man} )
fi
+ einstalldocs
if use examples ; then
- # dodoc is not recursive. So do a workaround.
- insinto /usr/share/doc/${PF}/examples/
- doins -r conf/*
+ docinto examples
+ dodoc -r conf/.
fi
}
pkg_postinst() {
ewarn "If you're upgrading from 0.6.x or less, you'll have to"
ewarn "upgrade your existing configuration as follows:"
- ewarn "1. Make the scripts in /usr/share/ccollect/scripts executable"
- ewarn "2. Run all config-pre-\$VER-to-\$VER.sh in /usr/share/ccollect/scripts"
+ ewarn "1. Make the scripts in ${EROOT%/}/usr/share/ccollect/scripts executable"
+ ewarn "2. Run all config-pre-\$VER-to-\$VER.sh in ${EROOT%/}/usr/share/ccollect/scripts"
ewarn " ascending order, where \$VER is greater or equal than the version"
ewarn " you upgraded from."
ewarn "Example:"
ewarn " You upgraded from 0.5, thus you have to run:"
- ewarn " /usr/share/ccollect/tools/config-pre-0.6-to-0.6.sh"
- ewarn " /usr/share/ccollect/tools/config-pre-0.7-to-0.7.sh"
- elog "Please note that many tools are now installed directly to /usr/bin"
+ ewarn " ${EROOT%/}/usr/share/ccollect/tools/config-pre-0.6-to-0.6.sh"
+ ewarn " ${EROOT%/}/usr/share/ccollect/tools/config-pre-0.7-to-0.7.sh"
+
+ elog "Please note that many tools are now installed directly to ${EROOT%/}/usr/bin"
elog "as recommended by upstream."
}