summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-25 19:07:25 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-25 19:07:25 -0500
commit7f044ef89b8f5c86d57fa0739807b4ece53aea5c (patch)
treeb390834f720720d625bb7ca4d1cb14126056ab61 /app-backup
parentapp-backup/backuppc: remove backuppc-3.3.0-r1 / backuppc-3.3.1-r1 (diff)
downloadgentoo-7f044ef89b8f5c86d57fa0739807b4ece53aea5c.tar.gz
gentoo-7f044ef89b8f5c86d57fa0739807b4ece53aea5c.tar.bz2
gentoo-7f044ef89b8f5c86d57fa0739807b4ece53aea5c.zip
app-backup/boxbackup: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/boxbackup/boxbackup-0.11.1-r1.ebuild76
-rw-r--r--app-backup/boxbackup/files/bbackupd.rc4
-rw-r--r--app-backup/boxbackup/files/bbstored.rc4
3 files changed, 80 insertions, 4 deletions
diff --git a/app-backup/boxbackup/boxbackup-0.11.1-r1.ebuild b/app-backup/boxbackup/boxbackup-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..f3b4419823f8
--- /dev/null
+++ b/app-backup/boxbackup/boxbackup-0.11.1-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils user
+
+DESCRIPTION="A completely automatic on-line backup system"
+HOMEPAGE="http://boxbackup.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+SRC_URI="http://boxbackup.org/svn/box/packages/${P/_/}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~ppc-macos ~x86-macos"
+IUSE="client-only libressl"
+DEPEND="sys-libs/zlib
+ sys-libs/db:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ >=dev-lang/perl-5.6"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+S="${WORKDIR}/${P/_/}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.11_rc8-testbbackupd.patch
+}
+
+src_compile() {
+ # bug #299411
+ emake -j1 || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+ emake -j1 DESTDIR="${D}" install-backup-client || die "client install failed"
+ use client-only || \
+ emake -j1 DESTDIR="${D}" install-backup-server || die "server install failed"
+
+ dodoc *.txt
+ newinitd "${FILESDIR}"/bbackupd.rc bbackupd
+ use client-only || \
+ newinitd "${FILESDIR}"/bbstored.rc bbstored
+
+ keepdir /etc/boxbackup
+
+ # apparently new versions have the files in the right location, so this is redundant
+ # move executables from /usr/bin to /usr/sbin, as configuration of
+ # this is unfortunately not optimal
+ #mv "${D%/}${EPREFIX}/usr/bin" "${D%/}${EPREFIX}/usr/sbin" || die "could not move files from bin to sbin"
+}
+
+pkg_preinst() {
+ if ! use client-only;
+ then
+ enewgroup bbstored
+ enewuser bbstored -1 -1 -1 bbstored
+ fi
+}
+
+pkg_postinst() {
+ while read line; do elog "${line}"; done <<EOF
+After configuring the Box Backup client and/or server, you can start
+the daemon using the init scripts /etc/init.d/bbackupd and
+/etc/init.d/bbstored.
+The configuration files can be found in /etc/boxbackup
+
+More information about configuring the client can be found at
+${HOMEPAGE}client.html,
+and more information about configuring the server can be found at
+${HOMEPAGE}server.html.
+EOF
+ echo
+}
diff --git a/app-backup/boxbackup/files/bbackupd.rc b/app-backup/boxbackup/files/bbackupd.rc
index a1a9ae2de771..d182fbd741f6 100644
--- a/app-backup/boxbackup/files/bbackupd.rc
+++ b/app-backup/boxbackup/files/bbackupd.rc
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/app-backup/boxbackup/files/bbstored.rc b/app-backup/boxbackup/files/bbstored.rc
index 8d54fdb5f72e..a06a10bded8a 100644
--- a/app-backup/boxbackup/files/bbstored.rc
+++ b/app-backup/boxbackup/files/bbstored.rc
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$