summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-16 18:11:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-16 18:42:44 +0200
commit866827f225d473894ee59deafd6b001d16a93759 (patch)
treec82e63c5aeeb10c275599f2e6e7c0e6693c54267 /app-backup
parentsys-kernel/gentoo-sources: Linux patch 4.4.138 (diff)
downloadgentoo-866827f225d473894ee59deafd6b001d16a93759.tar.gz
gentoo-866827f225d473894ee59deafd6b001d16a93759.tar.bz2
gentoo-866827f225d473894ee59deafd6b001d16a93759.zip
app-backup/rdiff-backup: EAPI-7 bump, fix RDEPEND
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild b/app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild
new file mode 100644
index 000000000000..2233c2d12fae
--- /dev/null
+++ b/app-backup/rdiff-backup/rdiff-backup-1.3.3-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+UPSTREAM_PV=$(ver_rs 0 '-')
+
+DESCRIPTION="Local/remote mirroring+incremental backup"
+HOMEPAGE="https://github.com/sol1/rdiff-backup"
+SRC_URI="https://github.com/sol1/${PN}/archive/r${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+DEPEND="
+ net-libs/librsync:0=
+"
+RDEPEND="${DEPEND}
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/pyxattr[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}/${P}-librsync-1.0.0.patch" )
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples.html )
+
+ distutils-r1_python_install_all
+}