summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-03-25 14:02:18 +0000
committerMarek Szuba <marecki@gentoo.org>2019-03-25 14:11:26 +0000
commit8bffcba23b6618942f7dbcac18bba5d6318ffd4a (patch)
treee1750fd9580da85f47427a76ba2ab09f3910f6a1 /app-backup
parentmedia-video/ffmpeg: bump to 4.1.2 (diff)
downloadgentoo-8bffcba23b6618942f7dbcac18bba5d6318ffd4a.tar.gz
gentoo-8bffcba23b6618942f7dbcac18bba5d6318ffd4a.tar.bz2
gentoo-8bffcba23b6618942f7dbcac18bba5d6318ffd4a.zip
app-backup/burp: bump to version 2.2.18 and EAPI 7
Seems to fix the problem with running the test suite on a file system not supporting user xattrs as well. Closes: https://bugs.gentoo.org/679758 Closes: https://bugs.gentoo.org/641926 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/burp/Manifest1
-rw-r--r--app-backup/burp/burp-2.2.18.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index 36b9ddd4865..e3ba14c4861 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1 +1,2 @@
DIST burp-2.1.32.tar.gz 591737 BLAKE2B fd525bff32348f1dbc37b1c065d262ff8af1d999d19f63711ebcff3fb55e90a7440cc6cfc0b7eefe6f8e250672c799d86e65ed599f0b8d7dd80bebcb99888987 SHA512 2477b7a9a2123b227a27519f7f3d9facca7173a9e63d66f6a8fb2ae5408d8af4ad5bfdd0a14efd6cf80e7bc8e91907f7c293a3d621b86bafdbf163bfa08d0c81
+DIST burp-2.2.18.tar.gz 632805 BLAKE2B 6106aa4bd96db035ad5893c2fe314537e620a67519295fdf99efaf2c5a639bedd15b4c8d95caa3daa3072dfac28a1ba7fd7bb4f949d9ea2b70bd13060a22f2c6 SHA512 beb14c61ace6d61b98a10fc4e6709eec9722e28990de862eef6a75984f9fbd0f903c5fe64d20ed84c95528a9889bc22618ba6d2318318cf5d515b35688db0a4d
diff --git a/app-backup/burp/burp-2.2.18.ebuild b/app-backup/burp/burp-2.2.18.ebuild
new file mode 100644
index 00000000000..94406549317
--- /dev/null
+++ b/app-backup/burp/burp-2.2.18.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd user
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="https://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl ipv6 libressl test xattr"
+
+CDEPEND="dev-libs/uthash
+ net-libs/librsync
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+RDEPEND="${CDEPEND}
+ virtual/logger"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
+ "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+)
+
+pkg_setup() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 "" "" "${PN}"
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ $(use_enable acl)
+ $(use_enable ipv6)
+ $(use_enable xattr)
+ )
+ # --runstatedir option will only work from autoconf-2.70 onwards
+ runstatedir='/run' \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/spool/burp
+ fowners -R root:${PN} /var/spool/burp
+ fperms 0770 /var/spool/burp
+
+ emake DESTDIR="${D}" install-configs
+ fowners -R root:${PN} /etc/burp
+ fperms 0750 /etc/burp
+ fperms 0640 /etc/burp/burp-server.conf
+ fperms 0750 /etc/burp/clientconfdir
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst() {
+ elog "Burp ebuilds now support the autoupgrade mechanism in both"
+ elog "client and server mode. In both cases it is disabled by"
+ elog "default. You almost certainly do NOT want to enable it in"
+ elog "client mode because upgrades obtained this way will not be"
+ elog "managed by Portage."
+
+ if [[ ! -e /etc/burp/CA/index.txt ]]; then
+ elog ""
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " /etc/burp/burp-server.conf"
+ elog ""
+ fi
+
+ # According to PMS this can be a space-separated list of version
+ # numbers, even though in practice it is typically just one.
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
+ ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+ ewarn "the server config file by default. If you use bedup, please"
+ ewarn "update your scripts to invoke it as"
+ ewarn ""
+ ewarn " bedup -c /etc/burp/burp-server.conf"
+ ewarn ""
+ ewarn "Otherwise deduplication will not work!"
+ break
+ fi
+ done
+}