summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/acovea/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/acovea/files')
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch16
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch12
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch14
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch12
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch119
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch10
6 files changed, 183 insertions, 0 deletions
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
new file mode 100644
index 000000000000..8bfb8a175550
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
@@ -0,0 +1,16 @@
+--- cmdline/Makefile.am
++++ cmdline/Makefile.am
+@@ -7,4 +7,4 @@
+
+ runacovea_SOURCES = runacovea.cpp
+
+-LIBS = -L../libacovea -lacovea -lcoyotl -levocosm -lexpat
++LIBS = -L../libacovea -lacovea -lcoyotl -levocosm
+--- libacovea/Makefile.am
++++ libacovea/Makefile.am
+@@ -16,3 +16,5 @@
+ library_include_HEADERS = $(h_sources)
+
+ DEFS=-I. -I$(srcdir)
++
++LIBS = -lexpat
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
new file mode 100644
index 000000000000..55b3b00e8897
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
@@ -0,0 +1,12 @@
+--- benchmarks/treebench.c
++++ benchmarks/treebench.c
+@@ -201,8 +201,8 @@
+ if (page->m_links[n] != NULL)
+ recursive_destroy_page(page->m_links[n]);
+
+- free(page);
+ }
++ free(page);
+ }
+
+ static void free_btree(btree * btree)
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch b/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
new file mode 100644
index 000000000000..c5e5392b2f99
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
@@ -0,0 +1,14 @@
+--- libacovea/acovea.cpp
++++ libacovea/acovea.cpp
+@@ -44,10 +44,11 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+
+ #include <vector>
++#include <cstdio>
+ #include <cstring>
+ #include <sstream>
+ #include <iostream>
+ #include <iomanip>
+ #include <stdexcept>
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch b/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch
new file mode 100644
index 000000000000..9763951a672a
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/336260
+
+--- libacovea/acovea.cpp
++++ libacovea/acovea.cpp
+@@ -44,6 +44,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
++#include <sys/stat.h>
+
+ #include <vector>
+ #include <cstring>
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
new file mode 100644
index 000000000000..f801b8c68bcb
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
@@ -0,0 +1,119 @@
+--- libacovea/acovea.cpp
++++ libacovea/acovea.cpp
+@@ -86,7 +86,7 @@
+ // randomize settings of this option
+ void option::randomize()
+ {
+- m_enabled = (g_random.get_rand_real2() < 0.5);
++ m_enabled = (g_random.get_real() < 0.5);
+ }
+
+ // mutate this option
+@@ -246,7 +246,7 @@
+ m_step = 1;
+
+ // possibly adjust value to randomize populations
+- size_t choice = g_random.get_rand_index(3);
++ size_t choice = g_random.get_index(3);
+
+ switch (choice)
+ {
+@@ -304,12 +304,12 @@
+ void tuning_option::mutate()
+ {
+ // select our mutation
+- if (g_random.get_rand_real2() < 0.5)
++ if (g_random.get_real() < 0.5)
+ option::mutate();
+ else
+ {
+ // mutate value of this option, up or down randomly
+- if (g_random.get_rand_real2() < 0.5)
++ if (g_random.get_real() < 0.5)
+ m_value -= m_step;
+ else
+ m_value += m_step;
+@@ -335,7 +335,7 @@
+ enum_option::enum_option(const vector<string> & a_choices, bool a_enabled)
+ : option(a_enabled),
+ m_choices(a_choices),
+- m_setting(g_random.get_rand_index(a_choices.size()))
++ m_setting(g_random.get_index(a_choices.size()))
+ {
+ // nada
+ }
+@@ -344,7 +344,7 @@
+ enum_option::enum_option(const char ** a_choices, size_t a_num_choices, bool a_enabled)
+ : option(a_enabled),
+ m_choices(),
+- m_setting(g_random.get_rand_index(a_num_choices))
++ m_setting(g_random.get_index(a_num_choices))
+ {
+ for (int n = 0; n < a_num_choices; ++n)
+ m_choices.push_back(string(a_choices[n]));
+@@ -369,7 +369,7 @@
+ token = strtok(NULL,"|");
+ }
+
+- m_setting = g_random.get_rand_index(m_choices.size());
++ m_setting = g_random.get_index(m_choices.size());
+
+ free(choices);
+ }
+@@ -407,17 +407,17 @@
+ void enum_option::randomize()
+ {
+ // randomize enabled
+- m_enabled = (g_random.get_rand_real2() < 0.5);
++ m_enabled = (g_random.get_real() < 0.5);
+
+ // randomize setting
+- m_setting = g_random.get_rand_index(m_choices.size());
++ m_setting = g_random.get_index(m_choices.size());
+ }
+
+ // mutate this option
+ void enum_option::mutate()
+ {
+ // select our mutation
+- if (g_random.get_rand() & 1)
++ if (g_random.get_real() < 0.5)
+ option::mutate();
+ else
+ {
+@@ -435,7 +435,7 @@
+
+ // find a different setting
+ while (new_setting == m_setting)
+- new_setting = g_random.get_rand_index(m_choices.size());
++ new_setting = g_random.get_index(m_choices.size());
+
+ m_setting = new_setting;
+ }
+@@ -915,7 +915,7 @@
+ // randomly pick an option from one of the parents
+ for (int n = 0; n < a_parent1.size(); ++n)
+ {
+- if (g_random.get_rand() & 1)
++ if (g_random.get_real() < 0.5)
+ child.push_back(a_parent1[n]->clone());
+ else
+ child.push_back(a_parent2[n]->clone());
+@@ -931,7 +931,7 @@
+ {
+ for (int n = 0; n < a_options.size(); ++n)
+ {
+- if (g_random.get_rand_real2() < a_mutation_chance)
++ if (g_random.get_real() < a_mutation_chance)
+ a_options[n]->mutate();
+ }
+ }
+@@ -1096,7 +1096,7 @@
+ acovea_organism * child;
+
+ // do we crossover?
+- if (g_random.get_rand_real2() <= m_crossover_rate)
++ if (g_random.get_real() <= m_crossover_rate)
+ {
+ // select a second parent
+ size_t second_index = first_index;
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch b/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch
new file mode 100644
index 000000000000..06ef410b6cc6
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-underlinking.patch
@@ -0,0 +1,10 @@
+diff --git a/cmdline/Makefile.am b/cmdline/Makefile.am
+index f3c763e..8e18d9c 100644
+--- a/cmdline/Makefile.am
++++ b/cmdline/Makefile.am
+@@ -7,4 +7,4 @@ bin_PROGRAMS = runacovea
+
+ runacovea_SOURCES = runacovea.cpp
+
+-LIBS = -L../libacovea -lacovea -lcoyotl -levocosm
++LIBS = -L../libacovea -lacovea -lcoyotl -levocosm -lbrahe