summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/bonnie++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/bonnie++')
-rw-r--r--app-benchmarks/bonnie++/Manifest2
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild43
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.96.ebuild34
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.97.ebuild46
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.93c-64bit.patch15
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch46
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch46
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.95-homepage.patch12
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.96-compile-flags.patch17
-rw-r--r--app-benchmarks/bonnie++/metadata.xml10
10 files changed, 271 insertions, 0 deletions
diff --git a/app-benchmarks/bonnie++/Manifest b/app-benchmarks/bonnie++/Manifest
new file mode 100644
index 000000000000..d04c043d5296
--- /dev/null
+++ b/app-benchmarks/bonnie++/Manifest
@@ -0,0 +1,2 @@
+DIST bonnie++-1.96.tgz 105183 SHA256 9c9d87bf09ac5a42a915ceeb9d8bb8358c0ca4642d86b85ed48ca5f15ee3456c SHA512 d389545be68eb236382ac1cc361d171e28b6204c9ea2427a6d4743086fb16a3a1ee78acc35fd0706237d8d90dd8403872ed743583496b1e2512fa57242ff0bb8 WHIRLPOOL 57b04f3cac809bd66e32c895c857bfce969ae16a207eecef743b5c522b6d7496bf518d352a673011fba3e9073f541a274cbc9a4ae5ddd88b37cb386ea2b2e5d4
+DIST bonnie++-1.97.tgz 102604 SHA256 44f5a05937648a6526ba99354555d7d15f2dd392e55d3436f6746da6f6c35982 SHA512 985fd4d0ef643fda5363e61609a5d73206ecfdd1c27470cc7babeaf9b7d87136c6bf40f62366d3f3ea58c50a307fa62aea59dc5efa69854fff9c43d1c940d3ab WHIRLPOOL 23af9926691868a208fd69f7ec401fa0c2332835ccc63e4b0143497faabb02f21ddd56a41014b532287f4418e0ac92c712aff2bc0657ad2512961fa5aa3567b9
diff --git a/app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild b/app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild
new file mode 100644
index 000000000000..b37e43482f30
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+SRC_URI="http://www.coker.com.au/bonnie++/experimental/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-compile-flags.patch
+}
+
+src_configure() {
+ econf \
+ $(use_with debug) \
+ --disable-stripping \
+ || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav || die
+ dobin bon_csv2html bon_csv2txt || die
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt credits.txt
+}
diff --git a/app-benchmarks/bonnie++/bonnie++-1.96.ebuild b/app-benchmarks/bonnie++/bonnie++-1.96.ebuild
new file mode 100644
index 000000000000..b0e81de23099
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.96.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+SRC_URI="http://www.coker.com.au/bonnie++/experimental/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ econf \
+ $(use_with debug) \
+ --disable-stripping \
+ || die
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav || die
+ dobin bon_csv2html bon_csv2txt || die
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt credits.txt
+}
diff --git a/app-benchmarks/bonnie++/bonnie++-1.97.ebuild b/app-benchmarks/bonnie++/bonnie++-1.97.ebuild
new file mode 100644
index 000000000000..66c735bc2f43
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.97.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+SRC_URI="http://www.coker.com.au/bonnie++/experimental/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+# hmm?
+S="${WORKDIR}/${P}.1"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.96-compile-flags.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_with debug) \
+ --disable-stripping \
+ || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav || die
+ dobin bon_csv2html bon_csv2txt || die
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt credits.txt
+}
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.93c-64bit.patch b/app-benchmarks/bonnie++/files/bonnie++-1.93c-64bit.patch
new file mode 100644
index 000000000000..2af76d8f8c80
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.93c-64bit.patch
@@ -0,0 +1,15 @@
+--- getc_putc.cpp.old 2004-09-15 02:37:21.500489552 +0200
++++ getc_putc.cpp 2004-09-15 02:40:58.623481840 +0200
+@@ -165,7 +165,11 @@
+ int size = 0, wrote;
+ while(size < file_size)
+ {
+- wrote = write(FILE_FD, buf, min(sizeof(buf), (unsigned int)file_size - size));
++ //wrote = write(FILE_FD, buf, min(sizeof(buf), (unsigned int)file_size - size));
++ /*
++ * gcc doesn't like above line. ? : should do the job as good as min()...
++ */
++ wrote = write(FILE_FD, buf, (sizeof(buf) < (file_size - size) ? (sizeof(buf)):(file_size - size)));
+ if(wrote < 0)
+ {
+ fprintf(stderr, "Can't extend file - disk full?\n");
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch b/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch
new file mode 100644
index 000000000000..2afe02b496bd
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch
@@ -0,0 +1,46 @@
+diff -Naur bonnie++-1.93c.orig/bon_csv2html.cpp bonnie++-1.93c/bon_csv2html.cpp
+--- bonnie++-1.93c.orig/bon_csv2html.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/bon_csv2html.cpp 2008-05-02 14:13:57.000000000 +0200
+@@ -3,6 +3,7 @@
+ #include <vector>
+ #include <string.h>
+ #include <math.h>
++#include <stdlib.h>
+
+ // Maximum number of items expected on a csv line
+ #define MAX_ITEMS 48
+diff -Naur bonnie++-1.93c.orig/getc_putc.cpp bonnie++-1.93c/getc_putc.cpp
+--- bonnie++-1.93c.orig/getc_putc.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc.cpp 2008-05-02 14:19:15.000000000 +0200
+@@ -12,6 +12,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include <vector>
+
+ #include "duration.h"
+diff -Naur bonnie++-1.93c.orig/getc_putc_helper.cpp bonnie++-1.93c/getc_putc_helper.cpp
+--- bonnie++-1.93c.orig/getc_putc_helper.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc_helper.cpp 2008-05-02 14:19:57.000000000 +0200
+@@ -7,6 +7,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include "duration.h"
+ #include <vector>
+ #include "getc_putc.h"
+diff -Naur bonnie++-1.93c.orig/zcav.cpp bonnie++-1.93c/zcav.cpp
+--- bonnie++-1.93c.orig/zcav.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/zcav.cpp 2008-05-02 14:20:42.000000000 +0200
+@@ -9,6 +9,9 @@
+ #include "getopt.h"
+ #endif
+
++#include <stdlib.h>
++#include <string.h>
++
+ #define TOO_MANY_LOOPS 100
+
+ void usage()
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch b/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch
new file mode 100644
index 000000000000..2afe02b496bd
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch
@@ -0,0 +1,46 @@
+diff -Naur bonnie++-1.93c.orig/bon_csv2html.cpp bonnie++-1.93c/bon_csv2html.cpp
+--- bonnie++-1.93c.orig/bon_csv2html.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/bon_csv2html.cpp 2008-05-02 14:13:57.000000000 +0200
+@@ -3,6 +3,7 @@
+ #include <vector>
+ #include <string.h>
+ #include <math.h>
++#include <stdlib.h>
+
+ // Maximum number of items expected on a csv line
+ #define MAX_ITEMS 48
+diff -Naur bonnie++-1.93c.orig/getc_putc.cpp bonnie++-1.93c/getc_putc.cpp
+--- bonnie++-1.93c.orig/getc_putc.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc.cpp 2008-05-02 14:19:15.000000000 +0200
+@@ -12,6 +12,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include <vector>
+
+ #include "duration.h"
+diff -Naur bonnie++-1.93c.orig/getc_putc_helper.cpp bonnie++-1.93c/getc_putc_helper.cpp
+--- bonnie++-1.93c.orig/getc_putc_helper.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc_helper.cpp 2008-05-02 14:19:57.000000000 +0200
+@@ -7,6 +7,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include "duration.h"
+ #include <vector>
+ #include "getc_putc.h"
+diff -Naur bonnie++-1.93c.orig/zcav.cpp bonnie++-1.93c/zcav.cpp
+--- bonnie++-1.93c.orig/zcav.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/zcav.cpp 2008-05-02 14:20:42.000000000 +0200
+@@ -9,6 +9,9 @@
+ #include "getopt.h"
+ #endif
+
++#include <stdlib.h>
++#include <string.h>
++
+ #define TOO_MANY_LOOPS 100
+
+ void usage()
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.95-homepage.patch b/app-benchmarks/bonnie++/files/bonnie++-1.95-homepage.patch
new file mode 100644
index 000000000000..114d4143453b
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.95-homepage.patch
@@ -0,0 +1,12 @@
+diff -Nu -Nu -uarN bonnie++-1.93c.orig/bonnie++.8 bonnie++-1.93c/bonnie++.8
+--- bonnie++-1.93c.orig/bonnie++.8 2008-05-27 09:49:18.000000000 +0200
++++ bonnie++-1.93c/bonnie++.8 2008-05-27 09:51:50.000000000 +0200
+@@ -32,7 +32,7 @@
+ INN.
+ .P
+ All the details of the tests performed by Bonnie++ are contained in the file
+-.BR /usr/share/doc/bonnie++/readme.html
++.BR /usr/share/doc/bonnie++-1.95/html/readme.html
+
+ .SH "OPTIONS"
+ For Bonnie++ every option is of the form of a hyphen followed by a letter and
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.96-compile-flags.patch b/app-benchmarks/bonnie++/files/bonnie++-1.96-compile-flags.patch
new file mode 100644
index 000000000000..05821f977ecc
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.96-compile-flags.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile.in b/Makefile.in
+index 4f14819..1092891 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -9,9 +9,9 @@ prefix=@prefix@
+ eprefix=@exec_prefix@
+ #MORE_WARNINGS=-Weffc++
+ WFLAGS=-Wall -W -Wshadow -Wpointer-arith -Wwrite-strings -pedantic -ffor-scope -Wcast-align -Wsign-compare -Wpointer-arith -Wwrite-strings -Wformat-security -Wswitch-enum -Winit-self $(MORE_WARNINGS)
+-CFLAGS=-O2 @debug@ -DNDEBUG $(WFLAGS) $(MORECFLAGS)
+-CXX=@CXX@ $(CFLAGS)
+-LINK=@CXX@
++CXXFLAGS += @debug@ -DNDEBUG $(WFLAGS)
++CXX=@CXX@ $(CXXFLAGS)
++LINK=@CXX@ $(LDFLAGS)
+ THREAD_LFLAGS=@thread_ldflags@
+
+ INSTALL=@INSTALL@
diff --git a/app-benchmarks/bonnie++/metadata.xml b/app-benchmarks/bonnie++/metadata.xml
new file mode 100644
index 000000000000..dbb54cf3d480
--- /dev/null
+++ b/app-benchmarks/bonnie++/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>benchmarks</herd>
+ <longdescription>
+ Bonnie++ is based on the Bonnie hard drive benchmark by Tim Bray. This
+ program is used by ReiserFS developers, but can be useful for anyone
+ who wants to know how fast their hard drive or file system is.
+ </longdescription>
+</pkgmetadata>