summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-21 11:15:05 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-21 11:15:05 +0200
commitc16993b6aff974fd5a9145801f6d3dac07511c1d (patch)
treec3d9536ed677534d71befaec2d7984fb26aeff0a /app-benchmarks/geekbench/geekbench-5.2.5.ebuild
parentxfce-extra/xfce4-systemload-plugin: panel-4.15 compatibility (diff)
downloadgentoo-c16993b6aff974fd5a9145801f6d3dac07511c1d.tar.gz
gentoo-c16993b6aff974fd5a9145801f6d3dac07511c1d.tar.bz2
gentoo-c16993b6aff974fd5a9145801f6d3dac07511c1d.zip
app-benchmarks/geekbench: bump to version 5.2.5
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks/geekbench/geekbench-5.2.5.ebuild')
-rw-r--r--app-benchmarks/geekbench/geekbench-5.2.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-benchmarks/geekbench/geekbench-5.2.5.ebuild b/app-benchmarks/geekbench/geekbench-5.2.5.ebuild
new file mode 100644
index 000000000000..82d4a4a67fbf
--- /dev/null
+++ b/app-benchmarks/geekbench/geekbench-5.2.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
+HOMEPAGE="https://www.geekbench.com/"
+SRC_URI="https://cdn.geekbench.com/Geekbench-${PV}-Linux.tar.gz"
+
+KEYWORDS="-* ~amd64"
+LICENSE="geekbench"
+SLOT="5"
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}/Geekbench-${PV}-Linux"
+
+QA_PREBUILT="
+ opt/geekbench5/geekbench5
+ opt/geekbench5/geekbench_x86_64
+"
+
+pkg_nofetch() {
+ elog "Please download ${A} from ${HOMEPAGE}/download/linux"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ exeinto /opt/geekbench5
+ doexe geekbench5 geekbench_x86_64
+
+ insinto /opt/geekbench5
+ doins geekbench.plar
+
+ dodir /opt/bin
+ dosym ../geekbench5/geekbench5 /opt/bin/geekbench5
+}
+
+pkg_postinst() {
+ elog "If you have purchased a commercial license, you can enter"
+ elog "your email address and your license key with the following command:"
+ elog "geekbench5 -r <email address> <license key>"
+}