summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-benchmarks/nbench
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-benchmarks/nbench')
-rw-r--r--app-benchmarks/nbench/Manifest1
-rw-r--r--app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch24
-rw-r--r--app-benchmarks/nbench/metadata.xml8
-rw-r--r--app-benchmarks/nbench/nbench-2.2.3-r1.ebuild39
4 files changed, 72 insertions, 0 deletions
diff --git a/app-benchmarks/nbench/Manifest b/app-benchmarks/nbench/Manifest
new file mode 100644
index 000000000000..531ac3c65afe
--- /dev/null
+++ b/app-benchmarks/nbench/Manifest
@@ -0,0 +1 @@
+DIST nbench-byte-2.2.3.tar.gz 111791 SHA256 723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed9101ac SHA512 68ae34c083e2e01f0114e6ff9ce04df41d70facbb05533b4cb9432fd9856048fde28e5c024d92f202e5f2de10fe223fdb46570873b1e2f69b2c847779645dec8 WHIRLPOOL a7433d75364920a44dd3d94966601ddb08422175b81d25412d0f74913caa44b20a2865e911d8dbd693d83fb29ad4ca68e02b1c156ba2650dec76418d46060cf9
diff --git a/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch b/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch
new file mode 100644
index 000000000000..c41fd07557b7
--- /dev/null
+++ b/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch
@@ -0,0 +1,24 @@
+--- Makefile.org 2004-12-30 03:23:30.000000000 +0100
++++ Makefile 2009-12-14 13:31:18.000000000 +0100
+@@ -19,10 +19,10 @@
+ # You should leave -static in the CFLAGS so that your sysinfo can be
+ # compiled into the executable.
+
+-CC = gcc
++#CC = gcc
+
+ # generic options for gcc
+-CFLAGS = -s -static -Wall -O3
++#CFLAGS = -s -static -Wall -O3
+
+ # if your gcc lets you do it, then try this one
+ #CFLAGS = -s -static -Wall -O3 -fomit-frame-pointer -funroll-loops
+@@ -126,7 +126,7 @@
+ if [ "4" = `./pointer` ] ; then touch pointer.h ;\
+ else echo "#define LONG64" >pointer.h ; fi
+
+-misc.o: misc.h misc.c Makefile
++misc.o: misc.h misc.c pointer.h Makefile
+ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+ -c misc.c
+
diff --git a/app-benchmarks/nbench/metadata.xml b/app-benchmarks/nbench/metadata.xml
new file mode 100644
index 000000000000..52363bff0cba
--- /dev/null
+++ b/app-benchmarks/nbench/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild b/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..a437b6ce8466
--- /dev/null
+++ b/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-byte-${PV}"
+DESCRIPTION="Linux/Unix of release 2 of BYTE Magazine's BYTEmark benchmark"
+HOMEPAGE="http://www.tux.org/~mayer/linux/bmark.html"
+SRC_URI="http://www.tux.org/~mayer/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 sh sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed \
+ -e 's:$compiler -v\( 2>&1 | sed -e "/version/!d"\|\):$compiler -dumpversion:' \
+ -i sysinfo.sh || die "patching sysinfo.sh failed"
+ sed -e 's:inpath="NNET.DAT":inpath="/usr/share/nbench/NNET.DAT":' \
+ -i nbench1.h || die "patching nbench1.h failed"
+}
+
+src_compile() {
+ emake LINKFLAGS="${LDFLAGS}" CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dobin nbench
+ insinto /usr/share/nbench
+ doins NNET.DAT
+ dodoc Changes README* bdoc.txt
+}