summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak (⚛) <0xe2.0x9a.0x9b@gmail.com>2016-02-26 23:55:24 +0100
committerJan Ziak (⚛) <0xe2.0x9a.0x9b@gmail.com>2016-02-26 23:55:24 +0100
commit1dc4a663afef9f5cba0809971293ffe866a55aa4 (patch)
tree217eb096c1a4207e653a0ab7dfe4cd1b80f65df0 /app-benchmarks/phoronix-test-suite
parentmedia-video/dvdstyler: Drop old (diff)
downloadgentoo-1dc4a663afef9f5cba0809971293ffe866a55aa4.tar.gz
gentoo-1dc4a663afef9f5cba0809971293ffe866a55aa4.tar.bz2
gentoo-1dc4a663afef9f5cba0809971293ffe866a55aa4.zip
Add app-benchmarks/phoronix-test-suite 6.2.1
Diffstat (limited to 'app-benchmarks/phoronix-test-suite')
-rw-r--r--app-benchmarks/phoronix-test-suite/Manifest1
-rw-r--r--app-benchmarks/phoronix-test-suite/phoronix-test-suite-6.2.1.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/app-benchmarks/phoronix-test-suite/Manifest b/app-benchmarks/phoronix-test-suite/Manifest
index 2126ac720118..45db1accc8e9 100644
--- a/app-benchmarks/phoronix-test-suite/Manifest
+++ b/app-benchmarks/phoronix-test-suite/Manifest
@@ -1,2 +1,3 @@
DIST phoronix-test-suite-4.8.4.tar.gz 523952 SHA256 113e6c725672c1f379885575e7cd51a3d0a387dc1c842606840e27fcd4695e43 SHA512 e7c201467a52fbbb9b0a87a47bd1eb772e24e43bedc2baf02845a9e9f355d6c22f46901be390d501a0e721ccfa05d28da4b8362817518ba5c801d6f4422c3b6f WHIRLPOOL 0760916473d8544652c0fc9c53f57a41015aacb99b42f53186d8b5008cbe5b2b396b024ce51ba3a3e31c35b319bac63db17db2b29295a8414c031c16d73813f6
DIST phoronix-test-suite-4.8.5.tar.gz 524136 SHA256 ca7bcbb5c72bee24075200449ee33fc75490ba528f804505d62fc3826d15456e SHA512 e37acdb48ba9ca532a6f409aea1c05b11b4320b967aac4576491ba5d401262d149f376506fef50ccee5506b77686aeed7a404102527472250cb7b5c1a247246a WHIRLPOOL be340514f3fdebafda449d60f069efcd44fa97d567b90616dc7332810d2802ed13433c94438937cab37f36744ddd383a918ceac92874f2702f28715c56ba3f9c
+DIST phoronix-test-suite-6.2.1.tar.gz 836633 SHA256 2b83d1c552d13b6e3fc6dde288b661698122003250b1eefe823d99dcabbb91f1 SHA512 d4e3d29645be76804c4ce96f8072d43653607fb34fd003771e614f4b5213c7bf8d9d629261ff2c696e685196d08e05a935d5a496d139a6e9efa37df9c5550fd6 WHIRLPOOL 808963909db7ff227515b05b404c4c1dec106f38c5cd47139b5e059a82d05d82ff47e277f7f6af0eda63c3fc3f3e83ff86d7fa58a5abc4561ef615646f3dcf86
diff --git a/app-benchmarks/phoronix-test-suite/phoronix-test-suite-6.2.1.ebuild b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-6.2.1.ebuild
new file mode 100644
index 000000000000..d67968b17c89
--- /dev/null
+++ b/app-benchmarks/phoronix-test-suite/phoronix-test-suite-6.2.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Phoronix's comprehensive, cross-platform testing and benchmark suite"
+HOMEPAGE="http://www.phoronix-test-suite.com"
+SRC_URI="http://www.phoronix-test-suite.com/download.php?file=${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+# php 5.3 doesn't have pcre and reflection useflags anymore
+RDEPEND="dev-lang/php[cli,curl,gd,json,posix,pcntl,truetype,zip]"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
+ phoronix-test-suite
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+
+ doman documentation/man-pages/phoronix-test-suite.1
+ dodoc AUTHORS ChangeLog README.md
+ dohtml -r documentation/
+ doicon pts-core/static/images/phoronix-test-suite.png
+ doicon pts-core/static/images/openbenchmarking.png
+ domenu pts-core/static/phoronix-test-suite.desktop
+ rm -f pts-core/static/phoronix-test-suite.desktop
+
+ doins -r pts-core
+ exeinto /usr/bin
+ doexe phoronix-test-suite
+
+ fperms a+x /usr/share/${PN}/pts-core/static/root-access.sh
+ fperms a+x /usr/share/${PN}/pts-core/external-test-dependencies/scripts/install-gentoo-packages.sh
+
+ newbashcomp pts-core/static/bash_completion ${PN}
+
+ # Need to fix the cli-php config for downloading to work. Very naughty!
+ local slots
+ local slot
+ if [[ "x${PHP_TARGETS}" == "x" ]] ; then
+ ewarn
+ ewarn "PHP_TARGETS seems empty, php.ini file can't be configured."
+ ewarn "Make sure that PHP_TARGETS in /etc/make.conf is set."
+ ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
+ ewarn "for downloading to work properly."
+ ewarn
+ else
+ for slot in ${PHP_TARGETS}; do
+ slots+=" ${slot/-/.}"
+ done
+ fi
+
+ for slot in ${slots}; do
+ local PHP_INI_FILE="/etc/php/cli-${slot}/php.ini"
+ if [[ -f ${PHP_INI_FILE} ]] ; then
+ dodir $(dirname ${PHP_INI_FILE})
+ cp ${PHP_INI_FILE} "${D}${PHP_INI_FILE}"
+ sed -e 's|^allow_url_fopen .*|allow_url_fopen = On|g' -i "${D}${PHP_INI_FILE}"
+ else
+ if [[ "x$(eselect php show cli)" == "x${slot}" ]] ; then
+ ewarn
+ ewarn "${slot} hasn't a php.ini file."
+ ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
+ ewarn "for downloading to work properly."
+ ewarn "Check that your PHP_INI_VERSION is set during ${slot} merge"
+ ewarn
+ else
+ elog
+ elog "${slot} hasn't a php.ini file."
+ elog "phoronix-test-suite may need the 'allow_url_fopen' option set to \"On\""
+ elog "for downloading to work properly if you switch to ${slot}"
+ elog "Check that your PHP_INI_VERSION is set during ${slot} merge"
+ elog
+ fi
+ fi
+ done
+
+ ewarn
+ ewarn "If you upgrade from phoronix-test-suite-2*, you should reinstall all"
+ ewarn "your tests because"
+ ewarn " \$HOME/.phoronix-test-suite/installed-tests/\$TEST_NAME/"
+ ewarn "moves to"
+ ewarn " \$HOME/.phoronix-test-suite/installed-tests/pts/\$TEST_NAME-\$TEST_VERSION/"
+ ewarn "in phoronix-test-suite-3* version. The \$TEST_VERSION can be find in"
+ ewarn "pts-install.xml file."
+ ewarn
+}